MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028959Open CASCADE[OCCT] OCCT:Configurationpublic2017-07-29 09:382017-09-29 16:29
Reporterabv 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028959: Configuration, genproj - provide warning on update of scripts in root folder (msvc.bat etc.)
DescriptionProcedure genproj.bat currently overrides file msvc.bat in the root folder by copying template from adm/templates/msvc.bat without any message. It can be quite confusing -- when you modify msvc.bat, it gets overridden silently and your changes get lost. To improve the situation, warning message can be given on override (unless the files are already the same); old copy can be saved in .bak file.
Steps To Reproducegenproj.bat
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships

-  Notes
(0068861)
git (administrator)
2017-07-29 09:42

Branch CR28959 has been created by abv.

SHA-1: 5993c8c6cd261a453a96cff372c06dc546ae7cce


Detailed log of new commits:

Author: abv
Date: Sat Jul 29 09:42:16 2017 +0300

    0028959: Configuration, genproj - provide warning on update of scripts in root folder (msvc.bat etc.)
    
    When updating files msvc.bat, env.bat/sh, and draw.bat/sh in the root folder by copying template from adm/templates, procedure genproj will give a warning (unless the files are already the same); if the target file is newer, its copy is saved with additional extension .bak.
(0068862)
abv (manager)
2017-07-29 09:53

Fix pushed to CR28959, please review.

Note that env.bat is now copied verbatim; in previous version it was copied with substitution of CASROOT macro; this was obsolete since env.bat does not contain such macro any more.
(0068863)
kgv (developer)
2017-07-29 09:53

No remark, please take the patch.
(0068864)
abv (manager)
2017-07-29 10:07

Sorry, template for env.sh still contains __CASROOT__ substitution; to be removed and checked
(0069515)
git (administrator)
2017-08-17 12:31

Branch CR28959_1 has been created by abv.

SHA-1: 708d8ca813a57fb1b17eb0dae5f23a47f1ce7a39


Detailed log of new commits:

Author: abv
Date: Sat Jul 29 09:42:16 2017 +0300

    0028959: Configuration, genproj - provide warning on update of scripts in root folder (msvc.bat etc.)
    
    When updating files msvc.bat and draw.bat/sh in the root folder by copying template from adm/templates, procedure genproj will give a warning (unless the files are already the same); if the target file is newer, its copy is saved with additional extension .bak.
(0069516)
abv (manager)
2017-08-17 12:34

Previous change was incorrect: in the current approach, products have their own env.bat/sh located in the folder which is current for genproj, and it should not be overwritten. Branch CR28959_1 contains only generation of warning, and no change of the logic. Please integrate.
(0069642)
git (administrator)
2017-08-18 17:00

Branch CR28959 has been deleted by kgv.

SHA-1: 5993c8c6cd261a453a96cff372c06dc546ae7cce
(0069643)
git (administrator)
2017-08-18 17:00

Branch CR28959_1 has been deleted by kgv.

SHA-1: 708d8ca813a57fb1b17eb0dae5f23a47f1ce7a39

- Related Changesets
occt: master 471a2ca0
Timestamp: 2017-07-29 06:42:16
Author: abv
Committer: abv
Details ] Diff ]
0028959: Configuration, genproj - provide warning on update of scripts in root folder (msvc.bat etc.)

When updating files msvc.bat and draw.bat/sh in the root folder by copying template from adm/templates, procedure genproj will give a warning (unless the files are already the same); if the target file is newer, its copy is saved with additional extension .bak.
mod - adm/genproj.tcl Diff ] File ]
mod - dox/dev_guides/building/code_blocks.md Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-07-29 09:38 abv New Issue
2017-07-29 09:38 abv Assigned To => bugmaster
2017-07-29 09:42 git Note Added: 0068861
2017-07-29 09:50 abv Assigned To bugmaster => kgv
2017-07-29 09:50 abv Status new => resolved
2017-07-29 09:50 abv Steps to Reproduce Updated View Revisions
2017-07-29 09:53 abv Note Added: 0068862
2017-07-29 09:53 abv Steps to Reproduce Updated View Revisions
2017-07-29 09:53 kgv Note Added: 0068863
2017-07-29 09:53 kgv Assigned To kgv => bugmaster
2017-07-29 09:53 kgv Status resolved => reviewed
2017-07-29 09:53 kgv Steps to Reproduce Updated View Revisions
2017-07-29 09:55 abv Steps to Reproduce Updated View Revisions
2017-07-29 10:07 abv Note Added: 0068864
2017-07-29 10:07 abv Assigned To bugmaster => abv
2017-07-29 10:07 abv Status reviewed => assigned
2017-08-17 12:31 git Note Added: 0069515
2017-08-17 12:34 abv Note Added: 0069516
2017-08-17 12:34 abv Assigned To abv => bugmaster
2017-08-17 12:34 abv Status assigned => resolved
2017-08-17 12:35 abv Status resolved => reviewed
2017-08-17 12:36 bugmaster Status reviewed => tested
2017-08-18 12:53 abv Changeset attached => occt master 471a2ca0
2017-08-18 12:53 abv Assigned To bugmaster => abv
2017-08-18 12:53 abv Status tested => verified
2017-08-18 12:53 abv Resolution open => fixed
2017-08-18 13:09 bugmaster Test case number => Not required
2017-08-18 17:00 git Note Added: 0069642
2017-08-18 17:00 git Note Added: 0069643
2017-09-29 16:17 user533 Fixed in Version => 7.2.0
2017-09-29 16:29 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker