View Issue Details

IDProjectCategoryView StatusLast Update
0028955Open CASCADEWebsite:Trackerpublic2021-09-03 14:13
Reporterabv Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status resolvedResolutionopen 
Target Version7.7.0 
Summary0028955: Mantis and Git integration - sort files in diff view
DescriptionCurrently list of files shown by Source Integration component in Mantis us completely disordered, and it is very difficult to find particular file in it.

For example here is fragment of diff in #28786:

mod - src/QABugs/QABugs_19.cxx [ Diff ] [ File ]
mod - src/TopoDS/FILES [ Diff ] [ File ]
mod - src/BRepAlgoAPI/BRepAlgoAPI_Splitter.hxx [ Diff ] [ File ]
mod - src/BOPAlgo/BOPAlgo_Algo.cxx [ Diff ] [ File ]
mod - src/BRepOffset/BRepOffset_MakeOffset_1.cxx [ Diff ] [ File ]
add - tests/bugs/modalg_7/bug28786_3 [ Diff ] [ File ]
mod - src/BOPAlgo/BOPAlgo_WireSplitter.cxx [ Diff ] [ File ]
mod - src/BOPAlgo/BOPAlgo_PaveFiller_4.cxx [ Diff ] [ File ]
mod - tests/boolean/bopcut_complex/B9 [ Diff ] [ File ]
mod - src/BOPAlgo/BOPAlgo_BuilderSolid.hxx [ Diff ] [ File ]
add - tests/bugs/modalg_7/bug28786_2

Please sort these diffs alphabetically by their file names (including path).
Steps To ReproduceClick on button 'Import Latest Data' and check the updated bugs.
The list of files in the "Related Changesets" should be sorted alphabetically
TagsNo tags attached.
Test case number

Activities

aiv

2017-09-13 14:12

reporter   ~0070501

It looks like this bug has already been resolved in the current version of Source Control Integration plugin, for example, files are sorted alphabetically on their bugtracker: http://www.mantisbt.org/bugs/view.php?id=22310

Source Control Integration plugin for MantisBT: https://github.com/mantisbt-plugins/source-integration

isv

2017-09-21 18:08

developer   ~0070747

Done.
Diffs sort alphabetically by their file names (including path).

Issue History

Date Modified Username Field Change
2017-07-28 08:03 abv New Issue
2017-07-28 08:03 abv Assigned To => aiv
2017-09-13 14:00 aiv Assigned To aiv => isv
2017-09-13 14:12 aiv Note Added: 0070501
2017-09-21 18:08 isv Note Added: 0070747
2017-09-21 18:08 isv Assigned To isv => bugmaster
2017-09-21 18:08 isv Status new => resolved
2017-09-21 18:08 isv Steps to Reproduce Updated
2021-09-03 14:13 bugmaster Target Version => 7.7.0