MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028950Open CASCADE[OCCT] OCCT:Documentationpublic2017-07-25 18:532017-09-29 16:29
Reporterbugmaster 
Assigned Tobugmaster 
PrioritynormalSeveritycrash 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028950: Generation of draw_test_harness and upgrade pdf files is crashed
DescriptionProblem reproduced both Windows and Linux platforms
Steps To Reproducegendoc.bat -overview -pdf -ug=user_guides/draw_test_harness/draw_test_harness.md
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships

-  Notes
(0068695)
bugmaster (administrator)
2017-07-25 18:55
edited on: 2017-07-25 20:20

OUTPUT of generation of pdf from draw_test_harness.md and upgrade.md:

Generating OCCT User Guides in PDF format...

Info: Processing file user_guides/draw_test_harness/draw_test_harness.md

2017-07-25 18:38 Generating Doxyfile...
2017-07-25 18:38 Generating PDF file...

Warning: Doxygen reported 2 messages.
See log in D:/builds/IR-2017-07-20_IR-2017-07-20/Windows-64-VC10-opt/OCCT/doc/doxygen_warnings_and_errors.log


Warning: PDFLaTeX reported 9 messages.
See log in D:/builds/IR-2017-07-20_IR-2017-07-20/Windows-64-VC10-opt/OCCT/doc/pdflatex_warnings_and_errors.log

Fatal: PDFLaTeX failed to create output file, stopping!
2017-07-25 18:38 Generation completed.

(0068722)
git (administrator)
2017-07-26 14:06

Branch CR28950 has been created by abv.

SHA-1: d91b9e045cbaae0301d8198b3e74f468fc458cb3


Detailed log of new commits:

Author: abv
Date: Wed Jul 26 13:47:04 2017 +0300

    0028950: Generation of draw_test_harness and upgrade pdf files is crashed
    
    Template for LaTeX header used in generation of PDF manuals is corrected to avoid multiple errors during processing by LaTeX (which can eventually lead to LaTeX aborting if their count exceeds 100).
    
    Names of log files generated by gendoc command are made dependent on target format and (for PDF output) document name.
    
    Formatting bug is fixed in DRAW User Guide
(0068723)
abv (manager)
2017-07-26 14:11
edited on: 2017-07-26 14:12

The fix is pushed to branch CR28950, please test.

The problem was in absence of definition of LaTeX command "\+" which apparently has been introduced in one of recent versions of Doxygen and defined in default LaTeX header template used by it. Since OCCT uses own header template, and it has not been updated for long time, that command was absent; this cause LaTeX to generate errors and eventually abort for long documents (where count of errors exceeds 100).

See related discussion here: http://doxygen.10944.n7.nabble.com/Undefined-control-sequence-error-when-using-user-defined-Latex-header-tex-td7602.html [^]

Please note that I have revised formatting of output of command gendoc to make it more compart for PDF generation, and changed names of log files generated by it so that now they depend on target format and (for PDF output) on file name.

(0068736)
bugmaster (administrator)
2017-07-26 16:32

draw_test_harness and upgrade pdf files are generated successfully
(0068962)
git (administrator)
2017-07-31 17:46

Branch CR28950 has been deleted by kgv.

SHA-1: d91b9e045cbaae0301d8198b3e74f468fc458cb3

- Related Changesets
occt: master cdec5927
Timestamp: 2017-07-26 10:47:04
Author: abv
Committer: bugmaster
Details ] Diff ]
0028950: Generation of draw_test_harness and upgrade pdf files is crashed

Template for LaTeX header used in generation of PDF manuals is corrected to avoid multiple errors during processing by LaTeX (which can eventually lead to LaTeX aborting if their count exceeds 100).

Names of log files generated by gendoc command are made dependent on target format and (for PDF output) document name.

Formatting bug is fixed in DRAW User Guide
mod - adm/gendoc.tcl Diff ] File ]
mod - dox/resources/occt_pdf_template.tex Diff ] File ]
mod - dox/resources/occt_ug_pdf.doxyfile Diff ] File ]
mod - dox/user_guides/draw_test_harness/draw_test_harness.md Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-07-25 18:53 bugmaster New Issue
2017-07-25 18:53 bugmaster Assigned To => bugmaster
2017-07-25 18:54 bugmaster Summary generation of draw pdf is crashed => Generation of draw_test_harness pdf is crashed
2017-07-25 18:55 bugmaster Note Added: 0068695
2017-07-25 19:11 bugmaster Description Updated View Revisions
2017-07-25 19:14 bugmaster Assigned To bugmaster => abv
2017-07-25 19:14 bugmaster Status new => feedback
2017-07-25 20:01 apn Summary Generation of draw_test_harness pdf is crashed => Generation of draw_test_harness and upgrade pdf files is crashed
2017-07-25 20:16 bugmaster Summary Generation of draw_test_harness and upgrade pdf files is crashed => Generation of draw_test_harness and occt_upgrade pdf files is crashed
2017-07-25 20:19 bugmaster Summary Generation of draw_test_harness and occt_upgrade pdf files is crashed => Generation of draw_test_harness and upgrade pdf files is crashed
2017-07-25 20:20 bugmaster Note Edited: 0068695 View Revisions
2017-07-26 13:44 abv Status feedback => assigned
2017-07-26 14:06 git Note Added: 0068722
2017-07-26 14:11 abv Note Added: 0068723
2017-07-26 14:11 abv Assigned To abv => bugmaster
2017-07-26 14:11 abv Status assigned => resolved
2017-07-26 14:11 abv Steps to Reproduce Updated View Revisions
2017-07-26 14:12 abv Note Edited: 0068723 View Revisions
2017-07-26 14:31 abv Relationship added related to 0028882
2017-07-26 16:31 bugmaster Status resolved => reviewed
2017-07-26 16:32 bugmaster Note Added: 0068736
2017-07-26 16:32 bugmaster Status reviewed => tested
2017-07-28 17:18 bugmaster Changeset attached => occt master cdec5927
2017-07-28 17:18 bugmaster Status tested => verified
2017-07-28 17:18 bugmaster Resolution open => fixed
2017-07-31 17:46 git Note Added: 0068962
2017-08-18 13:11 bugmaster Test case number => Not required
2017-09-29 16:17 user533 Fixed in Version => 7.2.0
2017-09-29 16:29 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker