MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028895Open CASCADE[OCCT] OCCT:Visualizationpublic2017-07-05 15:392017-07-17 10:07
Reporterisn 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.2.0Fixed in Version 
Summary0028895: Visualization, V3d_View::SetComputedMode() - HLR calculation is performed multiple times when 'hlr on' has been called
DescriptionA function StdPrs_HLRShape::Add (aPresentation, SH, myDrawer, aProjector) (from AIS_Shape::Compute(..)) called at least three times even if camera/eye is unchanged
Steps To Reproduce
pload MODELING VISUALIZATION
box s1 5 5 5
trotate s1 0 0 0 0 0 1 45
trotate s1 0 0 0 0 1 0 45
trotate s1 0 0 0 1 0 0 45
vinit Driver1/Viewer2/View1 w=1024 h=768
vsetcolorbg 255 255 255
vdisplay s1
vsetcolor s1 black
vfit
vhlrtype algo s1
chrono timer start
vhlr on
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
child of 0028088verifiedkgv Visualization, AIS_InteractiveContext - drop default value for Update Viewer parameter 
child of 0028407verifiedapn Visualization - remove ::UpdateMode() from Graphic3d_StructureManager 

-  Notes
(0068162)
git (administrator)
2017-07-10 15:43

Branch CR28895 has been created by kgv.

SHA-1: 783cd945dabd608cf19734fe9beb8c520fb85f14


Detailed log of new commits:

Author: kgv
Date: Mon Jul 10 15:43:25 2017 +0300

    0028895: Visualization, V3d_View::SetComputedMode() - HLR calculation is performed multiple times when 'hlr on' has been called
    
    V3d_View::SetComputedMode() - remove implicit View update.
(0068164)
git (administrator)
2017-07-10 16:26

Branch CR28895 has been updated forcibly by kgv.

SHA-1: d8b09110257ccdbc799d8bc3215ccdfdc80d7a10
(0068165)
kgv (developer)
2017-07-10 16:26
edited on: 2017-07-10 16:27

Please test the patch (test case is not needed).

(0068183)
mkv (tester)
2017-07-11 13:08

Dear BugMaster,
Branch CR28895 from occt git-repository and CR28895 from products git-repository are compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: d8b09110257ccdbc799d8bc3215ccdfdc80d7a10
SHA-1: b9697c4c5458689dd6ac893e6877f0e3c18a8450

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1135

Regressions/Differences/Improvements:
http://occt-tests/CR28895-CR28895-OCCT/Debian70-64/bugs/vis/bug24388_1.html [^]
http://occt-tests/CR28895-CR28895-OCCT/Windows-64-VC10/bugs/vis/bug24388_1.html [^]
bugs vis bug24388_1: FAILED

Testing cases:
Not needed

Testing on Linux:
occt component :
Total CPU difference: 19023.230000000218 / 19289.600000000315 [-1.38%]
Total MEMORY difference: 91708073 / 91874251 [-0.18%]
products component :
Total CPU difference: 6435.340000000056 / 6487.850000000069 [-0.81%]
Total MEMORY difference: 37535136 / 37650261 [-0.31%]
Testing on Windows:
occt component :
Total CPU difference: 17763.30346659862 / 17787.234019998614 [-0.13%]
Total MEMORY difference: 59028775 / 59031436 [-0.00%]
products component :
Total CPU difference: 6653.536250600055 / 6584.849010300061 [+1.04%]
Total MEMORY difference: 27877017 / 28099545 [-0.79%]

There are following differences in images found by testdiff.
http://occt-tests/CR28895-CR28895-OCCT/Debian70-64/diff-Debian70-64-image.html [^]
http://occt-tests/CR28895-CR28895-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html [^]
IMAGE bugs vis bug24837_1: bug24837_1_1_3.png differs
IMAGE bugs modalg_6 bug27341: bug27341.png differs
(0068184)
mkv (tester)
2017-07-11 13:08

Dear kgv,
Branch CR28895 has been rejected due to:
- regressions/differences/improvements
- differences in images
(0068195)
git (administrator)
2017-07-11 18:43

Branch CR28895 has been updated by kgv.

SHA-1: 4c1a45e3ce9dfc79cb935822f622bada75c9db73


Detailed log of new commits:

Author: kgv
Date: Mon Jul 10 15:43:25 2017 +0300

    Graphic3d_CView::SetComputedMode() - fixed uninitialized bounding box of Computed structure.
    Fixed error in test case bugs/vis/bug24388_1.
    PrsMgr_Presentation::Compute() - fixed computation of Computed structure with transformation within Connected presentation.

(0068197)
git (administrator)
2017-07-11 19:17

Branch CR28895 has been updated by kgv.

SHA-1: 8860041747db1f46989920c6fa7abf26e1e0ed84


Detailed log of new commits:

Author: kgv
Date: Mon Jul 10 15:43:25 2017 +0300

    StdPrs_HLRPolyShape::Add() now creates Graphic3d_ArrayOfSegments instead of
    inefficient Graphic3d_ArrayOfPolylines with boundaries at every segment.

(0068198)
git (administrator)
2017-07-11 19:18

Branch CR28895_1 has been created by kgv.

SHA-1: 58d5bff7228c7a580614e25f322c65ba47f3b8ff


Detailed log of new commits:

Author: kgv
Date: Mon Jul 10 15:43:25 2017 +0300

    0028895: Visualization, V3d_View::SetComputedMode() - HLR calculation is performed multiple times when 'hlr on' has been called
    
    V3d_View::SetComputedMode() - removed implicit View update.
    
    Graphic3d_CView::SetComputedMode() - fixed uninitialized bounding box of Computed structure.
    PrsMgr_Presentation::Compute() - fixed computation of Computed structure with transformation within Connected presentation.
    
    StdPrs_HLRPolyShape::Add() now creates Graphic3d_ArrayOfSegments instead of
    inefficient Graphic3d_ArrayOfPolylines with boundaries at every segment.
    
    Fixed error in test case bugs/vis/bug24388_1.
(0068199)
kgv (developer)
2017-07-11 19:19

Please test updated patch.
(0068215)
mkv (tester)
2017-07-12 16:42

Dear BugMaster,
Branch CR28895_1 from occt git-repository (and CR28895 from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 58d5bff7228c7a580614e25f322c65ba47f3b8ff
SHA-1: b9697c4c5458689dd6ac893e6877f0e3c18a8450

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1136

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total CPU difference: 19080.440000000268 / 19289.600000000315 [-1.08%]
Total MEMORY difference: 92520624 / 91851597 [+0.73%]
products component :
Total CPU difference: 6456.880000000062 / 6487.850000000069 [-0.48%]
Total MEMORY difference: 37637163 / 37650261 [-0.03%]
Testing on Windows:
occt component :
Total CPU difference: 17811.554575898717 / 17787.234019998614 [+0.14%]
Total MEMORY difference: 59028497 / 59031436 [-0.00%]
products component :
Total CPU difference: 6680.85202570007 / 6584.849010300061 [+1.46%]
Total MEMORY difference: 27877030 / 28099545 [-0.79%]

There are following differences in images found by testdiff.
http://occt-tests/CR28895_1-CR28895-OCCT/Debian70-64/diff-Debian70-64-image.html [^]
http://occt-tests/CR28895_1-CR28895-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html [^]
IMAGE bugs modalg_6 bug25813_1: bug25813_1.png differs
IMAGE bugs modalg_6 bug25813_4: bug25813_4.png differs
IMAGE bugs modalg_6 bug25813_5: bug25813_5.png differs
IMAGE bugs modalg_6 bug27341: bug27341.png differs
IMAGE bugs modalg_6 bug25813_2: bug25813_2.png differs
(0068216)
mkv (tester)
2017-07-12 16:43

Dear kgv,
Branch CR28895_1 has been rejected due to:
- differences in images
(0068220)
git (administrator)
2017-07-12 17:03

Branch CR28895_2 has been created by kgv.

SHA-1: 13bf331c35a85558b8a76581e7e4976571ee3408


Detailed log of new commits:

Author: kgv
Date: Mon Jul 10 15:43:25 2017 +0300

    0028895: Visualization, V3d_View::SetComputedMode() - HLR calculation is performed multiple times when 'hlr on' has been called
    
    V3d_View::SetComputedMode() - removed implicit View update.
    
    Graphic3d_CView::SetComputedMode(), ::ReCompute() - fixed
    uninitialized bounding box of Computed structure.
    
    PrsMgr_Presentation::Compute() - fixed computation of Computed structure
    with transformation within Connected presentation.
    
    StdPrs_HLRPolyShape::Add() now creates Graphic3d_ArrayOfSegments instead of
    inefficient Graphic3d_ArrayOfPolylines with boundaries at every segment.
    
    Fixed error in test case bugs/vis/bug24388_1.
(0068221)
kgv (developer)
2017-07-12 17:03

Please test updated patch.
(0068247)
mkv (tester)
2017-07-13 11:47

Dear BugMaster,
Branch CR28895_2 from occt git-repository (and CR28895 from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 13bf331c35a85558b8a76581e7e4976571ee3408
SHA-1: b9697c4c5458689dd6ac893e6877f0e3c18a8450

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1165

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total CPU difference: 19028.91000000007 / 19289.600000000315 [-1.35%]
Total MEMORY difference: 92236863 / 91866108 [+0.40%]
products component :
Total CPU difference: 6447.500000000075 / 6487.750000000069 [-0.62%]
Total MEMORY difference: 37718256 / 37648329 [+0.19%]
Testing on Windows:
occt component :
Total CPU difference: 17757.874631798535 / 17759.824644298613 [-0.01%]
Total MEMORY difference: 59014094 / 59017791 [-0.01%]
products component :
Total CPU difference: 6695.96852260008 / 6584.849010300061 [+1.69%]
Total MEMORY difference: 27877023 / 28099545 [-0.79%]

There are no differences in images found by testdiff.
(0068248)
mkv (tester)
2017-07-13 11:47

Dear BugMaster,
Branch CR28895_2 from occt git-repository and branch CR28895 from products git-repository are TESTED.
(0068349)
git (administrator)
2017-07-17 10:05

Branch CR28895 has been deleted by kgv.

SHA-1: 8860041747db1f46989920c6fa7abf26e1e0ed84
(0068350)
git (administrator)
2017-07-17 10:05

Branch CR28895_1 has been deleted by kgv.

SHA-1: 58d5bff7228c7a580614e25f322c65ba47f3b8ff
(0068351)
git (administrator)
2017-07-17 10:05

Branch CR28895_2 has been deleted by kgv.

SHA-1: 13bf331c35a85558b8a76581e7e4976571ee3408

- Related Changesets
occt: master 1eeef710
Timestamp: 2017-07-10 12:43:25
Author: kgv
Committer: bugmaster
Details ] Diff ]
0028895: Visualization, V3d_View::SetComputedMode() - HLR calculation is performed multiple times when 'hlr on' has been called

V3d_View::SetComputedMode() - removed implicit View update.

Graphic3d_CView::SetComputedMode(), ::ReCompute() - fixed
uninitialized bounding box of Computed structure.

PrsMgr_Presentation::Compute() - fixed computation of Computed structure
with transformation within Connected presentation.

StdPrs_HLRPolyShape::Add() now creates Graphic3d_ArrayOfSegments instead of
inefficient Graphic3d_ArrayOfPolylines with boundaries at every segment.

Fixed error in test case bugs/vis/bug24388_1.
mod - samples/CSharp/OCCTProxy/OCCTProxy.cpp Diff ] File ]
mod - samples/CSharp/OCCTProxy_D3D/OCCTProxyD3D.cpp Diff ] File ]
mod - samples/mfc/occtdemo/Common/WNT/OCCDemoView.cpp Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/src/Viewer3dView.cpp Diff ] File ]
mod - samples/mfc/standard/08_HLR/src/SelectionDialog.cpp Diff ] File ]
mod - samples/mfc/standard/09_Animation/src/AnimationView3D.cpp Diff ] File ]
mod - samples/mfc/standard/10_Convert/src/WNT/OCCDemoView.cpp Diff ] File ]
mod - samples/mfc/standard/Common/OCC_3dView.cpp Diff ] File ]
mod - samples/qt/Common/src/View.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_CView.cxx Diff ] File ]
mod - src/PrsMgr/PrsMgr_Presentation.cxx Diff ] File ]
mod - src/StdPrs/StdPrs_HLRPolyShape.cxx Diff ] File ]
mod - src/V3d/V3d_View.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ViewerCommands.cxx Diff ] File ]
mod - tests/bugs/vis/bug24388_1 Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-07-05 15:39 isn New Issue
2017-07-05 15:39 isn Assigned To => isn
2017-07-10 14:12 kgv Relationship added child of 0028088
2017-07-10 14:13 kgv Relationship added child of 0028407
2017-07-10 14:36 kgv Summary HLR calculation performs multiple times when 'hlr on' has been called => Visualization, V3d_View::SetComputedMode() - HLR calculation is performed multiple times when 'hlr on' has been called
2017-07-10 14:36 kgv Steps to Reproduce Updated View Revisions
2017-07-10 15:43 git Note Added: 0068162
2017-07-10 16:26 git Note Added: 0068164
2017-07-10 16:26 kgv Note Added: 0068165
2017-07-10 16:26 kgv Assigned To isn => bugmaster
2017-07-10 16:26 kgv Status new => resolved
2017-07-10 16:26 kgv Status resolved => reviewed
2017-07-10 16:27 kgv Note Edited: 0068165 View Revisions
2017-07-10 16:47 mkv Assigned To bugmaster => mkv
2017-07-11 13:08 mkv Note Added: 0068183
2017-07-11 13:08 mkv Note Added: 0068184
2017-07-11 13:08 mkv Assigned To mkv => kgv
2017-07-11 13:08 mkv Status reviewed => feedback
2017-07-11 13:08 mkv Test case number => Not needed
2017-07-11 18:43 git Note Added: 0068195
2017-07-11 19:17 git Note Added: 0068197
2017-07-11 19:18 git Note Added: 0068198
2017-07-11 19:19 kgv Note Added: 0068199
2017-07-11 19:19 kgv Assigned To kgv => bugmaster
2017-07-11 19:19 kgv Status feedback => reviewed
2017-07-11 20:10 mkv Assigned To bugmaster => mkv
2017-07-12 16:42 mkv Note Added: 0068215
2017-07-12 16:43 mkv Note Added: 0068216
2017-07-12 16:43 mkv Assigned To mkv => kgv
2017-07-12 16:43 mkv Status reviewed => assigned
2017-07-12 17:03 git Note Added: 0068220
2017-07-12 17:03 kgv Note Added: 0068221
2017-07-12 17:03 kgv Assigned To kgv => bugmaster
2017-07-12 17:03 kgv Status assigned => resolved
2017-07-12 17:03 kgv Status resolved => reviewed
2017-07-12 18:52 mkv Assigned To bugmaster => mkv
2017-07-13 11:47 mkv Note Added: 0068247
2017-07-13 11:47 mkv Note Added: 0068248
2017-07-13 11:47 mkv Assigned To mkv => bugmaster
2017-07-13 11:47 mkv Status reviewed => tested
2017-07-14 13:55 bugmaster Changeset attached => occt master 1eeef710
2017-07-14 13:55 bugmaster Status tested => verified
2017-07-14 13:55 bugmaster Resolution open => fixed
2017-07-17 10:05 git Note Added: 0068349
2017-07-17 10:05 git Note Added: 0068350
2017-07-17 10:05 git Note Added: 0068351


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker