MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028891Open CASCADE[OCCT] OCCT:Testspublic2017-07-04 16:142018-03-15 18:40
Reporterapn 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusfeedbackResolutionreopened 
PlatformAOSLOS VersionL
Product Version 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0028891: Add environment variable CSF_TestVolumeRenderDataPath
DescriptionAdd special environment variable CSF_TestVolumeRenderDataPath for loading data files from special repository for VolumeRender test cases.
Steps To Reproduceset env(CSF_TestVolumeRenderDataPath) /dn62/occt_tests_data_volumerender (lin)
set env(CSF_TestVolumeRenderDataPath) \\testex3\occt_tests_data_volumerender (wnt)
set env(CSF_TestScriptsPath) ./tests
testgrid volumerender
TagsNo tags attached.
Test case numbervolumerender
Attached Files

- Relationships

-  Notes
(0067990)
git (administrator)
2017-07-05 10:37

Branch CR28891 has been created by apn.

SHA-1: bf61566c69e6f2b7cb65cbc0ed0aec39cd64dfd5


Detailed log of new commits:

Author: apn
Date: Wed Jul 5 10:36:54 2017 +0300

    0028891: Add environment variable CSF_TestVolumeRenderDataPath
    
    Add environment variable CSF_TestVolumeRenderDataPath for loading data files from special repository for VolumeRender products test cases.
(0067992)
kgv (developer)
2017-07-05 10:40

Please provide more detailed description to this bug elaborating why existing variables can not be used.
(0067993)
bugmaster (administrator)
2017-07-05 10:48

Usage of CSF_TestDataPath variable for definition path at volumerender shapes in OCCT testing system is not acceptable.
It cause terrible slowdown in the performance of the testing due to too long a shape search in a sharply increased database.

Creation of new variable was agreed with ABV
(0067994)
apn (administrator)
2017-07-05 10:48

Environment variable CSF_TestVolumeRenderDataPath was added. I checked running volumerender test cases on CR25464-CR25464-VSV on linux, but there are some errors.

Dear vsv, could you please take commit from CR28891 and check test cases.
(0067995)
kgv (developer)
2017-07-05 11:10

> Creation of new variable was agreed with ABV
I'm not against the patch, I just would like the reasons and problem description being elaborated to foresee possible issues in future.

> Usage of CSF_TestDataPath variable for definition path at volumerender shapes in OCCT testing system is not acceptable.
> It cause terrible slowdown in the performance of the testing due to too long a shape search in a sharply increased database.
So the problem is a large amount of files added for testing Volume Rendering?
How many? How large this database in size?
(0067998)
apn (administrator)
2017-07-05 11:29

Size of database is approximately 6.8GB. It's available on \\salomer1\dn62\occt_tests_data_volumerender.
(0068002)
kgv (developer)
2017-07-05 12:00
edited on: 2017-07-05 12:01

> Size of database is approximately 6.8GB.
> It's available on \\salomer1\dn62\occt_tests_data_volumerender.
The problem is not specific to the Volume Renderer data set - other packages might also operate with thousands of files placed into sub-folder(s).

Example - STEP/JT assemblies with external references.
Note that it would be better skipping subfolders containing external references if not for a performance reasons,
but just to avoid possible name collision issues (it is not possible easily renaming names of external references files).

Thus, I propose more general solution to the problem - marking folders which are not expected to be recursively traversed.
This can be done by creating an empty file in the folder, e.g. "norecursion.rules" and processing such folders specifically within "locate_file" procedure.

(0071009)
git (administrator)
2017-09-29 17:11

Branch CR28891 has been deleted by kgv.

SHA-1: bf61566c69e6f2b7cb65cbc0ed0aec39cd64dfd5

- Issue History
Date Modified Username Field Change
2017-07-04 16:14 apn New Issue
2017-07-04 16:14 apn Assigned To => apn
2017-07-05 10:37 git Note Added: 0067990
2017-07-05 10:40 kgv Note Added: 0067992
2017-07-05 10:48 bugmaster Note Added: 0067993
2017-07-05 10:48 apn Test case number => volumerender
2017-07-05 10:48 apn Note Added: 0067994
2017-07-05 10:48 apn Assigned To apn => vsv
2017-07-05 10:48 apn Status new => resolved
2017-07-05 10:48 apn Steps to Reproduce Updated View Revisions
2017-07-05 11:10 kgv Note Added: 0067995
2017-07-05 11:29 apn Note Added: 0067998
2017-07-05 11:33 apn Steps to Reproduce Updated View Revisions
2017-07-05 12:00 kgv Note Added: 0068002
2017-07-05 12:00 kgv Assigned To vsv => apn
2017-07-05 12:00 kgv Status resolved => assigned
2017-07-05 12:01 kgv Note Edited: 0068002 View Revisions
2017-07-05 12:01 kgv Note Edited: 0068002 View Revisions
2017-07-24 10:09 bugmaster Status assigned => feedback
2017-07-24 10:40 bugmaster Status feedback => closed
2017-07-24 10:40 bugmaster Resolution open => no change required
2017-07-24 10:41 bugmaster Status closed => feedback
2017-07-24 10:41 bugmaster Resolution no change required => reopened
2017-08-27 11:00 bugmaster Target Version 7.2.0 => 7.3.0
2017-09-29 17:11 git Note Added: 0071009
2018-03-15 18:40 kgv Target Version 7.3.0 => 7.4.0*


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker