View Issue Details

IDProjectCategoryView StatusLast Update
0028824Open CASCADEOCCT:Configurationpublic2021-05-10 15:31
Reporteroan Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Target Version7.3.0Fixed in Version7.3.0 
Summary0028824: Possibility to build OCCT 7.1.0 and above using Visual Studio 2008
DescriptionSome oldfashioned 3rdparty software the OCCT-based plugin should be built for refuses to use builds made by VS2010 and above.
Steps To Reproducenone
Additional information
and documentation updates
Requires "Visual C++ 2008 Feature Pack Release"
TagsNo tags attached.
Test case numberNot required

Relationships

parent of 0032270 closedbugmaster Configuration - Removing VS 2008 from maintenance 
parent of 0032352 verifiedkgv Coding Rules - clean up code from compatibility hacks with pre-C++11 compilers 

Activities

git

2017-06-07 18:04

administrator   ~0067206

Branch CR28824 has been created by oan.

SHA-1: 6e7fe2921b3ce1d320ece959a2bc776cd2e19591


Detailed log of new commits:

Author: oan
Date: Wed Jun 7 17:42:04 2017 +0300

    0028824: Possibility to build OCCT 7.1.0 and above using Visual Studio 2008

oan

2017-08-02 11:59

developer   ~0069047

Last edited: 2017-08-02 12:01

Please note that current patch requires "Visual C++ 2008 Feature Pack Release" update for Visual Studio 2008 which includes an implementation of TR1 providing smart pointers, type traits, etc.

git

2017-08-07 12:41

administrator   ~0069148

Branch CR28824 has been updated forcibly by apn.

SHA-1: 0c2354ef9bc8c448bbe8ae028a156c552ad5a88f

apn

2017-08-07 13:24

administrator   ~0069151

There are compilation errors on all platforms:
http://jenkins-test-10.nnov.opencascade.com/view/CR28824-master-APN/view/OCCT%20compile/job/CR28824-master-APN-OCCT-Debian70-64-opt-compile/1/parsed_console/
http://jenkins-test-10.nnov.opencascade.com/view/CR28824-master-APN/view/OCCT%20compile/job/CR28824-master-APN-OCCT-MacOS-opt-compile/1/parsed_console/
http://jenkins-test-10.nnov.opencascade.com/view/CR28824-master-APN/view/OCCT%20compile/job/CR28824-master-APN-OCCT-Windows-64-VC10-opt-compile/3/parsed_console/

oan

2017-08-08 15:06

developer   ~0069207

DC,

unfortunately, I am unable to finalize issue before September.
Could you please reassign it to another person?

TIA,
Oleg.

git

2017-08-09 18:51

administrator   ~0069257

Branch CR28824 has been updated by oan.

SHA-1: c7cded4cd91788560b3a9c7d10d4bb23c0e19aae


Detailed log of new commits:

Author: oan
Date: Wed Aug 9 18:43:44 2017 +0300

    Fix compilation errors on current master

oan

2017-08-09 18:54

developer   ~0069258

DC,

Suddenly, I had to fix it due to necessity of latest changes from master branch.

Could you please check it again? I also suggest to add new Jenkins job that runs compilation for VS2008 in certification process in further.

BR,
Oleg.

oan

2017-08-09 19:11

developer   ~0069259

Please also note that modification of env.bat template is required due to changed approach of DevEnvDir variable specification (there is no support of vc9 anymore).

git

2017-09-13 18:44

administrator   ~0070513

Branch CR28824 has been updated forcibly by oan.

SHA-1: ac0880c35898f1a3c465fa45ef7208d5d6f1027c

git

2017-09-13 18:54

administrator   ~0070515

Branch CR28824 has been updated by oan.

SHA-1: 15d9bf5411b1ae08b481fddcdb4bd8ac44e6be31


Detailed log of new commits:

Author: oan
Date: Wed Sep 13 18:54:26 2017 +0300

    Modified env.bat.in template file

git

2017-09-14 11:40

administrator   ~0070524

Branch CR28824_1 has been created by oan.

SHA-1: 4b5ee1ef7f9ecc4b659c86ac419a5d74745065cd


Detailed log of new commits:

Author: oan
Date: Thu Sep 14 11:39:36 2017 +0300

    0028824: Possibility to build OCCT 7.1.0 and above using Visual Studio 2008

git

2017-09-14 20:04

administrator   ~0070555

Branch CR28824_2 has been created by abv.

SHA-1: eabf555359c0ec5c22179d7755be5dd615a157ec


Detailed log of new commits:

Author: oan
Date: Thu Sep 14 11:39:36 2017 +0300

    0028824: Possibility to build OCCT 7.1.0 and above using Visual Studio 2008
    
    Possibility to build OCCT using Visual Studio 2008 (VC9) is restored.
    For that:
    
    - template functions and classes from namespace std or tr1 (for VC9) are imported to namespace opencascade which is then used instead of std in relevant places
    - templates not provided by compiler (VC9) but required for OCCT are defined in this namespace (in Standard_Handle.hxx)
    - methods implementing move semantics are excluded for VC9 compiler (which does not support && syntax)
    - support of vc9 compiler is restored in build procedures and environment scripts
    - check of type of the current class in macros DEFINE_STANDARD_RTTI* is refactored

git

2017-09-15 18:58

administrator   ~0070609

Branch CR28824_2 has been updated by abv.

SHA-1: 95d434cca718650a35921c05312b9cd96214dd87


Detailed log of new commits:

Author: abv
Date: Fri Sep 15 18:57:57 2017 +0300

    VS 2008 is restored in the list of supported platforms on Overview / System Requirements.

abv

2017-09-18 12:06

manager   ~0070623

Reviewed and tested, see branch CR28824_2 and Jenkins job CR28824-master-abv; please consider for integration

kgv

2017-09-18 12:26

developer   ~0070625

Last edited: 2017-09-18 12:26

Note that patch is intended to allow building OCCT itself using VS2008, NOT the OCC Products!

git

2017-09-18 16:38

administrator   ~0070643

Branch CR28824_2 has been updated by abv.

SHA-1: 4965660d2f67f91f19ed409f886b3897036045a8


Detailed log of new commits:

Author: abv
Date: Mon Sep 18 16:37:51 2017 +0300

    // move standard definitions to namespace opencascade::std

bugmaster

2017-09-18 16:45

administrator   ~0070647

Combination -
OCCT : CR28824_2 SHA-1: 4965660d2f67f91f19ed409f886b3897036045a8
Products branch : master
was compiled on Linux, MacOS and Windows platforms and tested on optimize mode.

http://jenkins-test-10.nnov.opencascade.com/view/CR28824-master-abv/

Number of compiler warnings:

OCCT :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

Products :
Linux: 4 (4 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
No differences that require special attention

Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

abv

2017-09-19 14:26

manager   ~0070682

For the record, here are results of testing of binaries produced by VS 2008 (except problems due to remote desktop reported in 29124):

Failed
boolean bfuse_complex C4 C5

Improvements
bugs modalg_7 bug25104 bug25879
bugs moddata_3 bug25693_1 bug25693_2

git

2017-09-29 17:11

administrator   ~0071006

Branch CR28824 has been deleted by kgv.

SHA-1: 15d9bf5411b1ae08b481fddcdb4bd8ac44e6be31

git

2017-09-29 17:11

administrator   ~0071007

Branch CR28824_1 has been deleted by kgv.

SHA-1: 4b5ee1ef7f9ecc4b659c86ac419a5d74745065cd

git

2017-09-29 17:11

administrator   ~0071008

Branch CR28824_2 has been deleted by kgv.

SHA-1: 4965660d2f67f91f19ed409f886b3897036045a8

Related Changesets

occt: master 8b6ae617

2017-09-14 08:39:36

oan


Committer: bugmaster Details Diff
0028824: Possibility to build OCCT 7.1.0 and above using Visual Studio 2008

Possibility to build OCCT using Visual Studio 2008 (VC9) is restored.
For that:

- template functions and classes from namespace std or tr1 (for VC9) are imported to namespace opencascade which is then used instead of std in relevant places
- templates not provided by compiler (VC9) but required for OCCT are defined in this namespace (in Standard_Handle.hxx)
- methods implementing move semantics are excluded for VC9 compiler (which does not support && syntax)
- support of vc9 compiler is restored in build procedures and environment scripts
- check of type of the current class in macros DEFINE_STANDARD_RTTI* is refactored

VS 2008 is restored in the list of supported platforms on Overview / System Requirements.
Affected Issues
0028824
mod - adm/templates/env.bat Diff File
mod - adm/templates/env.bat.in Diff File
mod - adm/templates/template.vc9 Diff File
mod - dox/overview/overview.md Diff File
mod - src/BinLDrivers/BinLDrivers_DocumentRetrievalDriver.cxx Diff File
mod - src/BinLDrivers/BinLDrivers_DocumentSection.cxx Diff File
mod - src/BVH/BVH_BinaryTree.hxx Diff File
mod - src/BVH/BVH_Types.hxx Diff File
mod - src/DrawTrSurf/DrawTrSurf.hxx Diff File
mod - src/IGESData/IGESData_IGESWriter.hxx Diff File
mod - src/NCollection/NCollection_Array1.hxx Diff File
mod - src/NCollection/NCollection_DefineHSequence.hxx Diff File
mod - src/NCollection/NCollection_Shared.hxx Diff File
mod - src/NCollection/NCollection_StlIterator.hxx Diff File
mod - src/NCollection/NCollection_UBTreeFiller.hxx Diff File
mod - src/OpenGl/OpenGl_Context.cxx Diff File
mod - src/Poly/Poly_Connect.cxx Diff File
mod - src/QANCollection/QANCollection_Handle.cxx Diff File
mod - src/RWStl/RWStl_Reader.cxx Diff File
mod - src/Standard/Standard_ArrayStreamBuffer.hxx Diff File
mod - src/Standard/Standard_Handle.hxx Diff File
mod - src/Standard/Standard_Type.hxx Diff File
mod - src/Standard/Standard_TypeDef.hxx Diff File

occt: master 71c810df

2017-09-14 08:39:36

oan


Committer: bugmaster Details Diff
0028824: Possibility to build OCCT 7.1.0 and above using Visual Studio 2008

Possibility to build OCCT using Visual Studio 2008 (VC9) is restored.
For that:

- template functions and classes from namespace std or tr1 (for VC9) are imported to namespace opencascade which is then used instead of std in relevant places
- templates not provided by compiler (VC9) but required for OCCT are defined in this namespace (in Standard_Handle.hxx)
- methods implementing move semantics are excluded for VC9 compiler (which does not support && syntax)
- support of vc9 compiler is restored in build procedures and environment scripts
- check of type of the current class in macros DEFINE_STANDARD_RTTI* is refactored

VS 2008 is restored in the list of supported platforms on Overview / System Requirements.
Affected Issues
0028824
mod - adm/templates/env.bat Diff File
mod - adm/templates/env.bat.in Diff File
mod - adm/templates/template.vc9 Diff File
mod - dox/overview/overview.md Diff File
mod - src/BinLDrivers/BinLDrivers_DocumentRetrievalDriver.cxx Diff File
mod - src/BinLDrivers/BinLDrivers_DocumentSection.cxx Diff File
mod - src/BVH/BVH_BinaryTree.hxx Diff File
mod - src/BVH/BVH_Types.hxx Diff File
mod - src/DrawTrSurf/DrawTrSurf.hxx Diff File
mod - src/IGESData/IGESData_IGESWriter.hxx Diff File
mod - src/NCollection/NCollection_Array1.hxx Diff File
mod - src/NCollection/NCollection_DefineHSequence.hxx Diff File
mod - src/NCollection/NCollection_Shared.hxx Diff File
mod - src/NCollection/NCollection_StlIterator.hxx Diff File
mod - src/NCollection/NCollection_UBTreeFiller.hxx Diff File
mod - src/OpenGl/OpenGl_Context.cxx Diff File
mod - src/Poly/Poly_Connect.cxx Diff File
mod - src/QANCollection/QANCollection_Handle.cxx Diff File
mod - src/RWStl/RWStl_Reader.cxx Diff File
mod - src/Standard/Standard_ArrayStreamBuffer.hxx Diff File
mod - src/Standard/Standard_Handle.hxx Diff File
mod - src/Standard/Standard_Type.hxx Diff File
mod - src/Standard/Standard_TypeDef.hxx Diff File

Issue History

Date Modified Username Field Change
2017-06-07 17:39 oan New Issue
2017-06-07 17:39 oan Assigned To => bugmaster
2017-06-07 18:04 git Note Added: 0067206
2017-06-07 18:04 oan Status new => resolved
2017-06-07 18:04 oan Steps to Reproduce Updated
2017-07-04 11:11 bugmaster Assigned To bugmaster => apn
2017-07-04 11:11 bugmaster Status resolved => feedback
2017-08-02 11:59 oan Note Added: 0069047
2017-08-02 12:01 oan Note Edited: 0069047
2017-08-02 12:01 oan Note Edited: 0069047
2017-08-07 12:41 git Note Added: 0069148
2017-08-07 13:24 apn Note Added: 0069151
2017-08-07 13:24 apn Assigned To apn => oan
2017-08-08 15:05 oan Assigned To oan => abv
2017-08-08 15:06 oan Note Added: 0069207
2017-08-09 18:51 git Note Added: 0069257
2017-08-09 18:51 oan Assigned To abv => apn
2017-08-09 18:54 oan Note Added: 0069258
2017-08-09 19:11 oan Note Added: 0069259
2017-08-10 12:04 bugmaster Target Version 7.2.0 => 7.3.0
2017-09-13 18:44 git Note Added: 0070513
2017-09-13 18:54 git Note Added: 0070515
2017-09-14 10:31 oan Additional Information Updated
2017-09-14 11:40 git Note Added: 0070524
2017-09-14 11:57 oan Assigned To apn => abv
2017-09-14 11:57 oan Status feedback => resolved
2017-09-14 20:04 git Note Added: 0070555
2017-09-15 18:58 git Note Added: 0070609
2017-09-18 12:06 abv Note Added: 0070623
2017-09-18 12:06 abv Assigned To abv => bugmaster
2017-09-18 12:06 abv Status resolved => reviewed
2017-09-18 12:26 kgv Note Added: 0070625
2017-09-18 12:26 kgv Note Edited: 0070625
2017-09-18 16:38 git Note Added: 0070643
2017-09-18 16:45 bugmaster Note Added: 0070647
2017-09-18 16:45 bugmaster Status reviewed => tested
2017-09-18 16:46 bugmaster Test case number => Not required
2017-09-19 14:26 abv Note Added: 0070682
2017-09-21 19:33 bugmaster Changeset attached => occt master 8b6ae617
2017-09-21 19:33 bugmaster Status tested => verified
2017-09-21 19:33 bugmaster Resolution open => fixed
2017-09-21 19:51 apn Target Version 7.3.0 => 7.2.0
2017-09-22 12:06 bugmaster Target Version 7.2.0 => 7.3.0
2017-09-29 13:26 bugmaster Changeset attached => occt master 71c810df
2017-09-29 17:11 git Note Added: 0071006
2017-09-29 17:11 git Note Added: 0071007
2017-09-29 17:11 git Note Added: 0071008
2018-06-29 21:15 aiv Fixed in Version => 7.3.0
2018-06-29 21:19 aiv Status verified => closed
2021-05-10 15:18 kgv Relationship added parent of 0032270
2021-05-10 15:31 kgv Relationship added parent of 0032352