MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028727Community[OCCT] OCCT:Visualizationpublic2017-05-11 11:522018-03-20 12:43
ReporterMax121 
Assigned Toabv 
PrioritynormalSeveritytrivial 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028727: Visualization, AIS_RadiusDimension - fix misprint in AIS_RadiusDimension::IsValidAnchor() check
DescriptionThere is an error in logic of method void AIS_RadiusDimension::SetMeasuredGeometry (const gp_Circ& theCircle, const gp_Pnt& theAnchorPoint), that is calling when you try to create AIS_RadiusDimension based on circle and anchor point. The problem occured in anchor validation.

As you can see method "Standard_Boolean AIS_RadiusDimension::IsValidAnchor (const gp_Circ&, const gp_Pnt& theAnchor) const" returns "Abs (anAnchorDist - aRadius) > Precision::Confusion() && aCirclePlane.Contains (theAnchor, Precision::Confusion());". I think, it is clear that ancgor point can be placed on the circle, if Abs (anAnchorDist - aRadius) > Precision::Confusion(). So it shoulds be Abs (anAnchorDist - aRadius) "<" Precision::Confusion() for sure.
Steps To ReproduceTry to create AIS_RadiusDimension based on circle and anchor point.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0066129)
git (administrator)
2017-05-16 12:05

Branch CR28727 has been created by kgv.

SHA-1: b8d726bfd3624b532126a84dc6a10fdd2151014c


Detailed log of new commits:

Author: kgv
Date: Tue May 16 12:05:06 2017 +0300

    0028727: Visualization, AIS_RadiusDimension - fix misprint in AIS_RadiusDimension::IsValidAnchor() check
(0066130)
kgv (developer)
2017-05-16 12:05
edited on: 2017-05-16 12:13

Please test the patch.
Test case is not needed (covered by existing tests after modifications).

(0066225)
mkv (tester)
2017-05-17 18:58

Dear BugMaster,
Branch CR28727 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: b8d726bfd3624b532126a84dc6a10fdd2151014c

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1201

Regressions/Differences/Improvements:
http://occt-tests/CR28727-master-OCCT/Debian70-64/bugs/vis/bug24351_3.html [^]
http://occt-tests/CR28727-master-OCCT/Windows-64-VC10/bugs/vis/bug24351_3.html [^]
bugs vis bug24351_3: FAILED
http://occt-tests/CR28727-master-OCCT/Debian70-64/bugs/vis/bug24389.html [^]
http://occt-tests/CR28727-master-OCCT/Windows-64-VC10/bugs/vis/bug24389.html [^]
bugs vis bug24389: FAILED

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 91763018 / 91697349 [+0.07%]
Total CPU difference: 19001.26000000034 / 18651.010000000362 [+1.88%]
products component :
Total MEMORY difference: 31329438 / 31317049 [+0.04%]
Total CPU difference: 5431.699999999976 / 5416.239999999973 [+0.29%]
Testing on Windows:
occt component :
Total MEMORY difference: 58425619 / 58426407 [-0.00%]
Total CPU difference: 17539.254830398615 / 17338.309942298663 [+1.16%]
products component :
Total MEMORY difference: 22693835 / 22655560 [+0.17%]
Total CPU difference: 5384.358914899969 / 5279.479442599965 [+1.99%]

There are no differences in images found by testdiff.
(0066226)
mkv (tester)
2017-05-17 18:58

Dear kgv,
Branch CR28727 has been rejected due to:
- regressions/differences/improvements
(0066231)
git (administrator)
2017-05-17 19:48

Branch CR28727 has been updated forcibly by kgv.

SHA-1: 53080afa69f8f55cf190c454916475e55967a8b0
(0066232)
kgv (developer)
2017-05-17 19:49

Please check corrected patch.
(0066265)
mkv (tester)
2017-05-18 14:22

Dear BugMaster,
Branch CR28727 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 53080afa69f8f55cf190c454916475e55967a8b0

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1194

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 91862311 / 91709668 [+0.17%]
Total CPU difference: 19001.62000000028 / 18652.11000000036 [+1.87%]
products component :
Total MEMORY difference: 31262948 / 31317049 [-0.17%]
Total CPU difference: 5413.479999999982 / 5416.239999999973 [-0.05%]
Testing on Windows:
occt component :
Total MEMORY difference: 58428089 / 58426407 [+0.00%]
Total CPU difference: 18653.38277219859 / 17338.309942298663 [+7.58%]
products component :
Total MEMORY difference: 22693825 / 22655560 [+0.17%]
Total CPU difference: 5482.826746099975 / 5279.479442599965 [+3.85%]

There are no differences in images found by testdiff.
(0066266)
mkv (tester)
2017-05-18 14:22

Dear BugMaster,
Branch CR28727 is TESTED.
(0066770)
git (administrator)
2017-05-29 16:06

Branch CR28727 has been deleted by kgv.

SHA-1: 53080afa69f8f55cf190c454916475e55967a8b0

- Related Changesets
occt: master d29b2469
Timestamp: 2017-05-16 09:05:06
Author: abv
Committer: abv
Details ] Diff ]
0028727: Visualization, AIS_RadiusDimension - fix misprint in AIS_RadiusDimension::IsValidAnchor() check
mod - src/AIS/AIS_RadiusDimension.cxx Diff ] File ]
mod - src/AIS/AIS_RadiusDimension.hxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_RelationCommands.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-05-11 11:52 Max121 New Issue
2017-05-11 11:52 Max121 Assigned To => kgv
2017-05-16 12:04 kgv Severity minor => trivial
2017-05-16 12:04 kgv Target Version => 7.2.0
2017-05-16 12:04 kgv Summary Wrong logic in constructor of AIS_RadiusDimension => Visualization, AIS_RadiusDimension - fix misprint in AIS_RadiusDimension::IsValidAnchor() check
2017-05-16 12:05 git Note Added: 0066129
2017-05-16 12:05 kgv Note Added: 0066130
2017-05-16 12:05 kgv Assigned To kgv => bugmaster
2017-05-16 12:05 kgv Status new => resolved
2017-05-16 12:06 kgv Status resolved => reviewed
2017-05-16 12:10 kgv Relationship added child of 0024425
2017-05-16 12:10 kgv Product Version 7.1.0 => 6.7.0
2017-05-16 12:13 kgv Note Edited: 0066130 View Revisions
2017-05-16 12:30 mkv Assigned To bugmaster => mkv
2017-05-17 18:58 mkv Note Added: 0066225
2017-05-17 18:58 mkv Note Added: 0066226
2017-05-17 18:58 mkv Assigned To mkv => kgv
2017-05-17 18:58 mkv Status reviewed => assigned
2017-05-17 18:58 mkv Test case number => Not needed
2017-05-17 19:48 git Note Added: 0066231
2017-05-17 19:49 kgv Note Added: 0066232
2017-05-17 19:49 kgv Assigned To kgv => bugmaster
2017-05-17 19:49 kgv Status assigned => resolved
2017-05-17 19:49 kgv Status resolved => reviewed
2017-05-17 20:17 mkv Assigned To bugmaster => mkv
2017-05-18 14:22 mkv Note Added: 0066265
2017-05-18 14:22 mkv Note Added: 0066266
2017-05-18 14:22 mkv Assigned To mkv => bugmaster
2017-05-18 14:22 mkv Status reviewed => tested
2017-05-19 13:25 abv Changeset attached => occt master d29b2469
2017-05-19 13:25 abv Assigned To bugmaster => abv
2017-05-19 13:25 abv Status tested => verified
2017-05-19 13:25 abv Resolution open => fixed
2017-05-29 16:06 git Note Added: 0066770
2017-09-29 16:18 user533 Fixed in Version => 7.2.0
2017-09-29 16:25 user533 Status verified => closed
2018-03-20 12:43 kgv Relationship added parent of 0029595


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker