MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028690Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2017-04-26 10:452017-09-29 16:25
Reportermsv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028690: Section algorithm produces micro edge
DescriptionThis use case is given from the test boolean bsection M8. Two neighboring faces do not share common edge, and thus they are interfering. The section operation produces a micro edge build on one vertex with length 5.62798e-005.
Steps To Reproducerestore bug28690_m8_faces.brep a
plane f 20000 0 0 1 0 0
mkface f f
bsection r a f
checknbshapes r -edge 2
checkshape r
TagsNo tags attached.
Test case numberbugs modalg_6 bug28690, bug28690_1, bug28690_2, bug28690_3
Attached Files? file icon bug28690_m8_faces.brep (7,695 bytes) 2017-04-26 10:56
? file icon bug28690_gdml_G1_tore_sphere.brep (2,883 bytes) 2017-04-27 11:17
? file icon bug28690_m8_faces_1.brep (8,265 bytes) 2017-04-27 11:19
? file icon bug28690_m9_faces.brep (7,063 bytes) 2017-04-27 11:19

- Relationships
related to 0028775closedbugmaster Code duplication removal across the BOPAlgo_PaveFiller algorithm 

-  Notes
(0065533)
git (administrator)
2017-04-26 11:10

Branch CR28690 has been created by msv.

SHA-1: e8ea199039c922f438b87775a30ecb7c65a2117b


Detailed log of new commits:

Author: msv
Date: Wed Apr 26 11:09:51 2017 +0300

    0028690: Section algorithm produces micro edge
    
    In BOPAlgo_PaveFiller algorithm, prevent creation of vertex-edge interference if this vertex already has interference with one of vertices of this edge. This way we avoid creation of micro edges that are unwanted in the result shape.
(0065537)
msv (developer)
2017-04-26 11:20

Please review.
(0065538)
emv (developer)
2017-04-26 11:24

Reviewed.
(0065539)
git (administrator)
2017-04-26 11:26

Branch CR28690 has been updated forcibly by msv.

SHA-1: 8d57ecaab1cc70512e49214df82eca8d4c108f89
(0065544)
msv (developer)
2017-04-26 12:28

The fix is not ready yet.
(0065560)
git (administrator)
2017-04-26 15:54

Branch CR28690 has been updated forcibly by msv.

SHA-1: cdce3b9d7b66ffacd32d72f5156356c0c170c903
(0065561)
msv (developer)
2017-04-26 15:58
edited on: 2017-04-27 11:20

I have created the new version of the fix and 3 test cases:
bugs/modalg_6/bug28690,bug28690_1,bug28690_2.
The 2nd test does not work with this fix. It needs further improvement in PerformVE so that to check vertices coincidence after updating their tolerances.

(0065570)
git (administrator)
2017-04-26 18:08

Branch CR28690 has been updated forcibly by msv.

SHA-1: f90730fdc1d87d1aa5dbf799af6c1b5a9f9e7f1b
(0065587)
emv (developer)
2017-04-27 11:09

Another case when non-resolved interference between vertices leads to invalid result of Boolean operation:
restore bug28690_gdml_G1_tore_sphere.brep c
explode c
bclearobjects
bcleartools
baddobjects c_1 c_2
bfillds
bbuild result
checkshape result
(0065641)
git (administrator)
2017-04-28 13:34

Branch CR28690 has been updated forcibly by emv.

SHA-1: abbe786bca99e4a4b998391fb800fea43194626b
(0065642)
emv (developer)
2017-04-28 13:44

The branch CR28690 has been rebased on current master. New test case with the bug28690_gdml_G1_tore_sphere.brep input shape has been added.
(0066653)
emv (developer)
2017-05-26 16:16

The issue is fixed by the fix for the issue 0028775. The test cases for this issue are added into the patch for 0028775.
(0067090)
mkv (tester)
2017-06-05 16:31

Dear BugMaster,
The issue is TESTED in the branch CR28775_2.
(0067266)
bugmaster (administrator)
2017-06-09 14:17

Modification of code has been integrated with fix for issue CR28775
(0067360)
git (administrator)
2017-06-13 17:36

Branch CR28690 has been deleted by kgv.

SHA-1: abbe786bca99e4a4b998391fb800fea43194626b

- Issue History
Date Modified Username Field Change
2017-04-26 10:45 msv New Issue
2017-04-26 10:45 msv Assigned To => msv
2017-04-26 10:56 msv File Added: bug28690_m8_faces.brep
2017-04-26 10:56 msv Status new => assigned
2017-04-26 10:57 msv Steps to Reproduce Updated View Revisions
2017-04-26 11:10 git Note Added: 0065533
2017-04-26 11:20 msv Note Added: 0065537
2017-04-26 11:20 msv Assigned To msv => emv
2017-04-26 11:20 msv Status assigned => resolved
2017-04-26 11:24 emv Note Added: 0065538
2017-04-26 11:24 emv Assigned To emv => bugmaster
2017-04-26 11:24 emv Status resolved => reviewed
2017-04-26 11:26 git Note Added: 0065539
2017-04-26 12:13 apv Assigned To bugmaster => apv
2017-04-26 12:28 msv Note Added: 0065544
2017-04-26 12:28 msv Assigned To apv => msv
2017-04-26 12:28 msv Status reviewed => assigned
2017-04-26 15:54 git Note Added: 0065560
2017-04-26 15:55 msv Assigned To msv => emv
2017-04-26 15:58 msv Note Added: 0065561
2017-04-26 18:08 git Note Added: 0065570
2017-04-27 11:09 emv Note Added: 0065587
2017-04-27 11:17 emv File Added: bug28690_gdml_G1_tore_sphere.brep
2017-04-27 11:19 msv File Added: bug28690_m8_faces_1.brep
2017-04-27 11:19 msv File Added: bug28690_m9_faces.brep
2017-04-27 11:20 msv Note Edited: 0065561 View Revisions
2017-04-28 13:34 git Note Added: 0065641
2017-04-28 13:44 emv Note Added: 0065642
2017-05-25 16:06 emv Relationship added related to 0028775
2017-05-26 16:16 emv Note Added: 0066653
2017-05-31 13:14 mkv Test case number => bugs modalg_6 bug28690, bug28690_1, bug28690_2, bug28690_3
2017-06-05 16:31 mkv Note Added: 0067090
2017-06-05 16:31 mkv Assigned To emv => bugmaster
2017-06-05 16:31 mkv Status assigned => feedback
2017-06-05 16:31 mkv Status feedback => tested
2017-06-09 14:17 bugmaster Note Added: 0067266
2017-06-09 14:17 bugmaster Status tested => verified
2017-06-09 14:17 bugmaster Resolution open => fixed
2017-06-13 17:36 git Note Added: 0067360
2017-09-29 16:18 user533 Fixed in Version => 7.2.0
2017-09-29 16:25 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker