MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028681Open CASCADE[OCCT] OCCT:Shape Healingpublic2017-04-25 11:542018-03-08 09:05
Reportermsv 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.3.0Fixed in Version 
Summary0028681: UnifySameDomain distorts face boundary when merges a chain of small linear edges
DescriptionSee the test case "bugs modalg_6 bug28207". The 3rd operation is done with angular tolerance equal to 1 radian. The linear tolerance is as default 1e-7. The face boundary has significant distortion in the result shape.
Steps To Reproducerestore [locate_data_file bug28207_face.brep] a
unifysamedom r a -a 1
checkprops r -s 5.09613e+006
TagsNo tags attached.
Test case numberbugs modalg_6 bug28207
Attached Filespng file icon init_face.PNG (6,555 bytes) 2017-04-25 11:54
png file icon unified_face.PNG (6,755 bytes) 2017-04-25 11:54

- Relationships
parent of 0029544verifiedbugmaster Open CASCADE Regression vs 7.2.0: ShapeUpgrade_UnifySameDomain fails to merge linear edges 

-  Notes
(0065830)
git (administrator)
2017-05-11 13:57

Branch CR28681 has been created by isn.

SHA-1: eab278b5f4047b3f9ebd17848c9b93faddf558ce


Detailed log of new commits:

Author: isn
Date: Wed May 10 20:27:29 2017 +0300

    0028681: UnifySameDomain distorts face boundary when merges a chain of small linear edges
    
    GenerateSubSeq(..): take into account a linear tolerance
(0065864)
msv (developer)
2017-05-12 10:07

src\ShapeUpgrade\ShapeUpgrade_UnifySameDomain.cxx
- Make understandable names of parameters of the method IsMergingPossible 'bF', 'aFP', 'aRVec'. And start them with 'the'.
- 996: loop is extra, as trimmed curve cannot contain a trimmed curve.
- 1008: OK as it is.
- 1049: the line is extra.
- 1060: when IsClosed it is needed to call IsMergingPossible with 'isF' set to false.
(0065865)
msv (developer)
2017-05-12 10:08

Please create test case.
(0070494)
git (administrator)
2017-09-13 12:08

Branch CR28681_1 has been created by isn.

SHA-1: 0cc2df048d3e6b9ff2cae77d04f395dc69798431


No new revisions were added by this update.
(0070525)
msv (developer)
2017-09-14 11:42

Commit message must contain a clear description of changes. The phrase "GenerateSubSeq(..): take into account a linear tolerance" is very unclear.

- Again: Make understandable names of parameters of the method IsMergingPossible 'bF', 'aFP', 'aRVec'. And start them with 'the'.
(0070534)
git (administrator)
2017-09-14 15:28

Branch CR28681_1 has been updated by isn.

SHA-1: 36a72c18c1550fc55957f308557e35f6d65a44c5


Detailed log of new commits:

Author: isn
Date: Thu Sep 14 14:30:01 2017 +0300

    correction

(0070538)
git (administrator)
2017-09-14 15:34

Branch CR28681_2 has been created by isn.

SHA-1: c800f8cf25127aa73592366c7fef55dfa02bb21f


Detailed log of new commits:

Author: isn
Date: Mon Sep 11 16:53:31 2017 +0300

    0028681: UnifySameDomain distorts face boundary when merges a chain of small linear edges
    
    In case of sequence of edges based on lines (which are going to be unified into one line-segment), take into account a linear tolerance value.
(0070541)
msv (developer)
2017-09-14 15:52

tests/bugs/modalg_7/bug28681 is lost.
(0070542)
git (administrator)
2017-09-14 16:06

Branch CR28681_2 has been updated forcibly by isn.

SHA-1: f64c89460f0b014158a89e90e6facb69b7b7e110
(0070548)
isn (developer)
2017-09-14 17:06
edited on: 2017-09-14 17:07

job 'CR28681-master-isn' has been started

(0070568)
msv (developer)
2017-09-15 10:28

The tests failed:
bugs modalg_6 bug28207
bugs modalg_7 bug27004
Please update.
(0070602)
git (administrator)
2017-09-15 17:31

Branch CR28681_2 has been updated by isn.

SHA-1: aa2b6df48b169bc0c1d8dc63f5b5dbe30eb2638b


Detailed log of new commits:

Author: isn
Date: Fri Sep 15 17:31:09 2017 +0300

    get rid of regressions

(0070606)
msv (developer)
2017-09-15 18:08

Reviewed.
(0070616)
bugmaster (administrator)
2017-09-16 10:29

Combination -
OCCT branch : CR28681_2 SHA-1: aa2b6df48b169bc0c1d8dc63f5b5dbe30eb2638b
Products branch : master
was compiled on Linux, MacOS and Windows platforms and tested on optimize mode.

http://jenkins-test-10.nnov.opencascade.com/view/CR28681-master-isn [^]

Number of compiler warnings:
No new warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
No differences that require special attention

Image differences :
Please confirm image changes
http://occt-tests/CR28681-master-isn-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html [^]
http://occt-tests/CR28681-master-isn-OCCT/Debian70-64/diff-Debian70-64-image.html [^]
IMAGE bugs heal bug27729: bug27729.png differs
IMAGE bugs modalg_6 bug28207: bug28207.png differs

Memory differences :
No differences that require special attention
(0070624)
isn (developer)
2017-09-18 12:15

>> Please confirm image changes

This is OK, so reference images can be updated.
(0073056)
git (administrator)
2017-12-20 18:15

Branch CR28681_3 has been created by isn.

SHA-1: ad6df01bcdfc197b7cebbf8ae1ca17bea3a4416f


Detailed log of new commits:

Author: isn
Date: Fri Sep 15 17:31:09 2017 +0300

    get rid of regressions

Author: isn
Date: Mon Sep 11 16:53:31 2017 +0300

    0028681: UnifySameDomain distorts face boundary when merges a chain of small linear edges
    
    In case of sequence of edges based on lines (which are going to be unified into one line-segment), take into account a linear tolerance value.
(0073075)
isn (developer)
2017-12-21 16:47

Rebased (new branch is CR28681_3) and tested:
http://jenkins-test-10.nnov.opencascade.com/view/CR28681_3-master-isn/ [^]
There are some differences on linux (http://occt-tests/CR28681_3-master-isn-Products/Debian70-64/diff_summary.html [^]), but it looks like some kind of instability since Dxf-reader don't use unifysamedom.
(0073080)
msv (developer)
2017-12-22 10:09

Remarks:
- Remove the test bug28681, as it repeats the test bug28207.
- Improve the test bug28207, adding checkprops, and also putting the parameter "-t" in the commands to show ability of the algorithm to simplify such kind of shapes.

The test dxf read bug25988_14 always shows differences on both platforms.
(0073272)
git (administrator)
2018-01-09 16:31

Branch CR28681_4 has been created by isn.

SHA-1: 9766cb806db94110c8c3caecce087b166fd9c497


Detailed log of new commits:

Author: isn
Date: Tue Jan 9 15:31:52 2018 +0300

    updates of USD-tests

Author: isn
Date: Fri Sep 15 17:31:09 2017 +0300

    get rid of regressions

Author: isn
Date: Mon Sep 11 16:53:31 2017 +0300

    0028681: UnifySameDomain distorts face boundary when merges a chain of small linear edges
    
    In case of sequence of edges based on lines (which are going to be unified into one line-segment), take into account a linear tolerance value.
(0073349)
msv (developer)
2018-01-11 12:57

Reviewed.
(0073357)
apn (administrator)
2018-01-11 14:50

Combination -
OCCT branch : CR28681_4 SHA - 9766cb806db94110c8c3caecce087b166fd9c497
Products branch : master SHA - c667ca9e3bc920614b06911e337a09899f80aa2f
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

Test case:
bugs modalg_6 bug28207 - OK

CPU differences:
Debian70-64:
OCCT
Total CPU difference: 18557.969999999677 / 18498.959999999654 [+0.32%]
CPU bugs modalg_6 bug28207: 0.87 / 0.16 [+443.75%] - caused by significant changes in test case
Products
Total CPU difference: 7518.550000000003 / 7484.560000000007 [+0.45%]
Windows-64-VC10:
OCCT
Total CPU difference: 17995.698156298648 / 17960.90993329856 [+0.19%]
CPU bugs modalg_6 bug28207: 0.936006 / 0.1716011 [+445.45%] - caused by significant changes in test case
Products
Total CPU difference: 8011.509355499981 / 8020.448212799986 [-0.11%]

Image differences :
IMAGE bugs heal bug27729: bug27729.png differs
IMAGE bugs modalg_6 bug28207: bug28207.png differs
Differences in images were confirmed.

Memory differences :
No differences that require special attention
(0073760)
git (administrator)
2018-02-05 11:39

Branch CR28681 has been deleted by kgv.

SHA-1: eab278b5f4047b3f9ebd17848c9b93faddf558ce
(0073761)
git (administrator)
2018-02-05 11:39

Branch CR28681_1 has been deleted by kgv.

SHA-1: 36a72c18c1550fc55957f308557e35f6d65a44c5
(0073762)
git (administrator)
2018-02-05 11:39

Branch CR28681_2 has been deleted by kgv.

SHA-1: aa2b6df48b169bc0c1d8dc63f5b5dbe30eb2638b
(0073763)
git (administrator)
2018-02-05 11:39

Branch CR28681_3 has been deleted by kgv.

SHA-1: ad6df01bcdfc197b7cebbf8ae1ca17bea3a4416f
(0073764)
git (administrator)
2018-02-05 11:39

Branch CR28681_4 has been deleted by kgv.

SHA-1: 9766cb806db94110c8c3caecce087b166fd9c497

- Related Changesets
occt: master 1f59dfa9
Timestamp: 2017-09-11 13:53:31
Author: isn
Committer: apn
Details ] Diff ]
0028681: UnifySameDomain distorts face boundary when merges a chain of small linear edges

In case of sequence of edges based on lines (which are going to be unified into one line-segment), take into account a linear tolerance value.
Get rid of regressions.
Updates of USD-tests.
mod - src/ShapeUpgrade/ShapeUpgrade_UnifySameDomain.cxx Diff ] File ]
mod - tests/bugs/modalg_6/bug28207 Diff ] File ]
mod - tests/bugs/modalg_7/bug27004 Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-04-25 11:54 msv New Issue
2017-04-25 11:54 msv Assigned To => msv
2017-04-25 11:54 msv File Added: init_face.PNG
2017-04-25 11:54 msv File Added: unified_face.PNG
2017-04-25 11:55 msv Relationship added related to 0028207
2017-05-05 18:43 msv Assigned To msv => isn
2017-05-05 18:43 msv Status new => assigned
2017-05-11 13:57 git Note Added: 0065830
2017-05-11 14:02 isn Assigned To isn => msv
2017-05-11 14:02 isn Status assigned => resolved
2017-05-12 10:07 msv Note Added: 0065864
2017-05-12 10:07 msv Assigned To msv => isn
2017-05-12 10:07 msv Status resolved => assigned
2017-05-12 10:08 msv Note Added: 0065865
2017-07-20 13:00 msv Target Version 7.2.0 => 7.3.0
2017-07-20 14:05 msv Target Version 7.3.0 => 7.2.0
2017-08-28 18:37 abv Target Version 7.2.0 => 7.3.0
2017-09-13 12:08 git Note Added: 0070494
2017-09-13 12:11 isn Assigned To isn => msv
2017-09-13 12:11 isn Status assigned => resolved
2017-09-14 11:42 msv Note Added: 0070525
2017-09-14 11:42 msv Assigned To msv => isn
2017-09-14 11:42 msv Status resolved => assigned
2017-09-14 15:28 git Note Added: 0070534
2017-09-14 15:34 git Note Added: 0070538
2017-09-14 15:35 isn Assigned To isn => msv
2017-09-14 15:35 isn Status assigned => resolved
2017-09-14 15:52 msv Note Added: 0070541
2017-09-14 15:52 msv Assigned To msv => isn
2017-09-14 15:52 msv Status resolved => assigned
2017-09-14 16:06 git Note Added: 0070542
2017-09-14 16:09 isn Assigned To isn => msv
2017-09-14 16:09 isn Status assigned => resolved
2017-09-14 17:06 isn Note Added: 0070548
2017-09-14 17:07 isn Note Edited: 0070548 View Revisions
2017-09-15 10:28 msv Note Added: 0070568
2017-09-15 10:28 msv Assigned To msv => isn
2017-09-15 10:28 msv Status resolved => assigned
2017-09-15 17:31 git Note Added: 0070602
2017-09-15 17:55 isn Assigned To isn => msv
2017-09-15 17:55 isn Status assigned => resolved
2017-09-15 18:08 msv Note Added: 0070606
2017-09-15 18:08 msv Assigned To msv => bugmaster
2017-09-15 18:08 msv Status resolved => reviewed
2017-09-16 10:11 bugmaster Test case number => bugs modalg_7 bug28681
2017-09-16 10:29 bugmaster Note Added: 0070616
2017-09-16 10:29 bugmaster Status reviewed => feedback
2017-09-16 10:45 bugmaster Assigned To bugmaster => isn
2017-09-18 12:15 isn Note Added: 0070624
2017-09-18 12:16 isn Assigned To isn => bugmaster
2017-09-18 12:16 isn Status feedback => assigned
2017-12-20 18:15 git Note Added: 0073056
2017-12-21 16:47 isn Note Added: 0073075
2017-12-21 16:47 isn Assigned To bugmaster => msv
2017-12-21 16:47 isn Status assigned => resolved
2017-12-22 10:09 msv Note Added: 0073080
2017-12-22 10:09 msv Assigned To msv => isn
2017-12-22 10:09 msv Status resolved => assigned
2018-01-09 16:31 git Note Added: 0073272
2018-01-10 12:37 isn Assigned To isn => msv
2018-01-10 12:37 isn Status assigned => resolved
2018-01-11 12:57 msv Note Added: 0073349
2018-01-11 12:57 msv Assigned To msv => bugmaster
2018-01-11 12:57 msv Status resolved => reviewed
2018-01-11 14:50 apn Test case number bugs modalg_7 bug28681 => bugs modalg_6 bug28207
2018-01-11 14:50 apn Note Added: 0073357
2018-01-11 14:50 apn Status reviewed => tested
2018-01-13 15:26 apn Changeset attached => occt master 1f59dfa9
2018-01-13 15:26 apn Assigned To bugmaster => apn
2018-01-13 15:26 apn Status tested => verified
2018-01-13 15:26 apn Resolution open => fixed
2018-02-05 11:39 git Note Added: 0073760
2018-02-05 11:39 git Note Added: 0073761
2018-02-05 11:39 git Note Added: 0073762
2018-02-05 11:39 git Note Added: 0073763
2018-02-05 11:39 git Note Added: 0073764
2018-02-18 23:42 abv Target Version 7.3.0 => 7.4.0*
2018-02-20 12:58 aiv Target Version 7.4.0* => 7.3.0
2018-03-05 15:32 emv Relationship added parent of 0029544
2018-03-08 09:05 abv Relationship added related to 0027004


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker