MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028677Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2017-04-24 13:092017-09-29 16:25
Reporternbv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028677: Avoid change of wire orientation in BRepLib_MakeFace if the wire is open
DescriptionBRepLib_MakeFace does not allow to create a face as hole. I.e. if source closed wire has orientation that the material of future face is outside then this wire will be reversed by the method BRepLib_MakeFace::CheckInside().

However, it is impossible for open wire to understand where (from what side) the material of future face will be located. Therefore, there is no point in executing BRepLib_MakeFace::CheckInside() method.

In this case, location of material will be determined from the orientation of the wire (the source wire must be oriented correctly). If we go along the wire, the material will be on the left side.
Steps To ReproduceNew test case is not required.
TagsNo tags attached.
Test case numberNot needed
Attached Filespng file icon bugs modalg_6 bug26481.PNG (11,724 bytes) 2017-04-27 17:14
png file icon bugs moddata_1 bug20823.PNG (13,332 bytes) 2017-04-27 17:15

- Relationships

-  Notes
(0065468)
git (administrator)
2017-04-24 13:49

Branch CR28677 has been created by nbv.

SHA-1: a4ed1a7d8207097b9b25f144b4c233e285374cd7


Detailed log of new commits:

Author: nbv
Date: Mon Apr 24 13:48:28 2017 +0300

    0028677: Avoid change of wire orientation in BRepLib_MakeFace if the wire is open
    
    Method BRepLib_MakeFace::CheckInside() is not called for open wire.
(0065469)
nbv (developer)
2017-04-24 13:50

Dear Mikhail,

Please review CR28677 branch.
(0065470)
git (administrator)
2017-04-24 13:59

Branch CR28677 has been updated forcibly by nbv.

SHA-1: 2295bd6cf48208e14863b2215eacf902e8af02d6
(0065474)
msv (developer)
2017-04-24 14:21

Reviewed.
(0065503)
apv (tester)
2017-04-25 14:17

Dear BugMaster,

Branch CR28677 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 2295bd6cf48208e14863b2215eacf902e8af02d6

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1178

Regressions/Differences:
http://occt-tests/CR28677-master-OCCT/Debian70-64/summary.html [^]
http://occt-tests/CR28677-master-OCCT/Windows-64-VC10/summary.html [^]
bugs modalg_5 bug25298_01, bug25298_02, bug25334_3, bug25334_4, bug25334_9, bug25334_10
bugs modalg_6 bug6768, bug26296_5
offset wire_unclosed_outside_0_005 B6
offset wire_unclosed_outside_0_025 B6
offset wire_unclosed_outside_0_075 A1, B6

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 92018184 / 91849822 [+0.18%]
Total CPU difference: 19461.660000000236 / 19556.190000000326 [-0.48%]

Testing on Windows:
Total MEMORY difference: 58033693 / 58034445 [-0.00%]
Total CPU difference: 18135.25665089857 / 18123.182173498568 [+0.07%]

There are differences in images found by testdiff:
http://occt-tests/CR28677-master-OCCT/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR28677-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html [^]
bugs moddata_1 bug20823
bugs modalg_5 bug25298_02
bugs modalg_5 bug25298_01
bugs modalg_5 bug25334_3
bugs modalg_5 bug25334_9
bugs modalg_5 bug25334_4
bugs modalg_5 bug25334_10
bugs modalg_6 bug26296_5
bugs modalg_6 bug26481
(0065505)
apv (tester)
2017-04-25 14:19

Dear Nikolay,

Branch CR28677 has been rejected due to:
- regressions/differences/improvements
- differences in images
(0065525)
git (administrator)
2017-04-25 18:39

Branch CR28677 has been updated by nbv.

SHA-1: 5b3699f1ac0e78cb9ece87063ab0b504d8879c9e


Detailed log of new commits:

Author: nbv
Date: Tue Apr 25 15:57:12 2017 +0300

    Correction of test cases
    
    Documentation has been up-to-date.

(0065526)
nbv (developer)
2017-04-25 18:40

Dear Mikhail,

Please review the current state of CR28677 branch.
(0065541)
git (administrator)
2017-04-26 11:57

Branch CR28677 has been updated by nbv.

SHA-1: a2612823265feaac6d60b7e12df458fb3a95b86e


Detailed log of new commits:

Author: nbv
Date: Wed Apr 26 11:56:19 2017 +0300

    Correction in comment message.

(0065553)
msv (developer)
2017-04-26 15:06

Reviewed.
(0065618)
apv (tester)
2017-04-27 17:05

Dear BugMaster,

Branch CR28677 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: a2612823265feaac6d60b7e12df458fb3a95b86e

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1184

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 91587979 / 92245620 [-0.71%]
Total CPU difference: 19409.840000000208 / 19589.860000000295 [-0.92%]

Testing on Windows:
Total MEMORY difference: 58033974 / 58034193 [-0.00%]
Total CPU difference: 18119.51614999857 / 17968.101579398684 [+0.84%]

There are differences in images found by testdiff:
http://occt-tests/CR28677-master-OCCT/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR28677-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html [^]
bugs moddata_1 bug20823
bugs modalg_6 bug26481
(0065619)
apv (tester)
2017-04-27 17:06

Dear Nikolay,

Branch CR28677 has been rejected due to:
- differences in images
(0065621)
nbv (developer)
2017-04-27 17:25

New pictures respects the rule from bug description: "If we go along the wire, the material will be on the left side."

It can be seen in attached pictures (name of pictures correspond to the name of test cases). In every picture, "vori" DRAW-command is applied to the source wire (in order to show its real orientation).

As result,

1. bugs moddata_1 bug20823

New result of mkplane DRAW-command is correct.

2. bugs modalg_6 bug26481

Openoffset wit positive offset-value (+10.) is created in correct direction.

---

So, found differences in images are not regressions and shall be applied.
(0065623)
msv (developer)
2017-04-27 17:36
edited on: 2017-04-27 17:36

Looking at bug #26481, I would leave the picture as it is. It is better to invert sign of offset in the script.

(0065625)
git (administrator)
2017-04-27 17:47

Branch CR28677_1 has been created by nbv.

SHA-1: 96888be1bb6126d9540bc871b9af942bf9448f67


Detailed log of new commits:

Author: nbv
Date: Mon Apr 24 13:48:28 2017 +0300

    0028677: Avoid change of wire orientation in BRepLib_MakeFace if the wire is open
    
    Method BRepLib_MakeFace::CheckInside() is not called for open wire. So, if the input wire is open its orientation is not changed in the result face.
    
    Documentation has been up-to-date.
    
    Correction of test cases
(0065627)
git (administrator)
2017-04-27 17:57

Branch CR28677 has been updated by nbv.

SHA-1: b2dbb1f33ad9fe9e06b69a5fd33f20b1da8cf8c9


Detailed log of new commits:

Author: nbv
Date: Thu Apr 27 17:56:26 2017 +0300

    Correction of test case.

(0065628)
nbv (developer)
2017-04-27 17:59
edited on: 2017-04-27 17:59

Dear Mikhail,

Please review the current state of CR28677 branch.

-----

Dear BugMaster,

Please use CR28677_1 branch for integration. Branches CR28677_1 and CR28677 differ by commit-message only.

(0065629)
msv (developer)
2017-04-27 18:02

Reviewed.
Alexey, test the only case bugs modalg_6 bug26481. No recompilation is needed.
(0065639)
apv (tester)
2017-04-28 13:28
edited on: 2017-04-28 13:28

Test case bugs modalg_6 bug26481 has been retested with the following results:
http://occt-tests/CR28677-master-OCCT/Debian70-64/bugs/modalg_6/bug26481.html [^]
http://occt-tests/CR28677-master-OCCT/Windows-64-VC10/bugs/modalg_6/bug26481.html [^]

(0065640)
nbv (developer)
2017-04-28 13:31

Just for remember:

Dear BugMaster,

Please use CR28677_1 branch for integration. Branches CR28677_1 and CR28677 differ by commit-message only.
(0065748)
git (administrator)
2017-05-04 13:10

Branch CR28677_1 has been updated forcibly by nbv.

SHA-1: 83bea504ca19da0c96fe487f67b836b9b13555b9
(0065974)
git (administrator)
2017-05-12 11:36

Branch CR28677 has been deleted by kgv.

SHA-1: b2dbb1f33ad9fe9e06b69a5fd33f20b1da8cf8c9
(0065980)
git (administrator)
2017-05-12 11:40

Branch CR28677_1 has been deleted by kgv.

SHA-1: 83bea504ca19da0c96fe487f67b836b9b13555b9

- Related Changesets
occt: master b608f6a5
Timestamp: 2017-04-24 10:48:28
Author: nbv
Committer: bugmaster
Details ] Diff ]
0028677: Avoid change of wire orientation in BRepLib_MakeFace if the wire is open

Method BRepLib_MakeFace::CheckInside() is not called for open wire. So, if the input wire is open its orientation is not changed in the result face.
mod - dox/dev_guides/upgrade/upgrade.md Diff ] File ]
mod - src/BRepFill/BRepFill_OffsetWire.hxx Diff ] File ]
mod - src/BRepLib/BRepLib_MakeFace.cxx Diff ] File ]
mod - tests/bugs/modalg_5/bug25298_01 Diff ] File ]
mod - tests/bugs/modalg_5/bug25298_02 Diff ] File ]
mod - tests/bugs/modalg_5/bug25334_10 Diff ] File ]
mod - tests/bugs/modalg_5/bug25334_3 Diff ] File ]
mod - tests/bugs/modalg_5/bug25334_4 Diff ] File ]
mod - tests/bugs/modalg_5/bug25334_9 Diff ] File ]
mod - tests/bugs/modalg_6/bug26296_5 Diff ] File ]
mod - tests/bugs/modalg_6/bug26481 Diff ] File ]
mod - tests/bugs/modalg_6/bug6768 Diff ] File ]
mod - tests/offset/wire_unclosed_outside_0_005/B6 Diff ] File ]
mod - tests/offset/wire_unclosed_outside_0_025/B6 Diff ] File ]
mod - tests/offset/wire_unclosed_outside_0_075/A1 Diff ] File ]
mod - tests/offset/wire_unclosed_outside_0_075/B6 Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-04-24 13:09 nbv New Issue
2017-04-24 13:09 nbv Assigned To => msv
2017-04-24 13:20 nbv Assigned To msv => nbv
2017-04-24 13:20 nbv Status new => assigned
2017-04-24 13:38 msv Summary Avoid calling BRepLib_MakeFace::CheckInside() metfod when creation of face from open wire => Avoid change of wire orientation in BRepLib_MakeFace if the wire is open
2017-04-24 13:38 msv Description Updated View Revisions
2017-04-24 13:49 git Note Added: 0065468
2017-04-24 13:50 nbv Note Added: 0065469
2017-04-24 13:50 nbv Assigned To nbv => msv
2017-04-24 13:50 nbv Status assigned => resolved
2017-04-24 13:59 git Note Added: 0065470
2017-04-24 14:21 msv Note Added: 0065474
2017-04-24 14:21 msv Assigned To msv => bugmaster
2017-04-24 14:21 msv Status resolved => reviewed
2017-04-24 14:27 apv Assigned To bugmaster => apv
2017-04-24 17:27 apv Test case number => Not needed
2017-04-25 14:17 apv Note Added: 0065503
2017-04-25 14:17 apv Assigned To apv => nbv
2017-04-25 14:17 apv Status reviewed => assigned
2017-04-25 14:19 apv Note Added: 0065505
2017-04-25 18:39 git Note Added: 0065525
2017-04-25 18:40 nbv Note Added: 0065526
2017-04-25 18:40 nbv Assigned To nbv => msv
2017-04-25 18:40 nbv Status assigned => resolved
2017-04-26 11:57 git Note Added: 0065541
2017-04-26 15:06 msv Note Added: 0065553
2017-04-26 15:06 msv Assigned To msv => bugmaster
2017-04-26 15:06 msv Status resolved => reviewed
2017-04-26 15:32 apv Assigned To bugmaster => apv
2017-04-27 17:05 apv Note Added: 0065618
2017-04-27 17:05 apv Assigned To apv => nbv
2017-04-27 17:05 apv Status reviewed => assigned
2017-04-27 17:06 apv Note Added: 0065619
2017-04-27 17:14 nbv File Added: bugs modalg_6 bug26481.PNG
2017-04-27 17:15 nbv File Added: bugs moddata_1 bug20823.PNG
2017-04-27 17:25 nbv Note Added: 0065621
2017-04-27 17:26 nbv Assigned To nbv => msv
2017-04-27 17:26 nbv Status assigned => resolved
2017-04-27 17:36 msv Note Added: 0065623
2017-04-27 17:36 msv Assigned To msv => nbv
2017-04-27 17:36 msv Status resolved => assigned
2017-04-27 17:36 msv Note Edited: 0065623 View Revisions
2017-04-27 17:47 git Note Added: 0065625
2017-04-27 17:48 nbv Note Added: 0065626
2017-04-27 17:48 nbv Assigned To nbv => msv
2017-04-27 17:48 nbv Status assigned => resolved
2017-04-27 17:56 nbv Note Deleted: 0065626
2017-04-27 17:57 git Note Added: 0065627
2017-04-27 17:59 nbv Note Added: 0065628
2017-04-27 17:59 nbv Note Edited: 0065628 View Revisions
2017-04-27 18:02 msv Note Added: 0065629
2017-04-27 18:02 msv Assigned To msv => apv
2017-04-27 18:02 msv Status resolved => reviewed
2017-04-28 13:28 apv Note Added: 0065639
2017-04-28 13:28 apv Assigned To apv => bugmaster
2017-04-28 13:28 apv Status reviewed => tested
2017-04-28 13:28 apv Note Edited: 0065639 View Revisions
2017-04-28 13:31 nbv Note Added: 0065640
2017-05-04 13:10 git Note Added: 0065748
2017-05-05 13:34 bugmaster Changeset attached => occt master b608f6a5
2017-05-05 13:34 bugmaster Status tested => verified
2017-05-05 13:34 bugmaster Resolution open => fixed
2017-05-12 11:36 git Note Added: 0065974
2017-05-12 11:40 git Note Added: 0065980
2017-09-29 16:19 user533 Fixed in Version => 7.2.0
2017-09-29 16:25 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker