MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028646Open CASCADE[OCCT] OCCT:DRAWpublic2017-04-11 11:392017-09-29 16:25
Reporterkgv 
Assigned Toabv 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.2.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028646: Draw Harness, ViewerTest - rename vsetfilter command with vselfilter
Description#0028365 introduced new command vsetfilter for testing selection filters.
However the command name sounds misnamed - vselfilter would be more expected since command is related to selection.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0066153)
git (administrator)
2017-05-16 16:37

Branch CR28646 has been created by kgv.

SHA-1: d194e090b47eb95b65be6e9b21ad1726eb967d5e


Detailed log of new commits:

Author: kgv
Date: Tue May 16 16:37:18 2017 +0300

    0028646: Draw Harness, ViewerTest - rename vsetfilter command with vselfilter
    
    TopAbs::ShapeTypeToString() is now used instead of duplicating TopAbs_ShapeEnum printing code.
    vselmode now accepts shape type string for activating standard AIS_Shape selection modes.
(0066154)
kgv (developer)
2017-05-16 16:37

Please test the patch.
(0066216)
apv (tester)
2017-05-17 16:59

Dear BugMaster,

Branch CR28646 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: d194e090b47eb95b65be6e9b21ad1726eb967d5e

Number of compiler warnings:
occt component:
   Linux: 1 (0 on master)
   Windows: 1 (0 on master)
   MasOS: 1 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1192

New warning has been detected during OCCT component building
on Linux:
http://jenkins-test-05.nnov.opencascade.com/view/CR28646-master/job/CR28646-master-OCCT-Debian70-64-opt-compile/1/warnings19Result/ [^]
on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR28646-master/job/CR28646-master-OCCT-Windows-64-VC10-opt-compile/2/warnings38Result/ [^]
on MacOS:
http://jenkins-test-05.nnov.opencascade.com/view/CR28646-master/job/CR28646-master-OCCT-MacOS-opt-compile/1/warnings8Result/ [^]

Regressions/Differences:
http://occt-tests/CR28646-master-OCCT/Debian70-64/summary.html [^]
http://occt-tests/CR28646-master-OCCT/Windows-64-VC10/summary.html [^]
bugs vis bug12121

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 92279461 / 91759353 [+0.57%]
Total CPU difference: 18808.670000000246 / 18651.250000000364 [+0.84%]

Testing on Windows:
Total MEMORY difference: 58422506 / 58423846 [-0.00%]
Total CPU difference: 17466.152761798672 / 17338.185141498663 [+0.74%]
(0066217)
apv (tester)
2017-05-17 17:01

Dear Kirill,

Branch CR28646 has been rejected due to:
- additional warnings
- regressions/differences/improvements
(0066219)
git (administrator)
2017-05-17 17:22

Branch CR28646 has been updated by kgv.

SHA-1: cd6f97c6b803b15f42a90bed4f29efb8173a8b3c


Detailed log of new commits:

Author: kgv
Date: Wed May 17 17:21:53 2017 +0300

    // fix error in test script and compiler warning

(0066220)
kgv (developer)
2017-05-17 17:22

Please check updated patch (only modified test case can be re-checked).
(0066262)
apv (tester)
2017-05-18 13:49

Dear BugMaster,

Branch CR28646 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: cd6f97c6b803b15f42a90bed4f29efb8173a8b3c

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1183

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 92335574 / 91777456 [+0.61%]
Total CPU difference: 18751.12000000032 / 18651.940000000362 [+0.53%]

Testing on Windows:
Total MEMORY difference: 58421648 / 58423846 [-0.00%]
Total CPU difference: 17444.14102069858 / 17338.185141498663 [+0.61%]
(0066760)
git (administrator)
2017-05-29 16:05

Branch CR28646 has been deleted by kgv.

SHA-1: cd6f97c6b803b15f42a90bed4f29efb8173a8b3c

- Related Changesets
occt: master d2e60688
Timestamp: 2017-05-16 13:37:18
Author: abv
Committer: abv
Details ] Diff ]
0028646: Draw Harness, ViewerTest - rename vsetfilter command with vselfilter

TopAbs::ShapeTypeToString() is now used instead of duplicating TopAbs_ShapeEnum printing code.
vselmode now accepts shape type string for activating standard AIS_Shape selection modes.
mod - src/BOPDS/BOPDS_ShapeInfo.cxx Diff ] File ]
mod - src/BRepCheck/BRepCheck_Shell.cxx Diff ] File ]
mod - src/DBRep/DBRep_DrawableShape.cxx Diff ] File ]
mod - src/DNaming/DNaming_ModelingCommands.cxx Diff ] File ]
mod - src/MoniTool/MoniTool_SignShape.cxx Diff ] File ]
mod - src/QABugs/QABugs_1.cxx Diff ] File ]
mod - src/TopAbs/TopAbs.cxx Diff ] File ]
mod - src/TopAbs/TopAbs.hxx Diff ] File ]
mod - src/TopOpeBRepBuild/TopOpeBRepBuild_ShapeSet.cxx Diff ] File ]
mod - src/TopOpeBRepBuild/TopOpeBRepBuild_WireEdgeSet.cxx Diff ] File ]
mod - src/TopOpeBRepDS/TopOpeBRepDS.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ObjectCommands.cxx Diff ] File ]
mod - tests/bugs/vis/bug12121 Diff ] File ]
mod - tests/bugs/vis/bug28365 Diff ] File ]
rm - tests/bugs/vis/bug328 Diff ] File ]
mod - tests/v3d/face/F3 Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-04-11 11:39 kgv New Issue
2017-04-11 11:39 kgv Assigned To => kgv
2017-04-11 11:40 kgv Relationship added child of 0028365
2017-05-16 16:37 git Note Added: 0066153
2017-05-16 16:37 kgv Note Added: 0066154
2017-05-16 16:37 kgv Assigned To kgv => bugmaster
2017-05-16 16:37 kgv Status new => resolved
2017-05-16 16:38 kgv Status resolved => reviewed
2017-05-16 16:59 apv Assigned To bugmaster => apv
2017-05-17 16:56 apv Test case number => Not needed
2017-05-17 16:59 apv Note Added: 0066216
2017-05-17 16:59 apv Assigned To apv => kgv
2017-05-17 16:59 apv Status reviewed => assigned
2017-05-17 17:01 apv Note Added: 0066217
2017-05-17 17:22 git Note Added: 0066219
2017-05-17 17:22 kgv Note Added: 0066220
2017-05-17 17:22 kgv Assigned To kgv => bugmaster
2017-05-17 17:22 kgv Status assigned => resolved
2017-05-17 17:22 kgv Status resolved => reviewed
2017-05-17 17:38 apv Assigned To bugmaster => apv
2017-05-18 13:49 apv Note Added: 0066262
2017-05-18 13:49 apv Assigned To apv => bugmaster
2017-05-18 13:49 apv Status reviewed => tested
2017-05-19 13:25 abv Changeset attached => occt master d2e60688
2017-05-19 13:25 abv Assigned To bugmaster => abv
2017-05-19 13:25 abv Status tested => verified
2017-05-19 13:25 abv Resolution open => fixed
2017-05-29 16:05 git Note Added: 0066760
2017-09-29 16:18 user533 Fixed in Version => 7.2.0
2017-09-29 16:25 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker