MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028641Open CASCADE[OCCT] OCCT:Data Exchangepublic2017-04-07 13:552017-09-29 16:25
Reporterika 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028641: Data Exchange - Support alpha-channel of color
DescriptionXCAF data structure should be extended to store colors in RGBA formats
Steps To Reproducebugs xde bug28641
TagsNo tags attached.
Test case numberbugs xde bug28641
Attached Files

- Relationships
parent of 0028738closedbugmaster Open CASCADE Data Exchange, XCAFPrs_Style - add transparency property 

-  Notes
(0065029)
git (administrator)
2017-04-07 14:01

Branch CR28641 has been created by ika.

SHA-1: 0b5fed1fa145926e8890e335513d1a8b6a449e06


Detailed log of new commits:

Author: ika
Date: Mon Mar 27 10:18:05 2017 +0300

    0028641: Data Exchange - Support alpha-channel of color
    
    Use Quantity_ColorRGBA instead Quantity_Color in XCAFDoc_Color attribute
    Add methods to color tool for processing RGBA
    Update Color driver
    Update Draw commands
(0065030)
ika (developer)
2017-04-07 14:02

Dear GKA,

could you please review branch CR28641?
(0065031)
git (administrator)
2017-04-07 14:24

Branch CR28641 has been updated forcibly by ika.

SHA-1: 52860d8b2252c08f8d55471601121ede4428f202
(0065032)
gka (developer)
2017-04-07 14:29

Branch CR28641 is ready to be tested
(0065035)
git (administrator)
2017-04-07 15:00

Branch CR28641 has been updated forcibly by ika.

SHA-1: b00a51f76d3bbca5884904754c95e3bd05cf8a59
(0065084)
mkv (tester)
2017-04-10 13:36

Dear BugMaster,
Branch CR28641 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: b00a51f76d3bbca5884904754c95e3bd05cf8a59

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1191

Regressions/Differences/Improvements:
http://occt-tests/CR28641-master-Products/Debian70-64/sat/read_parallel_2/D9.html [^]
sat read_parallel_2 D9: FAILED

Testing cases:
http://occt-tests/CR28641-master-OCCT/Debian70-64/bugs/xde/bug28641.html [^]
http://occt-tests/CR28641-master-OCCT/Windows-64-VC10/bugs/xde/bug28641.html [^]
bugs xde bug28641: FAILED

Testing on Linux:
occt component :
Total MEMORY difference: 91479940 / 91293001 [+0.20%]
Total CPU difference: 19885.000000000284 / 19613.25000000024 [+1.39%]
products component :
Total MEMORY difference: 30769770 / 30740952 [+0.09%]
Total CPU difference: 5403.739999999984 / 5352.329999999984 [+0.96%]
Testing on Windows:
occt component :
Total MEMORY difference: 57857875 / 57855806 [+0.00%]
Total CPU difference: 18550.328511598444 / 18063.40259029849 [+2.70%]
products component :
Total MEMORY difference: 22295374 / 22257195 [+0.17%]
Total CPU difference: 5401.612625499983 / 5313.206858799958 [+1.66%]

There are no differences in images found by testdiff.
(0065085)
mkv (tester)
2017-04-10 13:36

Dear ika,
Branch CR28641 has been rejected due to:
- failed test-case for issue
- regressions/differences/improvements
(0065152)
git (administrator)
2017-04-11 18:43

Branch CR28641 has been updated forcibly by ika.

SHA-1: 58c4ad9b11cf9a2ce0618b4fa457132549f5b4f8
(0065153)
ika (developer)
2017-04-11 18:44

Dear MKV,

the problem was fixed.
(0065174)
mkv (tester)
2017-04-12 12:47

Dear BugMaster,
Branch CR28641 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 58c4ad9b11cf9a2ce0618b4fa457132549f5b4f8

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1194

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
http://occt-tests/CR28641-master-OCCT/Debian70-64/bugs/xde/bug28641.html [^]
http://occt-tests/CR28641-master-OCCT/Windows-64-VC10/bugs/xde/bug28641.html [^]
bugs xde bug28641: OK

Testing on Linux:
occt component :
Total MEMORY difference: 91438470 / 91391087 [+0.05%]
Total CPU difference: 19785.720000000314 / 19613.440000000242 [+0.88%]
products component :
Total MEMORY difference: 30848421 / 30770563 [+0.25%]
Total CPU difference: 5372.599999999975 / 5358.419999999984 [+0.26%]
Testing on Windows:
occt component :
Total MEMORY difference: 57858780 / 57855806 [+0.01%]
Total CPU difference: 18595.600001798437 / 18063.40259029849 [+2.95%]
products component :
Total MEMORY difference: 22295378 / 22257195 [+0.17%]
Total CPU difference: 5405.9806534999825 / 5313.206858799958 [+1.75%]

There are no differences in images found by testdiff.
(0065175)
mkv (tester)
2017-04-12 12:47

Dear BugMaster,
Branch CR28641 is TESTED.
(0065961)
git (administrator)
2017-05-12 11:36

Branch CR28641 has been deleted by kgv.

SHA-1: 58c4ad9b11cf9a2ce0618b4fa457132549f5b4f8

- Related Changesets
occt: master 973d410e
Timestamp: 2017-03-27 07:18:05
Author: ika
Committer: bugmaster
Details ] Diff ]
0028641: Data Exchange - Support alpha-channel of color

Use Quantity_ColorRGBA instead Quantity_Color in XCAFDoc_Color attribute
Add methods to color tool for processing RGBA
Update Color driver
Update Draw commands
mod - src/BinMXCAFDoc/BinMXCAFDoc_ColorDriver.cxx Diff ] File ]
mod - src/XCAFDoc/XCAFDoc_Color.cxx Diff ] File ]
mod - src/XCAFDoc/XCAFDoc_Color.hxx Diff ] File ]
mod - src/XCAFDoc/XCAFDoc_ColorTool.cxx Diff ] File ]
mod - src/XCAFDoc/XCAFDoc_ColorTool.hxx Diff ] File ]
mod - src/XDEDRAW/XDEDRAW.cxx Diff ] File ]
mod - src/XDEDRAW/XDEDRAW_Colors.cxx Diff ] File ]
add - tests/bugs/xde/bug28641 Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-04-07 13:55 ika New Issue
2017-04-07 13:55 ika Assigned To => ika
2017-04-07 13:56 ika Relationship added related to 0028521
2017-04-07 14:01 git Note Added: 0065029
2017-04-07 14:02 ika Note Added: 0065030
2017-04-07 14:02 ika Assigned To ika => gka
2017-04-07 14:02 ika Status new => resolved
2017-04-07 14:02 ika Steps to Reproduce Updated View Revisions
2017-04-07 14:24 git Note Added: 0065031
2017-04-07 14:29 gka Note Added: 0065032
2017-04-07 14:29 gka Assigned To gka => bugmaster
2017-04-07 14:29 gka Status resolved => reviewed
2017-04-07 14:35 mkv Assigned To bugmaster => mkv
2017-04-07 15:00 git Note Added: 0065035
2017-04-07 15:00 ika Steps to Reproduce Updated View Revisions
2017-04-07 15:13 ika Relationship deleted related to 0028521
2017-04-07 15:13 ika Relationship added duplicate of 0028521
2017-04-10 13:36 mkv Note Added: 0065084
2017-04-10 13:36 mkv Note Added: 0065085
2017-04-10 13:36 mkv Assigned To mkv => ika
2017-04-10 13:36 mkv Status reviewed => feedback
2017-04-10 13:37 mkv Test case number => bugs xde bug28641
2017-04-11 18:43 git Note Added: 0065152
2017-04-11 18:44 ika Note Added: 0065153
2017-04-11 18:44 ika Assigned To ika => mkv
2017-04-11 18:44 ika Status feedback => assigned
2017-04-11 19:20 kgv Assigned To mkv => bugmaster
2017-04-11 19:20 kgv Status assigned => resolved
2017-04-11 19:20 kgv Status resolved => reviewed
2017-04-11 19:38 mkv Assigned To bugmaster => ika
2017-04-11 19:39 mkv Assigned To ika => mkv
2017-04-12 12:47 mkv Note Added: 0065174
2017-04-12 12:47 mkv Note Added: 0065175
2017-04-12 12:47 mkv Assigned To mkv => bugmaster
2017-04-12 12:47 mkv Status reviewed => tested
2017-04-14 14:28 bugmaster Changeset attached => occt master 973d410e
2017-04-14 14:28 bugmaster Status tested => verified
2017-04-14 14:28 bugmaster Resolution open => fixed
2017-05-05 16:03 kgv Relationship added related to 0028522
2017-05-12 11:36 git Note Added: 0065961
2017-05-15 09:41 kgv Relationship added parent of 0028738
2017-09-29 16:18 aiv Fixed in Version => 7.2.0
2017-09-29 16:25 aiv Status verified => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker