View Issue Details

IDProjectCategoryView StatusLast Update
0028640CommunityOCCT:Modeling Algorithmspublic2022-11-02 13:52
Reporterdevocctgp Assigned Tonmanchen  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Product Version7.1.0 
Target Version7.7.0 
Summary0028640: Modeling Algorithms - BRepBuilderAPI_Transform builds invalid shape
DescriptionBRepBuilderAPI_Transform mirror a shape generates invalid shape
Steps To Reproduce
gp_Trsf _mirror_trsf;
_mirror_trsf.SetMirror(gp_Ax2(gp_Pnt(0, 0, 0), gp_Dir(1, 0, 0)));

_shape = BRepBuilderAPI_Transform(_origin_shape, _mirror_trsf)


## Draw script ##
restore origin_copy.brep a
tmirror a 0 0 0 1 0 0
checkshape a
TagsNo tags attached.
Test case numberbugs modalg_7 bug28640

Attached Files

  • error.png (76,379 bytes)
  • mirror.brep (4,372,559 bytes)
  • origin.zip (3,336,581 bytes)
  • origin_copy.brep (2,033,617 bytes)
  • image.png (330,260 bytes)

Activities

devocctgp

2017-04-07 12:51

developer  

error.png (76,379 bytes)

devocctgp

2017-04-07 12:55

developer  

mirror.brep (4,372,559 bytes)

devocctgp

2017-04-07 12:56

developer  

origin.zip (3,336,581 bytes)

devocctgp

2017-04-07 12:57

developer   ~0065023

Last edited: 2017-04-07 12:58

the origin brep file is lager than the limitation. so i zipped it !

and note the origin brep is about twice large as the mirror brep

msv

2017-04-07 16:09

developer  

origin_copy.brep (2,033,617 bytes)

msv

2017-04-07 16:15

developer   ~0065040

The size of origin shape is explained by redundant data in edges of the shape. The edges contain pogygons and triangulations not relevant to the faces of this shape. Transformation algorithm creates new edges and takes only relevant data.
The same origin shape without garbage can be got by deep copying it with BRepBuilderAPI_Copy algorithm. The Draw command 'tcopy' does it. I have attached such copy of origin. Now mirror creates a shape with the same file size.

I admit that the bug is reproduced. The mirrored shape does not pass the check by shape checker. I have put the draw script in steps to reproduce.

devocctgp

2017-04-08 21:44

developer   ~0065068

dear msv,

after your explain, i understand the difference of size.

so let's fix the mirror bug.

mkv

2017-09-01 15:03

tester   ~0070136

Problem described in issue is reproduced on current state of OCCT.

nmanchen

2022-09-23 16:13

developer   ~0111218

Problem was not reproduced (see attached image). It was found, that input shape is not valid. But it mirrors well (without losing its faces). Even if we fix input shape it still mirrors well.
image.png (330,260 bytes)

msv

2022-09-23 19:08

developer   ~0111234

@nmanchen, then please create a test case for this bug. And please try to find which fix corrected this bug, and make link with it.

git

2022-09-27 09:49

administrator   ~0111273

Branch CR28640 has been created by nmanchen.

SHA-1: 90115f648b3ed1ab3cf5b3a3cb5ee21b339e8599


Detailed log of new commits:

Author: nmanchen
Date: Tue Sep 27 09:46:43 2022 +0300

    0028640: Modeling Algorithms - BRepBuilderAPI_Transform builds invalid shape
    
    Adapt test case, the problem is not reproduced any more.

git

2022-09-28 16:13

administrator   ~0111294

Branch CR28640 has been updated forcibly by nmanchen.

SHA-1: 66362d52da5042be108a207f6cccf2ec27acf1f2

git

2022-09-30 10:36

administrator   ~0111314

Branch CR28640 has been updated forcibly by nmanchen.

SHA-1: f0049a95994eef92886f88d9ffce5dcf546bc59a

nmanchen

2022-09-30 11:26

developer   ~0111317

Problem is not reproduced. Test case is updated in brunch CR28640. Please review.
Debian test results: http://jenkins-test-08.nnov.opencascade.com/view/CR28640-master-nmanchen/view/TESTING/job/CR28640-master-nmanchen-OCCT-Debian80-64-opt-test-restart/HTML_20Report/
Windows test results: http://jenkins-test-08.nnov.opencascade.com/view/CR28640-master-nmanchen/view/TESTING/job/CR28640-master-nmanchen-OCCT-Windows-64-VC14-opt-test-restart/HTML_20Report/

emv

2022-09-30 14:18

developer   ~0111318

Reviewed, please integrate branch CR28640 into OCCT.

git

2022-11-02 13:52

administrator   ~0111853

Branch CR28640 has been deleted by mnt.

SHA-1: f0049a95994eef92886f88d9ffce5dcf546bc59a

Related Changesets

occt: master f0049a95

2022-09-27 09:46:43

nmanchen

Details Diff
0028640: Modeling Algorithms - BRepBuilderAPI_Transform builds invalid shape

Adapt test case, the problem is not reproduced any more.
Problem is fixed by the commit: 46478ffe32cfca537a35b744700e082f59ec4c4c (0030008: BRepMesh does not respect angular deflection in internal area of bspline surface)
Affected Issues
0028640
mod - tests/bugs/modalg_7/bug28640 Diff File

Issue History

Date Modified Username Field Change
2017-04-07 12:51 devocctgp New Issue
2017-04-07 12:51 devocctgp Assigned To => msv
2017-04-07 12:51 devocctgp File Added: error.png
2017-04-07 12:55 devocctgp File Added: mirror.brep
2017-04-07 12:56 devocctgp File Added: origin.zip
2017-04-07 12:57 devocctgp Note Added: 0065023
2017-04-07 12:58 devocctgp Note Edited: 0065023
2017-04-07 16:09 msv File Added: origin_copy.brep
2017-04-07 16:15 msv Note Added: 0065040
2017-04-07 16:22 msv Steps to Reproduce Updated
2017-04-08 21:44 devocctgp Note Added: 0065068
2017-07-21 11:22 msv Target Version 7.2.0 => 7.3.0
2017-09-01 15:03 mkv Test case number => bugs modalg_7 bug28640
2017-09-01 15:03 mkv Note Added: 0070136
2017-12-05 16:59 msv Target Version 7.3.0 => 7.4.0
2019-08-12 16:43 msv Target Version 7.4.0 => 7.5.0
2020-09-14 22:56 msv Target Version 7.5.0 => 7.6.0
2021-08-29 18:52 msv Target Version 7.6.0 => 7.7.0
2022-09-23 15:34 nmanchen Assigned To msv => nmanchen
2022-09-23 16:13 nmanchen Note Added: 0111218
2022-09-23 16:13 nmanchen File Added: image.png
2022-09-23 19:08 msv Note Added: 0111234
2022-09-23 19:08 msv Status new => assigned
2022-09-26 10:21 kgv Product Version => 7.1.0
2022-09-26 10:21 kgv Summary BRepBuilderAPI_Transform build invalid shape => Modeling Algorithms - BRepBuilderAPI_Transform builds invalid shape
2022-09-26 10:21 kgv Steps to Reproduce Updated
2022-09-27 09:49 git Note Added: 0111273
2022-09-28 16:13 git Note Added: 0111294
2022-09-30 10:36 git Note Added: 0111314
2022-09-30 11:26 nmanchen Assigned To nmanchen => emv
2022-09-30 11:26 nmanchen Status assigned => resolved
2022-09-30 11:26 nmanchen Note Added: 0111317
2022-09-30 14:18 emv Assigned To emv => bugmaster
2022-09-30 14:18 emv Status resolved => reviewed
2022-09-30 14:18 emv Note Added: 0111318
2022-11-02 13:41 smoskvin Status reviewed => tested
2022-11-02 13:46 nmanchen Changeset attached => occt master f0049a95
2022-11-02 13:46 nmanchen Assigned To bugmaster => nmanchen
2022-11-02 13:46 nmanchen Status tested => verified
2022-11-02 13:46 nmanchen Resolution open => fixed
2022-11-02 13:52 git Note Added: 0111853