MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028574Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2017-03-20 14:342017-09-29 16:25
Reporteremv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028574: Get rid of the TestTopOpe* packages
DescriptionIn view of the removal of the old Boolean operations (BRepAlgo_BooleanOperation) the packages for testing/debugging the old algorithm (TestTopOpe* packages) should be removed.
Steps To ReproduceNot needed.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0028575assignedemv Removal of the old Boolean Operations algorithm - BRepAlgo_BooleanOperation 

-  Notes
(0064635)
git (administrator)
2017-03-23 09:29

Branch CR28574 has been created by emv.

SHA-1: df520529454b10c76887b0cf36c62423868e57eb


Detailed log of new commits:

Author: emv
Date: Mon Mar 20 15:30:00 2017 +0300

    0028574: Get rid of the TestTopOpe* packages
    
    1. The TestTopOpe* packages have been removed.
    
    2. The commands *comapre*, *issubshape* and *projponf* have been moved to BRepTest package.
    
    3. The possibility to change the Extrema options has been added to projection algorithm (GeomAPI_ProjectPointOnSurf).
    
    4. Documentation has been updated.
(0064636)
emv (developer)
2017-03-23 09:30

Dear Mikhail, could you please review the git branch CR28574?
(0064652)
msv (developer)
2017-03-23 14:52
edited on: 2017-03-23 14:52

Remarks:

- misprint 'comapre' in commit message.

dox\user_guides\draw_test_harness\draw_test_harness.md
- numeration of subsections is broken:
@subsection occt_draw_6_10 Constraints
@subsubsection occt_draw_6_9_1 cirtang
@subsubsection occt_draw_6_9_2 lintan
@subsection occt_draw_6_11 Display
@subsubsection occt_draw_6_10_1 dmod, discr, defle
@subsubsection occt_draw_6_10_2 nbiso
@subsubsection occt_draw_6_10_3 clpoles, shpoles
@subsubsection occt_draw_6_10_4 clknots, shknots

src\BRepTest\BRepTest_BasicCommands.cxx
- Split log line 1232 like this:
"issubshape subshape shape\n"
"\t\tCheck if the shape is sub-shape of other shape and get its index in the shape.",
- In the command 'issubshape' it would be worth not to stop on first enter of subshape but show all enters.

src\BRepTest\BRepTest_SurfaceCommands.cxx
- Split log line 735 like this:
"projponf face pnt [extrema flag: -min/-max/-minmax] [extrema algo: -g(grad)/-t(tree)]\n"
"\t\tProject point on the face.",

(0064654)
git (administrator)
2017-03-23 15:18

Branch CR28574_1 has been created by emv.

SHA-1: 5e6957cb78e3a4c89a9addeeb04650b64fc9eb14


Detailed log of new commits:

Author: emv
Date: Mon Mar 20 15:30:00 2017 +0300

    0028574: Get rid of the TestTopOpe* packages
    
    1. The TestTopOpe* packages have been removed.
    
    2. The commands *compare*, *issubshape* and *projponf* have been moved to BRepTest package.
    
    3. The possibility to change the Extrema options has been added to projection algorithm (GeomAPI_ProjectPointOnSurf).
    
    4. Documentation has been updated.
(0064655)
emv (developer)
2017-03-23 15:18

Done, please review.
(0064661)
msv (developer)
2017-03-23 16:08

Reviewed.
(0064690)
mkv (tester)
2017-03-24 17:03

Dear emv,
could you please rebase branch CR28574_1 on current master,
there are conflict files.

(0064700)
git (administrator)
2017-03-27 07:28

Branch CR28574_1 has been updated forcibly by emv.

SHA-1: 1de6c8cfcb4046551b5f062d19efdf73013658e0
(0064701)
emv (developer)
2017-03-27 07:28

Done.
(0064732)
mkv (tester)
2017-03-27 20:35

Dear BugMaster,
Branch CR28574_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 1de6c8cfcb4046551b5f062d19efdf73013658e0

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1192

Regressions/Differences/Improvements:
http://occt-tests/CR28574_1-master-Products/Debian70-64/unfolding/analytic/A2.html [^]
http://occt-tests/CR28574_1-master-Products/Windows-64-VC10/unfolding/analytic/A2.html [^]
unfolding analytic A2: FAILED (exception)
http://occt-tests/CR28574_1-master-Products/Debian70-64/unfolding/analytic/A3.html [^]
http://occt-tests/CR28574_1-master-Products/Windows-64-VC10/unfolding/analytic/A3.html [^]
unfolding analytic A3: FAILED (exception)

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 91709358 / 92422378 [-0.77%]
Total CPU difference: 20001.690000000093 / 20023.26000000013 [-0.11%]
products component :
Total MEMORY difference: 30808810 / 31021131 [-0.68%]
Total CPU difference: 5469.679999999984 / 5448.519999999973 [+0.39%]
Testing on Windows:
occt component :
Total MEMORY difference: 57650164 / 57766343 [-0.20%]
Total CPU difference: 18831.83231609854 / 18379.710217898588 [+2.46%]
products component :
Total MEMORY difference: 22289804 / 22281694 [+0.04%]
Total CPU difference: 5452.593752299982 / 5345.280664399969 [+2.01%]

There are no differences in images found by testdiff.
(0064733)
mkv (tester)
2017-03-27 20:35

Dear emv,
Branch CR28574_1 has been rejected due to:
- regressions/differences/improvements
(0064735)
emv (developer)
2017-03-28 08:03

Dear Mikhail, the failing test cases have been updated. Please check if they are working now.
(0064741)
mkv (tester)
2017-03-28 12:19

Dear BugMaster,
unfolding analytic A2, A3 test cases are modified and retested:

http://occt-tests/CR28574_1-master-Products/Debian70-64/unfolding/analytic/A2.html [^]
http://occt-tests/CR28574_1-master-Products/Windows-64-VC10/unfolding/analytic/A2.html [^]
unfolding analytic A2: OK
http://occt-tests/CR28574_1-master-Products/Debian70-64/unfolding/analytic/A3.html [^]
http://occt-tests/CR28574_1-master-Products/Windows-64-VC10/unfolding/analytic/A3.html [^]
unfolding analytic A3: OK
(0064742)
mkv (tester)
2017-03-28 12:20

Dear BugMaster,
Branch CR28574_1 from occt git-repository and branch CR28574 from products git-repository are TESTED.
(0065931)
git (administrator)
2017-05-12 11:36

Branch CR28574 has been deleted by kgv.

SHA-1: df520529454b10c76887b0cf36c62423868e57eb
(0065932)
git (administrator)
2017-05-12 11:36

Branch CR28574_1 has been deleted by kgv.

SHA-1: 1de6c8cfcb4046551b5f062d19efdf73013658e0

- Related Changesets
occt: master 7868210d
Timestamp: 2017-03-20 12:30:00
Author: emv
Committer: bugmaster
Details ] Diff ]
0028574: Get rid of the TestTopOpe* packages

1. The TestTopOpe* packages have been removed.

2. The commands *compare*, *issubshape* and *projponf* have been moved to BRepTest package.

3. The possibility to change the Extrema options has been added to projection algorithm (GeomAPI_ProjectPointOnSurf).

4. Documentation has been updated.
mod - adm/UDLIST Diff ] File ]
mod - adm/upgrade.dat Diff ] File ]
mod - dox/dev_guides/upgrade/upgrade.md Diff ] File ]
mod - dox/user_guides/draw_test_harness/draw_test_harness.md Diff ] File ]
mod - src/BOPTest/BOPTest.cxx Diff ] File ]
mod - src/BRepAlgo/BRepAlgo_DSAccess.cxx Diff ] File ]
mod - src/BRepTest/BRepTest_BasicCommands.cxx Diff ] File ]
mod - src/BRepTest/BRepTest_SurfaceCommands.cxx Diff ] File ]
mod - src/ChFi3d/ChFi3d_Builder.cxx Diff ] File ]
mod - src/GeomAPI/GeomAPI_ProjectPointOnSurf.hxx Diff ] File ]
mod - src/IntTools/IntTools_Context.cxx Diff ] File ]
rm - src/TestTopOpe/FILES Diff ] File ]
rm - src/TestTopOpe/TestTopOpe.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe.hxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_BOOP.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_BOOP.hxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_BOOPCommands.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_CORCommands.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_DSF.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_EditBOOP.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_HDSCommands.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_HDSDisplayer.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_HDSDisplayer.hxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_KroBOOP.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_MesureCommands.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_MiscBOOP.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_OtherCommands.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_VarsTopo.cxx Diff ] File ]
rm - src/TestTopOpe/TestTopOpe_VarsTopo.hxx Diff ] File ]
rm - src/TestTopOpeDraw/FILES Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_Array1OfDrawableMesure.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_Array1OfDrawableP3D.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_Displayer.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_Displayer.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableC2D.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableC2D.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableC3D.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableC3D.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableMesure.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableMesure.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableP2D.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableP2D.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableP3D.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableP3D.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableSHA.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableSHA.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableSUR.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_DrawableSUR.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_HArray1OfDrawableMesure.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_HArray1OfDrawableP3D.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_ListIteratorOfListOfPnt2d.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_ListOfPnt2d.hxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_OtherCommands.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_SaveRestore.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_TTOT.cxx Diff ] File ]
rm - src/TestTopOpeDraw/TestTopOpeDraw_TTOT.hxx Diff ] File ]
rm - src/TestTopOpeTools/FILES Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools.cxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools.hxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools_Array1OfMesure.hxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools_HArray1OfMesure.hxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools_Mesure.cxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools_Mesure.hxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools_OtherCommands.cxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools_PMesure.hxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools_Trace.cxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools_Trace.hxx Diff ] File ]
rm - src/TestTopOpeTools/TestTopOpeTools_TraceCommands.cxx Diff ] File ]
mod - src/TKTopTest/PACKAGES Diff ] File ]
mod - src/TopOpeBRep/TopOpeBRep_EdgesIntersector.cxx Diff ] File ]
mod - src/TopOpeBRepBuild/TopOpeBRepBuild_ShapeSet.cxx Diff ] File ]
mod - src/TopOpeBRepBuild/TopOpeBRepBuild_ShellFaceSet.cxx Diff ] File ]
mod - src/TopOpeBRepBuild/TopOpeBRepBuild_WireEdgeSet.cxx Diff ] File ]
mod - tests/bugs/modalg_6/bug26565_8 Diff ] File ]
mod - tests/bugs/moddata_1/bug22489_2 Diff ] File ]
mod - tests/bugs/moddata_3/bug24138 Diff ] File ]
mod - tests/bugs/moddata_3/bug25223 Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-03-20 14:34 emv New Issue
2017-03-20 14:34 emv Assigned To => msv
2017-03-20 14:35 emv Relationship added related to 0028573
2017-03-20 14:36 emv Relationship added related to 0028567
2017-03-20 14:38 emv Description Updated View Revisions
2017-03-20 14:50 emv Assigned To msv => emv
2017-03-20 14:50 emv Status new => assigned
2017-03-20 14:50 emv Relationship deleted related to 0028573
2017-03-20 14:50 emv Relationship deleted related to 0028567
2017-03-20 14:50 emv Relationship added related to 0028575
2017-03-23 09:29 git Note Added: 0064635
2017-03-23 09:30 emv Note Added: 0064636
2017-03-23 09:30 emv Assigned To emv => msv
2017-03-23 09:30 emv Status assigned => resolved
2017-03-23 09:30 emv Steps to Reproduce Updated View Revisions
2017-03-23 14:52 msv Note Added: 0064652
2017-03-23 14:52 msv Assigned To msv => emv
2017-03-23 14:52 msv Status resolved => assigned
2017-03-23 14:52 msv Note Edited: 0064652 View Revisions
2017-03-23 15:18 git Note Added: 0064654
2017-03-23 15:18 emv Note Added: 0064655
2017-03-23 15:18 emv Assigned To emv => msv
2017-03-23 15:18 emv Status assigned => resolved
2017-03-23 16:08 msv Note Added: 0064661
2017-03-23 16:08 msv Assigned To msv => bugmaster
2017-03-23 16:08 msv Status resolved => reviewed
2017-03-23 16:10 mkv Assigned To bugmaster => mkv
2017-03-24 17:03 mkv Note Added: 0064690
2017-03-24 17:03 mkv Assigned To mkv => emv
2017-03-24 17:03 mkv Status reviewed => feedback
2017-03-27 07:28 git Note Added: 0064700
2017-03-27 07:28 emv Note Added: 0064701
2017-03-27 07:28 emv Assigned To emv => mkv
2017-03-27 07:28 emv Status feedback => reviewed
2017-03-27 20:35 mkv Note Added: 0064732
2017-03-27 20:35 mkv Note Added: 0064733
2017-03-27 20:35 mkv Assigned To mkv => emv
2017-03-27 20:35 mkv Status reviewed => feedback
2017-03-27 20:35 mkv Test case number => Not needed
2017-03-28 08:02 emv Assigned To emv => mkv
2017-03-28 08:03 emv Note Added: 0064735
2017-03-28 12:19 mkv Note Added: 0064741
2017-03-28 12:20 mkv Note Added: 0064742
2017-03-28 12:20 mkv Assigned To mkv => bugmaster
2017-03-28 12:20 mkv Status feedback => tested
2017-03-31 17:28 bugmaster Changeset attached => occt master 7868210d
2017-03-31 17:28 bugmaster Status tested => verified
2017-03-31 17:28 bugmaster Resolution open => fixed
2017-05-12 11:36 git Note Added: 0065931
2017-05-12 11:36 git Note Added: 0065932
2017-09-29 16:19 user533 Fixed in Version => 7.2.0
2017-09-29 16:25 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker