MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028573Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2017-03-20 09:522017-05-12 11:36
Reporteremv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.2.0Fixed in Version 
Summary0028573: Get rid of the old Boolean Operations in QA commands
DescriptionMany QA commands are using old Boolean operations and many are using both new and old algorithms. In view of removal of the old Boolean operations the QA commands will be cleared of the usage of the old algorithm.
Steps To ReproduceNot needed.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0028575assignedemv Removal of the old Boolean Operations algorithm - BRepAlgo_BooleanOperation 

-  Notes
(0064441)
git (administrator)
2017-03-20 14:23

Branch CR28573 has been created by emv.

SHA-1: 3482a7277abb42a1821f353cbbbddeb5801dedc0


Detailed log of new commits:

Author: emv
Date: Mon Mar 20 12:09:36 2017 +0300

    0028573: Get rid of the old Boolean Operations in QA commands
    
    The QA commands have been modified to use new Boolean operations instead of old.
(0064442)
emv (developer)
2017-03-20 14:24

Dear Mikhail, could you please review the git branch CR28573?
(0064544)
msv (developer)
2017-03-20 18:06

Remarks:

src\QABugs\QABugs_11.cxx
- 1409: extra comparison "argc > 5"
- 1970: extra comparison "argc > 6"
(0064558)
git (administrator)
2017-03-21 07:39

Branch CR28573 has been updated by emv.

SHA-1: bbb246ca597374a6285074c3ea907298cf53d8a5


Detailed log of new commits:

Author: emv
Date: Tue Mar 21 07:39:16 2017 +0300

    // Small correction.

(0064559)
emv (developer)
2017-03-21 07:40

Corrected, please review again.
(0064564)
msv (developer)
2017-03-21 09:48

Reviewed.
(0064610)
apv (tester)
2017-03-22 12:11

Dear BugMaster,

Branch CR28573 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: bbb246ca597374a6285074c3ea907298cf53d8a5

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1197

Regressions/Differences:
Not detected

Testing cases:
Not needed

CPU-problematic test case has been detected:
CPU bugs modalg_2 bug426: 0.7956051 / 0.1716011 [+363.64%]

Testing on Linux:
Total MEMORY difference: 93224840 / 92503842 [+0.78%]
Total CPU difference: 20255.41000000016 / 20183.74000000011 [+0.36%]

Testing on Windows:
Total MEMORY difference: 57774859 / 57774010 [+0.00%]
Total CPU difference: 18684.56737209853 / 18780.72638849851 [-0.51%]

There are differences in images found by testdiff:
http://occt-tests/CR28573-master-OCCT/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR28573-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html [^]
bugs modalg_4 bug825
bugs modalg_2 bug426
(0064611)
apv (tester)
2017-03-22 12:12

Dear Eugeny,

Branch CR28573 has been rejected due to:
- CPU problems
- differences in images
(0064638)
git (administrator)
2017-03-23 10:04

Branch CR28573_1 has been created by emv.

SHA-1: 06f356c8ea9d011de5933bf51382f90a1446e502


Detailed log of new commits:

Author: emv
Date: Mon Mar 20 12:09:36 2017 +0300

    0028573: Get rid of the old Boolean Operations in QA commands
    
    The QA commands have been modified to use new Boolean operations instead of old.
(0064640)
emv (developer)
2017-03-23 10:10

1. bugs modalg_2 bug426
The CPU problem in this case has appeared due to the blend operation performed on the result of fuse operation. Old Boolean algorithm performs also the unification of the faces. The new one does not. I have inserted this unification into the command.
The difference in images is due to 3d view was mistakenly enabled in the case. I have also corrected this.

2. bugs modalg_4 bug825
The difference is explained by the fact that better result of Boolean operation has been obtained with new algorithm.

Dear Mikhail, could you please review the git branch CR28573_1?

Dear Alexey, no testing is needed. Please just check the test case bugs modalg_2 bug426 and check if TODOs for MacOS are really needed here.
(0064644)
msv (developer)
2017-03-23 12:27

Reviewed.
(0064665)
apv (tester)
2017-03-23 16:47

Updated version of bugs modalg_2 bug426 has been tested, CPU problem has not been detected.
(0065929)
git (administrator)
2017-05-12 11:36

Branch CR28573 has been deleted by kgv.

SHA-1: bbb246ca597374a6285074c3ea907298cf53d8a5
(0065930)
git (administrator)
2017-05-12 11:36

Branch CR28573_1 has been deleted by kgv.

SHA-1: 06f356c8ea9d011de5933bf51382f90a1446e502

- Related Changesets
occt: master 431d0f18
Timestamp: 2017-03-20 09:09:36
Author: emv
Committer: bugmaster
Details ] Diff ]
0028573: Get rid of the old Boolean Operations in QA commands

The QA commands have been modified to use new Boolean operations instead of old.
mod - src/QABugs/QABugs_11.cxx Diff ] File ]
mod - tests/bugs/modalg_4/bug824 Diff ] File ]
mod - tests/bugs/modalg_2/bug426 Diff ] File ]
mod - src/QABugs/QABugs_10.cxx Diff ] File ]
rm - tests/bugs/modalg_4/bug825_1 Diff ] File ]
rm - tests/bugs/modalg_4/bug827_2 Diff ] File ]
mod - tests/bugs/modalg_4/bug822_1 Diff ] File ]
rm - tests/bugs/modalg_2/bug426_1 Diff ] File ]
rm - tests/bugs/modalg_4/bug825_2 Diff ] File ]
mod - src/QABugs/QABugs_17.cxx Diff ] File ]
mod - tests/bugs/modalg_4/bug822_2 Diff ] File ]
rm - tests/bugs/modalg_4/bug827_1 Diff ] File ]
rm - tests/bugs/modalg_4/bug824_1 Diff ] File ]
mod - src/QABugs/QABugs_13.cxx Diff ] File ]
mod - tests/bugs/modalg_4/bug825 Diff ] File ]
mod - src/QABugs/QABugs_2.cxx Diff ] File ]
mod - src/QABugs/QABugs_3.cxx Diff ] File ]
rm - tests/bugs/modalg_4/bug827_3 Diff ] File ]
rm - tests/bugs/modalg_4/bug823_1 Diff ] File ]
mod - tests/bugs/modalg_4/bug823 Diff ] File ]
rm - tests/bugs/modalg_4/bug826_1 Diff ] File ]
mod - src/QABugs/QABugs_19.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-03-20 09:52 emv New Issue
2017-03-20 09:52 emv Assigned To => msv
2017-03-20 09:53 emv Assigned To msv => emv
2017-03-20 09:53 emv Status new => assigned
2017-03-20 09:53 emv Steps to Reproduce Updated View Revisions
2017-03-20 09:53 emv Relationship added related to 0028567
2017-03-20 14:23 git Note Added: 0064441
2017-03-20 14:24 emv Note Added: 0064442
2017-03-20 14:24 emv Assigned To emv => msv
2017-03-20 14:24 emv Status assigned => resolved
2017-03-20 14:35 emv Relationship added related to 0028574
2017-03-20 14:50 emv Relationship deleted related to 0028574
2017-03-20 14:51 emv Relationship deleted related to 0028567
2017-03-20 14:51 emv Relationship added related to 0028575
2017-03-20 18:06 msv Note Added: 0064544
2017-03-20 18:06 msv Assigned To msv => emv
2017-03-20 18:06 msv Status resolved => assigned
2017-03-21 07:39 git Note Added: 0064558
2017-03-21 07:40 emv Note Added: 0064559
2017-03-21 07:40 emv Assigned To emv => msv
2017-03-21 07:40 emv Status assigned => resolved
2017-03-21 09:48 msv Note Added: 0064564
2017-03-21 09:48 msv Assigned To msv => bugmaster
2017-03-21 09:48 msv Status resolved => reviewed
2017-03-21 15:08 apv Assigned To bugmaster => apv
2017-03-22 12:08 apv Test case number => Not needed
2017-03-22 12:11 apv Note Added: 0064610
2017-03-22 12:11 apv Assigned To apv => emv
2017-03-22 12:11 apv Status reviewed => assigned
2017-03-22 12:12 apv Note Added: 0064611
2017-03-23 10:04 git Note Added: 0064638
2017-03-23 10:10 emv Note Added: 0064640
2017-03-23 10:10 emv Assigned To emv => msv
2017-03-23 10:10 emv Status assigned => resolved
2017-03-23 12:27 msv Note Added: 0064644
2017-03-23 12:27 msv Assigned To msv => bugmaster
2017-03-23 12:27 msv Status resolved => reviewed
2017-03-23 12:27 msv Assigned To bugmaster => apv
2017-03-23 16:47 apv Note Added: 0064665
2017-03-23 16:47 apv Assigned To apv => bugmaster
2017-03-23 16:47 apv Status reviewed => tested
2017-03-24 15:53 bugmaster Changeset attached => occt master 431d0f18
2017-03-24 15:53 bugmaster Status tested => verified
2017-03-24 15:53 bugmaster Resolution open => fixed
2017-05-12 11:36 git Note Added: 0065929
2017-05-12 11:36 git Note Added: 0065930


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker