MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028381Open CASCADE[OCCT] OCCT:DRAWpublic2017-01-23 10:582017-09-29 16:24
Reporternbv 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028381: Draw Harness - DRAWEXE still hangs up immediatly when redirecting input stream on Windows
DescriptionThe fix for issue 0028350 does not solve the problem on my machine (DRAW hangs up as before - see hanging.png attached picture).
Steps To ReproduceTest case is not required.

Try in command window:

"draw.bat" - OK

"echo pload;exit | draw.bat" - HANGING
TagsNo tags attached.
Test case numberNot needed
Attached Filespng file icon hanging.png (18,759 bytes) 2017-01-23 10:58

- Relationships
related to 0028350closedapn Draw Harness - DRAWEXE hangs up immediatly when redirecting input stream on Windows 

-  Notes
(0062886)
git (administrator)
2017-01-23 11:05

Branch CR28381 has been created by nbv.

SHA-1: 8addee0d63a0b93bd27a4b572ca38ce64e54db78


Detailed log of new commits:

Author: nbv
Date: Mon Jan 23 11:05:16 2017 +0300

    0028381: Draw Harness - DRAWEXE hangs up immediatly when redirecting input stream on Windows
(0062887)
nbv (developer)
2017-01-23 11:06

Dear Andrey,

Please review CR28381 branch. It fixes the problem on my machine.
(0062889)
kgv (developer)
2017-01-23 11:44

+      else if (fgetws(console_command, THE_COMMAND_SIZE, stdin))
+      {// fgetws() works only for characters within active locale (see setlocale())
+        console_semaphore = HAS_CONSOLE_COMMAND;
+      }

Please instead try removing check "if (anErr == ERROR_INVALID_HANDLE)" so that "isConsoleInput = false;" is set for any error.

On my system it was ERROR_INVALID_HANDLE, while on yours it is ERROR_INVALID_FUNCTION - have no idea why error code is different.
(0062891)
git (administrator)
2017-01-23 12:17

Branch CR28381 has been updated by nbv.

SHA-1: 52d0d05f719488e391ce725bf76f0d1545bf81f2


Detailed log of new commits:

Author: nbv
Date: Mon Jan 23 12:17:26 2017 +0300

    Changes according to the last remarks.

(0062892)
nbv (developer)
2017-01-23 12:18

Done.

Dear Kirill,

Please review the current state of CR28381 branch.
(0062893)
kgv (developer)
2017-01-23 12:24

> Changes according to the last remarks.
This change should replace your original patch, not "include" it.
"else" statement will never occur because you are calling fgetws() before and GetLastError() has nothing to do with fgetws() return value.
(0062898)
git (administrator)
2017-01-23 13:05

Branch CR28381 has been updated forcibly by nbv.

SHA-1: 17d79b5a25349bb33d5592e051aa1769af304527
(0062899)
nbv (developer)
2017-01-23 13:06

Done.

Dear Kirill,

Please review the current state of CR28381 branch.
(0062900)
kgv (developer)
2017-01-23 13:45

Please test the patch.
(0063002)
apv (tester)
2017-01-25 13:55

Dear BugMaster,

Branch CR28381 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 17d79b5a25349bb33d5592e051aa1769af304527

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 63
   Windows: 0
   MacOS: 1132

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 92983626 / 92067637 [+0.99%]
Total CPU difference: 21075.62000000011 / 21062.120000000155 [+0.06%]

Testing on Windows:
Total MEMORY difference: 58324735 / 58324216 [+0.00%]
Total CPU difference: 19385.43306479856 / 19152.585972198493 [+1.22%]
(0063623)
git (administrator)
2017-02-08 11:36

Branch CR28381 has been deleted by kgv.

SHA-1: 17d79b5a25349bb33d5592e051aa1769af304527

- Related Changesets
occt: master 0f358da3
Timestamp: 2017-01-23 08:05:16
Author: nbv
Committer: apn
Details ] Diff ]
0028381: Draw Harness - DRAWEXE hangs up immediatly when redirecting input stream on Windows
mod - src/Draw/Draw_Window.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-01-23 10:58 nbv New Issue
2017-01-23 10:58 nbv Assigned To => apn
2017-01-23 10:58 nbv File Added: hanging.png
2017-01-23 11:05 git Note Added: 0062886
2017-01-23 11:06 nbv Note Added: 0062887
2017-01-23 11:06 nbv Status new => resolved
2017-01-23 11:06 nbv Steps to Reproduce Updated View Revisions
2017-01-23 11:08 nbv Relationship added related to 0028350
2017-01-23 11:44 kgv Note Added: 0062889
2017-01-23 11:44 kgv Assigned To apn => nbv
2017-01-23 11:44 kgv Status resolved => assigned
2017-01-23 11:44 kgv Product Version => 7.1.0
2017-01-23 11:45 kgv Summary Draw Harness - DRAWEXE hangs up immediatly when redirecting input stream on Windows => Draw Harness - DRAWEXE still hangs up immediatly when redirecting input stream on Windows
2017-01-23 12:17 git Note Added: 0062891
2017-01-23 12:18 nbv Note Added: 0062892
2017-01-23 12:18 nbv Assigned To nbv => kgv
2017-01-23 12:18 nbv Status assigned => resolved
2017-01-23 12:24 kgv Note Added: 0062893
2017-01-23 12:25 kgv Assigned To kgv => nbv
2017-01-23 12:25 kgv Status resolved => assigned
2017-01-23 13:05 git Note Added: 0062898
2017-01-23 13:06 nbv Note Added: 0062899
2017-01-23 13:06 nbv Assigned To nbv => kgv
2017-01-23 13:06 nbv Status assigned => resolved
2017-01-23 13:45 kgv Note Added: 0062900
2017-01-23 13:45 kgv Assigned To kgv => bugmaster
2017-01-23 13:45 kgv Status resolved => reviewed
2017-01-24 17:24 apv Assigned To bugmaster => apv
2017-01-24 17:25 apv Test case number => Not needed
2017-01-25 13:55 apv Note Added: 0063002
2017-01-25 13:55 apv Assigned To apv => bugmaster
2017-01-25 13:55 apv Status reviewed => tested
2017-01-27 16:15 apn Changeset attached => occt master 0f358da3
2017-01-27 16:15 apn Assigned To bugmaster => apn
2017-01-27 16:15 apn Status tested => verified
2017-01-27 16:15 apn Resolution open => fixed
2017-02-08 11:36 git Note Added: 0063623
2017-09-29 16:21 user533 Fixed in Version => 7.2.0
2017-09-29 16:24 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker