MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028362Open CASCADE[OCCT] OCCT:Documentationpublic2017-01-16 19:122017-09-29 16:28
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028362: Documentation - Doxygen warnings
DescriptionCurrent master yields the following warnings when Doxygen documentation is generated (default compilation by CMake on Linux):

\\/home/abv/occt/dox/user_guides/boolean_operations/boolean_operations.md:\2668:\warning: image file /user_guides/boolean_operations/images/glue_options_image002.png is not found in IMAGE_PATH: assuming external image.\
\\/home/abv/occt/dox/user_guides/boolean_operations/boolean_operations.md:\2673:\warning: image file /user_guides/boolean_operations/images/glue_options_image001.png is not found in IMAGE_PATH: assuming external image.\
\\/home/abv/occt/dox/user_guides/boolean_operations/boolean_operations.md:\2676:\warning: image file /user_guides/boolean_operations/images/glue_options_image003.png is not found in IMAGE_PATH: assuming external image.\
\\/home/abv/occt/dox/user_guides/boolean_operations/boolean_operations.md:\2720:\warning: image file /user_guides/boolean_operations/images/glue_options_image004.png is not found in IMAGE_PATH: assuming external image.\
\\/home/abv/occt/dox/user_guides/boolean_operations/boolean_operations.md:\2726:\warning: image file /user_guides/boolean_operations/images/glue_options_image005.png is not found in IMAGE_PATH: assuming external image.\


\\/home/abv/occt/dox/dev_guides/upgrade/upgrade.md:\967:\warning: explicit link request to 'SelectionMode()' could not be resolved\
\\/home/abv/occt/dox/dev_guides/upgrade/upgrade.md:\1143:\warning: explicit link request to 'DefaultColor()' could not be resolved\
\\/home/abv/occt/dox/dev_guides/upgrade/upgrade.md:\1143:\warning: explicit link request to 'WasCurrentTouched()' could not be resolved\
\\/home/abv/occt/dox/dev_guides/upgrade/upgrade.md:\1143:\warning: explicit link request to 'ZDetection()' could not be resolved\
\\/home/abv/occt/dox/dev_guides/upgrade/upgrade.md:\1193:\warning: explicit link request to 'DynamicHilightAttributes()' could not be resolved\
\\/home/abv/occt/dox/dev_guides/upgrade/upgrade.md:\1193:\warning: explicit link request to 'HilightAttributes()' could not be resolved\
Steps To ReproduceNA
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0028440closedapn Open CASCADE Documentation - Doxygen errors on Linux 
related to 0028403closedapn Open CASCADE Avoid useless calls to BRepTools::Write() 
related to 0028836closedbugmaster Open CASCADE Doxygen warning in DRAW User Guide 

-  Notes
(0067016)
ysn (developer)
2017-06-02 12:45

I cannot reproduce these warnings when I compile the current version of documentation.

The images exist in the corresponding folder and there are no links, only method names.

I assume that this bug can be closed now.
(0067168)
abv (manager)
2017-06-07 10:57

Warnings "explicit link request... could not be resolved" have been fixed in commit for 0028403. Note that in Doxygen syntax, two colons followed by ID means link to some tag, and method names given with "::" in the beginning cause that warning. Such semicolons should be removed. Note that putting "::" before method name in C++ means name is in the global scope, which is not correct in most of the cases where such problem appears.

First set of warnings is reproduced on Linux only, apparently due to the fact that paths beginning with slash are interpreted as full path (not relative to current folder).
(0067555)
abv (manager)
2017-06-20 23:36

Second set of warnings (Linux specific) has been corrected within 0028440.

However, 41 new warnings appeared since then:

\\D:/ABV/OCCT/occt/dox/user_guides/draw_test_harness/draw_test_harness.md:\10022:\warning: Unsupported xml/html tag <face> found\
\\D:/ABV/OCCT/occt/dox/user_guides/draw_test_harness/draw_test_harness.md:\10022:\warning: Unsupported xml/html tag <X> found\
...

All these due to wrong formatting of code block (not closed properly) introduced by fix for #28346
(0067556)
git (administrator)
2017-06-20 23:38

Branch CR28362 has been created by abv.

SHA-1: febb2c2ee1adaef5751f3df69179d613e304d99a


Detailed log of new commits:

Author: abv
Date: Tue Jun 20 23:38:35 2017 +0300

    0028362: Documentation - Doxygen warnings
(0067557)
git (administrator)
2017-06-20 23:41

Branch CR28362 has been updated forcibly by abv.

SHA-1: ddc3db9666eed1c57bcbd1fba563f18ad8e48ade
(0067558)
abv (manager)
2017-06-20 23:41

Fix pushed to CR28362, please integrate
(0067561)
apv (tester)
2017-06-21 11:14

Dear BugMaster,

Please integrate branch CR28362 into the occt git-repository master.
(0067865)
git (administrator)
2017-07-03 08:45

Branch CR28362 has been deleted by kgv.

SHA-1: ddc3db9666eed1c57bcbd1fba563f18ad8e48ade

- Related Changesets
occt: master 21b1980f
Timestamp: 2017-06-20 20:38:35
Author: abv
Committer: bugmaster
Details ] Diff ]
0028362: Documentation - Doxygen warnings

Formatting of user guide is corrected (code block properly closed)
mod - dox/user_guides/draw_test_harness/draw_test_harness.md Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-01-16 19:12 abv New Issue
2017-01-16 19:12 abv Assigned To => ysn
2017-05-19 15:36 abv Target Version 7.2.1 => 7.2.0
2017-06-02 12:45 ysn Note Added: 0067016
2017-06-02 12:45 ysn Assigned To ysn => abv
2017-06-02 12:45 ysn Status new => resolved
2017-06-02 12:45 ysn Steps to Reproduce Updated View Revisions
2017-06-07 10:57 abv Note Added: 0067168
2017-06-07 10:57 abv Status resolved => assigned
2017-06-20 23:32 abv Relationship added related to 0028440
2017-06-20 23:32 abv Relationship added related to 0028403
2017-06-20 23:36 abv Note Added: 0067555
2017-06-20 23:36 abv Relationship added related to 0028346
2017-06-20 23:38 git Note Added: 0067556
2017-06-20 23:41 git Note Added: 0067557
2017-06-20 23:41 abv Note Added: 0067558
2017-06-20 23:41 abv Assigned To abv => bugmaster
2017-06-20 23:41 abv Status assigned => resolved
2017-06-20 23:41 abv Status resolved => reviewed
2017-06-21 11:14 apv Test case number => Not needed
2017-06-21 11:14 apv Note Added: 0067561
2017-06-21 11:14 apv Status reviewed => tested
2017-06-23 12:25 bugmaster Changeset attached => occt master 21b1980f
2017-06-23 12:25 bugmaster Status tested => verified
2017-06-23 12:25 bugmaster Resolution open => fixed
2017-07-03 08:45 git Note Added: 0067865
2017-07-27 10:40 abv Relationship added related to 0028836
2017-09-29 16:17 aiv Fixed in Version => 7.2.0
2017-09-29 16:28 aiv Status verified => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker