MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028335Open CASCADE[OCCT] OCCT:Configurationpublic2017-01-09 15:032017-05-12 11:35
Reporteribs 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 7.1.0 
Target Version[OCCT] UnscheduledFixed in Version 
Summary0028335: Configuration, Cmake - 3rdparty library names present in two places and aren't sync with each other
Description3RDPARTY_<library name>_LIBRARY variable ends with a library name that isn't consider when linking. The linking uses a library name specified in a corresponding CSF variable in occt_csf.cmake file.

it's required to parse a corresponding CSF variable when CMake searches 3rdparty libraries.

for example,

0. CSF_TBB variable is specified: tbb1 tbbmalloc1

1. the THIRDPARTY_PRODUCT macro receives a corresponding CSF variable and parses it (CSF_TBB in our case)

2. CMake seeks tbb1 and tbbmalloc1 and stores a result of the search in 3RDPARTY_TBB_LIBRARY_1 and 3RDPARTY_TBB_LIBRARY_2 correspondingly

3. 3RDPARTY_TBB_LIBRARY_DIR_1 and 3RDPARTY_TBB_LIBRARY_DIR_2 directories are used for linking

4. add 3RDPARTY_TBB_LIBRARY_1 and 3RDPARTY_TBB_LIBRARY_2 libraries to USED_EXTERNAL_LIBS_BY_CURRENT_PROJECT in occt_toolkit.cmake due to a user could change a name of 3rdparty library (e.g., tbb_debug instead tbb1)
Steps To Reproduce• Run CMake
• Start configure
• Set 3rd-parties path
• Press Configure -> All 3RDPARTY_*** variables should be filled as usual
• Try to change 3RDPARTY_TBBMALLOC_LIBRARY / 3RDPARTY_TBBMALLOC_DLL variables from occt700products/tbb44_20160526oss/bin/intel64/vc10/tbbmalloc.(dll/lib) to occt700products/tbb44_20160526oss/bin/intel64/vc10/tbbmalloc_debug.(dll/lib)
• Press Configure again
• Generate solution
• Check linker input properties of TKernel toolkit -> tbbmalloc_debug.lib should be used for linkage (with full path to the 3rd-party library)

The same behavior should be reproduced on all supported platforms for all 3rd-party libraries.
TagsNo tags attached.
Test case number
Attached Filesdocx file icon 28335-check.docx (495,604 bytes) 2017-04-06 16:28

- Relationships
has duplicate 0027073closedbugmaster Community No way to choose different tbb libs for release and debug using CMake 
has duplicate 0025972closedibs Community Threre is no way to link occ with debug tbb library using cmake 
related to 0028658verifiedbugmaster Open CASCADE Cannot execute DRAW.exe with draw.bat 

-  Notes
(0063127)
git (administrator)
2017-01-27 16:21

Branch CR28335 has been created by ski.

SHA-1: 38682bac192468cb7de387d21fd076698b4607ab


Detailed log of new commits:

Author: ski
Date: Fri Jan 27 15:53:06 2017 +0300

    0028335: Configuration, Cmake - 3rdparty library names present in two places and aren't sync with each other
    
    Libraries names from file adm/cmake/occt_csf.cmake are used to search libraries.
(0063332)
git (administrator)
2017-02-01 20:49

Branch CR28335 has been updated forcibly by ski.

SHA-1: 0ab360634b029f6f3ca52447bcb2250a1a88ecb4
(0063340)
git (administrator)
2017-02-02 11:02

Branch CR28335 has been updated forcibly by ski.

SHA-1: 6508100b278981247601682f1a774563a9d77564
(0063372)
git (administrator)
2017-02-02 16:23

Branch CR28335 has been updated forcibly by ski.

SHA-1: 0457dc39c0261601da3711463482afa39441d222
(0063378)
git (administrator)
2017-02-02 19:08

Branch CR28335 has been updated forcibly by ski.

SHA-1: 9d10a6071c843f1915fe2a3964a76606c5e0923a
(0063401)
git (administrator)
2017-02-03 15:06

Branch CR28335 has been updated forcibly by ski.

SHA-1: 807574a0a3b51b1be185f6f003c74d46fff675a7
(0063402)
git (administrator)
2017-02-03 15:13

Branch CR28335 has been updated forcibly by ski.

SHA-1: d977a523f6883cc08de0b7c43f0ac3c15f4377d1
(0063459)
git (administrator)
2017-02-06 13:06

Branch CR28335 has been updated forcibly by ski.

SHA-1: f4a3b86a124d1fbd9322c99bf58654dd0ccb4e70
(0063460)
ski (developer)
2017-02-06 13:14

Dear ibs,

3rd-parties searching uses libraries names from occt/adm/occt_csf.cmake file now.
Because of that including of this file was moved up in main CMakeList.txt (names should be known before searching).

In file occt/cmake/occt_toolkit.cmake content of variables 3RDPARTY_***_LIBRARY is used to link current toolkit. It is possible to set another library in CMake GUI and toolkits will be linked to this library instead of hardcoded in occt_csf.cmake.

Some names of libraries presented in CMake GUI were changed to have possibility to link toolkit with 3rd-party library without knowing of library's path/name.

Please review.
(0063745)
git (administrator)
2017-02-10 12:48

Branch CR28335 has been updated by ski.

SHA-1: c51ac75ec9a396cea95e55e585f67063c0166673


Detailed log of new commits:

Author: ski
Date: Fri Feb 10 12:31:14 2017 +0300

    Removed hardcoded variants of tcl/tk libraries names for searching.

(0064922)
ibs (developer)
2017-04-05 11:23

there are no remarks
(0064932)
git (administrator)
2017-04-05 12:43

Branch CR28335 has been updated forcibly by inv.

SHA-1: 788fb9ba8c699e861050aaa0655f5d0a809350ac
(0064933)
bugmaster (administrator)
2017-04-05 12:44

Branch CR28335 has been rebased on current master
(0064995)
bugmaster (administrator)
2017-04-06 16:28

Fix has been checked by SKI.

See report in attached documents
(0065907)
git (administrator)
2017-05-12 11:35

Branch CR28335 has been deleted by kgv.

SHA-1: 788fb9ba8c699e861050aaa0655f5d0a809350ac

- Related Changesets
occt: master 4fecc365
Timestamp: 2017-01-27 12:53:06
Author: ski
Committer: bugmaster
Details ] Diff ]
0028335: Configuration, Cmake - 3rdparty library names present in two places and aren't sync with each other

Libraries names from file adm/cmake/occt_csf.cmake are used to search libraries.

Removed hardcoded variants of tcl/tk libraries names for searching.
mod - adm/cmake/3rdparty_macro.cmake Diff ] File ]
mod - CMakeLists.txt Diff ] File ]
mod - adm/cmake/occt_macros.cmake Diff ] File ]
mod - adm/cmake/gl2ps.cmake Diff ] File ]
mod - adm/cmake/freeimage.cmake Diff ] File ]
mod - adm/cmake/tbb.cmake Diff ] File ]
mod - adm/cmake/freetype.cmake Diff ] File ]
mod - adm/cmake/gles2.cmake Diff ] File ]
mod - adm/cmake/occt_toolkit.cmake Diff ] File ]
mod - adm/cmake/glx.cmake Diff ] File ]
mod - adm/cmake/tk.cmake Diff ] File ]
mod - adm/cmake/tcl.cmake Diff ] File ]
mod - adm/cmake/eigen.cmake Diff ] File ]
mod - adm/cmake/egl.cmake Diff ] File ]
mod - adm/cmake/occt_csf.cmake Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-01-09 15:03 ibs New Issue
2017-01-09 15:03 ibs Assigned To => ski
2017-01-09 15:03 ibs Relationship added related to 0025972
2017-01-09 15:56 ibs Description Updated View Revisions
2017-01-09 15:58 ibs Description Updated View Revisions
2017-01-27 16:21 git Note Added: 0063127
2017-02-01 20:49 git Note Added: 0063332
2017-02-02 11:02 git Note Added: 0063340
2017-02-02 16:23 git Note Added: 0063372
2017-02-02 16:36 ski Status new => assigned
2017-02-02 19:08 git Note Added: 0063378
2017-02-03 15:06 git Note Added: 0063401
2017-02-03 15:13 git Note Added: 0063402
2017-02-06 13:06 git Note Added: 0063459
2017-02-06 13:14 ski Note Added: 0063460
2017-02-06 13:14 ski Assigned To ski => ibs
2017-02-06 13:14 ski Status assigned => resolved
2017-02-06 13:14 ski Steps to Reproduce Updated View Revisions
2017-02-06 13:15 ski Steps to Reproduce Updated View Revisions
2017-02-10 12:48 git Note Added: 0063745
2017-04-05 11:23 ibs Note Added: 0064922
2017-04-05 11:23 ibs Assigned To ibs => bugmaster
2017-04-05 11:23 ibs Status resolved => reviewed
2017-04-05 12:43 git Note Added: 0064932
2017-04-05 12:44 bugmaster Note Added: 0064933
2017-04-06 16:28 bugmaster Note Added: 0064995
2017-04-06 16:28 bugmaster Status reviewed => tested
2017-04-06 16:28 bugmaster File Added: 28335-check.docx
2017-04-14 14:28 bugmaster Changeset attached => occt master 4fecc365
2017-04-14 14:28 bugmaster Status tested => verified
2017-04-14 14:28 bugmaster Resolution open => fixed
2017-04-18 12:54 ski Relationship added related to 0028658
2017-04-24 10:15 bugmaster Relationship added has duplicate 0027073
2017-04-24 10:16 bugmaster Relationship deleted related to 0025972
2017-04-24 10:17 bugmaster Relationship added has duplicate 0025972
2017-05-12 11:35 git Note Added: 0065907


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker