MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028263Open CASCADE[OCCT] OCCT:Codingpublic2016-12-22 12:472017-09-29 16:31
Reporterkgv 
Assigned Toapv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028263: Coding Rules - clean up definition of the class Graphic3d_MaterialAspect
DescriptionGraphic3d_MaterialAspect has interface issues, the following methods operate with raw string Standard_CString, while class is holding TCollection_AsciiString:
  //! Returns the name of this material
  Standard_EXPORT Standard_CString MaterialName() const;


Other issues:
- Class properties are sorted in sub-optimal order (from memory layout point of view).
- It will be more optimal if most trivial methods (getters) will provide inline implementation in class header.
- myRequestedMaterialName property is not-accessible outside.
- Method ::IsEqual() is currently broken (should be fixed by patch for NCollection_Vec3 in #28180).
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0062335)
git (administrator)
2016-12-29 20:39

Branch CR28263 has been created by kgv.

SHA-1: 643a707a77f0365a165c52ea5a5d8ee014e72ef5


Detailed log of new commits:

Author: kgv
Date: Thu Dec 29 20:39:28 2016 +0300

    0028263: Coding Rules - clean up definition of the class Graphic3d_MaterialAspect
    
    Fixed uninitialized fields in several classes.
    Body of trivial methods have been moved to class definition (header file).
    Ensure that non-primitive types are returned by reference, when possible.
(0062341)
git (administrator)
2016-12-29 23:02

Branch CR28263 has been updated forcibly by kgv.

SHA-1: 67b67a587aab2e22de41dd17291f8c6cc694fb91
(0062342)
kgv (developer)
2016-12-29 23:03

Patch is ready for review.
(0062346)
git (administrator)
2016-12-29 23:36

Branch CR28263 has been updated forcibly by kgv.

SHA-1: 36a8bfa1a507dfcf2ee322289240070963111337
(0062660)
san (developer)
2017-01-16 20:55

Branch CR28263 reviewed without remarks, ready for testing.
(0062705)
git (administrator)
2017-01-17 16:15

Branch CR28263 has been updated forcibly by apv.

SHA-1: 49ad90f4c8ccf36de03a7cbbd03f804a78ea5394
(0062706)
apv (tester)
2017-01-17 16:15

Branch CR28263 has been rebased on the current master
(0062730)
apv (tester)
2017-01-18 10:43

Dear BugMaster,

During building of branch CR28263 (SHA-1: 49ad90f4c8ccf36de03a7cbbd03f804a78ea5394) from occt git-repository (and master from products git-repository) compilation errors have been detected.
On Linux:
http://jenkins-test-05.nnov.opencascade.com/view/CR28263-master/job/CR28263-master-OCCT-Debian70-64-opt-compile/1/parsed_console/ [^]
On Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR28263-master/job/CR28263-master-OCCT-Windows-64-VC10-opt-compile/1/parsed_console/ [^]
On MacOS:
http://jenkins-test-05.nnov.opencascade.com/view/CR28263-master/job/CR28263-master-OCCT-MacOS-opt-compile/1/parsed_console/ [^]
(0062731)
apv (tester)
2017-01-18 10:45

Dear Kirill,

Branch CR28263 has been rejected due to:
- compilation errors
(0062737)
git (administrator)
2017-01-18 11:15

Branch CR28263 has been updated forcibly by kgv.

SHA-1: 1fd2617fb6d5eaa0e02596b086972c5374a28702
(0062738)
kgv (developer)
2017-01-18 11:16

Please check updated patch with fixed misprint.
(0062853)
git (administrator)
2017-01-20 17:44

Branch CR28263 has been updated forcibly by apv.

SHA-1: 4e1bc39a81fc965d86aae06555a7c4a50bbf4eea
(0062854)
apv (tester)
2017-01-20 17:45

Branch CR28263 has been rebased on the current master
(0062933)
apv (tester)
2017-01-24 12:09

Dear BugMaster,

Branch CR28263 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 4e1bc39a81fc965d86aae06555a7c4a50bbf4eea

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 63
   Windows: 0
   MacOS: 1151

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 93105166 / 92063498 [+1.13%]
Total CPU difference: 21056.440000000253 / 21062.120000000155 [-0.03%]

Testing on Windows:
Total MEMORY difference: 58325545 / 58324216 [+0.00%]
Total CPU difference: 19347.24401999861 / 19152.585972198493 [+1.02%]
(0063600)
git (administrator)
2017-02-08 11:36

Branch CR28263 has been deleted by kgv.

SHA-1: 4e1bc39a81fc965d86aae06555a7c4a50bbf4eea

- Related Changesets
occt: master 4e1bc39a
Timestamp: 2016-12-29 17:39:28
Author: kgv
Committer: apv
Details ] Diff ]
0028263: Coding Rules - clean up definition of the class Graphic3d_MaterialAspect

Fixed uninitialized fields in several classes.
Body of trivial methods have been moved to class definition (header file).
Ensure that non-primitive types are returned by reference, when possible.
Removed unused class Prs3d_PlaneSet.
mod - src/AIS/AIS_InteractiveObject.cxx Diff ] File ]
mod - src/AIS/AIS_Plane.cxx Diff ] File ]
mod - src/AIS/AIS_PointCloud.cxx Diff ] File ]
mod - src/AIS/AIS_Shape.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_AspectFillArea3d.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_MaterialAspect.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_MaterialAspect.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_TypeOfReflection.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_AspectFace.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Context.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Workspace.cxx Diff ] File ]
mod - src/Prs3d/FILES Diff ] File ]
mod - src/Prs3d/Prs3d_ArrowAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_ArrowAspect.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_BasicAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_BasicAspect.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_DatumAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_DatumAspect.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_DimensionAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_DimensionAspect.hxx Diff ] File ]
rm - src/Prs3d/Prs3d_DimensionUnits.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_DimensionUnits.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_IsoAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_IsoAspect.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_LineAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_LineAspect.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_PlaneAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_PlaneAspect.hxx Diff ] File ]
rm - src/Prs3d/Prs3d_PlaneSet.cxx Diff ] File ]
rm - src/Prs3d/Prs3d_PlaneSet.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_PointAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_PointAspect.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_ShadingAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_ShadingAspect.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_TextAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_TextAspect.hxx Diff ] File ]
mod - src/QABugs/QABugs_17.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ObjectCommands.cxx Diff ] File ]
mod - src/XSDRAWSTLVRML/XSDRAWSTLVRML.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-12-22 12:47 kgv New Issue
2016-12-22 12:47 kgv Assigned To => kgv
2016-12-22 13:58 kgv Relationship added related to 0028180
2016-12-29 20:39 git Note Added: 0062335
2016-12-29 23:02 git Note Added: 0062341
2016-12-29 23:03 kgv Note Added: 0062342
2016-12-29 23:03 kgv Assigned To kgv => san
2016-12-29 23:03 kgv Status new => resolved
2016-12-29 23:36 git Note Added: 0062346
2017-01-16 20:55 san Note Added: 0062660
2017-01-16 20:55 san Assigned To san => bugmaster
2017-01-16 20:55 san Status resolved => reviewed
2017-01-17 16:07 apv Assigned To bugmaster => apv
2017-01-17 16:15 git Note Added: 0062705
2017-01-17 16:15 apv Note Added: 0062706
2017-01-17 16:16 apv Test case number => Not needed
2017-01-18 10:43 apv Note Added: 0062730
2017-01-18 10:43 apv Assigned To apv => kgv
2017-01-18 10:43 apv Status reviewed => assigned
2017-01-18 10:45 apv Note Added: 0062731
2017-01-18 11:15 git Note Added: 0062737
2017-01-18 11:16 kgv Note Added: 0062738
2017-01-18 11:16 kgv Assigned To kgv => bugmaster
2017-01-18 11:16 kgv Status assigned => resolved
2017-01-18 11:16 kgv Status resolved => reviewed
2017-01-18 16:57 apv Assigned To bugmaster => apv
2017-01-20 17:44 git Note Added: 0062853
2017-01-20 17:45 apv Note Added: 0062854
2017-01-24 12:09 apv Note Added: 0062933
2017-01-24 12:09 apv Assigned To apv => bugmaster
2017-01-24 12:09 apv Status reviewed => tested
2017-01-27 16:15 apv Changeset attached => occt master 4e1bc39a
2017-01-27 16:15 apv Assigned To bugmaster => apv
2017-01-27 16:15 apv Status tested => verified
2017-01-27 16:15 apv Resolution open => fixed
2017-02-08 11:36 git Note Added: 0063600
2017-09-29 16:21 user533 Fixed in Version => 7.2.0
2017-09-29 16:31 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker