MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028253Community[OCCT] OCCT:Visualizationpublic2016-12-20 16:192020-07-14 14:41
ReporterTimo 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target VersionFixed in Version[OCCT] 7.2.0 
Summary0028253: Incorrect treatment of transparency if a spline face overlaps itself in 3D view
DescriptionWhen a spline face is strongly bent it can occur that some part of the face is in front of another part of the face in the 3D view. In this case, if transparency is used, there occur ugly artefacts.

The problem does not occur if two different faces are behing each other.

Also, it could not be reproduced with simple geometry like box or sphere. So, it might be specific to more complex surfaces.
Steps To Reproducepload ALL
restore shell.brep s
vinit
vdisplay s
vfit
vsetdispmode s 1
vsettrans s 0.4
TagsNo tags attached.
Test case numberNot needed
Attached Filespng file icon transparency artefacts.png (93,860 bytes) 2016-12-20 16:19
? file icon shell.brep (322,579 bytes) 2016-12-20 16:20

- Relationships
duplicate of 0027716closedbugmaster Community Visualization - incorrect treatment of multiple transparent objects in 3D view 
duplicate of 0027925closedbugmaster Open CASCADE Visualization - implement order-independent transparency algorithm within rasterization rendering 

-  Notes
(0061927)
kgv (developer)
2016-12-20 16:33

Dear bugmaster,

please close the issue as duplicate of 0027716.
(0061928)
Timo (developer)
2016-12-20 16:35
edited on: 2016-12-20 16:35

0027716 seems to be a slightly different problem because it is about different objects behind each other, where I'm speaking about different parts of the same object behind each other. But maybe it has the same reason.
I cannot see 0027925, so cannot comment on that.

(0061929)
kgv (developer)
2016-12-20 16:43
edited on: 2016-12-20 16:45

> 0027716 seems to be a slightly different problem because
> it is about different objects behind each other,
> where I'm speaking about different parts
> of the same object behind each other.
Scenarios are different but the reason is the same - order-dependent transparency without any ordering.

Issue with several transparent objects can be worked around more simple (sorting objects)
than issues within the single transparent object
(which would require sorting triangles - and even this sorting might be not enough in case of their intersection).

General-purpose order-independent transparency algorithms can solve issues within both scenarios.

(0093082)
Matthias (developer)
2020-07-10 13:41

Reported issue still exists in OCCT 7.4.0.
(0093087)
kgv (developer)
2020-07-10 14:45
edited on: 2020-07-10 14:47

Dear Matthias,

please elaborate what exactly doesn't work as expected in use case.

Rendering semitransparent objects requires sorting and order-independent transparency (OIT) techniques. Within the current state (since 0027925 linked to the bug), OCCT implements one such OIT technique - Weighted OIT eliminating the main artifacts of unordered transparency at the cost of blurry transparency and a little bit slower framerate. There are other OIT techniques available in a wild providing better visual quality at lower framerate, which are currently not available in OCCT 3D Viewer. OCCT 3D Viewer also provides Ray-Tracing engine, which handles transparency more naturally.

OIT is disabled by default in OCCT 3D Viewer, so that application experiencing artifacts should enable it explicitly.

pload VISUALIZATION MODELING
restore shell.brep s
vinit View1
vdisplay -dispMode 1 s
vaspects s -setTransparency 0.4
vfit
vrenderparams -oit 0


(0093091)
Matthias (developer)
2020-07-10 16:15

Thank you Kirill,

it was unclear to me, that it's not a default, but has to be activated explicitly. There is a comment on the bottom of 0027925:

*Patch also simplifies processing of transparent objects for standard method:
rendering priority of transparent graphical structures is managed automatically,
therefore there is no need to care about it at application's side.*

The issue can be closed. Thanks again!
(0093092)
kgv (developer)
2020-07-10 16:20
edited on: 2020-07-10 16:21

> Patch also simplifies processing of transparent objects for standard method
Previously opaque and transparent objects have not been sorted, so that it was easy to draw something completely broken like opaque object overriding transparent one. The sorting have to be done manually via priorities (like it was done in AIS_Shape). Now transparent presentations are implicitly drawn after opaque ones, so that this specific kind of issue does no more occur (but it is irrelevant to the issue of combining several transparent presentations).


- Issue History
Date Modified Username Field Change
2016-12-20 16:19 Timo New Issue
2016-12-20 16:19 Timo Assigned To => kgv
2016-12-20 16:19 Timo File Added: transparency artefacts.png
2016-12-20 16:20 Timo File Added: shell.brep
2016-12-20 16:32 kgv Relationship added duplicate of 0027716
2016-12-20 16:32 kgv Relationship added duplicate of 0027925
2016-12-20 16:33 kgv Note Added: 0061927
2016-12-20 16:33 kgv Assigned To kgv => bugmaster
2016-12-20 16:33 kgv Status new => feedback
2016-12-20 16:33 kgv Resolution open => duplicate
2016-12-20 16:35 Timo Note Added: 0061928
2016-12-20 16:35 Timo Note Edited: 0061928 View Revisions
2016-12-20 16:43 kgv Note Added: 0061929
2016-12-20 16:45 kgv Note Edited: 0061929 View Revisions
2016-12-20 16:45 kgv Note Edited: 0061929 View Revisions
2016-12-20 16:45 kgv Note Edited: 0061929 View Revisions
2016-12-22 11:32 apn Test case number => Not needed
2016-12-22 11:32 apn Status feedback => closed
2016-12-22 11:32 apn Target Version 7.2.0 =>
2020-07-10 13:41 Matthias Note Added: 0093082
2020-07-10 13:41 Matthias Status closed => feedback
2020-07-10 13:41 Matthias Resolution duplicate => reopened
2020-07-10 14:45 kgv Note Added: 0093087
2020-07-10 14:45 kgv Assigned To bugmaster => Matthias
2020-07-10 14:46 kgv Note Edited: 0093087 View Revisions
2020-07-10 14:46 kgv Note Edited: 0093087 View Revisions
2020-07-10 14:47 kgv Note Edited: 0093087 View Revisions
2020-07-10 16:15 Matthias Note Added: 0093091
2020-07-10 16:15 Matthias Assigned To Matthias => bugmaster
2020-07-10 16:15 Matthias Resolution reopened => fixed
2020-07-10 16:20 kgv Note Added: 0093092
2020-07-10 16:20 kgv Note Edited: 0093092 View Revisions
2020-07-10 16:21 kgv Note Edited: 0093092 View Revisions
2020-07-10 16:21 kgv Note Edited: 0093092 View Revisions
2020-07-14 14:41 bugmaster Status feedback => closed
2020-07-14 14:41 bugmaster Fixed in Version => 7.2.0


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker