MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028242Community[OCCT] OCCT:Modeling Algorithmspublic2016-12-19 00:422019-09-07 16:27
Reporterdipts 
Assigned Toapn 
PrioritynormalSeveritymajor 
StatusverifiedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.4.0Fixed in Version 
Summary0028242: [Regression] HLR Poly Algo has broken edges
DescriptionFound in OCCT 7.1.0 as a regression to 7.0.0.

(I cannot select 7.1.0 as product Version, please correct this when available).

The HLR PolyAlgo breaks edges of even simple shapes into visible and invisible parts, although the whole edge is freely visible. See screenshot, in the upper right corner a part of the edge is missing.
Steps To Reproducepload VISUALIZATION

restore hlr.brep
vinit
vdisplay hlr
vaxo
vfit
vhlrtype polyalgo
vhlr on
TagsNo tags attached.
Test case numberhlr poly_hlr bug28242
Attached Filespng file icon HLR_BrokenEdge.png (28,841 bytes) 2016-12-19 00:42
? file icon hlr.tcl (92 bytes) 2016-12-19 00:43
? file icon hlr.brep (4,080 bytes) 2016-12-19 00:43

- Relationships
related to 0028475assignedjgv HLR IN 7.1.0 DIFFERENT TO 7.0.0 

-  Notes
(0086663)
git (administrator)
2019-09-02 18:18

Branch CR28242 has been created by abv.

SHA-1: 8c57c626d9181be6426128717deff31032119eae


Detailed log of new commits:

Author: abv
Date: Mon Sep 2 18:15:55 2019 +0300

    0028242: [Regression] HLR Poly Algo has broken edges
    
    Added test hlr poly_hlr bug28242
(0086664)
abv (manager)
2019-09-02 18:24

The problem is not reproduced on current master (but still present on OCCT 7.3.0), so I have added a test case to confirm that. Please add test shape to data files repo so that Jenkins tests could be run.
(0086666)
msv (developer)
2019-09-02 18:44

File added.
(0086667)
msv (developer)
2019-09-02 18:45

Reviewed.
(0086941)
git (administrator)
2019-09-07 16:27

Branch CR28242 has been deleted by inv.

SHA-1: 8c57c626d9181be6426128717deff31032119eae

- Related Changesets
occt: master 7185019a
Timestamp: 2019-09-02 15:15:55
Author: abv
Committer: apn
Details ] Diff ]
0028242: [Regression] HLR Poly Algo has broken edges

Added test hlr poly_hlr bug28242
add - tests/hlr/poly_hlr/bug28242 Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-12-19 00:42 dipts New Issue
2016-12-19 00:42 dipts Assigned To => msv
2016-12-19 00:42 dipts File Added: HLR_BrokenEdge.png
2016-12-19 00:43 dipts File Added: hlr.tcl
2016-12-19 00:43 dipts File Added: hlr.brep
2016-12-19 06:41 abv Product Version 7.0.0 => 7.1.0
2016-12-19 06:43 abv Target Version => 7.3.0
2016-12-19 10:16 msv Assigned To msv => jgv
2016-12-19 10:16 msv Status new => assigned
2017-05-19 15:36 abv Target Version 7.3.0 => 7.2.0
2017-07-21 11:17 msv Target Version 7.2.0 => 7.3.0
2017-12-05 17:09 msv Target Version 7.3.0 => 7.4.0
2018-02-26 14:10 dipts Relationship added related to 0028475
2019-08-12 17:59 msv Target Version 7.4.0 => 7.5.0*
2019-09-02 18:18 git Note Added: 0086663
2019-09-02 18:24 abv Note Added: 0086664
2019-09-02 18:24 abv Status assigned => resolved
2019-09-02 18:24 abv Target Version 7.5.0* => 7.4.0
2019-09-02 18:24 abv Assigned To jgv => msv
2019-09-02 18:44 msv Note Added: 0086666
2019-09-02 18:45 msv Note Added: 0086667
2019-09-02 18:45 msv Assigned To msv => bugmaster
2019-09-02 18:45 msv Status resolved => reviewed
2019-09-02 18:56 apn Test case number => hlr poly_hlr bug28242
2019-09-02 18:57 apn Status reviewed => tested
2019-09-07 11:38 apn Changeset attached => occt master 7185019a
2019-09-07 11:38 apn Assigned To bugmaster => apn
2019-09-07 11:38 apn Status tested => verified
2019-09-07 11:38 apn Resolution open => fixed
2019-09-07 16:27 git Note Added: 0086941


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker