View Issue Details

IDProjectCategoryView StatusLast Update
0028228Open CASCADEOCCT:Modeling Algorithmspublic2017-09-29 16:24
Reporteremv Assigned Tobugmaster  
PrioritynormalSeverityfeature 
Status closedResolutionfixed 
Product Version7.1.0 
Target Version7.2.0Fixed in Version7.2.0 
Summary0028228: Provide possibility to keep the given edges during unification of faces in ShapeUpgrade_UnifySameDomain algorithm
DescriptionThere should be possibility in the ShapeUpgrade_UnifySameDomain algorithm to avoid merging of the faces in given places, i.e. possibility to keep the given edges in the result.
Steps To Reproducebugs modalg_6 bug28228
TagsNo tags attached.
Test case numberheal unify_same_domain A1, A2, A3

Attached Files

  • unify_with_keep_input.PNG (14,303 bytes)
  • unify_with_keep_result.PNG (15,751 bytes)
  • unify_with_keep.brep (13,523 bytes)

Relationships

related to 0028245 closedbugmaster Result of Cells Builder algorithm becomes invalid after removal of internal boundaries on faces 

Activities

git

2016-12-22 18:57

administrator   ~0062022

Branch CR28228 has been created by imn.

SHA-1: 7b56dd8e00f84b94897424a2ca65f508c9b7d5ce


Detailed log of new commits:

Author: imn
Date: Thu Dec 22 18:55:55 2016 +0300

    0028228: Provide possibility to keep the given edges during unification of faces in ShapeUpgrade_UnifySameDomain algorithm
    
    - Added methods "KeepShape" and "KeepShapes" for "ShapeUpgrade_UnifySameDomain" class
    - Updated "unifysamedom" command in Draw

imn

2016-12-22 19:03

developer   ~0062023

Dear Mikhail, could you please review CR28228.

msv

2016-12-23 17:41

developer   ~0062077

src\SWDRAW\SWDRAW_ShapeUpgrade.cxx

Please correct old mistake in help of command unifysamedom: replace the option "-i" with "+i" in lines 1289 and 1587.

Update help of the command on the line 1587 with new options.

src\ShapeUpgrade\ShapeUpgrade_UnifySameDomain.hxx

It is needed to add a bit more details in description of KeepShape method. That the shape can be vertex or edge. In case of vertex it forbids merging of connected edges. In case of edge it forbids merging of connected faces.

src\ShapeUpgrade\ShapeUpgrade_UnifySameDomain.cxx

1118,1140: there is no need to initialize the list, as its default constructor will be called by default.
1266-1271: it is not clear why use call MapShapesAndAncestors for items of myKeepShapes. It has no sense.
I would prefer using the type TopTools_MapOfShape for the field myKeepShapes, so that it was ready by the time of calling Perform().
1371: it is better to use only one list aKeepEdges. The edges that earlier were put to the list aMultEdges are now to be put in aKeepEdges.
Please, do not consider the flag hasAllKeepEdges at all.
The block 1388-1419 must work for keep edges also.

git

2016-12-26 15:24

administrator   ~0062132

Branch CR28228 has been updated by imn.

SHA-1: 4f72acb4315f74c444431a42b3a8a8ab73ada30f


Detailed log of new commits:

Author: imn
Date: Mon Dec 26 15:23:59 2016 +0300

    Remarks correction

imn

2016-12-26 15:25

developer   ~0062133

Dear Mikhail, could you please review CR28228, branch is updated according to remarks

msv

2016-12-26 16:41

developer   ~0062139

src\ShapeUpgrade\ShapeUpgrade_UnifySameDomain.hxx
Include of TopTools_ListOfShape should be removed.
In 75, "This shapes" => "These shapes".

src\ShapeUpgrade\ShapeUpgrade_UnifySameDomain.cxx
In 1370, remove check of myAllowInternal.
Add the same treatment for vertices, when merging of edges.

git

2016-12-27 16:26

administrator   ~0062194

Branch CR28228_1 has been created by imn.

SHA-1: 9d8b449f1478f15034849aa2bfa0b503f73a1c6f


Detailed log of new commits:

Author: imn
Date: Thu Dec 22 18:55:55 2016 +0300

    0028228: Provide possibility to keep the given edges during unification of faces in ShapeUpgrade_UnifySameDomain algorithm
    
    - Added methods "KeepShape" and "KeepShapes" for "ShapeUpgrade_UnifySameDomain" class
    - Updated "unifysamedom" command in Draw

imn

2016-12-27 16:43

developer   ~0062198

Dear Mikhail, could you please review CR28228_1, branch is updated according to remarks and rebase onto current master

msv

2016-12-28 09:33

developer   ~0062214

src\ShapeUpgrade\ShapeUpgrade_UnifySameDomain.hxx
- Again, include of TopTools_ListOfShape should be removed.
- In 69, "These shape" => "This shape".

In test results, it seams that "result3" is not as expected. The faces left and upper right (divided by edges a_8 and a_9) must be merged, but they are not.

git

2016-12-30 16:00

administrator   ~0062378

Branch CR28228_1 has been updated by imn.

SHA-1: e8f869dfa7f73712218c7814def9d36b1de466f7


Detailed log of new commits:

Author: imn
Date: Fri Dec 30 15:57:05 2016 +0300

    Remarks correction

imn

2016-12-30 16:04

developer   ~0062379

Dear Mikhail, could you please review CR28228_1

msv

2017-01-09 11:12

developer   ~0062406

Logic of the code at lines 1397-1414 seems to be not correct. aLF.Extent() cannot be > 2, because aMapEF was build on a connected faces to be merged together. The sequence 'edges' must be updated if 'faces(i)' is to be removed.

The comment at 1379 is to be made more clear. The word 'keep' can be treated as a verb. It is not clear to which noun the word 'which' has connection.

msv

2017-01-09 11:26

developer   ~0062407

The result2 in the test is incorrect:
unifysamedom result2 a a_3 a_9
The edges a_3 and a_9 are disappeared by merging in the result.
The result3 is incorrect. It is obvious if we explode it on faces and see them separately.

git

2017-01-09 20:26

administrator   ~0062433

Branch CR28228_1 has been updated by imn.

SHA-1: c01e49662d90607802a4d0341a460f6c2ed3a874


Detailed log of new commits:

Author: imn
Date: Mon Jan 9 20:26:11 2017 +0300

    Additional remarks correction

git

2017-01-11 14:34

administrator   ~0062491

Branch CR28228_2 has been created by imn.

SHA-1: d04cde1760074f978666473320197e7cefc5ed87


Detailed log of new commits:

Author: imn
Date: Fri Dec 30 15:57:05 2016 +0300

    Remarks correction

Author: imn
Date: Thu Dec 22 18:55:55 2016 +0300

    0028228: Provide possibility to keep the given edges during unification of faces in ShapeUpgrade_UnifySameDomain algorithm
    
    - Added methods "KeepShape" and "KeepShapes" for "ShapeUpgrade_UnifySameDomain" class
    - Updated "unifysamedom" command in Draw

imn

2017-01-11 14:35

developer   ~0062492

Dear Mikhail, could you please review CR28228_2, branch is updated according to remarks and rebase onto current master

msv

2017-01-20 18:56

developer   ~0062871

Please correct the code as we agreed.

git

2017-01-24 19:06

administrator   ~0062979

Branch CR28228_3 has been created by imn.

SHA-1: 52a93d0088bd638245bbe5fa5536466c68582653


Detailed log of new commits:

Author: imn
Date: Fri Dec 30 15:57:05 2016 +0300

    Remarks correction

Author: imn
Date: Thu Dec 22 18:55:55 2016 +0300

    0028228: Provide possibility to keep the given edges during unification of faces in ShapeUpgrade_UnifySameDomain algorithm
    
    - Added methods "KeepShape" and "KeepShapes" for "ShapeUpgrade_UnifySameDomain" class
    - Updated "unifysamedom" command in Draw

imn

2017-01-24 19:07

developer   ~0062980

Dear Mikhail, could you please review CR28228_3, branch is updated according to remarks and rebase onto current master

msv

2017-01-25 17:16

developer   ~0063035

tests/bugs/modalg_6/bug28228
- Please create create a new case bug28228_1 for bug28228_face_circle.brep. Do not put all cases in one script.

src/ShapeUpgrade/ShapeUpgrade_UnifySameDomain.cxx
- 970: use method Find instead of Seek in case if you do not check pointer for null. Is it safe to not check it in this case?
- 1092,1468,1492,1497: too long lines.
- Logic of the loop at 1497 is incorrect.
- 1504: make continue at a separate line (for easier debug) and make a comment here that we stop merging the current set of faces.

git

2017-01-25 19:40

administrator   ~0063052

Branch CR28228_3 has been updated by imn.

SHA-1: c365210a955a77deff7d0a0a9b93acb631269a6e


Detailed log of new commits:

Author: imn
Date: Wed Jan 25 19:39:52 2017 +0300

    Additional remarks correction

imn

2017-01-25 19:42

developer   ~0063053

Dear Mikhail, could you please review CR28228_3, branch is updated according to remarks

msv

2017-01-26 10:25

developer   ~0063063

tests\bugs\modalg_6\bug28228
- why did you remove the lines:
   unifysamedom result a a_3 a_9 +i
   checknbshapes result -face 1 -edge 12 -vertex 12
Now the variable 'result' used in the command 'checkview' is not defined.

src\ShapeUpgrade\ShapeUpgrade_UnifySameDomain.cxx
- 970-971: not good code. The map may not contain the edge. In this case there will be exception. If it contains the edge then hardly it can be a null shape. So, the method Seek can be used to check the pointer for null before its dereference. See lines 1104-1107 for reference.
- The line 1504 can be omitted if you check that 'faces' is not empty before the line 1499. Just put all the block 1495-1517 in this condition.
- Unsafe code at 1507, you should check if aE is present in aMapEF. If some faces were removed from the set a keep edge can be not found there.
- However, it is not needed at all to clear and re-fill aMapEF. Use the same state of the map. So, the previous remark will be not relevant.

git

2017-01-26 10:51

administrator   ~0063065

Branch CR28228_3 has been updated by imn.

SHA-1: 15270fdea9ab438f0496fec43e8e13939d17b46b


Detailed log of new commits:

Author: imn
Date: Thu Jan 26 10:50:32 2017 +0300

    Correction according to the last remarks

msv

2017-01-26 11:43

developer   ~0063068

Please correct according to verbal remarks.

git

2017-01-26 11:53

administrator   ~0063071

Branch CR28228_3 has been updated by imn.

SHA-1: 497c49e69acfc38d17116055fd7672cbabc03e75


Detailed log of new commits:

Author: imn
Date: Thu Jan 26 11:53:06 2017 +0300

    Correction according to the verbal remarks

git

2017-01-26 12:17

administrator   ~0063074

Branch CR28228_3 has been updated by imn.

SHA-1: f90b50a49955a4b277542503ca073fa5c88d051c


Detailed log of new commits:

Author: imn
Date: Thu Jan 26 12:17:32 2017 +0300

    Remarks were applied

msv

2017-01-26 12:52

developer   ~0063079

Reviewed.

git

2017-01-26 17:39

administrator   ~0063101

Branch CR28228_3 has been updated forcibly by mkv.

SHA-1: 12f9c029d4af672e5b44adcc0bc1529680ee29b5

mkv

2017-01-27 20:01

tester   ~0063155

Dear BugMaster,
Branch CR28228_3 was rebased on IR-2017-01-26 of occt git-repository.
SHA-1: 12f9c029d4af672e5b44adcc0bc1529680ee29b5

mkv

2017-01-27 20:01

tester   ~0063156

Dear BugMaster,
Branch CR28228_3 from occt git-repository (and IR-2017-01-26 from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 12f9c029d4af672e5b44adcc0bc1529680ee29b5

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 63 (63 on master)
Windows: 0 (0 on master)
MacOS : 1128

Regressions/Differences/Improvements:
http://occt-tests/CR28228_3-master-OCCT/Debian70-64/bugs/modalg_6/bug27309.html
http://occt-tests/CR28228_3-master-OCCT/Windows-64-VC10/bugs/modalg_6/bug27309.html
bugs modalg_6 bug27309: FAILED

Testing cases:
http://occt-tests/CR28228_3-master-OCCT/Debian70-64/bugs/modalg_6/bug28228.html
http://occt-tests/CR28228_3-master-OCCT/Windows-64-VC10/bugs/modalg_6/bug28228.html
bugs modalg_6 bug28228: OK
http://occt-tests/CR28228_3-master-OCCT/Debian70-64/bugs/modalg_6/bug28228_1.html
http://occt-tests/CR28228_3-master-OCCT/Windows-64-VC10/bugs/modalg_6/bug28228_1.html
bugs modalg_6 bug28228_1: OK

Testing on Linux:
occt component :
Total MEMORY difference: 92250730 / 92289033 [-0.04%]
Total CPU difference: 19963.130000000157 / 19914.070000000218 [+0.25%]
products component :
Total MEMORY difference: 31392937 / 31467714 [-0.24%]
Total CPU difference: 5634.799999999979 / 5543.51999999998 [+1.65%]

Testing on Windows:
occt component :
Total MEMORY difference: 57620720 / 57618048 [+0.00%]
Total CPU difference: 18676.236918698633 / 18683.178963198647 [-0.04%]
products component :
Total MEMORY difference: 22659012 / 22621210 [+0.17%]
Total CPU difference: 5556.97402139997 / 5570.546108399986 [-0.24%]

There are no differences in images found by testdiff.

mkv

2017-01-27 20:01

tester   ~0063157

Dear imn,
Branch CR28228_3 has been rejected due to:
- regressions/differences/improvements

git

2017-02-08 10:53

administrator   ~0063522

Branch CR28228_4 has been created by imn.

SHA-1: 7a64627d4a9c4f861468cc2d80c241f1853e01c5


Detailed log of new commits:

Author: imn
Date: Wed Feb 8 10:48:09 2017 +0300

    Fixed regressions

Author: imn
Date: Thu Dec 22 18:55:55 2016 +0300

    0028228: Provide possibility to keep the given edges during unification of faces in ShapeUpgrade_UnifySameDomain algorithm
    
    - Added methods "KeepShape" and "KeepShapes" for "ShapeUpgrade_UnifySameDomain" class
    - Updated "unifysamedom" command in Draw

imn

2017-02-08 10:56

developer   ~0063523

Dear Mikhail, could you please review CR28228_4, branch is updated and rebase onto current master

msv

2017-02-10 20:27

developer   ~0063758

The proposed fix makes different processing of multi-connected edges and manually given "keep" edges. I.e., if we mark the multi-connected edge as a "keep" edge, it will be kept in the result (it is correct), but there will remain not merged other faces, between which there is no 'keep' or multi-connected edges (and it is incorrect).

msv

2017-02-10 20:32

developer  

unify_with_keep_input.PNG (14,303 bytes)

msv

2017-02-10 20:33

developer  

unify_with_keep_result.PNG (15,751 bytes)

msv

2017-02-10 20:34

developer   ~0063759

Please see the attached pictures, input shape and the result. The result must be the same regardless of providing the pointed edge as 'keep' or no.

msv

2017-02-10 20:36

developer  

unify_with_keep.brep (13,523 bytes)

msv

2017-02-10 20:38

developer   ~0063760

I have attached the input shape for this case. Please create a new test that checks this behavior.

git

2017-02-13 18:46

administrator   ~0063777

Branch CR28228_5 has been created by imn.

SHA-1: 4eb2a6c8ab13b958e8d897e025dae7bf8b4db68f


Detailed log of new commits:

Author: imn
Date: Thu Dec 22 18:55:55 2016 +0300

    0028228: Provide possibility to keep the given edges during unification of faces in ShapeUpgrade_UnifySameDomain algorithm
    
    - Added methods "KeepShape" and "KeepShapes" for "ShapeUpgrade_UnifySameDomain" class
    - Updated "unifysamedom" command in Draw

Author: imn
Date: Mon Feb 13 17:27:55 2017 +0300

    Remarks correction

imn

2017-02-13 18:49

developer   ~0063778

Dear Mikhail, could you please review CR28228_5, branch is updated and rebase onto current master

msv

2017-02-14 10:26

developer   ~0063783

Now it looks OK. One remark is that the new method UpdatedMergeArea seems to do the same thing as AddOrdinaryEdges. I propose to use AddOrdinaryEdges everywhere.

git

2017-02-14 12:41

administrator   ~0063796

Branch CR28228_5 has been updated forcibly by imn.

SHA-1: 7e1d906d773b38f43da2ccc8770a4b35d41638fb

imn

2017-02-14 12:45

developer   ~0063797

Dear Mikhail, could you please review CR28228_5, branch is updated

msv

2017-02-14 17:03

developer   ~0063800

Please change behavior: if the edge is marked as 'keep' but its vertices are not marked as 'keep' then the edge can be merged with neighboring edges.

git

2017-02-15 13:05

administrator   ~0063813

Branch CR28228_5 has been updated by imn.

SHA-1: 3804fd609c5607fb7096063feb2bc211edd2926d


Detailed log of new commits:

Author: imn
Date: Wed Feb 15 13:05:03 2017 +0300

    Additional remarks correction

imn

2017-02-15 13:06

developer   ~0063814

Dear Mikhail, could you please review CR28228_5, branch is updated

msv

2017-02-15 22:23

developer   ~0063827

I think in the method MergeEdges we do not need to check edges for belonging to theMapKeepShape. It is because the input map NonMergVrt already contains 'keep' vertices. So, you can revert the method to its initial state, when theMapKeepShape was not in its arguments. And this will be natural, indeed, with new meaning of 'keep' edges (to use them only during merging of faces).

git

2017-02-16 11:19

administrator   ~0063834

Branch CR28228_5 has been updated by imn.

SHA-1: d3ec3445a590a3ceb4a12f19bdcadfee2bfa485f


Detailed log of new commits:

Author: imn
Date: Thu Feb 16 11:19:47 2017 +0300

    Removed redundant checks

imn

2017-02-16 11:21

developer   ~0063835

Dear Mikhail, could you please review CR28228_5, branch is updated

msv

2017-02-16 12:12

developer   ~0063837

Reviewed.

mkv

2017-02-17 11:04

tester   ~0063864

Dear BugMaster,
Branch CR28228_5 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: d3ec3445a590a3ceb4a12f19bdcadfee2bfa485f

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1195

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
http://occt-tests/CR28228_5-master-OCCT/Debian70-64/heal/unify_same_domain/A1.html
http://occt-tests/CR28228_5-master-OCCT/Windows-64-VC10/heal/unify_same_domain/A1.html
heal unify_same_domain A1: OK
http://occt-tests/CR28228_5-master-OCCT/Debian70-64/heal/unify_same_domain/A2.html
http://occt-tests/CR28228_5-master-OCCT/Windows-64-VC10/heal/unify_same_domain/A2.html
heal unify_same_domain A2: OK
http://occt-tests/CR28228_5-master-OCCT/Debian70-64/heal/unify_same_domain/A3.html
http://occt-tests/CR28228_5-master-OCCT/Windows-64-VC10/heal/unify_same_domain/A3.html
heal unify_same_domain A3: OK

Testing on Linux:
occt component :
Total MEMORY difference: 92379239 / 93203130 [-0.88%]
Total CPU difference: 19817.920000000104 / 19801.520000000215 [+0.08%]
products component :
Total MEMORY difference: 30908929 / 31027507 [-0.38%]
Total CPU difference: 5490.619999999983 / 5509.529999999978 [-0.34%]

Testing on Windows:
occt component :
Total MEMORY difference: 57832431 / 57829936 [+0.00%]
Total CPU difference: 18587.612750598575 / 18793.846072598604 [-1.10%]
products component :
Total MEMORY difference: 22194874 / 22156738 [+0.17%]
Total CPU difference: 5507.740105799972 / 5447.523719799975 [+1.11%]

There are following differences in images found by testdiff.

mkv

2017-02-17 11:04

tester   ~0063865

Dear BugMaster,
Branch CR28228_5 is TESTED.

git

2017-03-02 12:47

administrator   ~0064075

Branch CR28228-IR has been created by msv.

SHA-1: 09a4933f0e143c8f906ac64b2b43e63478d28a57


Detailed log of new commits:

Author: msv
Date: Thu Mar 2 12:47:37 2017 +0300

    // Compilation warning is gone.

git

2017-03-20 14:33

administrator   ~0064461

Branch CR28228-IR has been deleted by inv.

SHA-1: 09a4933f0e143c8f906ac64b2b43e63478d28a57

git

2017-03-20 14:34

administrator   ~0064485

Branch CR28228_5 has been deleted by inv.

SHA-1: d3ec3445a590a3ceb4a12f19bdcadfee2bfa485f

git

2017-03-20 14:35

administrator   ~0064493

Branch CR28228_4 has been deleted by inv.

SHA-1: 7a64627d4a9c4f861468cc2d80c241f1853e01c5

git

2017-03-20 14:36

administrator   ~0064513

Branch CR28228_3 has been deleted by inv.

SHA-1: 12f9c029d4af672e5b44adcc0bc1529680ee29b5

git

2017-03-20 14:36

administrator   ~0064521

Branch CR28228_2 has been deleted by inv.

SHA-1: d04cde1760074f978666473320197e7cefc5ed87

git

2017-03-20 14:37

administrator   ~0064522

Branch CR28228_1 has been deleted by inv.

SHA-1: c01e49662d90607802a4d0341a460f6c2ed3a874

git

2017-03-20 14:37

administrator   ~0064526

Branch CR28228 has been deleted by inv.

SHA-1: 4f72acb4315f74c444431a42b3a8a8ab73ada30f

Related Changesets

occt: master 9ed6494b

2016-12-22 15:55:55

imn


Committer: bugmaster Details Diff
0028228: Provide possibility to keep the given edges during unification of faces in ShapeUpgrade_UnifySameDomain algorithm

- Added methods "KeepShape" and "KeepShapes" for "ShapeUpgrade_UnifySameDomain" class
- Updated "unifysamedom" command in Draw

Remarks correction

Additional remarks correction

Removed redundant checks

Removing compilation warning
Affected Issues
0028228
mod - src/ShapeUpgrade/ShapeUpgrade_UnifySameDomain.cxx Diff File
mod - src/ShapeUpgrade/ShapeUpgrade_UnifySameDomain.hxx Diff File
mod - src/SWDRAW/SWDRAW_ShapeUpgrade.cxx Diff File
mod - tests/heal/grids.list Diff File
add - tests/heal/unify_same_domain/A1 Diff File
add - tests/heal/unify_same_domain/A2 Diff File
add - tests/heal/unify_same_domain/A3 Diff File

Issue History

Date Modified Username Field Change
2016-12-15 13:45 emv New Issue
2016-12-15 13:45 emv Assigned To => msv
2016-12-19 11:03 msv Assigned To msv => imn
2016-12-19 11:03 msv Status new => assigned
2016-12-19 11:09 emv Relationship added related to 0028245
2016-12-22 18:22 imn Steps to Reproduce Updated
2016-12-22 18:57 git Note Added: 0062022
2016-12-22 19:03 imn Note Added: 0062023
2016-12-22 19:03 imn Assigned To imn => msv
2016-12-22 19:03 imn Status assigned => resolved
2016-12-23 17:41 msv Note Added: 0062077
2016-12-23 17:42 msv Assigned To msv => imn
2016-12-23 17:42 msv Status resolved => assigned
2016-12-26 15:24 git Note Added: 0062132
2016-12-26 15:25 imn Note Added: 0062133
2016-12-26 15:25 imn Assigned To imn => msv
2016-12-26 15:25 imn Status assigned => resolved
2016-12-26 16:41 msv Note Added: 0062139
2016-12-26 16:41 msv Assigned To msv => imn
2016-12-26 16:41 msv Status resolved => assigned
2016-12-27 16:26 git Note Added: 0062194
2016-12-27 16:43 imn Note Added: 0062198
2016-12-27 16:43 imn Assigned To imn => msv
2016-12-27 16:43 imn Status assigned => resolved
2016-12-28 09:33 msv Note Added: 0062214
2016-12-28 09:33 msv Assigned To msv => imn
2016-12-28 09:33 msv Status resolved => assigned
2016-12-30 16:00 git Note Added: 0062378
2016-12-30 16:04 imn Note Added: 0062379
2016-12-30 16:04 imn Assigned To imn => msv
2016-12-30 16:04 imn Status assigned => resolved
2017-01-09 11:12 msv Note Added: 0062406
2017-01-09 11:13 msv Assigned To msv => imn
2017-01-09 11:13 msv Status resolved => assigned
2017-01-09 11:26 msv Note Added: 0062407
2017-01-09 20:26 git Note Added: 0062433
2017-01-11 14:34 git Note Added: 0062491
2017-01-11 14:35 imn Note Added: 0062492
2017-01-11 14:35 imn Assigned To imn => msv
2017-01-11 14:35 imn Status assigned => resolved
2017-01-20 18:56 msv Note Added: 0062871
2017-01-20 18:56 msv Assigned To msv => imn
2017-01-20 18:56 msv Status resolved => assigned
2017-01-24 19:06 git Note Added: 0062979
2017-01-24 19:07 imn Note Added: 0062980
2017-01-24 19:07 imn Assigned To imn => msv
2017-01-24 19:07 imn Status assigned => resolved
2017-01-25 17:16 msv Note Added: 0063035
2017-01-25 17:16 msv Assigned To msv => imn
2017-01-25 17:16 msv Status resolved => assigned
2017-01-25 19:40 git Note Added: 0063052
2017-01-25 19:42 imn Note Added: 0063053
2017-01-25 19:42 imn Assigned To imn => msv
2017-01-25 19:42 imn Status assigned => resolved
2017-01-26 10:25 msv Note Added: 0063063
2017-01-26 10:25 msv Assigned To msv => imn
2017-01-26 10:25 msv Status resolved => assigned
2017-01-26 10:51 git Note Added: 0063065
2017-01-26 10:57 imn Assigned To imn => msv
2017-01-26 10:57 imn Status assigned => resolved
2017-01-26 11:43 msv Note Added: 0063068
2017-01-26 11:43 msv Assigned To msv => imn
2017-01-26 11:43 msv Status resolved => assigned
2017-01-26 11:53 git Note Added: 0063071
2017-01-26 11:57 imn Assigned To imn => msv
2017-01-26 11:57 imn Status assigned => resolved
2017-01-26 12:17 git Note Added: 0063074
2017-01-26 12:52 msv Note Added: 0063079
2017-01-26 12:52 msv Assigned To msv => bugmaster
2017-01-26 12:52 msv Status resolved => reviewed
2017-01-26 17:22 mkv Assigned To bugmaster => mkv
2017-01-26 17:39 git Note Added: 0063101
2017-01-27 20:01 mkv Note Added: 0063155
2017-01-27 20:01 mkv Note Added: 0063156
2017-01-27 20:01 mkv Note Added: 0063157
2017-01-27 20:01 mkv Assigned To mkv => imn
2017-01-27 20:01 mkv Status reviewed => assigned
2017-01-27 20:02 mkv Test case number => bugs modalg_6 bug28228, bug28228_1
2017-02-08 10:53 git Note Added: 0063522
2017-02-08 10:56 imn Note Added: 0063523
2017-02-08 10:56 imn Assigned To imn => msv
2017-02-08 10:56 imn Status assigned => resolved
2017-02-10 20:27 msv Note Added: 0063758
2017-02-10 20:27 msv Assigned To msv => imn
2017-02-10 20:27 msv Status resolved => assigned
2017-02-10 20:32 msv File Added: unify_with_keep_input.PNG
2017-02-10 20:33 msv File Added: unify_with_keep_result.PNG
2017-02-10 20:34 msv Note Added: 0063759
2017-02-10 20:36 msv File Added: unify_with_keep.brep
2017-02-10 20:38 msv Note Added: 0063760
2017-02-13 18:46 git Note Added: 0063777
2017-02-13 18:49 imn Note Added: 0063778
2017-02-13 18:49 imn Assigned To imn => msv
2017-02-13 18:49 imn Status assigned => resolved
2017-02-14 10:26 msv Note Added: 0063783
2017-02-14 10:26 msv Status resolved => assigned
2017-02-14 10:26 msv Assigned To msv => imn
2017-02-14 12:41 git Note Added: 0063796
2017-02-14 12:45 imn Note Added: 0063797
2017-02-14 12:45 imn Assigned To imn => msv
2017-02-14 12:45 imn Status assigned => resolved
2017-02-14 17:03 msv Note Added: 0063800
2017-02-14 17:03 msv Assigned To msv => imn
2017-02-14 17:03 msv Status resolved => assigned
2017-02-15 13:05 git Note Added: 0063813
2017-02-15 13:06 imn Note Added: 0063814
2017-02-15 13:06 imn Assigned To imn => msv
2017-02-15 13:06 imn Status assigned => resolved
2017-02-15 22:23 msv Note Added: 0063827
2017-02-15 22:23 msv Assigned To msv => imn
2017-02-15 22:23 msv Status resolved => assigned
2017-02-16 11:19 git Note Added: 0063834
2017-02-16 11:21 imn Note Added: 0063835
2017-02-16 11:21 imn Assigned To imn => msv
2017-02-16 11:21 imn Status assigned => resolved
2017-02-16 12:12 msv Note Added: 0063837
2017-02-16 12:12 msv Assigned To msv => bugmaster
2017-02-16 12:12 msv Status resolved => reviewed
2017-02-16 12:28 mkv Assigned To bugmaster => mkv
2017-02-17 11:04 mkv Note Added: 0063864
2017-02-17 11:04 mkv Note Added: 0063865
2017-02-17 11:04 mkv Assigned To mkv => bugmaster
2017-02-17 11:04 mkv Status reviewed => tested
2017-02-17 11:05 mkv Test case number bugs modalg_6 bug28228, bug28228_1 => heal unify_same_domain A1, A2, A3
2017-03-02 12:47 git Note Added: 0064075
2017-03-03 16:25 bugmaster Changeset attached => occt master 9ed6494b
2017-03-03 16:25 bugmaster Status tested => verified
2017-03-03 16:25 bugmaster Resolution open => fixed
2017-03-20 14:33 git Note Added: 0064461
2017-03-20 14:34 git Note Added: 0064485
2017-03-20 14:35 git Note Added: 0064493
2017-03-20 14:36 git Note Added: 0064513
2017-03-20 14:36 git Note Added: 0064521
2017-03-20 14:37 git Note Added: 0064522
2017-03-20 14:37 git Note Added: 0064526
2017-09-29 16:20 aiv Fixed in Version => 7.2.0
2017-09-29 16:24 aiv Status verified => closed