MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028144Open CASCADE[OCCT] OCCT:Modeling Datapublic2016-11-22 16:302019-09-22 11:40
Reporterepa 
Assigned Tokgv 
PrioritynormalSeveritymajor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.6.0 
Target Version[OCCT] 7.4.0Fixed in Version 
Summary0028144: Modeling Data, GeomAdaptor_Curve - regression in comparison of version OCCT654
DescriptionThe problem is in translation of face №128(entity 507:0000516). It looks the rage of edge is computed incorrectly (it was OK in OCCT654).

Steps To Reproducerestore [locate_data_file bug28144.brep] a
axo; fit
vdisplay a; vfit
TagsNo tags attached.
Test case numberbugs vis bug28144
Attached Files? file icon 18547.stp (491,547 bytes) 2016-11-22 16:30
png file icon face_128.png (21,310 bytes) 2016-11-22 16:32
png file icon bug28144_occt730_740.png (86,096 bytes) 2019-09-04 22:38
? file icon bug28144.brep (23,514 bytes) 2019-09-04 22:58

- Relationships
child of 0028118closedabv Community Mesh generation hangs then crashes 
child of 0023062closedika Open CASCADE Incorrect display of edge in draw axo viewer 

-  Notes
(0060715)
gka (developer)
2016-11-23 11:38

Face 128 read from entity 507 is valid. But AXON viewer shows this face as invalid. Please see attached image.
This due to that first edge in the face based on the periodic curve has range -1.31441524331422e-011 0.214529066155427.
(0069785)
mkv (tester)
2017-08-23 14:24

Problem described in issue is reproduced on current state of OCCT.
(0086757)
abv (manager)
2019-09-04 22:57

The problem was actually not in STEP translation but in visualization of the edge with specific range. The same face (translated with current master) is shown without edge in OCCT 7.3.0 (both AXO and V3d viewers) but is OK with current master. The issue thus should be considered as fixed.

I pushed branch CR28144 containing corrected test case for this issue: it reads BREP file instead of STEP (this should be both faster and not depending on translation), and uses wireframe in 3D viewer (the problem is not visible in shading). Please add the attached BREP file to the test databsse and consider the branch for integration.
(0086758)
git (administrator)
2019-09-04 23:00

Branch CR28144 has been created by abv.

SHA-1: 0166ba6fb7ba314f34e7fbc81d7ea70a26b91fc9


Detailed log of new commits:

Author: abv
Date: Wed Sep 4 22:57:24 2019 +0300

    0028144: Visualization - regression in comparison of version OCCT654
    
    Test case moved to grid vis and corrected to use BREP instead of STEP, and to use wireframe in 3D viewer
(0086760)
kgv (developer)
2019-09-04 23:44
edited on: 2019-09-04 23:51

> The problem was actually not in STEP translation
> but in visualization of the edge with specific range.
Sorry, I'm unable following this logic.
The fixed bug #0030273 was within GeomAdaptor_Curve::Intervals() algorithm, introduced by 0023062.

(0086779)
kgv (developer)
2019-09-05 10:27

> tests/bugs/vis/bug28144
Test should be moved to a proper group (moddata_X).
(0086821)
abv (manager)
2019-09-05 21:22

>> Sorry, I'm unable following this logic.

The logic is straightforward: I did not delve into research of the rootcause of the problem, just noticed that it is not due to STEP and problem manifests in visualization.
(0087083)
git (administrator)
2019-09-14 11:58

Branch CR28144 has been updated forcibly by abv.

SHA-1: fcc1f590c6908b382f70cb25e9062acf842a37b1
(0087084)
abv (manager)
2019-09-14 12:02

Test renamed to be in the same grid as test for #30273; branch CR28144 rebased on current IR (OCCT-740beta2). Please review again
(0087110)
git (administrator)
2019-09-16 09:50

Branch CR28144 has been updated forcibly by kgv.

SHA-1: cd58de63de485fca0c7da52c4541853af9c990d3
(0087406)
git (administrator)
2019-09-22 11:40

Branch CR28144 has been deleted by inv.

SHA-1: cd58de63de485fca0c7da52c4541853af9c990d3

- Related Changesets
occt: master cd58de63
Timestamp: 2019-09-04 19:57:24
Author: abv
Committer: kgv
Details ] Diff ]
0028144: Modeling Data, GeomAdaptor_Curve - regression in comparison of version OCCT654

Test case moved to grid modalg_7 and corrected to use BREP instead of STEP, and to use wireframe in 3D viewer
add - tests/bugs/modalg_7/bug28144 Diff ] File ]
rm - tests/bugs/step/bug28144 Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-11-22 16:30 epa New Issue
2016-11-22 16:30 epa Assigned To => gka
2016-11-22 16:30 epa File Added: 18547.stp
2016-11-22 16:30 epa File Added: face_128.png
2016-11-22 16:31 epa File Deleted: face_128.png
2016-11-22 16:32 epa File Added: face_128.png
2016-11-22 23:25 abv Relationship added child of 0028118
2016-11-22 23:26 abv Target Version 7.1.0 => 7.2.0
2016-11-23 11:38 gka Note Added: 0060715
2017-08-15 14:52 abv Target Version 7.2.0 => 7.4.0
2017-08-23 14:24 mkv Test case number => bugs step bug28144
2017-08-23 14:24 mkv Note Added: 0069785
2019-09-04 22:38 abv File Added: bug28144_occt730_740.png
2019-09-04 22:57 abv Test case number bugs step bug28144 => bugs vis bug28144
2019-09-04 22:57 abv Note Added: 0086757
2019-09-04 22:57 abv Assigned To gka => bugmaster
2019-09-04 22:57 abv Status new => resolved
2019-09-04 22:57 abv Category OCCT:Data Exchange => OCCT:Visualization
2019-09-04 22:57 abv Summary Step reader - regression in comparison of version OCCT654 => Visualization - regression in comparison of version OCCT654
2019-09-04 22:57 abv Steps to Reproduce Updated View Revisions
2019-09-04 22:58 abv File Added: bug28144.brep
2019-09-04 23:00 git Note Added: 0086758
2019-09-04 23:42 kgv Relationship added duplicate of 0030273
2019-09-04 23:43 kgv Relationship replaced related to 0030273
2019-09-04 23:44 kgv Note Added: 0086760
2019-09-04 23:44 kgv Category OCCT:Visualization => OCCT:Modeling Algorithms
2019-09-04 23:44 kgv Summary Visualization - regression in comparison of version OCCT654 => Modeling Algorithms - regression in comparison of version OCCT654
2019-09-04 23:45 kgv Note Edited: 0086760 View Revisions
2019-09-04 23:47 kgv Product Version => 6.6.0
2019-09-04 23:49 kgv Relationship added child of 0023062
2019-09-04 23:50 kgv Note Edited: 0086760 View Revisions
2019-09-04 23:51 kgv Note Edited: 0086760 View Revisions
2019-09-05 10:27 kgv Note Added: 0086779
2019-09-05 10:28 kgv Category OCCT:Modeling Algorithms => OCCT:Modeling Data
2019-09-05 10:28 kgv Summary Modeling Algorithms - regression in comparison of version OCCT654 => Modeling Data, GeomAdaptor_Curve - regression in comparison of version OCCT654
2019-09-05 21:22 abv Note Added: 0086821
2019-09-13 19:58 bugmaster Status resolved => reviewed
2019-09-14 10:57 bugmaster Assigned To bugmaster => epa
2019-09-14 10:57 bugmaster Status reviewed => assigned
2019-09-14 11:58 git Note Added: 0087083
2019-09-14 12:02 abv Note Added: 0087084
2019-09-14 12:02 abv Assigned To epa => kgv
2019-09-14 12:02 abv Status assigned => resolved
2019-09-16 09:50 git Note Added: 0087110
2019-09-16 09:51 kgv Assigned To kgv => bugmaster
2019-09-16 09:51 kgv Status resolved => reviewed
2019-09-18 07:56 bugmaster Status reviewed => tested
2019-09-21 18:13 kgv Changeset attached => occt master cd58de63
2019-09-21 18:13 kgv Assigned To bugmaster => kgv
2019-09-21 18:13 kgv Status tested => verified
2019-09-21 18:13 kgv Resolution open => fixed
2019-09-22 11:40 git Note Added: 0087406


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker