MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028110Open CASCADE[OCCT] OCCT:Configurationpublic2016-11-15 16:452017-09-30 19:53
Reporterski 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028110: Configuration - specify Unicode charset instead of multibyte in project files for Visual Studio
DescriptionOCCT is already using explicitly Unicode (wide-char) API in most places on Windows and MFC samples are build with Unicode charset. However, project files for OCCT itself are still generated with obsolete multibyte charset flag (both CMake and genproj).

The charset in project files should be changed to Unicode and remaining places relying on UNICODE macros in OCCT should be replaced by usage of wide-char API explicitly (thus technically OCCT should be build in the same way irrelevant to charset options in project settings).
Steps To Reproduce• Generate Visual Studio project via CMake / genproj
• Check that Character set of projects is Unicode
• Build solution
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0024943closedbugmaster Open CASCADE Port MFC sample to UNICODE for compatibility with VS2013 
parent of 0029169closedbugmaster Open CASCADE Configuration - fix compilation with undefined UNICODE on Windows 
related to 0028350closedapn Open CASCADE Draw Harness - DRAWEXE hangs up immediatly when redirecting input stream on Windows 
child of 0022484closedbugmaster Open CASCADE UNICODE characters support. 

-  Notes
(0061503)
git (administrator)
2016-12-08 16:37

Branch CR28110 has been created by ski.

SHA-1: 8a6f606dc9f16df8968e3c4692a8f020b2eaa43d


Detailed log of new commits:

Author: ski
Date: Mon Nov 14 14:31:00 2016 +0300

    0028110: Configuration - specify Unicode charset instead of multibyte in project files for Visual Studio
    
    Eliminated usage of ANSI methods.
    All Visual Studio projects generated by genproj or CMake use Unicode character set.
(0061504)
ski (developer)
2016-12-08 18:06

Dear abv,

branch CR28110 contains changed to generate Unicode projects for Visual Studio,
 it is possible now to build occt using both Multibyte and Unicode character sets.

Please review.
(0061546)
git (administrator)
2016-12-09 21:23

Branch CR28110 has been updated forcibly by kgv.

SHA-1: c19b6a853fbc040909d1306bf20c355ad983847d
(0061547)
git (administrator)
2016-12-10 00:44

Branch CR28110 has been updated by kgv.

SHA-1: 824579415631c1819c954a5e4b252a42cd53b8e6


Detailed log of new commits:

Author: kgv
Date: Sat Dec 10 00:44:16 2016 +0300

    corrections

(0061548)
git (administrator)
2016-12-10 03:48

Branch CR28110 has been updated by kgv.

SHA-1: 082f8603f047a0b77bd6f33741015d58531145b6


Detailed log of new commits:

Author: kgv
Date: Sat Dec 10 03:47:59 2016 +0300

    Draw Harness now handles Unicode input on Windows.
    
    Tcl test scripts are now expected in UTF-8 encoding by default.

(0061549)
git (administrator)
2016-12-10 03:49

Branch CR28110_1 has been created by kgv.

SHA-1: 029122cb037ef19372ffb73ba755a5653b2219e8


Detailed log of new commits:

Author: kgv
Date: Sat Dec 10 03:47:59 2016 +0300

    Draw Harness now handles Unicode input on Windows.
    
    Tcl test scripts are now expected in UTF-8 encoding by default.

Author: ski
Date: Mon Nov 14 14:31:00 2016 +0300

    0028110: Configuration - specify Unicode charset instead of multibyte in project files for Visual Studio
    
    Eliminated usage of ANSI methods.
    All Visual Studio projects generated by genproj or CMake use Unicode character set.
(0061550)
kgv (developer)
2016-12-10 03:54

Updated patch is ready for review.
(0061612)
abv (manager)
2016-12-13 13:05

No remarks, please test
(0061957)
kgv (developer)
2016-12-21 15:13

Why the patch is still not processed within normal queue?
(0061965)
git (administrator)
2016-12-21 17:45

Branch CR28110_1 has been updated forcibly by apv.

SHA-1: 9193591deca4a3fbb4962f59b0ce42a1a1bf796e
(0061966)
apv (tester)
2016-12-21 17:45

Branch CR28110_1 has been rebased on the current master
(0061985)
apv (tester)
2016-12-22 11:04

Dear BugMaster,

During building of branch CR28110_1 (SHA-1: 9193591deca4a3fbb4962f59b0ce42a1a1bf796e) from occt git-repository (and master from products git-repository) compilation errors have been detected.
On Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR28110_1-master/job/CR28110_1-master-OCCT-Windows-64-VC10-opt-compile/2/parsed_console/ [^]
On MacOS:
http://jenkins-test-05.nnov.opencascade.com/view/CR28110_1-master/job/CR28110_1-master-OCCT-MacOS-opt-compile/2/parsed_console/ [^]
(0061986)
apv (tester)
2016-12-22 11:04

Dear Kirill,

Branch CR28110_1 has been rejected due to:
- compilation errors
(0061995)
git (administrator)
2016-12-22 11:53

Branch CR28110_1 has been updated by kgv.

SHA-1: 5821edabf5e53db76692a6d2e23cba71ab129c92


Detailed log of new commits:

Author: kgv
Date: Thu Dec 22 11:52:58 2016 +0300

    Correct IVtkDraw::WClass() definition and add missing TCollection_AsciiString definition.

(0061996)
git (administrator)
2016-12-22 11:54

Branch CR28110_2 has been created by kgv.

SHA-1: 1c90075136e8c0a2cd7f798ccaf30404449289a2


Detailed log of new commits:

Author: ski
Date: Mon Nov 14 14:31:00 2016 +0300

    0028110: Configuration - specify Unicode charset instead of multibyte in project files for Visual Studio
    
    Eliminated usage of ANSI methods.
    All Visual Studio projects generated by genproj or CMake use Unicode character set.
    
    Draw Harness now handles Unicode input on Windows.
    Tcl test scripts are now expected in UTF-8 encoding by default.
(0061997)
kgv (developer)
2016-12-22 11:54

Please check updated patch in branch CR28110_2.
(0062068)
git (administrator)
2016-12-23 16:03

Branch CR28110_2 has been updated forcibly by apv.

SHA-1: 0f2c2785c8a15e82c139d63999b0ed6197e6a17e
(0062069)
apv (tester)
2016-12-23 16:04

Branch CR28110_2 has been rebased on the current master
(0062107)
apv (tester)
2016-12-26 10:35

Dear BugMaster,

Branch CR28110_2 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 0f2c2785c8a15e82c139d63999b0ed6197e6a17e

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 63
   Windows: 0
   MacOS: 1132

Compilation errors have been detected during building of CSharp Products samples on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR28110_2-master/job/CR28110_2-master-Products-Windows-64-VC10-csharp-samples/1/parsed_console/ [^]

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 93444851 / 93048855 [+0.43%]
Total CPU difference: 21557.14000000025 / 21520.60000000037 [+0.17%]

Testing on Windows:
Total MEMORY difference: 58631217 / 58650770 [-0.03%]
Total CPU difference: 19384.419058298598 / 19731.318481998722 [-1.76%]
(0062108)
apv (tester)
2016-12-26 10:36

Dear Kirill,

Branch CR28110_2 has been rejected due to:
- compilation errors
(0062116)
kgv (developer)
2016-12-26 12:50

Please check compilation of modified C# sample, regression testing is not needed.
(0062162)
apv (tester)
2016-12-27 11:29

Dear BugMaster,

Branch CR28110_2 from occt git-repository (and CR28110_2 from products git-repository) was compiled on Linux, MacOS and Windows platforms.
SHA-1: 0f2c2785c8a15e82c139d63999b0ed6197e6a17e
SHA-1: 88d177502ae0061ec5d746fcbb8dd588c1e78685

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 63
   Windows: 0
   MacOS: 1152
(0063542)
git (administrator)
2017-02-08 11:31

Branch CR28110 has been deleted by kgv.

SHA-1: 082f8603f047a0b77bd6f33741015d58531145b6
(0063543)
git (administrator)
2017-02-08 11:31

Branch CR28110_1 has been deleted by kgv.

SHA-1: 5821edabf5e53db76692a6d2e23cba71ab129c92
(0063544)
git (administrator)
2017-02-08 11:31

Branch CR28110_2 has been deleted by kgv.

SHA-1: 0f2c2785c8a15e82c139d63999b0ed6197e6a17e

- Related Changesets
occt: master ad03c234
Timestamp: 2016-11-14 11:31:00
Author: ski
Committer: apn
Details ] Diff ]
0028110: Configuration - specify Unicode charset instead of multibyte in project files for Visual Studio

Eliminated usage of ANSI methods.
All Visual Studio projects generated by genproj or CMake use Unicode character set.

Draw Harness now handles Unicode input on Windows.
Tcl test scripts are now expected in UTF-8 encoding by default.
mod - adm/genproj.tcl Diff ] File ]
mod - CMakeLists.txt Diff ] File ]
mod - src/Draw/CommandWindow.cxx Diff ] File ]
mod - src/Draw/COMMANDWINDOW.h Diff ] File ]
mod - src/Draw/Draw.cxx Diff ] File ]
mod - src/Draw/Draw_Appli.hxx Diff ] File ]
mod - src/Draw/Draw_Main.cxx Diff ] File ]
mod - src/Draw/Draw_Viewer.cxx Diff ] File ]
mod - src/Draw/Draw_Window.cxx Diff ] File ]
mod - src/Draw/Draw_Window.hxx Diff ] File ]
mod - src/Draw/Draw_Window_1.mm Diff ] File ]
mod - src/Draw/init.cxx Diff ] File ]
mod - src/Draw/init.h Diff ] File ]
mod - src/Draw/MainWindow.cxx Diff ] File ]
mod - src/IVtkDraw/IVtkDraw.cxx Diff ] File ]
mod - src/IVtkDraw/IVtkDraw.hxx Diff ] File ]
mod - src/OSD/OSD_Environment.cxx Diff ] File ]
mod - src/OSD/OSD_File.cxx Diff ] File ]
mod - src/OSD/OSD_Host.cxx Diff ] File ]
mod - src/OSD/OSD_Process.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest.hxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ViewerCommands.cxx Diff ] File ]
mod - src/WNT/FILES Diff ] File ]
mod - src/WNT/WNT_WClass.cxx Diff ] File ]
mod - src/WNT/WNT_WClass.hxx Diff ] File ]
rm - src/WNT/WNT_WClass.lxx Diff ] File ]
mod - src/WNT/WNT_Window.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-11-15 16:45 ski New Issue
2016-11-15 16:45 ski Assigned To => ski
2016-11-16 10:25 kgv Category OCCT:Coding => OCCT:Configuration
2016-11-16 10:25 kgv Summary Coding - Port OCCT to UNICODE => Configuration - specify Unicode charset instead of multibyte in project files for Visual Studio
2016-11-16 10:25 kgv Description Updated View Revisions
2016-11-16 10:26 kgv Relationship added related to 0027350
2016-11-16 10:27 kgv Relationship added child of 0022484
2016-11-16 10:27 kgv Relationship added related to 0024943
2016-11-16 10:28 kgv Product Version => 6.8.0
2016-12-08 16:37 git Note Added: 0061503
2016-12-08 17:53 ski Status new => assigned
2016-12-08 18:06 ski Note Added: 0061504
2016-12-08 18:06 ski Assigned To ski => abv
2016-12-08 18:06 ski Status assigned => resolved
2016-12-08 18:06 ski Steps to Reproduce Updated View Revisions
2016-12-09 21:23 git Note Added: 0061546
2016-12-10 00:44 git Note Added: 0061547
2016-12-10 03:48 git Note Added: 0061548
2016-12-10 03:49 git Note Added: 0061549
2016-12-10 03:54 kgv Note Added: 0061550
2016-12-13 13:05 abv Note Added: 0061612
2016-12-13 13:05 abv Assigned To abv => bugmaster
2016-12-13 13:05 abv Status resolved => reviewed
2016-12-21 15:13 kgv Note Added: 0061957
2016-12-21 15:17 apv Assigned To bugmaster => apv
2016-12-21 17:45 git Note Added: 0061965
2016-12-21 17:45 apv Note Added: 0061966
2016-12-22 11:04 apv Note Added: 0061985
2016-12-22 11:04 apv Assigned To apv => kgv
2016-12-22 11:04 apv Status reviewed => assigned
2016-12-22 11:04 apv Note Added: 0061986
2016-12-22 11:53 git Note Added: 0061995
2016-12-22 11:54 git Note Added: 0061996
2016-12-22 11:54 kgv Note Added: 0061997
2016-12-22 11:54 kgv Assigned To kgv => bugmaster
2016-12-22 11:54 kgv Status assigned => resolved
2016-12-22 11:55 kgv Status resolved => reviewed
2016-12-22 12:16 apv Assigned To bugmaster => apv
2016-12-23 16:03 git Note Added: 0062068
2016-12-23 16:04 apv Note Added: 0062069
2016-12-26 10:35 apv Note Added: 0062107
2016-12-26 10:35 apv Assigned To apv => kgv
2016-12-26 10:35 apv Status reviewed => assigned
2016-12-26 10:35 apv Test case number => Not needed
2016-12-26 10:36 apv Note Added: 0062108
2016-12-26 12:50 kgv Note Added: 0062116
2016-12-26 12:50 kgv Assigned To kgv => bugmaster
2016-12-26 12:50 kgv Status assigned => resolved
2016-12-26 12:50 kgv Status resolved => reviewed
2016-12-26 14:45 apv Assigned To bugmaster => apv
2016-12-27 11:29 apv Note Added: 0062162
2016-12-27 11:29 apv Assigned To apv => bugmaster
2016-12-27 11:29 apv Status reviewed => tested
2016-12-30 18:08 apn Changeset attached => occt master ad03c234
2016-12-30 18:08 apn Assigned To bugmaster => apn
2016-12-30 18:08 apn Status tested => verified
2016-12-30 18:08 apn Resolution open => fixed
2017-01-12 16:53 nbv Relationship added related to 0028350
2017-02-08 11:31 git Note Added: 0063542
2017-02-08 11:31 git Note Added: 0063543
2017-02-08 11:31 git Note Added: 0063544
2017-09-29 16:21 user533 Fixed in Version => 7.2.0
2017-09-29 16:24 user533 Status verified => closed
2017-09-30 19:53 kgv Relationship added parent of 0029169


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker