MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028038Open CASCADE[OCCT] Website:Portalpublic2016-11-02 11:572016-12-09 16:39
Reporteraml 
Assigned Toapn 
PriorityhighSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0028038: Incorrect documentation generated for "user guides/BRep Format"
DescriptionIt was found that "BRep Format" document contains a lot of TEX formulas. For some strange reason images have not been generated. The example below demonstrates such situation.

 \( f_{1}\; f_{2}\; f_{3}\; f_{4}\; f_{5}\; f_{6}\; f_{7} \) <flag>s \( f_{i}\;(1\leq i \leq 7) \)
Steps To ReproduceOpen https://dev.opencascade.org/doc/overview/html/occt_dev_guides__documentation.html [^] and check that the formulae at the end of the document are rendered correctly
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0060571)
abv (manager)
2016-11-19 17:16

Apparently the problem is that MathJax does not load properly.

The problem exists only for documentation that is located on our servers, including docs for previous releases, e.g.:

https://dev.opencascade.org/doc/overview/html/occt_dev_guides__documentation.html [^]
https://www.opencascade.com/doc/occt-6.7.0/overview/html/dev_guides__documentation.html [^]

(examples of formulae are put at the end of this document).

There is no such problem in documentation local documentation included with official release (installer) or generated from code.

I could not find any difference between HTML code of the documentation from server against local version (apart of URLs). Hence, the problem seems to be most likely in server settings / configuration. Please investigate this.

As a first step, I suggest copying docs back from server to local station and checking if the problem appears.
(0060608)
user533
2016-11-21 12:21

This is because out websites moved to HTTPS, while the documentation contains links to external HTTP resources (MathJax), that is insecure from the the point of view of browsers.

It is always better to load external resources via HTTPS, if available.
Thus could you please take care of this in next releases. Another way is to deliver documentation with local versions of external .js libraries.

As for the old versions of documentation on the server, I will replace all links:
http://cdn.mathjax.org/mathjax/latest/MathJax.js [^]
with the HTTPS ones:
https://cdn.mathjax.org/mathjax/latest/MathJax.js [^]
(0060646)
git (administrator)
2016-11-21 18:26

Branch CR28038 has been created by aiv.

SHA-1: 28e094c81b9152c5e2eab8ba79feeee2f70a2356


Detailed log of new commits:

Author: aiv
Date: Mon Nov 21 18:23:28 2016 +0300

    0028038: Incorrect documentation generated for "user guides/BRep Format"
    
    References to external MathJax.js library were changed from HTTP to HTTPS alternative.
(0060647)
user533
2016-11-21 18:37

Hi Andrey,

I fixed references to MathJax.js on www.opencascade.com/doc/...
I see no impact if references will be updated everywhere, so please find the corresponding changes in the CR28038 branch as well.
As for updating documentation on dev.opencascade.org - it is yours.
(0060663)
abv (manager)
2016-11-22 11:17

Reviewed and checked; please integrate (no testing is needed)
(0061262)
git (administrator)
2016-12-07 11:30

Branch CR28038 has been deleted by kgv.

SHA-1: 28e094c81b9152c5e2eab8ba79feeee2f70a2356

- Related Changesets
occt: master ce73cfd0
Timestamp: 2016-11-21 15:23:28
Author: user533
Committer: apn
Details ] Diff ]
0028038: Incorrect documentation generated for "user guides/BRep Format"

References to external MathJax.js library were changed from HTTP to HTTPS alternative.
mod - adm/gendoc.tcl Diff ] File ]
mod - dox/CMakeLists.txt Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-11-02 11:57 aml New Issue
2016-11-02 11:57 aml Assigned To => ysn
2016-11-19 17:16 abv Note Added: 0060571
2016-11-19 17:16 abv Assigned To ysn => user533
2016-11-19 17:16 abv Priority normal => high
2016-11-19 17:16 abv Status new => assigned
2016-11-19 17:16 abv Category OCCT:Documentation => Website:Portal
2016-11-21 12:21 user533 Note Added: 0060608
2016-11-21 18:26 git Note Added: 0060646
2016-11-21 18:36 user533 Assigned To user533 => apn
2016-11-21 18:37 user533 Note Added: 0060647
2016-11-22 11:16 abv Assigned To apn => abv
2016-11-22 11:16 abv Status assigned => resolved
2016-11-22 11:16 abv Steps to Reproduce Updated View Revisions
2016-11-22 11:17 abv Note Added: 0060663
2016-11-22 11:17 abv Assigned To abv => bugmaster
2016-11-22 11:17 abv Status resolved => reviewed
2016-11-22 12:25 apv Test case number => Not needed
2016-11-22 12:25 apv Status reviewed => tested
2016-11-24 15:52 apn Changeset attached => occt master ce73cfd0
2016-11-24 15:52 apn Assigned To bugmaster => apn
2016-11-24 15:52 apn Status tested => verified
2016-11-24 15:52 apn Resolution open => fixed
2016-12-07 11:30 git Note Added: 0061262
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker