MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028027Open CASCADE[OCCT] OCCT:Configurationpublic2016-10-28 22:122016-12-09 16:39
Reporterkgv 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0028027: Configuration - option BUILD_RESOURCES does not work on CMake 2.8
DescriptionNew CMake option BUILD_RESOURCES added in scope 0027258 does not work with CMake 2.8:
CMake Error at adm/cmake/occt_resources.cmake:51 (string):
  string does not recognize sub-command APPEND
Call Stack (most recent call first):
  adm/cmake/occt_resources.cmake:76 (OCCT_GENERATE_CONTENT_ONLY)
  CMakeLists.txt:12 (include)
  CMakeLists.txt:292 (OCCT_INCLUDE_CMAKE_FILE)


Since this option is not mandatory, it is not critical to make it compatible with old CMake (if it is complicated), but probably comment should be added specifying minimal required version.
Steps To ReproduceIn CMake GUI/console application:
• Set option BUILD_RESOURCES ON
• Try to configure/generate occt via CMake 2.8.12 (it is minimum required version of CMake)
Result: no warning/error appears

Repeat same steps for some new version of CMake -> no warning/error appears
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
child of 0027258closedapn Configuration - generate built-in replacement for mandatory resource files 

-  Notes
(0059625)
git (administrator)
2016-10-31 11:55

Branch CR28027 has been created by ski.

SHA-1: 63d70c6bbb09191fe96e587462052f22ee26b7b0


Detailed log of new commits:

Author: ski
Date: Mon Oct 31 11:54:54 2016 +0300

    0028027: Configuration - option BUILD_RESOURCES does not work on CMake 2.8
    
    CMake command "string (APPEND ...)" was replaced by SET equivalent to support CMake 2.8
(0059628)
ski (developer)
2016-10-31 12:27

Dear ibs,

i have replaced command "string (APPEND ...)" by "SET (...)" equivalent to support CMake 2.8.12.
Configuration was checked on my local station using CMake 2.8.12 and 3.5.2.

Please, review.
(0059629)
kgv (developer)
2016-10-31 12:30

           set (OCCT_HEADER_FILE_CONTENT)
-          string (APPEND OCCT_HEADER_FILE_CONTENT "// This file has been automatically generated 
from resource file src/${CurrentResource_Directory}/${RESOURCE_FILE}\n\n")
+          set (OCCT_HEADER_FILE_CONTENT "${OCCT_HEADER_FILE_CONTENT}// This file has been automatically 
generated from resource file src/${CurrentResource_Directory}/${RESOURCE_FILE}\n\n"

I think theses two lines can be merged.
(0059630)
ski (developer)
2016-10-31 12:34

String "set (OCCT_HEADER_FILE_CONTENT)" is necessary for cleaning of variable OCCT_HEADER_FILE_CONTENT between generation of different resource header files.
(0059631)
kgv (developer)
2016-10-31 12:39

So, the following initialization will not work as expected?
set (OCCT_HEADER_FILE_CONTENT "// This file has been automatically 
generated from resource file src/${CurrentResource_Directory}/${RESOURCE_FILE}\n\n"
(0059632)
git (administrator)
2016-10-31 12:41

Branch CR28027 has been updated forcibly by ski.

SHA-1: 3cc0e90d3513e2fdd439b51854f400299baf17a6
(0059633)
ski (developer)
2016-10-31 12:42

I have updated branch CR28027 due to remarks.
(0059674)
ibs (developer)
2016-11-01 11:35

there are no remarks
(0059942)
git (administrator)
2016-11-07 15:51

Branch CR28027 has been updated forcibly by apn.

SHA-1: a42c4c6721e60f996151877bb64395f4e39f1c2c
(0061255)
git (administrator)
2016-12-07 11:30

Branch CR28027 has been deleted by kgv.

SHA-1: a42c4c6721e60f996151877bb64395f4e39f1c2c

- Related Changesets
occt: master b2134621
Timestamp: 2016-10-31 08:54:54
Author: ski
Committer: apn
Details ] Diff ]
0028027: Configuration - option BUILD_RESOURCES does not work on CMake 2.8

CMake command "string (APPEND ...)" was replaced by SET equivalent to support CMake 2.8
mod - adm/cmake/occt_resources.cmake Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-10-28 22:12 kgv New Issue
2016-10-28 22:12 kgv Assigned To => ski
2016-10-28 22:12 kgv Relationship added child of 0027258
2016-10-31 11:55 git Note Added: 0059625
2016-10-31 11:55 ski Status new => assigned
2016-10-31 12:27 ski Note Added: 0059628
2016-10-31 12:27 ski Assigned To ski => ibs
2016-10-31 12:27 ski Status assigned => resolved
2016-10-31 12:27 ski Steps to Reproduce Updated View Revisions
2016-10-31 12:30 kgv Note Added: 0059629
2016-10-31 12:34 ski Note Added: 0059630
2016-10-31 12:39 kgv Note Added: 0059631
2016-10-31 12:41 git Note Added: 0059632
2016-10-31 12:42 ski Note Added: 0059633
2016-11-01 11:35 ibs Note Added: 0059674
2016-11-01 11:35 ibs Assigned To ibs => bugmaster
2016-11-01 11:35 ibs Status resolved => reviewed
2016-11-07 15:51 git Note Added: 0059942
2016-11-07 16:10 apn Test case number => Not needed
2016-11-07 16:10 apn Status reviewed => tested
2016-11-09 17:43 apn Changeset attached => occt master b2134621
2016-11-09 17:43 apn Assigned To bugmaster => apn
2016-11-09 17:43 apn Status tested => verified
2016-11-09 17:43 apn Resolution open => fixed
2016-12-07 11:30 git Note Added: 0061255
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker