MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028010Open CASCADE[OCCT] OCCT:Visualizationpublic2016-10-26 22:102016-12-09 16:39
Reporterkgv 
Assigned Toapn 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0028010: Visualization, Prs3d_Arrow - add Shading presentation builder
DescriptionIt is desired to extend Prs3d_Arrow class with method for building shaded (triangulated) arrow presentation.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0027958closedbugmaster Open CASCADE Visualization, AIS_Trihedron - add shaded presentation option 

-  Notes
(0059220)
git (administrator)
2016-10-26 23:40

Branch CR28010 has been created by kgv.

SHA-1: a8ce7ce635d71d06dac4414f59e0908834b16172


Detailed log of new commits:

Author: isk
Date: Fri Oct 14 09:17:36 2016 +0300

    0028010: Visualization, Prs3d_Arrow - add Shading presentation builder
    
    StdPrs_ToolCylinder, StdPrs_ToolDisk, StdPrs_ToolQuadric and StdPrs_ToolSphere
    have been moved from StdPrs package to Prs3d.
(0059221)
kgv (developer)
2016-10-26 23:40

Please test the patch.
(0059334)
git (administrator)
2016-10-28 15:08

Branch CR28010 has been updated forcibly by mkv.

SHA-1: 2faa5c68a31348464ba9571210d5250e62e0b035
(0059703)
mkv (tester)
2016-11-01 16:00

Dear BugMaster,
Branch CR28010 was rebased on current master of occt git-repository.
SHA-1: 2faa5c68a31348464ba9571210d5250e62e0b035
(0059704)
mkv (tester)
2016-11-01 16:01

Dear BugMaster,
Branch CR28010 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 2faa5c68a31348464ba9571210d5250e62e0b035

There are following compilation errors:
Windows:

http://jenkins-test-07.nnov.opencascade.com:8080/view/CR28010-master/job/CR28010-master-Products-Windows-64-VC10-csharp-samples/1/parsed_console/ [^]

1>occcsharp_wrap.cxx(90196): error C2248: 'Prs3d_Arrow::operator new' : cannot access private member declared in class 'Prs3d_Arrow'
1> d:/install/CR28010-master/Windows-64-VC10-opt/OCCT/inc\Prs3d_Arrow.hxx(33) : see declaration of 'Prs3d_Arrow::operator new'
1> d:/install/CR28010-master/Windows-64-VC10-opt/OCCT/inc\Prs3d_Arrow.hxx(31) : see declaration of 'Prs3d_Arrow'
1>occcsharp_wrap.cxx(90198): error C2248: 'Prs3d_Arrow::operator delete' : cannot access private member declared in class 'Prs3d_Arrow'
1> d:/install/CR28010-master/Windows-64-VC10-opt/OCCT/inc\Prs3d_Arrow.hxx(33) : see declaration of 'Prs3d_Arrow::operator delete'
1> d:/install/CR28010-master/Windows-64-VC10-opt/OCCT/inc\Prs3d_Arrow.hxx(31) : see declaration of 'Prs3d_Arrow'
1>
1>Build FAILED.

http://jenkins-test-07.nnov.opencascade.com:8080/view/CR28010-master/job/CR28010-master-Products-Windows-64-VC10-java-samples/1/parsed_console/ [^]

..\..\..\OCCwrapJava\occjava_wrap.cxx(101309): error C2248: 'Prs3d_Arrow::operator new' : cannot access private member declared in class 'Prs3d_Arrow' [D:\install\CR28010-master\Windows-64-VC10-opt\Products\samples\java\win64\VC10\cmake\OCCwrapJava.vcxproj]
..\..\..\OCCwrapJava\occjava_wrap.cxx(101312): error C2248: 'Prs3d_Arrow::operator delete' : cannot access private member declared in class 'Prs3d_Arrow' [D:\install\CR28010-master\Windows-64-VC10-opt\Products\samples\java\win64\VC10\cmake\OCCwrapJava.vcxproj]
  ..\..\..\OCCwrapJava\occjava_wrap.cxx(101309): error C2248: 'Prs3d_Arrow::operator new' : cannot access private member declared in class 'Prs3d_Arrow' [D:\install\CR28010-master\Windows-64-VC10-opt\Products\samples\java\win64\VC10\cmake\OCCwrapJava.vcxproj]
  ..\..\..\OCCwrapJava\occjava_wrap.cxx(101312): error C2248: 'Prs3d_Arrow::operator delete' : cannot access private member declared in class 'Prs3d_Arrow' [D:\install\CR28010-master\Windows-64-VC10-opt\Products\samples\java\win64\VC10\cmake\OCCwrapJava.vcxproj]
    2 Error(s)

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 63 (63 on master)
Windows: 0 (0 on master)
MacOS : 1136

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 90800734 / 90754809 [+0.05%]
Total CPU difference: 19434.75999999992 / 19313.639999999898 [+0.63%]
products component :
Total MEMORY difference: 30552214 / 30591759 [-0.13%]
Total CPU difference: 5329.72999999998 / 5294.23999999997 [+0.67%]

Testing on Windows:
occt component :


products component :



There are no differences in images found by testdiff.
(0059706)
mkv (tester)
2016-11-01 16:02

Dear kgv,
Branch CR28010 has been rejected due to:
- compilation errors
(0059711)
git (administrator)
2016-11-01 16:33

Branch CR28010 has been updated forcibly by kgv.

SHA-1: 19297764f5fddca82a24f7a8ecab4c4a90d70c72
(0059713)
kgv (developer)
2016-11-01 16:34

Please check compilation of updated patch, regression testing is not needed.
(0059787)
mkv (tester)
2016-11-02 14:36

Dear BugMaster,
Branch CR28010 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 19297764f5fddca82a24f7a8ecab4c4a90d70c72

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 63 (63 on master)
Windows: 0 (0 on master)
MacOS : 1142
(0059788)
mkv (tester)
2016-11-02 14:36

Dear BugMaster,
Branch CR28010 is TESTED.
(0061219)
git (administrator)
2016-12-07 11:25

Branch CR28010 has been deleted by kgv.

SHA-1: 19297764f5fddca82a24f7a8ecab4c4a90d70c72

- Related Changesets
occt: master 62ef08df
Timestamp: 2016-10-14 06:17:36
Author: isk
Committer: apn
Details ] Diff ]
0028010: Visualization, Prs3d_Arrow - add Shading presentation builder

StdPrs_ToolCylinder, StdPrs_ToolDisk, StdPrs_ToolQuadric and StdPrs_ToolSphere
have been moved from StdPrs package to Prs3d.
mod - src/AIS/AIS_Manipulator.cxx Diff ] File ]
mod - src/AIS/AIS_Manipulator.hxx Diff ] File ]
mod - src/Prs3d/FILES Diff ] File ]
mod - src/Prs3d/Prs3d_Arrow.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_Arrow.hxx Diff ] File ]
mod - src/StdPrs/FILES Diff ] File ]
mod - src/V3d/V3d_Trihedron.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-10-26 22:10 kgv New Issue
2016-10-26 22:10 kgv Assigned To => kgv
2016-10-26 23:40 git Note Added: 0059220
2016-10-26 23:40 kgv Relationship added related to 0027958
2016-10-26 23:40 kgv Note Added: 0059221
2016-10-26 23:40 kgv Assigned To kgv => bugmaster
2016-10-26 23:40 kgv Status new => resolved
2016-10-26 23:41 kgv Status resolved => reviewed
2016-10-26 23:41 kgv Relationship added related to 0027038
2016-10-27 16:03 mkv Assigned To bugmaster => mkv
2016-10-28 15:08 git Note Added: 0059334
2016-11-01 16:00 mkv Note Added: 0059703
2016-11-01 16:01 mkv Note Added: 0059704
2016-11-01 16:02 mkv Note Added: 0059706
2016-11-01 16:02 mkv Assigned To mkv => kgv
2016-11-01 16:02 mkv Status reviewed => assigned
2016-11-01 16:02 mkv Test case number => Not needed
2016-11-01 16:33 git Note Added: 0059711
2016-11-01 16:34 kgv Note Added: 0059713
2016-11-01 16:34 kgv Assigned To kgv => bugmaster
2016-11-01 16:34 kgv Status assigned => resolved
2016-11-01 16:35 kgv Status resolved => reviewed
2016-11-01 16:41 mkv Assigned To bugmaster => mkv
2016-11-02 14:36 mkv Note Added: 0059787
2016-11-02 14:36 mkv Note Added: 0059788
2016-11-02 14:36 mkv Assigned To mkv => bugmaster
2016-11-02 14:36 mkv Status reviewed => tested
2016-11-03 17:10 apn Changeset attached => occt master 62ef08df
2016-11-03 17:10 apn Assigned To bugmaster => apn
2016-11-03 17:10 apn Status tested => verified
2016-11-03 17:10 apn Resolution open => fixed
2016-12-07 11:25 git Note Added: 0061219
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker