View Issue Details

IDProjectCategoryView StatusLast Update
0027958Open CASCADEOCCT:Visualizationpublic2021-01-14 17:09
ReporteriskAssigned Tobugmaster  
PrioritynormalSeverityfeature 
Status closedResolutionfixed 
Target Version7.2.0Fixed in Version7.2.0 
Summary0027958: Visualization, AIS_Trihedron - add shaded presentation option
DescriptionAdd a shading mode for AIS_Trihedron.
Steps To Reproducebugs vis bug27958
TagsNo tags attached.
Test case numberbugs vis bug27958

Attached Files

  • Shaded_AIS_Trihedron.png (5,628 bytes)

Relationships

related to 0024291 closedapn Open CASCADE Visualization - move Z-buffer trihedron presentation from TKOpenGl to TKV3d 
parent of 0029049 closedbugmaster Open CASCADE Visualization - restore removed class DsgPrs_DatumPrs 
parent of 0029165 closedbugmaster Open CASCADE Visualization - misuse of enumeration in Prs3d_DatumAspect 
parent of 0029670 closedbugmaster Community Draw Harness - vtrihedron xaxis zaxis is wrong 
parent of 0031909 closedbugmaster Open CASCADE Visualization, AIS_Trihedron - replace maps with arrays 
parent of 0032056 closedbugmaster Open CASCADE Coding Rules - remove package MMgt and other types deprecated since OCCT 7.2.0 
related to 0028010 closedapn Open CASCADE Visualization, Prs3d_Arrow - add Shading presentation builder 
related to 0028647 closedbugmaster Open CASCADE Visualization, OpenGl_AspectMarker - invalid marker size on re-setting aspect without redraw 
related to 0024577 closedbugmaster Open CASCADE Duplicating local selection of AIS_Trihedron 
related to 0029254 newkgv Community [Regression to OCCT 7.1.0] Programmatically highlighting AIS_Trihedron is not possible anymore 
related to 0029950 closedbugmaster Community Visualization - AIS_Trihedron.SetDatumPartColor doesn't work for arrows 
related to 0030450 closedbugmaster Open CASCADE Visualization - AIS_InteractiveContext::MoveTo() never uses V3d_View::ImmediateRedraw() 

Activities

git

2016-10-14 09:17

administrator   ~0058707

Branch CR27958 has been created by isk.

SHA-1: e0c8c1ca5bbb86ac14ed6d3471d6499a14908bb5


Detailed log of new commits:

Author: isk
Date: Fri Oct 14 09:17:36 2016 +0300

    0027958: Visualization - add a shading mode for AIS_Trihedron

isk

2016-10-14 09:18

developer   ~0058708

Dear Kirill,
Please review the branch CR27958.

isk

2016-10-14 09:57

developer  

Shaded_AIS_Trihedron.png (5,628 bytes)

git

2016-10-14 13:54

administrator   ~0058717

Branch CR27958 has been updated forcibly by isk.

SHA-1: b67e6b7a36c67dd66e7d9eca0a4737dcaa94932f

git

2016-10-14 15:15

administrator   ~0058735

Branch CR27958 has been updated by isk.

SHA-1: 419974469d5cfc873967da80f3b31ec91fca8503


Detailed log of new commits:

Author: isk
Date: Fri Oct 14 15:10:15 2016 +0300

    Move Tools from StdPrs to Prs3d.

git

2016-10-14 15:17

administrator   ~0058736

Branch CR27958_1 has been created by isk.

SHA-1: 5c3d53e34f39f161f9072ff48b0f118184cc8575


Detailed log of new commits:

Author: isk
Date: Fri Oct 14 09:17:36 2016 +0300

    0027958: Visualization - add a shading mode for AIS_Trihedron
    Add a new static method Prs3d_Arrow::Draw which fills the given Graphic3d_Group by using StdPrs_Tools.
    Move Tools from StdPrs to Prs3d.

kgv

2016-10-18 12:07

developer   ~0058856

src/Prs3d/Prs3d_ToolPoint.cxx 	[moved from src/StdPrs/StdPrs_ToolPoint.cxx with 90% similarity]
src/Prs3d/Prs3d_ToolPoint.hxx 	[moved from src/StdPrs/StdPrs_ToolPoint.hxx with 88% similarity]
src/Prs3d/Prs3d_ToolRFace.cxx 	[moved from src/StdPrs/StdPrs_ToolRFace.cxx with 87% similarity]
src/Prs3d/Prs3d_ToolRFace.hxx 	[moved from src/StdPrs/StdPrs_ToolRFace.hxx with 85% similarity]
src/Prs3d/Prs3d_ToolTriangulatedShape.cxx 	[moved from src/StdPrs/StdPrs_ToolTriangulatedShape.cxx with 94% similarity]
src/Prs3d/Prs3d_ToolTriangulatedShape.hxx 	[moved from src/StdPrs/StdPrs_ToolTriangulatedShape.hxx with 96% similarity]
src/Prs3d/Prs3d_ToolVertex.cxx 	[moved from src/StdPrs/StdPrs_ToolVertex.cxx with 91% similarity]
src/Prs3d/Prs3d_ToolVertex.hxx 	[moved from src/StdPrs/StdPrs_ToolVertex.hxx with 88% similarity]

please revert unrelated modifications - these StdPr classes existed in previous OCCT releases and their rename will affect API.
Only StdPrs_ToolQuadric, StdPrs_ToolSphere, StdPrs_ToolDisk and StdPrs_ToolCylinder should be moved (which are new for OCCT 7.1.0).

+  //! Defines the representation of the arrow by using StdPrs_Tool for creating it.
+  Standard_EXPORT static void Draw (const Handle(Graphic3d_Group)& theGroup,

Better "DrawShaded()" to distinguish method from others.

+Standard_Boolean AIS_Trihedron::AcceptDisplayMode (const Standard_Integer aMode) const
+{
+  return aMode < 2;

It is unusual check - better checking for (theMode >= 0 && theMode <= 1).

+void AIS_Trihedron::computeShadingPresentation (const Handle(Prs3d_Presentation)& thePrs)

ComputeSelection() should be also updated depending on Display Mode (similar to AIS_Manipulator).

git

2016-10-19 16:22

administrator   ~0058899

Branch CR27958_1 has been updated by isk.

SHA-1: 98c44407403aec4c04f26a6c7b279c29281abf4c


Detailed log of new commits:

Author: isk
Date: Wed Oct 19 13:40:15 2016 +0300

    Fix remarks by Kirill.

git

2016-10-19 16:23

administrator   ~0058900

Branch CR27958_2 has been created by isk.

SHA-1: 4343908b81d403e01a32de693c38e50efc390d4a


Detailed log of new commits:

Author: isk
Date: Fri Oct 14 09:17:36 2016 +0300

    0027958: Visualization - add a shading mode for AIS_Trihedron
    Add a new static method Prs3d_Arrow::Draw which fills the given Graphic3d_Group by using StdPrs_Tools.
    Move Tools from StdPrs to Prs3d.

git

2016-10-20 12:45

administrator   ~0058918

Branch CR27958_2 has been updated forcibly by isk.

SHA-1: 0fbb898e19c82a5bf6b779c734089e1f5c41cdd4

kgv

2016-10-20 19:12

developer   ~0058939

Last edited: 2016-10-20 19:13

Other selection modes should be updated as well.
It is also better specifying custom display mode in constructor to avoid trihedron misbehavior on changing global display mode in interactive context.

git

2016-10-25 13:46

administrator   ~0059082

Branch CR27958_2 has been updated by isk.

SHA-1: 0bc582efd82c94004950777d75e9107b59916ee6


Detailed log of new commits:

Author: isk
Date: Tue Oct 25 13:23:23 2016 +0300

    Fix remarks by Kirill.

isk

2016-10-25 13:47

developer   ~0059083

Dear Kirill,
please review the branch CR27958_2.

git

2016-10-25 21:13

administrator   ~0059124

Branch CR27958_3 has been created by kgv.

SHA-1: 6f19c1517ba199f7f4b5be52c474370614c0a534


Detailed log of new commits:

Author: isk
Date: Fri Oct 14 09:17:36 2016 +0300

    0027958: Visualization, AIS_Trihedron - add Shading display mode
    
    AIS_Trihedron now supports display mode 1 which creates a Shaded presentation.
    
    Prs3d_Arrow - added new static method creating a Shaded (triangulated) presentation of an arrow.
    StdPrs_ToolCylinder, StdPrs_ToolDisk, StdPrs_ToolQuadric and StdPrs_ToolSphere
    have been moved from StdPrs package to Prs3d.

git

2016-10-25 23:22

administrator   ~0059126

Branch CR27958_3 has been updated by kgv.

SHA-1: 133bd21ccad7500dc689b0ebf7bcd8d6d306d109


Detailed log of new commits:

Author: kgv
Date: Tue Oct 25 23:22:39 2016 +0300

    cosmetics, fix compiler warnings

kgv

2016-10-25 23:24

developer   ~0059127

+  myCurrentMode = aMode;

this logic is broken by design - each object might have several selection modes activates simultaneously.

git

2016-10-25 23:25

administrator   ~0059128

Branch CR27958_4 has been created by kgv.

SHA-1: 1fe418c2066fd5e61979edcbed8f62f73d6fdba2


Detailed log of new commits:

Author: isk
Date: Fri Oct 14 09:17:36 2016 +0300

    0027958: Visualization, AIS_Trihedron - add Shading display mode
    
    AIS_Trihedron now supports display mode 1 which creates a Shaded presentation.
    
    Prs3d_Arrow - added new static method creating a Shaded (triangulated) presentation of an arrow.
    StdPrs_ToolCylinder, StdPrs_ToolDisk, StdPrs_ToolQuadric and StdPrs_ToolSphere
    have been moved from StdPrs package to Prs3d.

git

2017-02-15 16:00

administrator   ~0063823

Branch CR27958_5 has been created by nds.

SHA-1: 14be87eade06efa3b84c870be0778ade16753c1e


Detailed log of new commits:

Author: nds
Date: Wed Feb 15 15:59:48 2017 +0300

    Implementation of shading trihedron, remove auxiliary presentations from trihedron

git

2017-02-20 08:03

administrator   ~0063900

Branch CR27958_5 has been updated by nds.

SHA-1: 4b44aa4534726ef5445a99633c462edfa7975561


Detailed log of new commits:

Author: nds
Date: Mon Feb 20 08:03:28 2017 +0300

    Issue 0027958: Visualization, AIS_Trihedron - add Shading display mode
    
    - arrow color is united for both display modes, primitives are calculated in datum aspect
    - priority of trihedron owners has set/get methods
    - labels of trihedron have set/get methods
    - declaration of deprecated methods, it is preferable to use methods with kind of property in parameter

git

2017-02-22 08:15

administrator   ~0063957

Branch CR27958_5 has been updated by nds.

SHA-1: ac305daac02e8d0d3d2540788b7635e8d602d750


Detailed log of new commits:

Author: nds
Date: Wed Feb 22 08:15:23 2017 +0300

    Debug of visualization variable count of axes (e.g. only Z or only XY). Draw functionality to check possibilities of trihedron.

git

2017-02-22 08:43

administrator   ~0063958

Branch CR27958_6 has been created by nds.

SHA-1: 3314e6d6aa6469be723ae8fecf09b3a125cbeef5


Detailed log of new commits:

Author: nds
Date: Wed Feb 15 15:59:48 2017 +0300

    Implementation of shading trihedron, remove auxiliary presentations from trihedron
    
    Issue 0027958: Visualization, AIS_Trihedron - add Shading display mode
    
    - Implementation of Shading/Wireframe mode of trihedron in Datum aspect
    - Remove auxiliary Axis/Point/Plane presentations in Trihedron presentation. There was a problem of visualization these presentations in local selection mode.
    - Trihedron is improved to have different colors by default, possibility to set arrows color is implemented
    - Draw command is extended to wrap more functionality of trihedron.

nds

2017-02-22 09:14

developer   ~0063959

Dear Kirill

Could you please check modifications on CR27958_6.

There is a problem case with local selection of a point in trihedron(in wireframe mode). Could you please debug it or give some advice how it might be corrected. Test case for the problem is 'bug27958_1'. After perform of this case in DRAW, please select origin point, deselect it(click in empty place of viewer) and select the point again. Result: the marker of the selected point is empty. At the same time result of 'vnbselected' is 1(the point is selected).
Here, please have a look at 'POINT_SELECTION_MODE' define in AIS_Trihedron, it seems that implementation closed by this define is more correct.

Thank you in advance, Natalia

git

2017-04-11 15:41

administrator   ~0065143

Branch CR27958_6 has been updated by kgv.

SHA-1: d0955565e83dc976363cc6e4335f96cc24299a66


Detailed log of new commits:

Author: kgv
Date: Tue Apr 11 15:41:00 2017 +0300

    // cosmetics

git

2017-04-11 18:33

administrator   ~0065151

Branch CR27958_6 has been updated by kgv.

SHA-1: a15d9bddd3381328ebac71eb08d10ef73389c6eb


Detailed log of new commits:

Author: kgv
Date: Tue Apr 11 18:33:00 2017 +0300

    // remove dead code

Author: kgv
Date: Tue Apr 11 18:23:48 2017 +0300

    // drop useless test bug64

git

2017-04-11 19:13

administrator   ~0065154

Branch CR27958_6 has been updated by kgv.

SHA-1: 066c1d331d9ff403087d77c0b84d0a259b8dd6ff


Detailed log of new commits:

Author: kgv
Date: Tue Apr 11 19:13:18 2017 +0300

    // cosmetics

git

2017-04-11 19:18

administrator   ~0065155

Branch CR27958_7 has been created by kgv.

SHA-1: 446124f25096215ec285eda6a81e43b0963a2cc0


Detailed log of new commits:

Author: nds
Date: Wed Feb 15 15:59:48 2017 +0300

    0027958: Visualization, AIS_Trihedron - add shaded presentation option
    
    Added new Shaded presentation flag configured through Datum aspect (NOT as usual Display Mode).
    
    Removed auxiliary Axis/Point/Plane presentations in Trihedron presentation.
    Trihedron has been improved to have different colors by default;
    possibility to set arrows color is implemented.
    
    Draw command vtrihedron has been extended to pass more options provided by AIS_Trihedron.

kgv

2017-04-11 19:18

developer   ~0065156

Please test the patch.

git

2017-04-11 20:44

administrator   ~0065160

Branch CR27958_7 has been updated by kgv.

SHA-1: d1b5c0e17dea5f2061a268724ee40bcd4826905f


Detailed log of new commits:

Author: kgv
Date: Tue Apr 11 20:43:54 2017 +0300

    // add missing Standard_EXPORT

kgv

2017-04-11 20:45

developer   ~0065161

Updated - added missing Standard_EXPORT (for external applications).

git

2017-04-12 11:21

administrator   ~0065169

Branch CR27958_7 has been updated forcibly by apv.

SHA-1: 524a62356257e7862a5af4f408acd4e4b0fda1aa

apv

2017-04-12 11:22

tester   ~0065170

Branch CR27958_7 has been rebased on the current master

apv

2017-04-12 16:27

tester   ~0065184

Dear BugMaster,

Branch CR27958_7 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 524a62356257e7862a5af4f408acd4e4b0fda1aa

Number of compiler warnings:
occt component:
   Linux: 3 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 3 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1226

New warnings have been detected during OCCT component building
on Linux:
http://jenkins-test-05.nnov.opencascade.com/view/CR27958_7-master/job/CR27958_7-master-OCCT-Debian70-64-opt-compile/1/warnings17Result/
on MacOS:
http://jenkins-test-05.nnov.opencascade.com/view/CR27958_7-master/job/CR27958_7-master-OCCT-MacOS-opt-compile/1/warnings7Result/new/

Compilation errors have been detected during building of
CSharp Products samples on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27958_7-master/job/CR27958_7-master-Products-Windows-64-VC10-csharp-samples/1/parsed_console/
Java Products samples on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27958_7-master/job/CR27958_7-master-Products-Windows-64-VC10-java-samples/1/parsed_console/

Regressions/Differences:
http://occt-tests/CR27958_7-master-OCCT/Debian70-64/summary.html
http://occt-tests/CR27958_7-master-OCCT/Windows-64-VC10/summary.html
3rdparty export A2, A3, A4, A6, A7
bugs vis buc60574, buc60814, bug61, bug21091_4, bug21091_5, bug21091_6, bug21091_8, bug21091_9, bug25340, bug26754
demo draw bug23745

Testing cases:
bugs vis bug27958 - OK
http://occt-tests/CR27958_7-master-OCCT/Debian70-64/bugs/vis/bug27958.html
http://occt-tests/CR27958_7-master-OCCT/Windows-64-VC10/bugs/vis/bug27958.html

Testing on Linux:
Total MEMORY difference: 91655662 / 91183595 [+0.52%]
Total CPU difference: 19660.63000000024 / 19608.58000000024 [+0.27%]

Testing on Windows:
Total MEMORY difference: 57957252 / 57853808 [+0.18%]
Total CPU difference: 18310.898176798484 / 18063.29338959849 [+1.37%]

There are differences in images found by testdiff:
http://occt-tests/CR27958_7-master-OCCT/Debian70-64/diff-Debian70-64.html
http://occt-tests/CR27958_7-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html
http://occt-tests/CR27958_7-master-Products/Debian70-64/diff-Debian70-64.html
http://occt-tests/CR27958_7-master-Products/Windows-64-VC10/diff-Windows-64-VC10-image.html

apv

2017-04-12 16:31

tester   ~0065185

Dear Kirill,

Branch CR27958_7 has been rejected due to:
- compilation errors (CSharp and Java Products samples on Windows)
- additional warnings
- regressions/differences/improvements
- differences in images

git

2017-04-12 18:48

administrator   ~0065190

Branch CR27958_7 has been updated by kgv.

SHA-1: 6541bcecee9a11e24ed02e6e11aaf9af008951b4


Detailed log of new commits:

Author: kgv
Date: Wed Apr 12 18:48:51 2017 +0300

    // add more missing Standard_EXPORT

git

2017-04-19 16:40

administrator   ~0065354

Branch CR27958_7 has been updated by nds.

SHA-1: ca88dbc6fc51ccc80dc6cd6089e0ece76d780afb


Detailed log of new commits:

Author: nds
Date: Wed Apr 19 16:40:27 2017 +0300

    Issue 0027958: Visualization, AIS_Trihedron - add shaded presentation option: default style should be obtained from default driver of context, so we do not create DatumAspect in trihedron constructor. By the reason, graphical primitives filling is moved from the datum aspect(it is in charge of only style) from trihedron presentation.

Author: nds
Date: Wed Apr 19 16:14:14 2017 +0300

    0028647: Visualization, OpenGl_AspectMarker - invalid marker size on re-setting aspect without redraw
    
    OpenGl_AspectMarker::Resources::BuildSprites(), fixed uninitialized theMarkerSize
    in case if aspect has been already initialized for specified marker type.
    
    Draw Harness command vaspects has been extended with new options -setMarkerType and -setMarkerSize.

git

2017-04-19 17:22

administrator   ~0065357

Branch CR27958_7 has been updated by nds.

SHA-1: 4e2ddcc98c60efc8b1c5c00770c36185ed71cba1


Detailed log of new commits:

Author: nds
Date: Wed Apr 19 17:22:33 2017 +0300

    Issue 0027958: Visualization, AIS_Trihedron - add shaded presentation option: correction after review(Standard_Export, lower case of methods name, own datum aspect methods are protected)

git

2017-04-19 17:50

administrator   ~0065358

Branch CR27958_7 has been updated by nds.

SHA-1: 85f67e6b12f8c212629a7b1653c3ab0561f4a82e


Detailed log of new commits:

Author: nds
Date: Wed Apr 19 17:50:05 2017 +0300

    Issue 0027958: Visualization, AIS_Trihedron - brackets correction.

git

2017-04-19 17:57

administrator   ~0065359

Branch CR27958_8 has been created by nds.

SHA-1: 577de9ec3cd9825a9fef09b739d8f4d3a79dfcb8


Detailed log of new commits:

Author: nds
Date: Wed Feb 15 15:59:48 2017 +0300

    0027958: Visualization, AIS_Trihedron - add shaded presentation option
    
    Added new Shaded presentation flag configured through Datum aspect (NOT as usual Display Mode).
    Removed auxiliary Axis/Point/Plane presentations in Trihedron presentation.

kgv

2017-04-19 18:08

developer   ~0065363

Please test the patch.

mkv

2017-04-20 15:01

tester   ~0065394

Dear BugMaster,
Branch CR27958_8 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 577de9ec3cd9825a9fef09b739d8f4d3a79dfcb8

Number of compiler warnings:

occt component :
Linux: 3 (0 on master)
Windows: 0 (0 on master)
MacOS : 3 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1207
There are new additional compilation warning on Linux and MacOS platforms:
Linux:
http://jenkins-test-07.nnov.opencascade.com:8080/user/mnt/my-views/view/A_mnt_warnings/portlet/dashboard_portlet_13912/job/CR27958_8-master-OCCT-Debian70-64-opt-compile/1/warnings21Result/
AIS_Trihedron.cxx:58, GNU C Compiler 4 (gcc), Priority: Normal
when initialized here [-Wreorder]
AIS_Trihedron.hxx:272, GNU C Compiler 4 (gcc), Priority: Normal
'Prs3d_DatumMode AIS_Trihedron::myTrihDispMode' [-Wreorder]
AIS_Trihedron.hxx:273, GNU C Compiler 4 (gcc), Priority: Normal
'AIS_Trihedron::myComponent' will be initialized after [-Wreorder]

MacOS :
http://jenkins-test-07.nnov.opencascade.com:8080/user/mnt/my-views/view/A_mnt_warnings/portlet/dashboard_portlet_13912/job/CR27958_8-master-OCCT-MacOS-opt-compile/1/warnings9Result/
AIS_Trihedron.cxx:62, Clang (LLVM based), Priority: Normal
field 'myComponent' will be initialized after field 'myTrihDispMode'
AIS_Trihedron.hxx:143, Clang (LLVM based), Priority: Normal
'AIS_Trihedron::Color' hides overloaded virtual functions
AIS_Trihedron.hxx:202, Clang (LLVM based), Priority: Normal
'HilightOwnerWithColor' overrides a member function but is not marked 'override'

Regressions/Differences/Improvements:
http://occt-tests/CR27958_8-master-OCCT/Debian70-64/summary.html
http://occt-tests/CR27958_8-master-OCCT/Windows-64-VC10/summary.html
Failed:
  3rdparty export A2, A3, A4, A6, A7
  bugs vis bug21091_4, bug21091_5, bug21091_6, bug21091_8, bug21091_9, bug26754

Testing cases:
http://occt-tests/CR27958_8-master-OCCT/Debian70-64/bugs/vis/bug27958.html
http://occt-tests/CR27958_8-master-OCCT/Windows-64-VC10/bugs/vis/bug27958.html
bugs vis bug27958: OK

Testing on Linux:
occt component :
Total MEMORY difference: 91570548 / 90634175 [+1.03%]
Total CPU difference: 19896.23000000039 / 19725.380000000332 [+0.87%]
products component :
Total MEMORY difference: 30343173 / 30341918 [+0.00%]
Total CPU difference: 5386.629999999974 / 5356.299999999965 [+0.57%]
Testing on Windows:
occt component :
Total MEMORY difference: 57905278 / 57802192 [+0.18%]
Total CPU difference: 18262.007463398655 / 18136.379858098546 [+0.69%]
products component :
Total MEMORY difference: 22320676 / 22265369 [+0.25%]
Total CPU difference: 5304.517603099962 / 5359.788757399982 [-1.03%]

There are following differences in images found by testdiff.
http://occt-tests/CR27958_8-master-OCCT/Debian70-64/diff-Debian70-64.html
http://occt-tests/CR27958_8-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html
IMAGE bugs vis buc60574: buc60574.png differs

mkv

2017-04-20 15:02

tester   ~0065395

Dear kgv,

Branch CR27958_8 has been rejected due to:
- additional warnings
- regressions/differences/improvements
- differences in images

git

2017-04-21 09:55

administrator   ~0065411

Branch CR27958_8 has been updated by nds.

SHA-1: fca5c3687b5c3d9725e9c3e43473d4cf42fa1fdb


Detailed log of new commits:

Author: nds
Date: Fri Apr 21 09:55:21 2017 +0300

    Corrections for: warnings, coding style, draw command description

git

2017-04-21 09:58

administrator   ~0065412

Branch CR27958_8 has been updated by nds.

SHA-1: a9ed6a50e6f15682ebcc6646b72659dde217b387


Detailed log of new commits:

Author: nds
Date: Fri Apr 21 09:57:23 2017 +0300

    Corrections for: warnings, coding style, draw command description

git

2017-04-21 10:10

administrator   ~0065413

Branch CR27958_9 has been created by nds.

SHA-1: ce73656b6f1575d29e3bdab0f686d192629d1e4a


Detailed log of new commits:

Author: nds
Date: Wed Feb 15 15:59:48 2017 +0300

    Added new Shaded presentation flag configured through Datum aspect (NOT as usual Display Mode).
    Removed auxiliary Axis/Point/Plane presentations in Trihedron presentation.
    Extending DRAW vtrihedron command to change parameters of trihedron.

nds

2017-04-21 10:16

developer   ~0065414

Dear kgv,
could you please revise the branch once again.

Modifications:
1. Warnings are corrected
2. Coding style is corrected
3. buc60574.png image on http://occt-tests/CR27958_8-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html is more correct than it was in B. This picture should be updated in test base.

git

2017-04-24 10:48

administrator   ~0065457

Branch CR27958_9 has been updated by nds.

SHA-1: e1e227a08fdfdec538857e260ddda0d59cfcbf1f


Detailed log of new commits:

Author: nds
Date: Mon Apr 24 10:47:57 2017 +0300

    Update PDF file sizes in DRAW test changed due to lower number of primitives in AIS trihedron.

git

2017-04-24 10:56

administrator   ~0065458

Branch CR27958_9 has been updated by nds.

SHA-1: a6141c1c10c4e600b4ffb572242bc194eb0c56e4


Detailed log of new commits:

Author: nds
Date: Mon Apr 24 10:55:42 2017 +0300

    Aligning correction

git

2017-04-24 15:57

administrator   ~0065481

Branch CR27958_10 has been created by nds.

SHA-1: 4a47b5b2bab085c9c45bcc635c00e07b4047f7b2


Detailed log of new commits:

Author: nds
Date: Wed Feb 15 15:59:48 2017 +0300

    Added new Shaded presentation flag configured through Datum aspect (NOT as usual Display Mode).
    Removed auxiliary Axis/Point/Plane presentations in Trihedron presentation.
    Extending DRAW vtrihedron command to change parameters of trihedron.

git

2017-04-24 16:23

administrator   ~0065484

Branch CR27958_10 has been updated forcibly by nds.

SHA-1: fee4bfaec3bf88e0c51bb2c99547a3d9e438b33c

kgv

2017-04-24 17:15

developer   ~0065487

Please test the patch.

mkv

2017-04-25 18:31

tester   ~0065523

Last edited: 2017-04-25 18:35

Dear BugMaster,
Branch CR27958_10 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: fee4bfaec3bf88e0c51bb2c99547a3d9e438b33c

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1194

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
http://occt-tests/CR27958_10-master-OCCT/Debian70-64/bugs/vis/bug27958.html
http://occt-tests/CR27958_10-master-OCCT/Windows-64-VC10/bugs/vis/bug27958.html
bugs vis bug27958: OK

Testing on Linux:
occt component :
Total MEMORY difference: 91785170 / 91844731 [-0.06%]
Total CPU difference: 19656.010000000235 / 19560.55000000033 [+0.49%]
products component :
Total MEMORY difference: 31318986 / 31266420 [+0.17%]
Total CPU difference: 5427.749999999981 / 5400.099999999974 [+0.51%]
Testing on Windows:
occt component :
http://occt-tests/CR27958_10-master-OCCT/Windows-64-VC10-cpu/diff-Windows-64-VC10-cpu.html
CPU bugs vis bug24623_4: 3.7596241 / 0.5148033 [+630.30%]
CPU bugs vis bug25853: 6.3492407 / 2.8860185 [+120.00%]
CPU bugs vis bug22879: 1.1232072 / 0.2964019 [+278.95%]
CPU bugs vis bug24389: 2.4024154 / 0.7332047 [+227.66%]
CPU bugs vis bug24131_markers_bitmap: 1.3416086 / 0.3744024 [+258.33%]
CPU bugs vis bug24623_3: 2.0124129 / 0.624004 [+222.50%]
CPU bugs vis bug26538: 9.0324579 / 0.5148033 [+1654.55%]
CPU bugs vis bug24131_markers_glsl: 0.9984064 / 0.312002 [+220.00%]
CPU bugs vis bug24307_1: 0.8892057 / 0.1716011 [+418.18%]
CPU bugs vis bug25760_2: 7.5348483 / 0.8424054 [+794.44%]
CPU bugs vis bug27318: 5.9748383 / 2.1060135 [+183.70%]
CPU bugs vis bug25760_1: 2.1372137 / 0.4836031 [+341.94%]

Total MEMORY difference: 58136602 / 58032448 [+0.18%]
Total CPU difference: 18161.402418498765 / 18122.99497229857 [+0.21%]
products component :
Total MEMORY difference: 22667167 / 22611847 [+0.24%]
Total CPU difference: 5245.377623999969 / 5410.192680499973 [-3.05%]

There are following differences in images found by testdiff.
http://occt-tests/CR27958_10-master-OCCT/Debian70-64/diff-Debian70-64.html
http://occt-tests/CR27958_10-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html
IMAGE bugs vis buc60574: buc60574.png differs

mkv

2017-04-25 18:33

tester   ~0065524

Dear nds,
Branch CR27958_10 has been rejected due to:
- cpu test problems

kgv

2017-04-25 18:51

developer   ~0065527

> IMAGE bugs vis buc60574: buc60574.png differs
The image difference is OK (patch fixes the old bug).

> cpu test problems
Please re-check this regression - I don't see how patch might affect test cases which do not even create modified functionality (vtrihedron).

mkv

2017-04-26 18:26

tester   ~0065574

Dear BugMaster,
Branch CR27958_10 is TESTED.

git

2017-05-12 11:21

administrator   ~0065874

Branch CR27958 has been deleted by kgv.

SHA-1: 419974469d5cfc873967da80f3b31ec91fca8503

git

2017-05-12 11:21

administrator   ~0065875

Branch CR27958_1 has been deleted by kgv.

SHA-1: 98c44407403aec4c04f26a6c7b279c29281abf4c

git

2017-05-12 11:21

administrator   ~0065876

Branch CR27958_2 has been deleted by kgv.

SHA-1: 0bc582efd82c94004950777d75e9107b59916ee6

git

2017-05-12 11:21

administrator   ~0065877

Branch CR27958_3 has been deleted by kgv.

SHA-1: 133bd21ccad7500dc689b0ebf7bcd8d6d306d109

git

2017-05-12 11:21

administrator   ~0065878

Branch CR27958_4 has been deleted by kgv.

SHA-1: 1fe418c2066fd5e61979edcbed8f62f73d6fdba2

git

2017-05-12 11:35

administrator   ~0065887

Branch CR27958_10 has been deleted by kgv.

SHA-1: fee4bfaec3bf88e0c51bb2c99547a3d9e438b33c

git

2017-05-12 11:35

administrator   ~0065888

Branch CR27958_5 has been deleted by kgv.

SHA-1: ac305daac02e8d0d3d2540788b7635e8d602d750

git

2017-05-12 11:35

administrator   ~0065889

Branch CR27958_6 has been deleted by kgv.

SHA-1: 066c1d331d9ff403087d77c0b84d0a259b8dd6ff

git

2017-05-12 11:35

administrator   ~0065890

Branch CR27958_7 has been deleted by kgv.

SHA-1: 85f67e6b12f8c212629a7b1653c3ab0561f4a82e

git

2017-05-12 11:35

administrator   ~0065891

Branch CR27958_8 has been deleted by kgv.

SHA-1: a9ed6a50e6f15682ebcc6646b72659dde217b387

git

2017-05-12 11:35

administrator   ~0065892

Branch CR27958_9 has been deleted by kgv.

SHA-1: a6141c1c10c4e600b4ffb572242bc194eb0c56e4

Related Changesets

occt: master bc001a40

2017-02-15 12:59:48

nds


Committer: bugmaster Details Diff
0027958: Visualization, AIS_Trihedron - add shaded presentation option
A new Shaded presentation flag configured through Datum aspect (NOT as usual Display Mode).
Creation of auxiliary Axis/Point/Plane presentations in Trihedron presentation is removed.
'vtrihedron' DRAW command to change parameters of trihedron is extended to cover whole functionality of AIS_Trihedron.

The following classes are redesignede:
AIS_Trihedron,
Prs3d_DatumAspect.

The followin enumermations are created to manage properties of trihedron:
Prs3d_DatumAttribute,
Prs3d/Prs3d_DatumAxes,
Prs3d_DatumMode
Affected Issues
0027958
mod - dox/user_guides/draw_test_harness/draw_test_harness.md Diff File
mod - src/AIS/AIS_Axis.cxx Diff File
mod - src/AIS/AIS_GraphicTool.cxx Diff File
mod - src/AIS/AIS_InteractiveContext.cxx Diff File
mod - src/AIS/AIS_Plane.cxx Diff File
mod - src/AIS/AIS_PlaneTrihedron.cxx Diff File
mod - src/AIS/AIS_PlaneTrihedron.hxx Diff File
mod - src/AIS/AIS_Trihedron.cxx Diff File
mod - src/AIS/AIS_Trihedron.hxx Diff File
add - src/AIS/AIS_TrihedronOwner.cxx Diff File
add - src/AIS/AIS_TrihedronOwner.hxx Diff File
mod - src/AIS/FILES Diff File
rm - src/DsgPrs/DsgPrs_DatumPrs.cxx Diff File
mod - src/DsgPrs/FILES Diff File
mod - src/Prs3d/FILES Diff File
mod - src/Prs3d/Prs3d_Arrow.cxx Diff File
mod - src/Prs3d/Prs3d_Arrow.hxx Diff File
mod - src/Prs3d/Prs3d_DatumAspect.cxx Diff File
mod - src/Prs3d/Prs3d_DatumAspect.hxx Diff File
add - src/Prs3d/Prs3d_DatumAxes.hxx Diff File
mod - src/Prs3d/Prs3d_Drawer.cxx Diff File
mod - src/QADraw/QADraw.cxx Diff File
mod - src/ViewerTest/ViewerTest.cxx Diff File
mod - src/ViewerTest/ViewerTest_ObjectCommands.cxx Diff File
mod - tests/3rdparty/export/A2 Diff File
mod - tests/3rdparty/export/A3 Diff File
mod - tests/3rdparty/export/A4 Diff File
mod - tests/3rdparty/export/A6 Diff File
mod - tests/3rdparty/export/A7 Diff File
mod - tests/bugs/vis/bug21091_4 Diff File
mod - tests/bugs/vis/bug21091_5 Diff File
mod - tests/bugs/vis/bug21091_6 Diff File
mod - tests/bugs/vis/bug21091_8 Diff File
mod - tests/bugs/vis/bug21091_9 Diff File
mod - tests/bugs/vis/bug25369 Diff File
mod - tests/bugs/vis/bug26754 Diff File
add - tests/bugs/vis/bug27958 Diff File
rm - tests/bugs/vis/bug64 Diff File

Issue History

Date Modified Username Field Change
2016-10-13 13:49 isk New Issue
2016-10-13 13:49 isk Assigned To => isk
2016-10-13 16:36 kgv Relationship added related to 0024291
2016-10-13 16:36 kgv Status new => assigned
2016-10-13 16:36 kgv Summary Visualization - add a shading mode for AIS_Trihedron. => Visualization - add a shading mode for AIS_Trihedron
2016-10-14 09:17 git Note Added: 0058707
2016-10-14 09:18 isk Note Added: 0058708
2016-10-14 09:18 isk Assigned To isk => kgv
2016-10-14 09:18 isk Status assigned => resolved
2016-10-14 09:18 isk Steps to Reproduce Updated
2016-10-14 09:57 isk File Added: Shaded_AIS_Trihedron.png
2016-10-14 13:54 git Note Added: 0058717
2016-10-14 15:15 git Note Added: 0058735
2016-10-14 15:17 git Note Added: 0058736
2016-10-18 12:07 kgv Note Added: 0058856
2016-10-18 12:07 kgv Assigned To kgv => isk
2016-10-18 12:07 kgv Status resolved => assigned
2016-10-19 16:22 git Note Added: 0058899
2016-10-19 16:23 git Note Added: 0058900
2016-10-19 16:33 isk Assigned To isk => kgv
2016-10-19 16:33 isk Status assigned => resolved
2016-10-20 12:45 git Note Added: 0058918
2016-10-20 19:12 kgv Note Added: 0058939
2016-10-20 19:12 kgv Assigned To kgv => isk
2016-10-20 19:12 kgv Status resolved => assigned
2016-10-20 19:13 kgv Note Edited: 0058939
2016-10-25 13:46 git Note Added: 0059082
2016-10-25 13:47 isk Note Added: 0059083
2016-10-25 13:47 isk Assigned To isk => kgv
2016-10-25 13:47 isk Status assigned => feedback
2016-10-25 21:12 kgv Summary Visualization - add a shading mode for AIS_Trihedron => Visualization, AIS_Trihedron - add Shading display mode
2016-10-25 21:13 git Note Added: 0059124
2016-10-25 23:22 git Note Added: 0059126
2016-10-25 23:24 kgv Note Added: 0059127
2016-10-25 23:24 kgv Assigned To kgv => isk
2016-10-25 23:24 kgv Status feedback => assigned
2016-10-25 23:25 git Note Added: 0059128
2016-10-26 23:40 kgv Relationship added related to 0028010
2016-11-09 10:41 abv Target Version 7.1.0 => 7.2.0
2017-01-02 11:35 kgv Assigned To isk => kgv
2017-02-15 16:00 git Note Added: 0063823
2017-02-20 08:03 git Note Added: 0063900
2017-02-22 08:15 git Note Added: 0063957
2017-02-22 08:43 git Note Added: 0063958
2017-02-22 09:14 nds Note Added: 0063959
2017-02-22 09:15 nds Status assigned => resolved
2017-03-04 11:54 kgv Assigned To kgv => san
2017-04-11 15:41 git Note Added: 0065143
2017-04-11 17:56 kgv Relationship added related to 0028647
2017-04-11 18:33 git Note Added: 0065151
2017-04-11 19:13 git Note Added: 0065154
2017-04-11 19:14 kgv Summary Visualization, AIS_Trihedron - add Shading display mode => Visualization, AIS_Trihedron - add shaded presentation option
2017-04-11 19:18 git Note Added: 0065155
2017-04-11 19:18 kgv Note Added: 0065156
2017-04-11 19:18 kgv Assigned To san => bugmaster
2017-04-11 19:18 kgv Status resolved => reviewed
2017-04-11 19:38 apv Assigned To bugmaster => apv
2017-04-11 20:44 git Note Added: 0065160
2017-04-11 20:45 kgv Note Added: 0065161
2017-04-12 11:21 git Note Added: 0065169
2017-04-12 11:22 apv Note Added: 0065170
2017-04-12 16:27 apv Note Added: 0065184
2017-04-12 16:27 apv Assigned To apv => kgv
2017-04-12 16:27 apv Status reviewed => assigned
2017-04-12 16:31 apv Note Added: 0065185
2017-04-12 18:48 git Note Added: 0065190
2017-04-13 10:34 kgv Assigned To kgv => nds
2017-04-19 16:40 git Note Added: 0065354
2017-04-19 17:22 git Note Added: 0065357
2017-04-19 17:50 git Note Added: 0065358
2017-04-19 17:57 git Note Added: 0065359
2017-04-19 18:08 kgv Note Added: 0065363
2017-04-19 18:08 kgv Assigned To nds => bugmaster
2017-04-19 18:08 kgv Status assigned => resolved
2017-04-19 18:08 kgv Status resolved => reviewed
2017-04-19 18:41 mkv Assigned To bugmaster => mkv
2017-04-20 15:01 mkv Note Added: 0065394
2017-04-20 15:02 mkv Note Added: 0065395
2017-04-20 15:02 mkv Assigned To mkv => kgv
2017-04-20 15:02 mkv Status reviewed => assigned
2017-04-20 15:02 mkv Test case number => bugs vis bug27958
2017-04-20 15:07 kgv Assigned To kgv => nds
2017-04-21 09:55 git Note Added: 0065411
2017-04-21 09:58 git Note Added: 0065412
2017-04-21 10:10 git Note Added: 0065413
2017-04-21 10:16 nds Note Added: 0065414
2017-04-21 10:16 nds Assigned To nds => kgv
2017-04-21 10:16 nds Status assigned => resolved
2017-04-24 10:48 git Note Added: 0065457
2017-04-24 10:56 git Note Added: 0065458
2017-04-24 15:57 git Note Added: 0065481
2017-04-24 16:23 git Note Added: 0065484
2017-04-24 17:15 kgv Note Added: 0065487
2017-04-24 17:15 kgv Assigned To kgv => bugmaster
2017-04-24 17:15 kgv Status resolved => reviewed
2017-04-24 17:24 mkv Assigned To bugmaster => mkv
2017-04-25 18:31 mkv Note Added: 0065523
2017-04-25 18:33 mkv Note Added: 0065524
2017-04-25 18:33 mkv Assigned To mkv => nds
2017-04-25 18:33 mkv Status reviewed => assigned
2017-04-25 18:35 mkv Note Edited: 0065523
2017-04-25 18:51 kgv Note Added: 0065527
2017-04-25 18:51 kgv Assigned To nds => bugmaster
2017-04-25 18:51 kgv Status assigned => feedback
2017-04-26 09:54 bugmaster Assigned To bugmaster => mkv
2017-04-26 18:26 mkv Note Added: 0065574
2017-04-26 18:26 mkv Assigned To mkv => bugmaster
2017-04-26 18:26 mkv Status feedback => tested
2017-04-28 13:08 bugmaster Changeset attached => occt master bc001a40
2017-04-28 13:08 bugmaster Status tested => verified
2017-04-28 13:08 bugmaster Resolution open => fixed
2017-05-12 11:21 git Note Added: 0065874
2017-05-12 11:21 git Note Added: 0065875
2017-05-12 11:21 git Note Added: 0065876
2017-05-12 11:21 git Note Added: 0065877
2017-05-12 11:21 git Note Added: 0065878
2017-05-12 11:35 git Note Added: 0065887
2017-05-12 11:35 git Note Added: 0065888
2017-05-12 11:35 git Note Added: 0065889
2017-05-12 11:35 git Note Added: 0065890
2017-05-12 11:35 git Note Added: 0065891
2017-05-12 11:35 git Note Added: 0065892
2017-07-10 13:58 kgv Relationship added related to 0024577
2017-08-25 09:14 kgv Relationship added parent of 0029049
2017-09-29 16:17 aiv Fixed in Version => 7.2.0
2017-09-29 16:29 aiv Status verified => closed
2017-09-29 20:17 kgv Relationship added parent of 0029165
2017-10-23 13:01 kgv Relationship added related to 0029254
2018-07-12 11:03 kgv Relationship added related to 0029950
2019-01-10 14:30 kgv Relationship added parent of 0029670
2019-01-21 15:45 kgv Relationship added related to 0030450
2020-11-05 16:17 kgv Relationship added parent of 0031909
2021-01-14 17:09 kgv Relationship added parent of 0032056