View Issue Details

IDProjectCategoryView StatusLast Update
0027884Open CASCADEOCCT:Modeling Algorithmspublic2021-09-04 16:48
Reporterisn Assigned Tobugmaster  
PrioritylowSeverityfeature 
Status closedResolutionfixed 
Target Version7.6.0Fixed in Version7.6.0 
Summary0027884: Modeling Algorithms - Possible improvement for 2d classifier
DescriptionSome internal 2d classification tools (like TopClass_Classifier2d) checks the intersection between the 2d edge representation on the face and 2d line (passed through the test point).
It's possible to speed up the classification process by using of additional information about (2d) bounding boxes of this edges (i.e. their pcurves). This allows to skip many calls of 2d intersectors & extremas.
----
User can pass the bnd boxes information externally (via datamap edge (on face) -> its bndbox2d). Or it can be calculated internally.
----
currently, bndbox <-> line intersection implemented only for 3D. For this improvement it also should be implemented for 2D.

Steps To ReproduceTest case name: bugs modalg_6 bug27884
TagsNo tags attached.
Test case numberbugs/modalg_6/bug27884

Activities

msv

2016-09-22 09:41

developer   ~0058007

Last edited: 2016-09-22 09:41

Before making this imp, it is needed to create a test case[s] that will allow comparing results (for performance) with and without fix.

ifv

2021-04-22 09:17

developer   ~0100505

Analisys

git

2021-07-14 23:42

administrator   ~0102539

Branch CR27884 has been created by abulychev-ext.

SHA-1: 3863e04cc5da3920e5bb6b0e0f2a40f788aa66af


Detailed log of new commits:

Author: abulyche
Date: Wed Jul 14 23:40:32 2021 +0300

    0027884: Modeling Algorithms - Possible improvement for 2d classifier
    
    Added the implementation of bndbox<->line intersection for 2D to Bnd_Box2d
    Added the speedup for 2d classification to BRepClass_Intersector.cxx

git

2021-07-16 13:48

administrator   ~0102571

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: f87a3efea02dcef762e407236cf0b5572bfd6f1c

git

2021-07-19 07:25

administrator   ~0102617

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 47ff691be49d29e8d0a4256d783280ad2e7f60c6

git

2021-07-20 18:40

administrator   ~0102686

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 74f08a32ef87aa6350044945fbc8cf8c74d99ae7

git

2021-07-21 14:39

administrator   ~0102709

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 4416f7df616b4c10a89a4a20ce091ba3cf45d39e

git

2021-07-22 17:22

administrator   ~0102729

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: c7cc6dcb6c3ecc86c9af7d8836d1dbd4c6420d71

git

2021-07-23 11:00

administrator   ~0102737

Branch CR27884_ifv has been created by ifv.

SHA-1: 22fdf9d76e80f8c963891fe3bf332b3792f10432


Detailed log of new commits:

Author: ifv
Date: Fri Jul 23 10:59:21 2021 +0300

    Some minor corrections

git

2021-07-26 15:35

administrator   ~0102817

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 07b4e710b5878ad162b807b3d3e8ae0ac77f97ee

git

2021-07-28 02:20

administrator   ~0102842

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 01010074ddd689b1006f54f28329703701d0239e

git

2021-07-29 02:13

administrator   ~0102864

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 0dc3f7426593372d69d6008ed67fb71b29536fec

git

2021-07-29 13:05

administrator   ~0102871

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 6077eaf5b1d52f3fb1753d2a3de9e8132cfbb967

git

2021-07-29 19:30

administrator   ~0102877

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 6927179a3b6d1530be0765e6ab3986ee30e61388

git

2021-07-30 21:01

administrator   ~0102904

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 2cc40408e99f0adc4c1063a44d6d7fa28bafa0a6

git

2021-08-03 12:07

administrator   ~0102950

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 04a66f044a62a957bd29959a2a77456c4085c356

git

2021-08-03 16:49

administrator   ~0102957

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 5d642785019c3f7ad91c2cbcc24c1eae918066e3

git

2021-08-06 03:40

administrator   ~0103020

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: af1716909647d25ff14e4f5ed6766e1d40416981

git

2021-08-09 18:53

administrator   ~0103102

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 945d5db5d3132a5bcbfc0ab9c14eb22b88e7d26e

git

2021-08-09 22:23

administrator   ~0103111

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 61cbff76c1930de4bb58c4e079172466ec15e9ea

git

2021-08-10 16:59

administrator   ~0103113

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 162842f6ede4c8c092a1d0efdb21cc37ba9c37b3

git

2021-08-11 12:48

administrator   ~0103129

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: ed10218c65e4ad9e864822f9cbb67e5f43fd9866

git

2021-08-11 12:59

administrator   ~0103130

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: fbae22c806df6522c580b5cb2fc901559aabf2f7

git

2021-08-11 16:45

administrator   ~0103134

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 369ca60af88103e8b6dd3ec47fefa5f1c91fa419

git

2021-08-12 01:55

administrator   ~0103143

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: e011894d9d0b73b2c870697f8e97dbc80d3a403e

git

2021-08-12 11:09

administrator   ~0103147

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: 2859809e3ff93d36422bdd0ea49d467bd74cb6cb

git

2021-08-12 11:32

administrator   ~0103148

Branch CR27884 has been updated forcibly by abulychev-ext.

SHA-1: aa818c31e8770ca83fe4706e9c4815ffb15810b0

ifv

2021-08-13 15:00

developer   ~0103183

Branch CR27884 seems to be valid

Branches for integration
OCCT - CR27884
Products - Not

bugmaster

2021-08-14 13:23

administrator   ~0103205

Combination -
OCCT branch : IR-2021-08-13
master SHA - 7b5f784419eb9fd9a1d3dc69eff89d3e720d6e97
a87b7ddc8cb44606b91e3f37113847c3f5f50fdc
Products branch : IR-2021-08-13 SHA - 8dc957c07e49e8db2f1330ec126160fe1c7eb89d
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17368.20000000041 / 17370.70000000038 [-0.01%]
Products
Total CPU difference: 11492.330000000085 / 11466.840000000084 [+0.22%]
Windows-64-VC14:
OCCT
Total CPU difference: 19143.8125 / 19180.875 [-0.19%]
Products
Total CPU difference: 12803.65625 / 12837.4375 [-0.26%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2021-08-14 14:01

administrator   ~0103210

Branch CR27884 has been deleted by mnt.

SHA-1: aa818c31e8770ca83fe4706e9c4815ffb15810b0

git

2021-08-14 14:01

administrator   ~0103211

Branch CR27884_ifv has been deleted by mnt.

SHA-1: 22fdf9d76e80f8c963891fe3bf332b3792f10432

ifv

2021-08-16 12:03

developer   ~0103232

Review

Related Changesets

occt: master 715fcb5a

2021-07-14 20:40:32

abulyche


Committer: bugmaster Details Diff
0027884: Modeling Algorithms - Possible improvement for 2d classifier

Added the implementation of bndbox<->line and bndbox<->segment intersections for 2D to Bnd_Box2d
Added the speedup for 2d classification to BRepClass_Intersector.cxx
Added the test for our improvement
Affected Issues
0027884
mod - src/Bnd/Bnd_Box2d.cxx Diff File
mod - src/Bnd/Bnd_Box2d.hxx Diff File
mod - src/BOPTest/BOPTest_LowCommands.cxx Diff File
mod - src/BRepClass/BRepClass_Edge.cxx Diff File
mod - src/BRepClass/BRepClass_Edge.hxx Diff File
mod - src/BRepClass/BRepClass_FaceClassifier.cxx Diff File
mod - src/BRepClass/BRepClass_FaceClassifier.hxx Diff File
mod - src/BRepClass/BRepClass_FaceExplorer.cxx Diff File
mod - src/BRepClass/BRepClass_FaceExplorer.hxx Diff File
mod - src/BRepClass/BRepClass_Intersector.cxx Diff File
mod - src/BRepClass/BRepClass_Intersector.hxx Diff File
mod - src/BRepClass3d/BRepClass3d_SolidExplorer.cxx Diff File
mod - src/QABugs/QABugs_20.cxx Diff File
add - tests/bugs/modalg_6/bug27884 Diff File

Issue History

Date Modified Username Field Change
2016-09-20 15:47 isn New Issue
2016-09-20 15:47 isn Assigned To => isn
2016-09-20 15:47 isn Description Updated
2016-09-20 15:48 isn Description Updated
2016-09-22 09:41 msv Note Added: 0058007
2016-09-22 09:41 msv Priority normal => low
2016-09-22 09:41 msv Status new => assigned
2016-09-22 09:41 msv Note Edited: 0058007
2016-10-28 16:28 msv Target Version 7.1.0 => 7.2.0
2017-07-24 09:32 msv Target Version 7.2.0 => 7.3.0
2017-12-05 17:08 msv Target Version 7.3.0 => 7.4.0
2019-08-12 16:45 msv Target Version 7.4.0 => 7.5.0
2020-09-14 22:54 msv Target Version 7.5.0 => 7.6.0
2021-04-22 09:17 ifv Note Added: 0100505
2021-04-22 09:25 szy Assigned To isn => ifv
2021-06-01 17:03 ifv Assigned To ifv => abulyche
2021-06-01 17:06 kgv Summary Possible improvement for 2d classifier => Modeling Algorithms - Possible improvement for 2d classifier
2021-07-12 14:03 bugmaster Assigned To abulyche => abulychev-ext
2021-07-14 23:42 git Note Added: 0102539
2021-07-16 13:48 git Note Added: 0102571
2021-07-19 07:25 git Note Added: 0102617
2021-07-20 18:40 git Note Added: 0102686
2021-07-21 14:39 git Note Added: 0102709
2021-07-22 17:22 git Note Added: 0102729
2021-07-23 11:00 git Note Added: 0102737
2021-07-26 15:35 git Note Added: 0102817
2021-07-28 02:20 git Note Added: 0102842
2021-07-29 02:13 git Note Added: 0102864
2021-07-29 13:05 git Note Added: 0102871
2021-07-29 19:30 git Note Added: 0102877
2021-07-30 21:01 git Note Added: 0102904
2021-08-03 12:07 git Note Added: 0102950
2021-08-03 16:49 git Note Added: 0102957
2021-08-06 03:40 git Note Added: 0103020
2021-08-09 18:53 git Note Added: 0103102
2021-08-09 22:23 git Note Added: 0103111
2021-08-10 16:59 git Note Added: 0103113
2021-08-11 12:48 git Note Added: 0103129
2021-08-11 12:59 git Note Added: 0103130
2021-08-11 16:45 git Note Added: 0103134
2021-08-12 01:55 git Note Added: 0103143
2021-08-12 11:09 git Note Added: 0103147
2021-08-12 11:32 git Note Added: 0103148
2021-08-13 12:04 abulychev-ext Assigned To abulychev-ext => ifv
2021-08-13 12:08 abulychev-ext Assigned To ifv => abulychev-ext
2021-08-13 12:22 abulychev-ext Assigned To abulychev-ext => ifv
2021-08-13 12:22 abulychev-ext Status assigned => resolved
2021-08-13 12:22 abulychev-ext Steps to Reproduce Updated
2021-08-13 15:00 ifv Note Added: 0103183
2021-08-13 15:00 ifv Assigned To ifv => bugmaster
2021-08-13 15:00 ifv Status resolved => reviewed
2021-08-14 13:23 bugmaster Note Added: 0103205
2021-08-14 13:23 bugmaster Status reviewed => tested
2021-08-14 13:31 bugmaster Changeset attached => occt master 715fcb5a
2021-08-14 13:31 bugmaster Status tested => verified
2021-08-14 13:31 bugmaster Resolution open => fixed
2021-08-14 14:01 git Note Added: 0103210
2021-08-14 14:01 git Note Added: 0103211
2021-08-16 12:03 ifv Note Added: 0103232
2021-09-04 16:48 smoskvin Test case number => bugs/modalg_6/bug27884