MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027855Open CASCADE[OCCT] OCCT:Codingpublic2016-09-08 23:052017-05-12 11:21
Reporterkgv 
Assigned Tobugmaster 
PrioritylowSeverityintegration request 
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target VersionFixed in Version 
Summary0027855: Coding rules - mark Local Context creation in AIS_InteractiveContext with Standard_DEPRECATED
DescriptionThe local context functionality in AIS_InteractiveContext has been deprecated since OCCT 7.0.0 in release notes, however related functions are still available in code without any warnings.

The method creating Local Context should be marked Standard_DEPRECATED to indicate users that this functionality should be avoided and will be removed at some point.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
duplicate of 0028162closedapn Draw Harness - eliminate usage of deprecated Local Context 
related to 0026807closedbugmaster Documentation - describe dropping of Visual3d and UserDraw within porting notes 

-  Notes
(0057634)
git (administrator)
2016-09-09 12:14

Branch CR27855 has been created by kgv.

SHA-1: 7754201b7ca40c681bdaad222eb210e53c64e633


Detailed log of new commits:

Author: kgv
Date: Fri Sep 9 12:14:36 2016 +0300

    0027855: Coding rules - mark Local Context creation in AIS_InteractiveContext with Standard_DEPRECATED
(0057636)
kgv (developer)
2016-09-09 12:24

Patch is ready for review in branches CR27855 for OCCT and Products.
(0057637)
git (administrator)
2016-09-09 12:45

Branch CR27855 has been updated forcibly by kgv.

SHA-1: 012cc3bac1e37f22f82c647ee4dd866b2462bd14
(0057709)
git (administrator)
2016-09-12 19:49

Branch CR27855 has been updated forcibly by kgv.

SHA-1: 8398ff2e28df105d98bcd5e90a60b3422d05b1db
(0057714)
san (developer)
2016-09-12 22:02

Branch CR27855 reviewed without remarks, ready for testing.
(0057745)
mkv (tester)
2016-09-13 16:04

Dear BugMaster,
Branch CR27855 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms on Release mode.
SHA-1: 8398ff2e28df105d98bcd5e90a60b3422d05b1db

There are following compilation errors:
Linux:
http://jenkins-test-07.nnov.opencascade.com:8080/view/CR27855-master/job/CR27855-master-OCCT-Debian70-64-opt-compile/1/parsed_console/ [^]
...
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2362:5: error: expected ‘}’ before ‘else’
...
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2368:3: error: ‘myMainPM’ does not name a type
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2370:3: error: expected unqualified-id before ‘if’
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2376:3: error: expected unqualified-id before ‘if’
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2382:3: error: expected unqualified-id before ‘if’
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2388:3: error: expected unqualified-id before ‘for’
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2388:86: error: ‘aSelModeIter’ does not name a type
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2388:107: error: ‘aSelModeIter’ does not name a type
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2392:3: error: ‘aStatus’ does not name a type
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2393:3: error: ‘aStatus’ does not name a type
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2395:3: error: expected unqualified-id before ‘if’
/dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.cxx:2399:1: error: expected declaration before ‘}’ token


Number of compiler warnings:

occt component :
Windows: 0 (0 on master)
MacOS : 84 (0 on master)

products component :
Windows: 0 (0 on master)
MacOS : 1158
(0057747)
mkv (tester)
2016-09-13 16:04

Dear kgv,
Branch CR27855 has been rejected due to:
- compilation errors
(0057748)
git (administrator)
2016-09-13 16:16

Branch CR27855 has been updated forcibly by kgv.

SHA-1: 9621198b750f0856d6f270b0bbcb780acffe6966
(0057749)
kgv (developer)
2016-09-13 16:16

Please try corrected patch.
(0057759)
mkv (tester)
2016-09-14 11:45

Dear BugMaster,
Branch CR27855 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 9621198b750f0856d6f270b0bbcb780acffe6966

Number of compiler warnings:

occt component :
Linux: 86 (0 on master)
Windows: 0 (0 on master)
MacOS : 85 (0 on master)

products component :
Linux: 70 (64 on master)
Windows: 0 (0 on master)
MacOS : 1151

There are new additional compilation warnings on Linux and MacOS platforms:
http://jenkins-test-07.nnov.opencascade.com:8080/user/mnt/my-views/view/A_mnt_warnings/portlet/dashboard_portlet_13912/job/CR27855-master-OCCT-Debian70-64-opt-compile/1/warnings17Result/ [^]
ViewerTest_ObjectCommands.cxx:173, GNU C Compiler 4 (gcc), Priority: Normal
‘void AIS_InteractiveContext::CloseAllContexts(Standard_Boolean)’ is deprecated (declared at /dn54/builds/CR27855-master/Debian70-64-opt/OCCT/src/AIS/AIS_InteractiveContext.hxx:1285): Local Context is deprecated - local selection should be used without Local Context [-Wdeprecated-declarations]
....

http://jenkins-test-07.nnov.opencascade.com:8080/user/mnt/my-views/view/A_mnt_warnings/portlet/dashboard_portlet_13912/job/CR27855-master-Products-Debian70-64-opt-compile/1/warnings17Result/category.1856243221/package.1305669456/ [^]
OMFTest_DisplayCommands.cxx:135, GNU C Compiler 4 (gcc), Priority: Normal
‘void AIS_InteractiveContext::CloseLocalContext(Standard_Integer, Standard_Boolean)’ is deprecated (declared at /dn61/builds/CR27855-master/Debian70-64-opt/OCCT/inc/AIS_InteractiveContext.hxx:1272): Local Context is deprecated - local selection should be used without Local Context [-Wdeprecated-declarations]
OMFTest_DisplayCommands.cxx:179, GNU C Compiler 4 (gcc), Priority: Normal
‘void AIS_InteractiveContext::CloseLocalContext(Standard_Integer, Standard_Boolean)’ is deprecated (declared at /dn61/builds/CR27855-master/Debian70-64-opt/OCCT/inc/AIS_InteractiveContext.hxx:1272): Local Context is deprecated - local selection should be used without Local Context [-Wdeprecated-declarations]
OMFTest_DisplayCommands.cxx:184, GNU C Compiler 4 (gcc), Priority: Normal
‘Standard_Integer AIS_InteractiveContext::OpenLocalContext(Standard_Boolean, Standard_Boolean, Standard_Boolean, Standard_Boolean)’ is deprecated (declared at /dn61/builds/CR27855-master/Debian70-64-opt/OCCT/inc/AIS_InteractiveContext.hxx:1254): Local Context is deprecated - local selection should be used without Local Context [-Wdeprecated-declarations]
OMFTest_DisplayCommands.cxx:225, GNU C Compiler 4 (gcc), Priority: Normal
‘Standard_Integer AIS_InteractiveContext::OpenLocalContext(Standard_Boolean, Standard_Boolean, Standard_Boolean, Standard_Boolean)’ is deprecated (declared at /dn61/builds/CR27855-master/Debian70-64-opt/OCCT/inc/AIS_InteractiveContext.hxx:1254): Local Context is deprecated - local selection should be used without Local Context [-Wdeprecated-declarations]
OMFTest_DisplayCommands.cxx:230, GNU C Compiler 4 (gcc), Priority: Normal
‘void AIS_InteractiveContext::CloseAllContexts(Standard_Boolean)’ is deprecated (declared at /dn61/builds/CR27855-master/Debian70-64-opt/OCCT/inc/AIS_InteractiveContext.hxx:1285): Local Context is deprecated - local selection should be used without Local Context [-Wdeprecated-declarations]
OMFTest_DisplayCommands.cxx:527, GNU C Compiler 4 (gcc), Priority: Normal
‘Standard_Integer AIS_InteractiveContext::OpenLocalContext(Standard_Boolean, Standard_Boolean, Standard_Boolean, Standard_Boolean)’ is deprecated (declared at /dn61/builds/CR27855-master/Debian70-64-opt/OCCT/inc/AIS_InteractiveContext.hxx:1254): Local Context is deprecated - local selection should be used without Local Context [-Wdeprecated-declarations]


http://jenkins-test-07.nnov.opencascade.com:8080/user/mnt/my-views/view/A_mnt_warnings/portlet/dashboard_portlet_13912/job/CR27855-master-OCCT-MacOS-opt-compile/4/warnings7Result/ [^]
ViewerTest_ObjectCommands.cxx:173, Clang (LLVM based), Priority: Normal
'CloseAllContexts' is deprecated: Local Context is deprecated - local selection should be used without Local Context
...

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 90259779 / 90409715 [-0.17%]
Total CPU difference: 19248.229999999967 / 19445.440000000133 [-1.01%]
products component :
Total MEMORY difference: 30017716 / 29998667 [+0.06%]
Total CPU difference: 5045.739999999984 / 5044.539999999978 [+0.02%]

Testing on Windows:
occt component :
Total MEMORY difference: 57165422 / 57172575 [-0.01%]
Total CPU difference: 18202.820683998772 / 18100.047225198865 [+0.57%]
products component :
Total MEMORY difference: 21260898 / 21225414 [+0.17%]
Total CPU difference: 4854.376717599944 / 4888.104133799955 [-0.69%]

There are no differences in images found by testdiff.
(0057760)
mkv (tester)
2016-09-14 11:46

Dear kgv,
Branch CR27855 has been rejected due to:
- additional warnings
(0062208)
kgv (developer)
2016-12-27 21:47

Dear bugmaster,

please close the issue as duplicate of 0028162.
(0065872)
git (administrator)
2017-05-12 11:21

Branch CR27855 has been deleted by kgv.

SHA-1: 9621198b750f0856d6f270b0bbcb780acffe6966

- Issue History
Date Modified Username Field Change
2016-09-08 23:05 kgv New Issue
2016-09-08 23:05 kgv Assigned To => kgv
2016-09-09 12:14 git Note Added: 0057634
2016-09-09 12:24 kgv Note Added: 0057636
2016-09-09 12:24 kgv Assigned To kgv => san
2016-09-09 12:24 kgv Status new => resolved
2016-09-09 12:24 kgv Priority normal => low
2016-09-09 12:45 git Note Added: 0057637
2016-09-10 10:18 kgv Relationship added related to 0026807
2016-09-12 19:49 git Note Added: 0057709
2016-09-12 22:02 san Note Added: 0057714
2016-09-12 22:02 san Assigned To san => bugmaster
2016-09-12 22:02 san Status resolved => reviewed
2016-09-13 10:59 mkv Assigned To bugmaster => mkv
2016-09-13 16:04 mkv Note Added: 0057745
2016-09-13 16:04 mkv Note Added: 0057747
2016-09-13 16:04 mkv Assigned To mkv => kgv
2016-09-13 16:04 mkv Status reviewed => assigned
2016-09-13 16:04 mkv Test case number => Not needed
2016-09-13 16:16 git Note Added: 0057748
2016-09-13 16:16 kgv Note Added: 0057749
2016-09-13 16:16 kgv Assigned To kgv => bugmaster
2016-09-13 16:16 kgv Status assigned => resolved
2016-09-13 16:17 kgv Status resolved => reviewed
2016-09-13 16:41 mkv Assigned To bugmaster => mkv
2016-09-14 11:45 mkv Note Added: 0057759
2016-09-14 11:46 mkv Note Added: 0057760
2016-09-14 11:46 mkv Assigned To mkv => kgv
2016-09-14 11:46 mkv Status reviewed => assigned
2016-11-22 10:41 abv Target Version 7.1.0 => 7.2.0
2016-11-24 10:20 kgv Assigned To kgv => isk
2016-12-27 21:47 kgv Relationship added duplicate of 0028162
2016-12-27 21:47 kgv Note Added: 0062208
2016-12-27 21:47 kgv Assigned To isk => bugmaster
2016-12-27 21:47 kgv Status assigned => feedback
2016-12-27 21:47 kgv Resolution open => duplicate
2017-02-09 17:06 apn Status feedback => closed
2017-02-09 17:06 apn Target Version 7.2.0 =>
2017-05-12 11:21 git Note Added: 0065872


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker