MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027845Open CASCADE[OCCT] OCCT:Meshpublic2016-09-06 17:412018-11-11 12:01
Reporterssv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0027845: BRepMesh produces invalid result on spline cavity
DescriptionOn the attached CAD model, our faceter (BRepMesh) gives invalid result for the following deflection values:

- linear deflection: 10
- angular deflection: 10
Steps To Reproducerestore onshape_box_with_cavities.brep a
tclean a
incmesh a 10 -a 180

vinit
vdefaults -autoTriang 0
vdisplay a
vfit
vsetdispmode 1
TagsNo tags attached.
Test case numberbugs/mesh/bug27845
Attached Files? file icon onshape_box_with_cavities.brep (1,535,023 bytes) 2016-09-06 17:41
png file icon brepmesh_problem.png (50,521 bytes) 2016-09-06 17:44
png file icon brepmesh_finer_parameters.png (51,951 bytes) 2016-09-06 17:44

- Relationships
duplicate of 0025061newoan Open CASCADE BRepMesh should skip internal wires with self intersections to produce mesh for the shape anyway 

-  Notes
(0057531)
oan (developer)
2016-09-06 18:55

Such behaviour is possible due to rough discretization of internal wire degenerated to two points which complicates classification of triangles as internal/external. Current implementation of algorithm does not support explicit separation between inner/outer discrete wires thus implementation of such feature using current structure can lead to significant overhead.
(0069315)
oan (developer)
2017-08-11 12:55

Fixed by #26106.
(0080760)
bugmaster (administrator)
2018-11-06 15:53

Please create testing case
(0080922)
nbv (developer)
2018-11-08 11:08

Dear Mikhail,

Please review the branch CR27845.

Test results are here:
Windows: http://jenkins-test-12.nnov.opencascade.com/view/MeshTest-master_NBV/view/TESTING/job/MeshTest-master_NBV-OCCT-Windows-64-VC14-opt-test-restart/HTML_20Report/ [^]

Linux: http://jenkins-test-12.nnov.opencascade.com/view/MeshTest-master_NBV/view/TESTING/job/MeshTest-master_NBV-OCCT-Debian80-64-opt-test-restart/HTML_20Report/ [^]
(0080923)
git (administrator)
2018-11-08 11:08

Branch CR27845 has been created by nbv.

SHA-1: f6184472542072e29299b91f497d3b2930ee0d55


Detailed log of new commits:

Author: nbv
Date: Thu Nov 8 10:39:21 2018 +0300

    0027845: BRepMesh produces invalid result on spline cavity
    
    Adding test case for the problem.
    The issue has been fixed by a patch for #26106.
(0080927)
oan (developer)
2018-11-08 11:43

Reviewed.
(0080945)
bugmaster (administrator)
2018-11-08 13:48

Adding test case
(0081030)
git (administrator)
2018-11-11 12:01

Branch CR27845 has been deleted by inv.

SHA-1: f6184472542072e29299b91f497d3b2930ee0d55

- Related Changesets
occt: master 24f355f0
Timestamp: 2018-11-08 07:39:21
Author: nbv
Committer: bugmaster
Details ] Diff ]
0027845: BRepMesh produces invalid result on spline cavity

Adding test case for the problem.
The issue has been fixed by a patch for #26106.
add - tests/bugs/mesh/bug27845 Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-09-06 17:41 ssv New Issue
2016-09-06 17:41 ssv Assigned To => oan
2016-09-06 17:41 ssv File Added: onshape_box_with_cavities.brep
2016-09-06 17:44 ssv File Added: brepmesh_problem.png
2016-09-06 17:44 ssv File Added: brepmesh_finer_parameters.png
2016-09-06 18:40 oan Relationship added duplicate of 0025061
2016-09-06 18:46 oan Steps to Reproduce Updated View Revisions
2016-09-06 18:55 oan Note Added: 0057531
2016-09-06 18:55 oan Relationship added related to 0026106
2016-11-03 17:38 abv Target Version 7.1.0 => 7.2.0
2017-07-20 12:43 oan Target Version 7.2.0 => 7.3.0
2017-08-11 12:55 oan Note Added: 0069315
2018-02-25 21:14 abv Target Version 7.3.0 => 7.4.0*
2018-11-02 15:35 nbv Steps to Reproduce Updated View Revisions
2018-11-02 15:37 nbv Assigned To oan => bugmaster
2018-11-02 15:37 nbv Status new => feedback
2018-11-06 15:47 bugmaster Status feedback => verified
2018-11-06 15:47 bugmaster Resolution open => fixed
2018-11-06 15:53 bugmaster Status verified => closed
2018-11-06 15:53 bugmaster Note Added: 0080760
2018-11-06 15:53 bugmaster Status closed => assigned
2018-11-07 19:25 oan Assigned To bugmaster => nbv
2018-11-08 11:08 nbv Note Added: 0080922
2018-11-08 11:08 nbv Assigned To nbv => oan
2018-11-08 11:08 nbv Status assigned => resolved
2018-11-08 11:08 git Note Added: 0080923
2018-11-08 11:43 oan Assigned To oan => bugmaster
2018-11-08 11:43 oan Status resolved => reviewed
2018-11-08 11:43 oan Note Added: 0080927
2018-11-08 13:48 bugmaster Note Added: 0080945
2018-11-08 13:48 bugmaster Status reviewed => tested
2018-11-09 15:45 bugmaster Test case number => bugs/mesh/bug27845
2018-11-11 11:52 bugmaster Changeset attached => occt master 24f355f0
2018-11-11 11:52 bugmaster Status tested => verified
2018-11-11 12:01 git Note Added: 0081030


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker