MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027827Open CASCADE[OCCT] OCCT:Samplespublic2016-08-31 12:292016-12-09 16:39
Reporterski 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSOS Version
Product Version 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027827: Samples - fix compilation errors in XAML (UWP) sample.
DescriptionSample XAML (UWP) needs to use TKIGES, TKSTEP, TKXSBase, TKSTL for successful compilation currently. It is necessary to build all possible toolkits for UWP platform.
Steps To Reproduce• Build OCCT and XAML sample with UWP
• Try to build and run XAML sample
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
child of 0027811closedbugmaster Open CASCADE Configuration - allow building TKOpenGl with OpenGL ES on Windows 

-  Notes
(0057322)
git (administrator)
2016-08-31 12:35

Branch CR27827 has been created by ski.

SHA-1: 0b5c7382024ae383402342fb774d011c780bc074


Detailed log of new commits:

Author: ski
Date: Wed Aug 31 12:35:03 2016 +0300

    0027827: Samples - fix compilation errors in XAML (UWP) sample.
    
    Building of additional toolkits from DataExchange and ApplicationFramework modules was added.
    Error about deployment target was fixed.
(0057323)
ski (developer)
2016-08-31 12:37

Dear abv,

Building of additional toolkits from DataExchange and ApplicationFramework modules was added for correct compilation of XAML (UWP) sample.

Also, error about deployment target was fixed by using of current target version as minimum target version for UWP sample.

Please, review.
(0057361)
git (administrator)
2016-08-31 18:00

Branch CR27827 has been updated forcibly by ski.

SHA-1: b4eb646b88864e442f77f86e3f87d1c677354942
(0057362)
ski (developer)
2016-08-31 18:02

Branch CR27827 was rebased on issue 0027811.

It contains changes to eliminate error about deployment target version.
(0057363)
git (administrator)
2016-08-31 18:05

Branch CR27827 has been updated forcibly by ski.

SHA-1: 3f4a35307637f021bc4efb15fe0d9871c49b68b8
(0057365)
git (administrator)
2016-08-31 18:14

Branch CR27827 has been updated by ski.

SHA-1: c1347f4084c8054b5f2fe727f007c6c94bd45db0


Detailed log of new commits:

Author: ski
Date: Wed Aug 31 12:35:03 2016 +0300

    Check of export to VRML format was added to sample XAML (UWP).

(0057366)
ski (developer)
2016-08-31 18:16

Also, i have uncommented checking of export to VRML format in sample XAML (UWP) because it is possible now to built TKVRML toolkit using changes in 0027811.
(0057367)
git (administrator)
2016-08-31 18:23

Branch CR27827 has been updated forcibly by ski.

SHA-1: 84cefbd8fd680b07fcf1a68352a8fbdad7981fd5
(0057368)
ski (developer)
2016-08-31 18:25

Dear abv,

please review.
(0057427)
git (administrator)
2016-09-02 15:22

Branch CR27827 has been updated forcibly by ski.

SHA-1: b5295378df1880e8c179ce3aafcb3184c4d0b6f1
(0057428)
san (developer)
2016-09-02 15:25

Branch CR27827 reviewed without remarks, ready for testing.

Note that this patch requires a patch for 0027811 and should be tested on the top of it.
(0057536)
git (administrator)
2016-09-06 19:11

Branch CR27827 has been updated by ski.

SHA-1: 9c5b19ffa58539e1a0cc193fe026c540a47655a3


Detailed log of new commits:

Author: ski
Date: Tue Sep 6 19:10:08 2016 +0300

    Copy freetype.dll for correct execution of sample from Visual Studio.

(0057564)
git (administrator)
2016-09-07 14:31

Branch CR27827 has been updated forcibly by ski.

SHA-1: fd1263601a3aa5b838bb609ffc8b30aa2ce13b09
(0057570)
apn (administrator)
2016-09-07 15:35

CR27827 was compiled on Windows 10 using Universal Windows Platform.
Checked execution of Xaml sample from visual studio. Also it successfully starts after installation on PC.
(0059576)
git (administrator)
2016-10-28 21:48

Branch CR27827 has been deleted by kgv.

SHA-1: fd1263601a3aa5b838bb609ffc8b30aa2ce13b09

- Related Changesets
occt: master 1ae83f57
Timestamp: 2016-08-31 09:35:03
Author: ski
Committer: bugmaster
Details ] Diff ]
0027827: Samples - fix compilation errors in XAML (UWP) sample.

Error about deployment target version was fixed.
Check of export to VRML format was added to sample XAML (UWP).

Add freetype.dll to the sample project for correct execution of sample from Visual Studio.
mod - samples/xaml/CMakeLists.txt Diff ] File ]
mod - samples/xaml/MainPage.xaml.cpp Diff ] File ]
mod - samples/xaml/MainPage.xaml.h Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-08-31 12:29 ski New Issue
2016-08-31 12:29 ski Assigned To => ski
2016-08-31 12:30 ski Relationship added related to 0027350
2016-08-31 12:30 ski Status new => assigned
2016-08-31 12:30 ski Summary Samples - fix compilations errors in XAML (UWP) sample. => Samples - fix compilation errors in XAML (UWP) sample.
2016-08-31 12:35 git Note Added: 0057322
2016-08-31 12:37 ski Note Added: 0057323
2016-08-31 12:37 ski Assigned To ski => abv
2016-08-31 12:37 ski Status assigned => resolved
2016-08-31 18:00 git Note Added: 0057361
2016-08-31 18:02 ski Note Added: 0057362
2016-08-31 18:02 ski Relationship added child of 0027811
2016-08-31 18:05 git Note Added: 0057363
2016-08-31 18:14 git Note Added: 0057365
2016-08-31 18:16 ski Note Added: 0057366
2016-08-31 18:23 git Note Added: 0057367
2016-08-31 18:25 ski Note Added: 0057368
2016-09-02 15:22 git Note Added: 0057427
2016-09-02 15:25 san Note Added: 0057428
2016-09-02 15:25 san Assigned To abv => bugmaster
2016-09-02 15:25 san Status resolved => reviewed
2016-09-05 17:42 bugmaster Assigned To bugmaster => ski
2016-09-05 17:50 apn Assigned To ski => apn
2016-09-06 19:11 git Note Added: 0057536
2016-09-07 14:31 git Note Added: 0057564
2016-09-07 15:35 apn Note Added: 0057570
2016-09-07 15:35 apn Test case number => Not needed
2016-09-07 15:35 apn Assigned To apn => bugmaster
2016-09-07 15:35 apn Status reviewed => tested
2016-09-09 09:40 bugmaster Changeset attached => occt master 1ae83f57
2016-09-09 09:40 bugmaster Status tested => verified
2016-09-09 09:40 bugmaster Resolution open => fixed
2016-10-28 21:48 git Note Added: 0059576
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker