MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027817Open CASCADE[OCCT] OCCT:Visualizationpublic2016-08-28 19:172016-12-09 16:39
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027817: Visualization, StdSelect_BRepOwner - copy transformation persistence flag
DescriptionStdSelect_BRepOwner does not copy transformation persistence flag for created presentation leading to highlighting artifacts within local selection.
Steps To Reproduce
pload MODELING VISUALIZATION
vclear
vinit View1
vtrih t
vdisplay -trsfPers trihedron -trsfPersPos -1 -1 40 t
box b 30 40 50
vdisplay -trsfPers trihedron -trsfPersPos -1 -1 40 -dispMode 1 b
vselmode b 4 1
vmoveto 50 350
if { [vreadpixel 50 350 rgb name] != "DARKTURQUOISE" } { puts "Error: face is not highlighted" 
}
TagsNo tags attached.
Test case numberbugs vis bug27817
Attached Filespng file icon trsfpers_face_KO.png (1,955 bytes) 2016-08-28 19:20
png file icon trsfpers_face_OK.png (1,958 bytes) 2016-08-28 19:20

- Relationships
related to 0027860closedkgv Open CASCADE Visualization - clean up Transformation Persistence API 

-  Notes
(0057236)
git (administrator)
2016-08-28 19:25

Branch CR27817 has been created by kgv.

SHA-1: ecfcdde32536a243dd1029ed1dfebca4799e90d6


Detailed log of new commits:

Author: kgv
Date: Sun Aug 28 19:21:13 2016 +0300

    0027817: Visualization, StdSelect_BRepOwner - copy transformation persistence flag
(0057237)
kgv (developer)
2016-08-28 19:26

Patch is ready for review.
(0057303)
apl (developer)
2016-08-30 18:08

Dear bugmaster,

Please test the patch.
(0057331)
apv (tester)
2016-08-31 14:01

Dear BugMaster,

Branch CR27817 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: ecfcdde32536a243dd1029ed1dfebca4799e90d6

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1133

Regressions/Differences:
Not detected

Testing cases:
bugs vis bug27817 - FAILED
http://occt-tests/CR27817-master-OCCT/Debian70-64/bugs/vis/bug27817.html [^]
http://occt-tests/CR27817-master-OCCT/Windows-64-VC10/bugs/vis/bug27817.html [^]

Testing on Linux:
Total MEMORY difference: 90073805 / 89930812 [+0.16%]
Total CPU difference: 19304.429999999982 / 19309.479999999934 [-0.03%]

Testing on Windows:
Total MEMORY difference: 57089032 / 57107084 [-0.03%]
Total CPU difference: 17993.34254119884 / 18053.73052829886 [-0.33%]
(0057332)
apv (tester)
2016-08-31 14:02

Dear Kirill,

Branch CR27817 has been rejected due to:
- failed test-case for issue
(0057333)
git (administrator)
2016-08-31 14:07

Branch CR27817 has been updated forcibly by kgv.

SHA-1: 3d3ee085831c9a1fc8a9ee47335c8e2c9ef4f4b8
(0057334)
kgv (developer)
2016-08-31 14:07

The erroneous short syntax of vtrihedron command has been corrected in test case - please re-check this test case.
(0057345)
apv (tester)
2016-08-31 15:28

Testing cases:
bugs vis bug27817 - OK
http://occt-tests/CR27817-master-OCCT/Debian70-64/bugs/vis/bug27817.html [^]
http://occt-tests/CR27817-master-OCCT/Windows-64-VC10/bugs/vis/bug27817.html [^]
(0059573)
git (administrator)
2016-10-28 21:48

Branch CR27817 has been deleted by kgv.

SHA-1: 3d3ee085831c9a1fc8a9ee47335c8e2c9ef4f4b8

- Related Changesets
occt: master e7879c57
Timestamp: 2016-08-28 16:21:13
Author: kgv
Committer: bugmaster
Details ] Diff ]
0027817: Visualization, StdSelect_BRepOwner - copy transformation persistence flag
mod - src/StdSelect/StdSelect_BRepOwner.cxx Diff ] File ]
add - tests/bugs/vis/bug27817 Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-08-28 19:17 kgv New Issue
2016-08-28 19:17 kgv Assigned To => kgv
2016-08-28 19:20 kgv File Added: trsfpers_face_KO.png
2016-08-28 19:20 kgv File Added: trsfpers_face_OK.png
2016-08-28 19:21 kgv Summary Visualization - StdSelect_BRepOwner does not copy transformation persistence flag => Visualization, StdSelect_BRepOwner - copy transformation persistence flag
2016-08-28 19:25 git Note Added: 0057236
2016-08-28 19:26 kgv Note Added: 0057237
2016-08-28 19:26 kgv Assigned To kgv => san
2016-08-28 19:26 kgv Status new => resolved
2016-08-28 19:26 kgv Product Version => 7.1.0
2016-08-28 19:26 kgv Relationship added related to 0027793
2016-08-30 16:20 kgv Assigned To san => apl
2016-08-30 18:08 apl Note Added: 0057303
2016-08-30 18:08 apl Assigned To apl => bugmaster
2016-08-30 18:08 apl Status resolved => reviewed
2016-08-30 18:15 apv Assigned To bugmaster => apv
2016-08-31 13:43 apv Test case number => bugs vis bug27817
2016-08-31 14:01 apv Note Added: 0057331
2016-08-31 14:01 apv Assigned To apv => kgv
2016-08-31 14:01 apv Status reviewed => assigned
2016-08-31 14:02 apv Note Added: 0057332
2016-08-31 14:07 git Note Added: 0057333
2016-08-31 14:07 kgv Note Added: 0057334
2016-08-31 14:07 kgv Assigned To kgv => bugmaster
2016-08-31 14:07 kgv Status assigned => resolved
2016-08-31 14:08 kgv Status resolved => reviewed
2016-08-31 14:36 apv Assigned To bugmaster => apv
2016-08-31 15:28 apv Note Added: 0057345
2016-08-31 15:28 apv Assigned To apv => bugmaster
2016-08-31 15:28 apv Status reviewed => tested
2016-09-02 10:27 bugmaster Changeset attached => occt master e7879c57
2016-09-02 10:27 bugmaster Status tested => verified
2016-09-02 10:27 bugmaster Resolution open => fixed
2016-09-10 14:35 kgv Relationship added related to 0027860
2016-10-28 21:48 git Note Added: 0059573
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker