MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027813Community[OCCT] OCCT:Visualizationpublic2016-08-26 14:022016-12-09 16:39
ReporterTimo 
Assigned Tomkv 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027813: Visualization - add method V3d_View::DiagnosticInformation() similar to vglinfo command
DescriptionWould it be possible to put the code of Draw command VGlInfo (see ViewerTest_OpenGlCommands.cxx) or something similar into an API function, so that application code could easily use it?

In this way, information about the OpneGL version,... could be e.g. easily put into an automatically generated bug report of an application and facilitate analysis of errors that are connected to the graphics card.

It would be especially helpful for C# or other wrapper based applications which do not have direct access to OpenGL functions like glGetString.

What do you think about it?

TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0057093)
kgv (developer)
2016-08-26 14:12

> It would be especially helpful for C# or other wrapper based applications
> which do not have direct access to OpenGL functions like glGetString.
It is possible to do this in C# application - we have already did this before.
But I agree that it will be much better and simpler to have this information through indirect API from OCCT.
(0057234)
git (administrator)
2016-08-28 17:58

Branch CR27813 has been created by kgv.

SHA-1: ab0827fbddd7aa93ea937e8ce1b5e89a6fd4a4f5


Detailed log of new commits:

Author: kgv
Date: Thu Aug 25 22:22:35 2016 +0300

    0027813: Visualization - add method V3d_View::DiagnosticInformation() similar to vglinfo command
    
    New method V3d_View::DiagnosticInformation() has been introduced
    providing the access to low-level OpenGL context information
    for diagnostic automated reports or displaying in application About System.
(0057235)
kgv (developer)
2016-08-28 18:01

Patch is ready for review.
(0057304)
apl (developer)
2016-08-30 18:44

Dear bugmaster,

The patch has been reviewed. Please test.
(0057326)
mkv (tester)
2016-08-31 13:03

Dear BugMaster,
Branch CR27813 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms on Release mode.
SHA-1: ab0827fbddd7aa93ea937e8ce1b5e89a6fd4a4f5

There are following compilation errors:
Linux:
http://jenkins-test-07.nnov.opencascade.com:8080/view/CR27813-master/job/CR27813-master-OCCT-Debian70-64-opt-compile/1/parsed_console/ [^]
/dn54/builds/CR27813-master/Debian70-64-opt/OCCT/src/OpenGl/OpenGl_Context.cxx:2529:67: error: ambiguous overload for ‘operator+’ in ‘TCollection_AsciiString() + aVMemMiB’

MacOS:
http://jenkins-test-07.nnov.opencascade.com:8080/view/CR27813-master/job/CR27813-master-OCCT-MacOS-opt-compile/1/parsed_console/ [^]
/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk/System/Library/Frameworks/ApplicationServices.framework/Frameworks/HIServices.framework/Headers/Icons.h:179:32: error: use of undeclared identifier 'IconGetterProcPtr'
...
(0057327)
mkv (tester)
2016-08-31 13:04

Dear kgv,
Branch CR27813 has been rejected due to:
- compilation errors
(0057371)
git (administrator)
2016-08-31 21:07

Branch CR27813 has been updated forcibly by kgv.

SHA-1: 1dacfe5ca827f9fe332b1311d3d81fa6b736e8d2
(0057372)
kgv (developer)
2016-08-31 21:07

Please check updated branch.
(0057390)
git (administrator)
2016-09-01 15:03

Branch CR27813 has been updated forcibly by mkv.

SHA-1: 26d9c83516ab1bc077697ea795be29fa5b049c24
(0057413)
mkv (tester)
2016-09-02 13:32

Dear BugMaster,
Branch CR27813 was rebased on IR-2016-09-01 of occt git-repository.
(0057414)
mkv (tester)
2016-09-02 13:32

Dear BugMaster,
Branch CR27813 from occt git-repository (and IR-2016-09-01 from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 26d9c83516ab1bc077697ea795be29fa5b049c24

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1135

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 89831781 / 89472953 [+0.40%]
Total CPU difference: 19336.269999999946 / 19241.090000000015 [+0.49%]
products component :
Total MEMORY difference: 30002480 / 29985574 [+0.06%]
Total CPU difference: 5075.209999999989 / 5115.309999999973 [-0.78%]

Testing on Windows:
occt component :
Total MEMORY difference: 57147628 / 57155154 [-0.01%]
Total CPU difference: 18283.832003298834 / 18057.115749998855 [+1.26%]
products component :
Total MEMORY difference: 21260692 / 21225231 [+0.17%]
Total CPU difference: 4903.5638328999485 / 4849.119483899957 [+1.12%]

There are no differences in images found by testdiff.
(0057415)
mkv (tester)
2016-09-02 13:32

Dear BugMaster,
Branch CR27813 is TESTED.
(0059571)
git (administrator)
2016-10-28 21:48

Branch CR27813 has been deleted by kgv.

SHA-1: 26d9c83516ab1bc077697ea795be29fa5b049c24

- Related Changesets
occt: master 26d9c835
Timestamp: 2016-08-31 18:06:54
Author: kgv
Committer: mkv
Details ] Diff ]
0027813: Visualization - add method V3d_View::DiagnosticInformation() similar to vglinfo command

New method V3d_View::DiagnosticInformation() has been introduced
providing the access to low-level OpenGL context information
for diagnostic automated reports or displaying in application About System.
mod - src/Graphic3d/FILES Diff ] File ]
mod - src/Graphic3d/Graphic3d_CView.hxx Diff ] File ]
add - src/Graphic3d/Graphic3d_DiagnosticInfo.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_Context.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Context.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_GlFunctions.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_View.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_View.hxx Diff ] File ]
mod - src/TCollection/TCollection_AsciiString.cxx Diff ] File ]
mod - src/TCollection/TCollection_AsciiString.hxx Diff ] File ]
mod - src/TCollection/TCollection_HAsciiString.cxx Diff ] File ]
mod - src/TColStd/FILES Diff ] File ]
add - src/TColStd/TColStd_IndexedDataMapOfStringString.hxx Diff ] File ]
mod - src/V3d/V3d_View.cxx Diff ] File ]
mod - src/V3d/V3d_View.hxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_OpenGlCommands.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-08-26 14:02 Timo New Issue
2016-08-26 14:02 Timo Assigned To => kgv
2016-08-26 14:12 kgv Note Added: 0057093
2016-08-28 17:18 kgv Summary Put VGlInfo into the API => Visualization - add method V3d_View::DiagnosticInformation() similar to vglinfo command
2016-08-28 17:58 git Note Added: 0057234
2016-08-28 18:01 kgv Note Added: 0057235
2016-08-28 18:01 kgv Assigned To kgv => san
2016-08-28 18:01 kgv Status new => resolved
2016-08-30 16:20 kgv Assigned To san => apl
2016-08-30 18:44 apl Note Added: 0057304
2016-08-30 18:44 apl Assigned To apl => bugmaster
2016-08-30 18:44 apl Status resolved => reviewed
2016-08-30 18:56 mkv Assigned To bugmaster => mkv
2016-08-31 13:03 mkv Note Added: 0057326
2016-08-31 13:04 mkv Note Added: 0057327
2016-08-31 13:04 mkv Assigned To mkv => kgv
2016-08-31 13:04 mkv Status reviewed => assigned
2016-08-31 21:07 git Note Added: 0057371
2016-08-31 21:07 kgv Note Added: 0057372
2016-08-31 21:07 kgv Assigned To kgv => bugmaster
2016-08-31 21:07 kgv Status assigned => resolved
2016-08-31 21:08 kgv Status resolved => reviewed
2016-09-01 14:19 mkv Assigned To bugmaster => mkv
2016-09-01 15:03 git Note Added: 0057390
2016-09-02 13:32 mkv Note Added: 0057413
2016-09-02 13:32 mkv Note Added: 0057414
2016-09-02 13:32 mkv Note Added: 0057415
2016-09-02 13:32 mkv Assigned To mkv => bugmaster
2016-09-02 13:32 mkv Status reviewed => tested
2016-09-02 13:32 mkv Test case number => Not needed
2016-09-09 09:40 mkv Changeset attached => occt master 26d9c835
2016-09-09 09:40 mkv Assigned To bugmaster => mkv
2016-09-09 09:40 mkv Status tested => verified
2016-09-09 09:40 mkv Resolution open => fixed
2016-10-28 21:48 git Note Added: 0059571
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker