MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027811Open CASCADE[OCCT] OCCT:Visualizationpublic2016-08-25 22:212018-06-30 14:08
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2015OS Version64 bit
Product Version 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027811: Configuration - allow building TKOpenGl with OpenGL ES on Windows
DescriptionIt is proposed to support building of TKOpenGl with EGL/GLESv2 (like Angle project) as alternative to desktop OpenGL.

References:
- Angle project.
  OpenGL ES implementation on top of Direct3D, used by Chrome/Firefox browsers:
  http://angleproject.org [^]
  https://github.com/google/angle [^]
- ANGLE fork from Microsoft:
  https://github.com/Microsoft/angle [^]
TagsNo tags attached.
Test case numberNot needed
Attached Filespng file icon uwp_occt_viewer.png (8,963 bytes) 2016-08-28 00:36

- Relationships
parent of 0027827closedbugmaster Open CASCADE Samples - fix compilation errors in XAML (UWP) sample. 
related to 0028095closedapn Open CASCADE Draw Harness, ViewerTest - use RGBA format instead of BGRA within vreadpixel 
related to 0029918assignedapn Open CASCADE Samples - extend UWP sample with 3D Viewer 

-  Notes
(0057081)
git (administrator)
2016-08-25 22:23

Branch CR27811 has been created by kgv.

SHA-1: b5400f74ca4f95fa512f06cca793da2ad9dd35d7


Detailed log of new commits:

Author: kgv
Date: Thu Aug 25 22:22:35 2016 +0300

    0027811: Configuration - allow building TKOpenGl with OpenGL ES on Windows
(0057083)
kgv (developer)
2016-08-25 23:33
edited on: 2016-08-26 11:45

Draw[1]> pload MODELING VISUALIZATION
Draw[2]> box b 1 2 3
Draw[3]> vinit View1
Driver1/Viewer1/View1
Draw[4]> vglinfo
OpenGL info:
  GLvendor    = 'Google Inc.'
  GLdevice    = 'ANGLE (AMD Radeon R9 200 Series Direct3D11 vs_5_0 ps_5_0)'
  GLversion   = 'OpenGL ES 2.0 (ANGLE 2.1.0.46ad513f4e5b)'
  GLSLversion = 'OpenGL ES GLSL ES 1.00 (ANGLE 2.1.0.46ad513f4e5b)'

Draw[5]> vglinfo EXTENSIONS
GL_OES_element_index_uint GL_OES_packed_depth_stencil GL_OES_get_program_binary
GL_OES_rgb8_rgba8 GL_EXT_texture_format_BGRA8888 GL_EXT_read_format_bgra
GL_NV_pixel_buffer_object GL_OES_mapbuffer GL_EXT_map_buffer_range GL_EXT_color_buffer_half_float
GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_float
GL_OES_texture_float_linear GL_EXT_texture_rg GL_EXT_texture_compression_dxt1
GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_OES_compressed_ETC1_RGB8_texture

GL_EXT_sRGB GL_ANGLE_depth_texture GL_OES_depth32 GL_EXT_texture_storage GL_OES_texture_npot
GL_EXT_draw_buffers GL_EXT_texture_filter_anisotropic GL_EXT_occlusion_query_boolean
GL_NV_fence GL_EXT_disjoint_timer_query GL_EXT_robustness GL_EXT_blend_minmax GL_ANGLE_framebuffer_blit

GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_pack_reverse_row_order
GL_OES_standard_derivatives GL_EXT_shader_texture_lod GL_EXT_frag_depth GL_ANGLE_texture_usage
GL_ANGLE_translated_shader_source GL_EXT_discard_framebuffer GL_EXT_debug_marker
GL_OES_EGL_image GL_OES_EGL_image_external GL_NV_EGL_stream_consumer_external
GL_EXT_unpack_subimage GL_NV_pack_subimage GL_OES_vertex_array_object GL_KHR_debug
GL_ANGLE_lossy_etc_decode GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_sync_query GL_CHROMIUM_copy_texture



(0057092)
git (administrator)
2016-08-26 14:00

Branch CR27811 has been updated forcibly by kgv.

SHA-1: 96b10ff6e35f2388a458f338b5a0e6f9584987da
(0057228)
git (administrator)
2016-08-27 16:20

Branch CR27811 has been updated forcibly by kgv.

SHA-1: 03a72c889f4f57f57e1a7d380609c7053ef919b4
(0057230)
git (administrator)
2016-08-28 00:36

Branch CR27811 has been updated forcibly by kgv.

SHA-1: a105c11dceb05e9d3f6c8fab0f7f4e2415e324ed
(0057231)
kgv (developer)
2016-08-28 00:37
edited on: 2016-08-28 09:25

Patch is ready for review in branch CR27811 (uwp sample in CR27811_sample using 3D viewer is not for integration).

(0057232)
git (administrator)
2016-08-28 01:39

Branch CR27811_sample has been created by kgv.

SHA-1: 1f5f160f1c39bbdf61c88dc7fe96d73646c85239


Detailed log of new commits:

Author: kgv
Date: Thu Aug 25 22:22:35 2016 +0300

    UWP sample creating OCCT 3D Viewer
(0057233)
git (administrator)
2016-08-28 09:24

Branch CR27811 has been updated forcibly by kgv.

SHA-1: 46e0277b1da3b2a065fe5a1f16c49a10f5b9b107
(0057354)
git (administrator)
2016-08-31 17:15

Branch CR27811 has been updated forcibly by kgv.

SHA-1: a8efe771aaf8bee92280809aa3b5f512553e65c0
(0057369)
git (administrator)
2016-08-31 19:34

Branch CR27811 has been updated forcibly by kgv.

SHA-1: 47dd00f2c8a5e8b50e669cfb173af7c285164997
(0057370)
san (developer)
2016-08-31 19:36

Branch CR27811 reviewed without remarks, ready for testing.
(0057384)
mkv (tester)
2016-09-01 14:10

Dear BugMaster,
Branch CR27811 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 47dd00f2c8a5e8b50e669cfb173af7c285164997

There are following compilation errors:

Windows:
http://jenkins-test-07.nnov.opencascade.com:8080/view/CR27811-master/job/CR27811-master-Products-Windows-64-VC10-csharp-samples/2/parsed_console/ [^]

d:\install\CR27811-master\Windows-64-VC10-opt\Products\samples\csharp\OCCCSharp\OpenGl_ViewControl.cs(27,7): error CS0246: The type or namespace name 'WNT' could not be found (are you missing a using directive or an assembly reference?)
d:\install\CR27811-master\Windows-64-VC10-opt\Products\samples\csharp\OCCCSharp\D3DHost_ImageView.cs(33,7): error CS0246: The type or namespace name 'WNT' could not be found (are you missing a using directive or an assembly reference?)
d:\install\CR27811-master\Windows-64-VC10-opt\Products\samples\csharp\OCCCSharp\OpenGl_ViewControl.cs(94,12): error CS0246: The type or namespace name 'WNT_Window' could not be found (are you missing a using directive or an assembly reference?)
d:\install\CR27811-master\Windows-64-VC10-opt\Products\samples\csharp\OCCCSharp\OpenGl_ViewControl.cs(242,15): error CS0246: The type or namespace name 'WNT_Window' could not be found (are you missing a using directive or an assembly reference?)
d:\install\CR27811-master\Windows-64-VC10-opt\Products\samples\csharp\OCCCSharp\D3DHost_ImageView.cs(81,12): error CS0246: The type or namespace name 'WNT_Window' could not be found (are you missing a using directive or an assembly reference?)
d:\install\CR27811-master\Windows-64-VC10-opt\Products\samples\csharp\OCCCSharp\D3DHost_ImageView.cs(351,15): error CS0246: The type or namespace name 'WNT_Window' could not be found (are you missing a using directive or an assembly reference?)


Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 64 (64 on master)
Windows: 0 (0 on master)
MacOS : 1137

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 90156808 / 89957043 [+0.22%]
Total CPU difference: 19286.679999999993 / 19309.479999999934 [-0.12%]
products component :
Total MEMORY difference: 30013128 / 30026483 [-0.04%]
Total CPU difference: 5086.989999999973 / 5045.099999999974 [+0.83%]

Testing on Windows:
occt component :
Total MEMORY difference: 57099338 / 57107084 [-0.01%]
Total CPU difference: 18236.891302398883 / 18053.73052829886 [+1.01%]
products component :
Total MEMORY difference: 21259115 / 21223623 [+0.17%]
Total CPU difference: 4895.732582699957 / 4857.465537399941 [+0.79%]

There are no differences in images found by testdiff.
(0057385)
mkv (tester)
2016-09-01 14:11

Dear kgv,
Branch CR27811 has been rejected due to:
- compilation errors
(0057392)
kgv (developer)
2016-09-01 16:19

The branch CR27811 has been pushed into Products git fixing parameters for C#/Java wrapper samples.

Please check compilation of these samples on this branch (full re-testing is not needed).
(0057420)
mkv (tester)
2016-09-02 14:37

Dear BugMaster,
Branch CR27811 was rebased on IR-2016-09-01 of products git-repository.
SHA-1: 601e4fea536a46e76dedb07209765c8eba9405b1
(0057421)
mkv (tester)
2016-09-02 14:37

Dear BugMaster,
Branch CR27811 from products git-repository was recompiled on Linux, MacOS and Windows platforms on Release mode.
SHA-1: 601e4fea536a46e76dedb07209765c8eba9405b1

Compilation error was fixed.
(0057422)
mkv (tester)
2016-09-02 14:37

Dear BugMaster,
Branch CR27811 is TESTED.
(0059570)
git (administrator)
2016-10-28 21:48

Branch CR27811 has been deleted by kgv.

SHA-1: 47dd00f2c8a5e8b50e669cfb173af7c285164997
(0077163)
git (administrator)
2018-06-30 13:35

Branch CR27811_sample has been deleted by inv.

SHA-1: 1f5f160f1c39bbdf61c88dc7fe96d73646c85239

- Related Changesets
occt: master 1ce0716b
Timestamp: 2016-08-31 16:34:32
Author: kgv
Committer: bugmaster
Details ] Diff ]
0027811: Configuration - allow building TKOpenGl with OpenGL ES on Windows

OpenGl_ShaderManager::prepareStdProgramFboBlit() now tries using extension
GL_EXT_frag_depth within OpenGL ES 2.0 when OpenGL ES 3.0 is not available.
OpenGl_View::blitBuffers() now disables Depth test
when copying depth values is not supported by OpenGL ES 2.0 hardware.

Fixed building for UWP with SDK 10.0.10240.0
Fixed building TKService, TKV3d and TKOpenGl for UWP.

OSD_Environment now defines global environment map
for emulating desktop behavior on UWP.
add - adm/cmake/egl.cmake Diff ] File ]
add - adm/cmake/gles2.cmake Diff ] File ]
mod - adm/cmake/occt_csf.cmake Diff ] File ]
mod - adm/cmake/tcl.cmake Diff ] File ]
mod - adm/cmake/tk.cmake Diff ] File ]
mod - adm/cmake/vardescr.cmake Diff ] File ]
mod - adm/genconf.tcl Diff ] File ]
mod - adm/genconfdeps.tcl Diff ] File ]
mod - adm/genproj.tcl Diff ] File ]
mod - adm/templates/custom.build.bat.in Diff ] File ]
mod - adm/templates/custom.install.bat.in Diff ] File ]
mod - adm/templates/env.bat Diff ] File ]
mod - adm/templates/env.bat.in Diff ] File ]
mod - adm/templates/env.sh Diff ] File ]
mod - adm/templates/OpenCASCADEConfig.cmake.in Diff ] File ]
mod - CMakeLists.txt Diff ] File ]
add - src/Aspect/Aspect_NeutralWindow.cxx Diff ] File ]
add - src/Aspect/Aspect_NeutralWindow.hxx Diff ] File ]
mod - src/Aspect/FILES Diff ] File ]
mod - src/Font/Font_FontMgr.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_AVIWriter.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_Context.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Context.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_GlFunctions.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_GraphicDriver.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_GraphicDriver.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_ShaderManager.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_View_Redraw.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Window.cxx Diff ] File ]
mod - src/OSD/OSD_Environment.cxx Diff ] File ]
mod - src/OSD/OSD_signal.cxx Diff ] File ]
mod - src/Standard/Standard_Mutex.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_OpenGlCommands.cxx Diff ] File ]
mod - src/WNT/WNT_WClass.cxx Diff ] File ]
mod - src/WNT/WNT_WClass.hxx Diff ] File ]
mod - src/WNT/WNT_Window.cxx Diff ] File ]
mod - src/WNT/WNT_Window.hxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-08-25 22:21 kgv New Issue
2016-08-25 22:21 kgv Assigned To => kgv
2016-08-25 22:23 git Note Added: 0057081
2016-08-25 22:42 kgv Relationship added related to 0027350
2016-08-25 23:33 kgv Note Added: 0057083
2016-08-25 23:47 kgv Description Updated View Revisions
2016-08-25 23:47 kgv Description Updated View Revisions
2016-08-26 11:45 kgv Note Edited: 0057083 View Revisions
2016-08-26 11:45 kgv Note Edited: 0057083 View Revisions
2016-08-26 14:00 git Note Added: 0057092
2016-08-27 16:20 git Note Added: 0057228
2016-08-28 00:36 git Note Added: 0057230
2016-08-28 00:36 kgv File Added: uwp_occt_viewer.png
2016-08-28 00:37 kgv Note Added: 0057231
2016-08-28 00:37 kgv Assigned To kgv => san
2016-08-28 00:37 kgv Status new => resolved
2016-08-28 01:39 git Note Added: 0057232
2016-08-28 09:24 git Note Added: 0057233
2016-08-28 09:25 kgv Note Edited: 0057231 View Revisions
2016-08-31 17:15 git Note Added: 0057354
2016-08-31 18:02 ski Relationship added parent of 0027827
2016-08-31 19:34 git Note Added: 0057369
2016-08-31 19:36 san Note Added: 0057370
2016-08-31 19:36 san Assigned To san => bugmaster
2016-08-31 19:36 san Status resolved => reviewed
2016-08-31 19:39 mkv Assigned To bugmaster => mkv
2016-08-31 19:54 san Relationship added related to 0027829
2016-09-01 14:10 mkv Note Added: 0057384
2016-09-01 14:11 mkv Note Added: 0057385
2016-09-01 14:11 mkv Assigned To mkv => kgv
2016-09-01 14:11 mkv Status reviewed => assigned
2016-09-01 14:11 mkv Test case number => Not needed
2016-09-01 16:19 kgv Note Added: 0057392
2016-09-01 16:19 kgv Assigned To kgv => bugmaster
2016-09-01 16:19 kgv Status assigned => resolved
2016-09-01 16:19 kgv Status resolved => reviewed
2016-09-01 16:42 mkv Assigned To bugmaster => mkv
2016-09-02 14:37 mkv Note Added: 0057420
2016-09-02 14:37 mkv Note Added: 0057421
2016-09-02 14:37 mkv Note Added: 0057422
2016-09-02 14:37 mkv Assigned To mkv => bugmaster
2016-09-02 14:37 mkv Status reviewed => tested
2016-09-09 09:40 bugmaster Changeset attached => occt master 1ce0716b
2016-09-09 09:40 bugmaster Status tested => verified
2016-09-09 09:40 bugmaster Resolution open => fixed
2016-10-28 21:48 git Note Added: 0059570
2016-11-12 14:21 kgv Relationship added related to 0028095
2016-12-09 16:29 user533 Status verified => closed
2016-12-09 16:40 user533 Fixed in Version => 7.1.0
2018-06-30 13:35 git Note Added: 0077163
2018-06-30 14:08 kgv Relationship added related to 0029918


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker