MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027782Community[OCCT] OCCT:Modeling Algorithmspublic2016-08-16 17:542016-12-09 16:38
Reporterickby 
Assigned Toapn 
PrioritynormalSeveritymajor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027782: Hidden Line Removal algorithm fails to handle filleted edges
DescriptionThe hidden line removal algorithm fails for attached shape to generate the correct projection at multiple views. The attached example shows the problem at the back view (vback), but the same happens for front, right and left. Only top and bottom work. Note that the HLR type "polyalgo" works, only "algo" fails in draw.exe.
Steps To ReproduceSee attached shape and script
 
pload VISUALIZATION
restore hlr.brep
vinit
vdisplay hlr
vback
vfit
vhlrtype algo
vhlr on
TagsNo tags attached.
Test case numberbugs modalg_6 bug27782
Attached Filespng file icon hlr.png (24,586 bytes) 2016-08-16 17:54
? file icon hlr.brep (144,376 bytes) 2016-08-16 17:54
? file icon hlr.tcl (90 bytes) 2016-08-16 17:54

- Relationships

-  Notes
(0056766)
ickby (reporter)
2016-08-16 17:55

The attached picture shows the problem at the top right corner, there a edge is missing.
(0059043)
git (administrator)
2016-10-24 18:33

Branch CR27782 has been created by msv.

SHA-1: 572fd7b32db17178abfa9665661ffd49e7f3280b


Detailed log of new commits:

Author: msv
Date: Mon Oct 24 18:33:30 2016 +0300

    0027782: Hidden Line Removal algorithm fails to handle filleted edges
    
    Create test case for the bug.
(0059044)
msv (developer)
2016-10-24 18:36

The bug is not reproduced in the current master version.
I have create a test case for integration.
(0059181)
git (administrator)
2016-10-26 16:14

Branch CR27782 has been updated by apv.

SHA-1: 660233c2fe3280447b91f0a6e0896be552c25ba0


Detailed log of new commits:

Author: apv
Date: Wed Oct 26 16:13:38 2016 +0300

    Minor correction in test case bugs/modalg_6/bug27782

(0059413)
git (administrator)
2016-10-28 21:37

Branch CR27782 has been deleted by kgv.

SHA-1: 660233c2fe3280447b91f0a6e0896be552c25ba0

- Related Changesets
occt: master dd6b34fd
Timestamp: 2016-10-27 14:24:20
Author: msv
Committer: apn
Details ] Diff ]
0027782: Hidden Line Removal algorithm fails to handle filleted edges

Create test case for the bug.
Minor correction in test case bugs/modalg_6/bug27782
add - tests/bugs/modalg_6/bug27782 Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-08-16 17:54 ickby New Issue
2016-08-16 17:54 ickby Assigned To => msv
2016-08-16 17:54 ickby File Added: hlr.png
2016-08-16 17:54 ickby File Added: hlr.brep
2016-08-16 17:54 ickby File Added: hlr.tcl
2016-08-16 17:55 ickby Note Added: 0056766
2016-10-24 18:33 git Note Added: 0059043
2016-10-24 18:36 msv Note Added: 0059044
2016-10-24 18:36 msv Status new => resolved
2016-10-24 18:36 msv Resolution open => unable to reproduce
2016-10-24 18:36 msv Target Version => 7.1.0
2016-10-24 18:36 msv Assigned To msv => bugmaster
2016-10-24 18:36 msv Status resolved => reviewed
2016-10-24 18:57 apv Assigned To bugmaster => apv
2016-10-26 16:14 git Note Added: 0059181
2016-10-26 16:14 apv Assigned To apv => bugmaster
2016-10-26 16:14 apv Status reviewed => tested
2016-10-26 17:58 apv Test case number => bugs modalg_6 bug27782
2016-10-28 14:35 apn Changeset attached => occt master dd6b34fd
2016-10-28 14:35 apn Assigned To bugmaster => apn
2016-10-28 14:35 apn Status tested => verified
2016-10-28 14:35 apn Resolution unable to reproduce => fixed
2016-10-28 21:37 git Note Added: 0059413
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:38 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker