MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027764Open CASCADE[OCCT] OCCT:Visualizationpublic2016-08-10 22:392016-12-25 20:08
Reporteraba 
Assigned Toapn 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027764: Visualization - add functionality for animation of 3D camera and interactive objects
DescriptionIt is supposed to add possibility to animate view camera and interactive objects.
Steps To Reproducetests/v3d/anim
TagsNo tags attached.
Test case numberv3d anim objects, propeller, rotate, scale, translate
Attached Files

- Relationships
related to 0025382closedkgv Visualization, TKOpenGl - improved video recording capability 
parent of 0028056closedapn Draw Harness, ViewerTest - correct vanimation command to produce stable timestamp on seek 
related to 0027980closedbugmaster Foundation Classes - gp_Trsf computes incorrect transformation between two gp_Ax3 
related to 0028281closedapn Draw Harness - remove unused command vperf 

-  Notes
(0056625)
git (administrator)
2016-08-10 22:43

Branch CR27764 has been created by aba.

SHA-1: 812346571d9146213e3d5eda78d48788207b0296


Detailed log of new commits:

Author: aba
Date: Wed Aug 10 22:43:21 2016 +0300

    0027764: Visualization - add functionality for animation of 3D camera and interactive objects
    
    -Added TKMotion toolkit - it allows to perform animated elements
    -Added vanimation test command and test cases into tests/v3d/motion.
(0056635)
git (administrator)
2016-08-11 11:27

Branch CR27764 has been updated forcibly by aba.

SHA-1: 7d1a6b3a9c5699e30e5c68690bf088f2f7c900cd
(0056669)
git (administrator)
2016-08-11 22:24

Branch CR27764 has been updated forcibly by aba.

SHA-1: 076b4cf61d067208db970c43c8207198a8266f8f
(0056670)
aba (developer)
2016-08-12 10:15

Dear kgv,

could you please review the patch in CR27764?
(0056681)
git (administrator)
2016-08-12 12:18

Branch CR27764 has been updated forcibly by aba.

SHA-1: 8522b50a4ef35577da8ae078b9b9784aef639d62
(0058758)
git (administrator)
2016-10-15 17:09

Branch CR27764 has been updated forcibly by kgv.

SHA-1: cfde4a83d578bfbcbb5dd6c6c62ad22de3940f29
(0058761)
git (administrator)
2016-10-17 01:10

Branch CR27764_1 has been created by kgv.

SHA-1: 6ab2d9a14a1a4feed0dbd973d506555e276d6668


Detailed log of new commits:

Author: aba
Date: Thu Aug 11 11:28:41 2016 +0300

    0027764: Visualization - add functionality for animation of 3D camera and interactive objects
    
    Added class AIS_Animation.
    Added Draw Harness command vanimation.
(0058868)
git (administrator)
2016-10-18 21:21

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: a1794b660170bf630197274602cf0df46e3f5d2c
(0058870)
git (administrator)
2016-10-18 22:27

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: f0e5f1a6d275fdafd48749cf101223eb0fcc24bc
(0058871)
git (administrator)
2016-10-18 23:14

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 027b4b547d4c57dcaee55fb23c472d3579ef1bd7
(0058904)
git (administrator)
2016-10-19 18:08

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 1e3045176c65ebf6daeda37711ab013f4f4ce271
(0058907)
git (administrator)
2016-10-20 00:36

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 1c0d667dabc9fa0bdb1900c5fb065c054fa3e8de
(0058908)
git (administrator)
2016-10-20 00:58

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 7ba696ed2a9711b7daa720da6c6eafec91759a0a
(0058921)
git (administrator)
2016-10-20 15:09

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 2c6d7331fd12f7afa6befc31c5cd35fc3f5a31d2
(0058925)
kgv (developer)
2016-10-20 15:16

Updated patch in branch CR27764_1 is ready for review.
(0058926)
git (administrator)
2016-10-20 15:43

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 0da639f72078c9f344a7441409a1c4ba40f4bec4
(0058930)
git (administrator)
2016-10-20 18:04

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: cd8bca7df8ffc2bda06557638721d2fce8441dc5
(0058937)
git (administrator)
2016-10-20 18:57

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 54787c418f6d2faab6f2dd5d7338aefcfc625bcb
(0058986)
git (administrator)
2016-10-23 17:33

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 1eec0849f04213a83e11ad8a2f51cf04608c39e1
(0058987)
git (administrator)
2016-10-23 17:59

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 553d45f3810cf92849d3acbfbdb17aa05edcb31c
(0058988)
san (developer)
2016-10-23 18:37

Branch CR27764_1 reviewed without remarks, ready for testing.
(0059005)
git (administrator)
2016-10-24 11:54

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 6ab11542b2993c084e2c2cbc29b612d920c85942
(0059058)
mkv (tester)
2016-10-25 11:53

Dear BugMaster,
Branch CR27764_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms on Release mode.
SHA-1: 6ab11542b2993c084e2c2cbc29b612d920c85942

There are following compilation errors:

Linux:
http://jenkins-test-07.nnov.opencascade.com:8080/view/CR27764_1-master/job/CR27764_1-master-OCCT-Debian70-64-opt-compile/3/parsed_console/ [^]
/dn54/builds/CR27764_1-master/Debian70-64-opt/OCCT/src/AIS/AIS_AnimationObject.cxx:76:104: error: cannot convert ‘Graphic3d_ZLayerSettings::IsImmediate’ from type ‘Standard_Boolean (Graphic3d_ZLayerSettings::)()const {aka bool (Graphic3d_ZLayerSettings::)()const}’ to type ‘const Standard_Boolean {aka const bool}’
/dn54/builds/CR27764_1-master/Debian70-64-opt/OCCT/src/AIS/AIS_AnimationObject.cxx:77:8: error: in argument to unary !
make[2]: *** [src/TKV3d/CMakeFiles/TKV3d.dir/__/AIS/AIS_AnimationObject.cxx.o] Error 1

Windows:
http://jenkins-test-07.nnov.opencascade.com:8080/view/CR27764_1-master/job/CR27764_1-master-OCCT-Windows-64-VC10-opt-compile/1/parsed_console/ [^]
27>..\..\..\src\AIS\AIS_AnimationObject.cxx(76): error C3867: 'Graphic3d_ZLayerSettings::IsImmediate': function call missing argument list; use '&Graphic3d_ZLayerSettings::IsImmediate' to create a pointer to member

MacOS:
http://jenkins-test-07.nnov.opencascade.com:8080/view/CR27764_1-master/job/CR27764_1-master-OCCT-MacOS-opt-compile/1/parsed_console/ [^]
/Users/mnt/builds/CR27764_1-master/MacOS-opt/OCCT/src/AIS/AIS_AnimationObject.cxx:76:104: error: reference to non-static member function must be called; did you mean to call it with no arguments?
  const Standard_Boolean isImmediate = myContext->CurrentViewer()->ZLayerSettings (myObject->ZLayer()).IsImmediate;
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~
                                 ()
1 error generated.
(0059059)
mkv (tester)
2016-10-25 11:53

Dear kgv,
Branch CR27764_1 has been rejected due to:
- compilation errors
(0059061)
git (administrator)
2016-10-25 11:58

Branch CR27764_1 has been updated forcibly by kgv.

SHA-1: 4a3a608dc93cda1a20f6d88863ceeaab17eff04e
(0059063)
kgv (developer)
2016-10-25 11:59

The compilation error after rebase should be fixed now.
(0059117)
mkv (tester)
2016-10-25 19:47

Dear BugMaster,
Branch CR27764_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 4a3a608dc93cda1a20f6d88863ceeaab17eff04e

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 63 (63 on master)
Windows: 0 (0 on master)
MacOS : 1145

Regressions/Differences/Improvements:
http://occt-tests/CR27764_1-master-OCCT/Debian70-64/summary.html [^]
http://occt-tests/CR27764_1-master-OCCT/Windows-64-VC10/summary.html [^]
Failed:
  bugs vis bug24623_3, bug25532
  v3d ivtk bgcolor, bug27567, detect, display_mode, erase, select, selection_mode

Testing cases:
http://occt-tests/CR27764_1-master-OCCT/Debian70-64/v3d/anim/objects.html [^]
http://occt-tests/CR27764_1-master-OCCT/Windows-64-VC10/v3d/anim/objects.html [^]
v3d anim objects: OK

http://occt-tests/CR27764_1-master-OCCT/Debian70-64/v3d/anim/propeller.html [^]
http://occt-tests/CR27764_1-master-OCCT/Windows-64-VC10/v3d/anim/propeller.html [^]
v3d anim propeller: OK

http://occt-tests/CR27764_1-master-OCCT/Debian70-64/v3d/anim/rotate.html [^]
http://occt-tests/CR27764_1-master-OCCT/Windows-64-VC10/v3d/anim/rotate.html [^]
v3d anim rotate: OK

http://occt-tests/CR27764_1-master-OCCT/Debian70-64/v3d/anim/scale.html [^]
http://occt-tests/CR27764_1-master-OCCT/Windows-64-VC10/v3d/anim/scale.html [^]
v3d anim scale: OK

http://occt-tests/CR27764_1-master-OCCT/Debian70-64/v3d/anim/translate.html [^]
http://occt-tests/CR27764_1-master-OCCT/Windows-64-VC10/v3d/anim/translate.html [^]
v3d anim translate: OK

Testing on Linux:
occt component :
Total MEMORY difference: 90425141 / 90255347 [+0.19%]
Total CPU difference: 19320.909999999836 / 19222.429999999847 [+0.51%]
products component :
Total MEMORY difference: 30010063 / 30089650 [-0.26%]
Total CPU difference: 5293.329999999975 / 5340.149999999966 [-0.88%]

Testing on Windows:
occt component :
Total MEMORY difference: 57226121 / 57220230 [+0.01%]
Total CPU difference: 18481.20446849853 / 18211.026336598778 [+1.48%]
products component :
Total MEMORY difference: 21310516 / 21272088 [+0.18%]
Total CPU difference: 5353.611117799969 / 5194.536898099958 [+3.06%]

There are following differences in images found by testdiff.
http://occt-tests/CR27764_1-master-OCCT/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR27764_1-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10-image.html [^]
IMAGE v3d glsl msaa: msaa.png differs
IMAGE v3d glsl tiles: tiles.png differs
IMAGE v3d glsl double_precision: double_precision.png differs
(0059118)
mkv (tester)
2016-10-25 19:48

Dear kgv,
Branch CR27764_1 has been rejected due to:
- regressions/differences/improvements
- differences in images
(0059121)
git (administrator)
2016-10-25 20:55

Branch CR27764_1 has been updated by kgv.

SHA-1: 4988271e5b950dd805e2d4a09a86837c2b992dbc


Detailed log of new commits:

Author: kgv
Date: Tue Oct 25 20:55:23 2016 +0300

    v3d/ivtk test group does not call vfit anymore.
    
    Fixed misprint in test cases bugs/vis/bug24623_3 and bug25532.

(0059123)
kgv (developer)
2016-10-25 20:57
edited on: 2016-10-25 20:58

Regressions should be fixed now - test cases have been corrected.

Image difference is OK - redundant Fit All is not called anymore for groups v3d/masterials and v3d/glsl and this is for good
(final screenshots now provide more correct state).

(0059189)
mkv (tester)
2016-10-26 17:16

Dear BugMaster,
fixed test cases are OK.
(0059190)
mkv (tester)
2016-10-26 17:16

Dear BugMaster,
Branch CR27764_1 is TESTED.
(0059411)
git (administrator)
2016-10-28 21:37

Branch CR27764_1 has been deleted by kgv.

SHA-1: 4988271e5b950dd805e2d4a09a86837c2b992dbc
(0059448)
git (administrator)
2016-10-28 21:41

Branch CR27764 has been deleted by kgv.

SHA-1: cfde4a83d578bfbcbb5dd6c6c62ad22de3940f29

- Related Changesets
occt: master 1beb58d7
Timestamp: 2016-10-27 14:20:38
Author: kgv
Committer: apn
Details ] Diff ]
0027764: Visualization - add functionality for animation of 3D camera and interactive objects

Added classes AIS_Animation, AIS_AnimationCamera, AIS_AnimationObjectLocatio.

Draw Harness command vanimation has been modified to manage animation timeline.
Command vfit has been extended with option -noupdate.
Formatting of vviewparams command output has been improved.
Functionality of commands vlocreset, vlocmove, vloctranslate, vlocrotate,
vlocmirror, vlocscale has been merged into vlocation/vsetlocation.
vlocation now can print the current local transformation of the object.

v3d/ivtk test group does not call vfit anymore.

Fixed misprint in test cases bugs/vis/bug24623_3 and bug25532.
add - src/AIS/AIS_Animation.cxx Diff ] File ]
add - src/AIS/AIS_Animation.hxx Diff ] File ]
add - src/AIS/AIS_AnimationCamera.cxx Diff ] File ]
add - src/AIS/AIS_AnimationCamera.hxx Diff ] File ]
add - src/AIS/AIS_AnimationObject.cxx Diff ] File ]
add - src/AIS/AIS_AnimationObject.hxx Diff ] File ]
add - src/AIS/AIS_AnimationTimer.cxx Diff ] File ]
add - src/AIS/AIS_AnimationTimer.hxx Diff ] File ]
mod - src/AIS/AIS_InteractiveContext.cxx Diff ] File ]
mod - src/AIS/FILES Diff ] File ]
mod - src/gp/FILES Diff ] File ]
mod - src/gp/gp_QuaternionNLerp.hxx Diff ] File ]
mod - src/gp/gp_QuaternionSLerp.hxx Diff ] File ]
add - src/gp/gp_TrsfNLerp.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Camera.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Camera.hxx Diff ] File ]
mod - src/NCollection/FILES Diff ] File ]
add - src/NCollection/NCollection_Lerp.hxx Diff ] File ]
mod - src/OSD/OSD_Chronometer.hxx Diff ] File ]
mod - src/OSD/OSD_Timer.cxx Diff ] File ]
mod - src/OSD/OSD_Timer.hxx Diff ] File ]
mod - src/V3d/V3d_View.hxx Diff ] File ]
mod - src/ViewerTest/ViewerTest.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_AutoUpdater.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ObjectCommands.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ViewerCommands.cxx Diff ] File ]
mod - tests/bugs/vis/bug24623_3 Diff ] File ]
mod - tests/bugs/vis/bug25276 Diff ] File ]
mod - tests/bugs/vis/bug25532 Diff ] File ]
mod - tests/bugs/vis/bug26599 Diff ] File ]
add - tests/v3d/anim/objects Diff ] File ]
add - tests/v3d/anim/propeller Diff ] File ]
add - tests/v3d/anim/rotate Diff ] File ]
add - tests/v3d/anim/scale Diff ] File ]
add - tests/v3d/anim/translate Diff ] File ]
mod - tests/v3d/end Diff ] File ]
mod - tests/v3d/grids.list Diff ] File ]
mod - tests/v3d/raytrace/bug26070 Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-08-10 22:39 aba New Issue
2016-08-10 22:39 aba Assigned To => aba
2016-08-10 22:39 aba Status new => assigned
2016-08-10 22:43 git Note Added: 0056625
2016-08-11 08:11 aba Relationship added related to 0025382
2016-08-11 11:27 git Note Added: 0056635
2016-08-11 22:24 git Note Added: 0056669
2016-08-12 10:15 aba Note Added: 0056670
2016-08-12 10:15 aba Assigned To aba => kgv
2016-08-12 10:15 aba Status assigned => resolved
2016-08-12 10:15 aba Steps to Reproduce Updated View Revisions
2016-08-12 12:18 git Note Added: 0056681
2016-10-15 17:09 git Note Added: 0058758
2016-10-17 01:10 git Note Added: 0058761
2016-10-18 21:21 git Note Added: 0058868
2016-10-18 22:27 git Note Added: 0058870
2016-10-18 23:14 git Note Added: 0058871
2016-10-19 18:08 git Note Added: 0058904
2016-10-20 00:36 git Note Added: 0058907
2016-10-20 00:58 git Note Added: 0058908
2016-10-20 15:09 git Note Added: 0058921
2016-10-20 15:16 kgv Note Added: 0058925
2016-10-20 15:16 kgv Assigned To kgv => san
2016-10-20 15:17 kgv Steps to Reproduce Updated View Revisions
2016-10-20 15:43 git Note Added: 0058926
2016-10-20 18:04 git Note Added: 0058930
2016-10-20 18:57 git Note Added: 0058937
2016-10-20 18:58 kgv Relationship added related to 0027980
2016-10-23 17:33 git Note Added: 0058986
2016-10-23 17:59 git Note Added: 0058987
2016-10-23 18:37 san Note Added: 0058988
2016-10-23 18:37 san Assigned To san => bugmaster
2016-10-23 18:37 san Status resolved => reviewed
2016-10-24 11:54 git Note Added: 0059005
2016-10-24 14:44 mkv Assigned To bugmaster => mkv
2016-10-25 11:53 mkv Note Added: 0059058
2016-10-25 11:53 mkv Note Added: 0059059
2016-10-25 11:53 mkv Assigned To mkv => kgv
2016-10-25 11:53 mkv Status reviewed => assigned
2016-10-25 11:58 git Note Added: 0059061
2016-10-25 11:59 kgv Note Added: 0059063
2016-10-25 11:59 kgv Assigned To kgv => bugmaster
2016-10-25 11:59 kgv Status assigned => resolved
2016-10-25 11:59 kgv Status resolved => reviewed
2016-10-25 13:03 mkv Assigned To bugmaster => mkv
2016-10-25 19:47 mkv Note Added: 0059117
2016-10-25 19:48 mkv Note Added: 0059118
2016-10-25 19:48 mkv Assigned To mkv => kgv
2016-10-25 19:48 mkv Status reviewed => assigned
2016-10-25 19:48 mkv Test case number => v3d anim objects, propeller, rotate, scale, translate
2016-10-25 20:55 git Note Added: 0059121
2016-10-25 20:57 kgv Note Added: 0059123
2016-10-25 20:57 kgv Assigned To kgv => bugmaster
2016-10-25 20:57 kgv Status assigned => resolved
2016-10-25 20:57 kgv Status resolved => reviewed
2016-10-25 20:58 kgv Note Edited: 0059123 View Revisions
2016-10-26 11:54 mkv Assigned To bugmaster => mkv
2016-10-26 17:16 mkv Note Added: 0059189
2016-10-26 17:16 mkv Note Added: 0059190
2016-10-26 17:16 mkv Assigned To mkv => bugmaster
2016-10-26 17:16 mkv Status reviewed => tested
2016-10-28 14:35 apn Changeset attached => occt master 1beb58d7
2016-10-28 14:35 apn Assigned To bugmaster => apn
2016-10-28 14:35 apn Status tested => verified
2016-10-28 14:35 apn Resolution open => fixed
2016-10-28 21:37 git Note Added: 0059411
2016-10-28 21:41 git Note Added: 0059448
2016-11-07 14:20 kgv Relationship added parent of 0028056
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0
2016-12-25 20:08 kgv Relationship added related to 0028281


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker