MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027753Community[OCCT] OCCT:Modeling Algorithmspublic2016-08-05 17:262017-09-29 16:25
ReporterMarkus 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0027753: Nearly plane cones should not be created by BRepPrimAPI_MakeRevol
DescriptionIf a curve is rotated using BRepPrimAPI_MakeRevol, different kinds of geometrical objects are created depending on the nature of the curve. If the curve is a line the result can be a Geom_Plane, a Geom_ConicalSurface or a Geom_CylindricalSurface depending on the angle between line and rotation axis. The decision is made in GeomAdaptor_SurfaceOfRevolution::GetType().

There is a certain range (when the angle is nearly Pi/2) which leads to nearly plane cones. According to 0027705, nearly plane cones should be avoided to use because they lead to different problems within OCCT and sometimes also when exported to other CAD systems.

Therefore, it is proposed to modify GeomAdaptor_SurfaceOfRevolution::GetType() to create a Geom_SurfaceOfRevolution instead of such nearly plane cones. The question is, what would be the best threshold angle when to create a Geom_SurfaceOfRevolution instead of a cone.

In our code we use something like [pseudo code]:
  (Math.Abs(Geom_ConicalSurface.SemiAngle() - Math.PI / 2) <= 1e-6)

But this might be possible to improve.

In the probleamtic case of 0027705 the semi angle is 1.5707963236984104. So, it differs from Pi/2 by 3e-9.
In 0027015 the semi angle is 1.5707963. It differs from Pi/2 by 2e-8.
Steps To ReproduceNot required
TagsNo tags attached.
Test case numberNot needed
Attached Fileszip file icon cone.zip (18,701 bytes) 2016-08-05 17:29
png file icon s10 imported in NX10.png (61,138 bytes) 2016-08-08 11:04

- Relationships
related to 0027705assignednbv Community Boolean operation returns empty compound for a shape containing a nearly plane cone 
related to 0027015closedbugmaster Community Sewing returns invalid shape if some faces are nearly plane cones 

-  Notes
(0056539)
Timo (developer)
2016-08-08 11:07

The screenshot "s10 imported in NX10" shows how the face s10.stp, which was created by the script (see steps to reproduce) looks like when imported in Siemens NX10. The other faces look better.
Here, the semi angle is 1,5707963267848966, which differs from Pi/2 by 1e-11.
(0062897)
ifv (developer)
2017-01-23 12:56

Fix is branch CR28261_28266
(0063024)
mkv (tester)
2017-01-25 15:44

Dear BugMaster,
Branch CR28261_28266 is TESTED.

- Issue History
Date Modified Username Field Change
2016-08-05 17:26 Timo New Issue
2016-08-05 17:26 Timo Assigned To => msv
2016-08-05 17:26 Timo Relationship added related to 0027705
2016-08-05 17:28 Timo Steps to Reproduce Updated View Revisions
2016-08-05 17:29 Timo File Added: cone.zip
2016-08-08 10:10 Timo Description Updated View Revisions
2016-08-08 10:10 Timo Steps to Reproduce Updated View Revisions
2016-08-08 10:15 Timo Relationship added related to 0027015
2016-08-08 10:22 Timo Description Updated View Revisions
2016-08-08 11:04 Timo File Added: s10 imported in NX10.png
2016-08-08 11:07 Timo Note Added: 0056539
2016-08-08 12:19 Timo Steps to Reproduce Updated View Revisions
2016-10-17 16:09 san Relationship added related to 0027968
2016-10-28 12:16 msv Target Version 7.1.0 => 7.2.0
2016-12-23 10:10 msv Relationship added related to 0028266
2016-12-23 10:26 msv Assigned To msv => ifv
2016-12-23 10:26 msv Status new => assigned
2016-12-23 10:51 msv Relationship added related to 0028261
2017-01-23 12:56 ifv Note Added: 0062897
2017-01-23 12:56 ifv Assigned To ifv => msv
2017-01-23 12:56 ifv Status assigned => resolved
2017-01-23 12:56 ifv Steps to Reproduce Updated View Revisions
2017-01-23 18:21 msv Note Added: 0062919
2017-01-23 18:21 msv Assigned To msv => ifv
2017-01-23 18:21 msv Status resolved => assigned
2017-01-23 18:22 msv Note Deleted: 0062919
2017-01-23 18:22 msv Assigned To ifv => msv
2017-01-23 18:22 msv Status assigned => resolved
2017-01-25 15:44 mkv Note Added: 0063024
2017-01-25 15:44 mkv Assigned To msv => bugmaster
2017-01-25 15:44 mkv Status resolved => reviewed
2017-01-25 15:44 mkv Test case number => Not needed
2017-01-25 15:44 mkv Status reviewed => tested
2017-01-27 16:18 apn Status tested => verified
2017-01-27 16:18 apn Resolution open => fixed
2017-05-31 15:34 Timo Reporter Timo => Markus
2017-09-29 16:18 user533 Fixed in Version => 7.2.0
2017-09-29 16:25 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker