MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027750Open CASCADE[OCCT] OCCT:Visualizationpublic2016-08-03 17:202016-12-09 16:40
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027750: Visualization, V3d_View - remove unused functionality ZClipping and ZCueing
DescriptionV3d_View API defines the special kind of Z Clipping Plane (methods V3d_View::SetZClippingType(), ::SetZClippingDepth(), ::SetZClippingWidth()) and ZCueing functionality (::SetZCueingDepth(), ::SetZCueingWidth(), ::SetZCueingOn(), ::SetZCueingOff()).

This is quite awkward functionality and it seems to be not used by any modern OCCT-based application (and not maintained by OCCT developers). It is suggested to remove it to simplify implementation.
Additional information
and documentation updates
Applications using removed methods V3d_View::SetZClippingType(), ::SetZClippingDepth(), ::SetZClippingWidth(), ::ZClipping() should define Clipping Plane using general mechanism (e.g. V3d_View::AddClipPlane()) and update it position on camera movements.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0027748newkgv Visualization - clipping and capping improvements 

-  Notes
(0056448)
git (administrator)
2016-08-03 22:08

Branch CR27750 has been created by kgv.

SHA-1: d793737b14889cfd1fa03052e2cdc296e73e57aa


Detailed log of new commits:

Author: kgv
Date: Wed Aug 3 22:08:01 2016 +0300

    0027750: Visualization, V3d_View - remove unused functionality ZClipping and ZCueing
    
    Methods V3d_View::SetZClippingType(), ::SetZClippingDepth(), ::SetZClippingWidth(),
    ::SetZCueingDepth(), ::SetZCueingWidth(), ::SetZCueingOn(), ::SetZCueingOff()
    have been removed.

Author: kgv
Date: Wed Aug 3 15:39:07 2016 +0300

    0027735: Visualization, OpenGl_ShaderManager - fix clipping state management
    
    OpenGl_CappingAlgo::RenderCapping() now updates clipping state in Shader Manager.
    OpenGl_View::render() clipping state setup has been moved to OpenGl_View::renderScene().
    
    OpenGl_ShaderManager now converts position to homogeneous coordinates within clipping code GLSL.
    This fixes capping plane rendering with clipping planes applied.
(0056449)
kgv (developer)
2016-08-03 22:12

Patch is ready for review.
(0056452)
git (administrator)
2016-08-04 09:49

Branch CR27750 has been updated forcibly by kgv.

SHA-1: 0dd2a7dda65e17974223f73a7fda7c115e7f9f71
(0056462)
git (administrator)
2016-08-04 12:52

Branch CR27750 has been updated forcibly by kgv.

SHA-1: 925ecd98f6ee4ca27b2fbd2d5a77f9acc0a41297
(0056471)
git (administrator)
2016-08-04 15:58

Branch CR27750 has been updated forcibly by kgv.

SHA-1: e34367e0efa58a8891378147aa7e61ac2f32aafb
(0056472)
san (developer)
2016-08-04 16:05

Branch CR27750 reviewed without remarks, ready for testing.
(0056487)
git (administrator)
2016-08-04 20:29

Branch CR27750 has been updated forcibly by kgv.

SHA-1: 8ed82777606dafdeecf98dfb11a9105899db5878
(0056512)
git (administrator)
2016-08-05 21:08

Branch CR27750 has been updated forcibly by kgv.

SHA-1: 588c5fd36d88651525ced2957e0096bb1383beed
(0056589)
apv (tester)
2016-08-09 12:51
edited on: 2016-08-09 12:51

Dear BugMaster,

Branch CR27750 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 588c5fd36d88651525ced2957e0096bb1383beed

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1134

Compilation errors have been detected during building
C# Products sample on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27750-master/job/CR27750-master-Products-Windows-64-VC10-csharp-samples/1/parsed_console/ [^]
Java Products sample on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27750-master/job/CR27750-master-Products-Windows-64-VC10-java-samples/1/parsed_console/ [^]

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 89427152 / 88481883 [+1.07%]
Total CPU difference: 19514.909999999985 / 19248.74000000006 [+1.38%]

Testing on Windows:
Total MEMORY difference: 57131568 / 57170140 [-0.07%]
Total CPU difference: 17947.743448898782 / 18044.604469798804 [-0.54%]

(0056590)
apv (tester)
2016-08-09 12:52

Dear Kirill,

Branch CR27750 has been rejected due to:
- compilation errors
(0056591)
kgv (developer)
2016-08-09 13:39

> Compilation errors have been detected during building
> C# Products sample on Windows
Could you please confirm that you have used CR27750 in Products git?
(0056613)
kgv (developer)
2016-08-10 12:14

(just a note - CR27750 in Products is not rebased onto current master)
(0056615)
git (administrator)
2016-08-10 12:50

Branch CR27750 has been updated forcibly by apv.

SHA-1: 322761fa1cc82591a05303fd72fc880384274fa0
(0056616)
apv (tester)
2016-08-10 12:54

Branches CR27750 from occt and products repositories have been rebased on the current masters.
(0056628)
apv (tester)
2016-08-11 09:15

ear BugMaster,

Branch CR27750 from occt git-repository (and CR27750 from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 322761fa1cc82591a05303fd72fc880384274fa0
SHA-1: 90d294448aed881d9388a41471bce320ab19824b

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1159

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
occt component:
Total MEMORY difference: 88745179 / 88446843 [+0.34%]
Total CPU difference: 19372.499999999964 / 19248.74000000006 [+0.64%]
products components:
Total MEMORY difference: 30063877 / 30023278 [+0.14%]
Total CPU difference: 5093.50999999998 / 5098.489999999977 [-0.10%]

Testing on Windows:
occt component:
Total MEMORY difference: 57132783 / 57170140 [-0.07%]
Total CPU difference: 18057.724153898776 / 18044.604469798804 [+0.07%]
products component:
Total MEMORY difference: 21269893 / 21236271 [+0.16%]
Total CPU difference: 4824.986129199943 / 4792.459920699942 [+0.68%]
(0057148)
git (administrator)
2016-08-26 16:23

Branch CR27750 has been deleted by inv.

SHA-1: 322761fa1cc82591a05303fd72fc880384274fa0

- Related Changesets
occt: master 89a929ea
Timestamp: 2016-08-03 19:08:01
Author: kgv
Committer: bugmaster
Details ] Diff ]
0027750: Visualization, V3d_View - remove unused functionality ZClipping and ZCueing

Methods V3d_View::SetZClippingType(), ::SetZClippingDepth(), ::SetZClippingWidth(),
::SetZCueingDepth(), ::SetZCueingWidth(), ::SetZCueingOn(), ::SetZCueingOff()
have been removed.
mod - dox/dev_guides/upgrade/upgrade.md Diff ] File ]
mod - dox/user_guides/modeling_algos/modeling_algos.md Diff ] File ]
mod - dox/user_guides/visualization/visualization.md Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc10/Viewer3d.vcxproj Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc10/Viewer3d.vcxproj.filters Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc11/Viewer3d.vcxproj Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc11/Viewer3d.vcxproj.filters Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc12/Viewer3d.vcxproj Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc12/Viewer3d.vcxproj.filters Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc14/Viewer3d.vcxproj Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc14/Viewer3d.vcxproj.filters Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/CMakeLists.txt Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/res/resource.h Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/res/Toolbar.bmp Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/res/Viewer3d.rc Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/src/Viewer3dView.cpp Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/src/Viewer3dView.h Diff ] File ]
rm - samples/mfc/standard/04_Viewer3d/src/ZClippingDlg.cpp Diff ] File ]
rm - samples/mfc/standard/04_Viewer3d/src/ZClippingDlg.h Diff ] File ]
rm - samples/mfc/standard/04_Viewer3d/src/ZCueingDlg.cpp Diff ] File ]
rm - samples/mfc/standard/04_Viewer3d/src/ZCueingDlg.h Diff ] File ]
mod - samples/mfc/standard/Common/OCC_2dView.cpp Diff ] File ]
mod - src/Graphic3d/Graphic3d_CView.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_CView.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_Clipping.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Clipping.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_GraphicDriver.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_ShaderManager.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_ShaderProgram.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_ShaderProgram.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_View.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_View.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_View_Redraw.cxx Diff ] File ]
mod - src/Shaders/Declarations.glsl Diff ] File ]
mod - src/Shaders/PhongShading.fs Diff ] File ]
mod - src/V3d/FILES Diff ] File ]
rm - src/V3d/V3d_TypeOfZclipping.hxx Diff ] File ]
mod - src/V3d/V3d_View.cxx Diff ] File ]
mod - src/V3d/V3d_View.hxx Diff ] File ]
rm - src/V3d/V3d_View_1.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ViewerCommands.cxx Diff ] File ]
rm - tests/bugs/vis/bug270_1 Diff ] File ]
rm - tests/bugs/vis/bug270_2 Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-08-03 17:20 kgv New Issue
2016-08-03 17:20 kgv Assigned To => kgv
2016-08-03 17:21 kgv Relationship added related to 0027748
2016-08-03 20:25 kgv Summary Visualization - remove unused clipping API V3d_View::SetZClippingType() => Visualization, V3d_View - remove unused functionality ZClipping and ZCueing
2016-08-03 20:25 kgv Description Updated View Revisions
2016-08-03 20:25 kgv Additional Information Updated View Revisions
2016-08-03 22:08 git Note Added: 0056448
2016-08-03 22:12 kgv Note Added: 0056449
2016-08-03 22:12 kgv Assigned To kgv => san
2016-08-03 22:12 kgv Status new => resolved
2016-08-04 09:49 git Note Added: 0056452
2016-08-04 12:52 git Note Added: 0056462
2016-08-04 15:58 git Note Added: 0056471
2016-08-04 16:05 san Note Added: 0056472
2016-08-04 16:05 san Assigned To san => bugmaster
2016-08-04 16:05 san Status resolved => reviewed
2016-08-04 20:29 git Note Added: 0056487
2016-08-05 15:59 apv Assigned To bugmaster => apv
2016-08-05 16:01 apv Test case number => Not needed
2016-08-05 21:08 git Note Added: 0056512
2016-08-09 12:51 apv Note Added: 0056589
2016-08-09 12:51 apv Assigned To apv => kgv
2016-08-09 12:51 apv Status reviewed => assigned
2016-08-09 12:51 apv Note Edited: 0056589 View Revisions
2016-08-09 12:52 apv Note Added: 0056590
2016-08-09 13:39 kgv Note Added: 0056591
2016-08-09 13:39 kgv Assigned To kgv => bugmaster
2016-08-09 13:39 kgv Status assigned => feedback
2016-08-09 17:13 apv Assigned To bugmaster => apv
2016-08-10 12:14 kgv Note Added: 0056613
2016-08-10 12:50 git Note Added: 0056615
2016-08-10 12:54 apv Note Added: 0056616
2016-08-11 09:15 apv Note Added: 0056628
2016-08-11 09:15 apv Assigned To apv => bugmaster
2016-08-11 09:15 apv Status feedback => tested
2016-08-12 10:48 bugmaster Changeset attached => occt master 89a929ea
2016-08-12 10:48 bugmaster Status tested => verified
2016-08-12 10:48 bugmaster Resolution open => fixed
2016-08-26 16:23 git Note Added: 0057148
2016-12-09 16:29 user533 Status verified => closed
2016-12-09 16:40 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker