MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027716Community[OCCT] OCCT:Visualizationpublic2016-07-27 14:452018-03-13 16:14
ReporterRoman Lygin 
Assigned Tobugmaster 
PrioritylowSeverityminor 
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0027716: Visualization - incorrect treatment of multiple transparent objects in 3D view
DescriptionWhen several objects in 3D view have transparency set then display results gets weird - see screenshot.
At the same time, when only one object has transparency then everything seems to be in order.

My guess is that this may have something to do with simple setting display priority to maximum (ten) in AIS_Shape::SetTransparency(). That is, when multiple objects have the same priority the result is getting incrrect.
Steps To Reproduce
pload MODELING VISUALIZATION
box b 100 200 300
box bb 50 10 20 100 150 200
bop b bb
bopcut r
vclear
vinit View1
vsetgradientbg 180 200 255 180 180 180 2
vsetdispmode 1
vdisplay r bb
vsetcolor r RED
vsettransparency r 0.75
vsettransparency bb 0.5 
vaxo
vfit
vrotate 0 5 0
vfit


Original test case:
box b 100 200 300
box bb 50 10 20 100 150 200
bop b bb
bopcut r
vinit
vdisplay r bb
vsetcolor r RED
vsettranspar r 0.75 #OK
vsettranspar bb 0.5 #result gets weird
TagsNo tags attached.
Test case numberNot required
Attached Filespng file icon screenshot_draw.png (30,971 bytes) 2016-07-27 14:45
png file icon transparency_raster.png (5,122 bytes) 2016-07-27 15:41
png file icon transparency_raytrace.png (4,775 bytes) 2016-07-27 15:42

- Relationships
duplicate of 0027925closedbugmaster Open CASCADE Visualization - implement order-independent transparency algorithm within rasterization rendering 
has duplicate 0028155closedbugmaster Community Visual artefacts when setting transparency 
has duplicate 0028253closedbugmaster Community Incorrect treatment of transparency if a spline face overlaps itself in 3D view 

-  Notes
(0056245)
kgv (developer)
2016-07-27 15:41
edited on: 2016-07-27 15:42

Dear Roman,

this behavior is a known limitation of current implementation of transparent object in OCCT viewer.
In contrast to traditional rasterization pipeline, Ray-Tracing in OCCT viewer supports proper order-independent transparency.
Alternatively, application might sort transparent objects themselves to workaround artifacts in most obvious cases.

There are many various rendering techniques intended to solve this problem (to some degree) for rasterization approach.
You are welcome to our support services if you would like us implementing some of them in OCCT.

(0056247)
Roman Lygin (developer)
2016-07-27 16:04

Dear Kirill,

Thank you for the explanation. We will take that into account.
(0069566)
apv (tester)
2017-08-18 12:11

Problem described in issue is reproduced on current state of OCCT.
(0074433)
kgv (developer)
2018-03-13 14:40

Please close issue as duplicate of 0027925.

- Issue History
Date Modified Username Field Change
2016-07-27 14:45 Roman Lygin New Issue
2016-07-27 14:45 Roman Lygin Assigned To => kgv
2016-07-27 14:45 Roman Lygin File Added: screenshot_draw.png
2016-07-27 15:41 kgv Note Added: 0056245
2016-07-27 15:41 kgv Priority normal => low
2016-07-27 15:41 kgv Resolution open => no change required
2016-07-27 15:41 kgv Target Version 7.1.0 => Unscheduled
2016-07-27 15:41 kgv Summary Incorrect treatment of multiple transparent objects in 3D view => Visualization - incorrect treatment of multiple transparent objects in 3D view
2016-07-27 15:41 kgv Steps to Reproduce Updated View Revisions
2016-07-27 15:41 kgv File Added: transparency_raster.png
2016-07-27 15:42 kgv File Added: transparency_raytrace.png
2016-07-27 15:42 kgv Note Edited: 0056245 View Revisions
2016-07-27 15:42 kgv Note Edited: 0056245 View Revisions
2016-07-27 16:04 Roman Lygin Note Added: 0056247
2016-07-29 12:29 kgv Relationship added related to 0027725
2016-10-03 14:08 kgv Relationship added related to 0027925
2016-11-25 16:56 kgv Relationship added has duplicate 0028155
2016-12-20 16:32 kgv Relationship added has duplicate 0028253
2017-08-18 12:11 apv Test case number => bugs vis bug27716
2017-08-18 12:11 apv Note Added: 0069566
2017-08-18 13:11 apv Test case number bugs vis bug27716 => Not required
2018-03-13 14:40 kgv Note Added: 0074433
2018-03-13 14:40 kgv Assigned To kgv => bugmaster
2018-03-13 14:40 kgv Status new => feedback
2018-03-13 14:40 kgv Resolution no change required => duplicate
2018-03-13 14:40 kgv Fixed in Version => 7.2.0
2018-03-13 14:40 kgv Target Version Unscheduled => 7.2.0
2018-03-13 14:41 kgv Relationship replaced duplicate of 0027925
2018-03-13 16:14 bugmaster Status feedback => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker