MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027684Open CASCADE[OCCT] OCCT:Codingpublic2016-07-16 14:362016-12-09 16:40
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027684: Coding rules - drop unused declarations from Graphic3d
DescriptionGraphic3d package contains the following declarations that can be removed:
Graphic3d_TypeOfPolygon
Graphic3d_TypeOfPrimitive
Graphic3d_Array1OfVector.hxx
Graphic3d_Array1OfVertex.hxx
Graphic3d_Array2OfVertex.hxx
Graphic3d_CStructurePtr.hxx
Graphic3d_CycleError.hxx
Graphic3d_DataStructure.pxx
Graphic3d_HSequenceOfStructure.hxx
Graphic3d_InitialisationError.hxx
Graphic3d_ListIteratorOfListOfShortReal.hxx
Graphic3d_ListOfShortReal.hxx
Graphic3d_NListOfHAsciiString.hxx
Graphic3d_CBitFields8.hxx
Graphic3d_CBitFields16.hxx
Graphic3d_CBitFields20.hxx

Graphic3d_CBitFields4.hxx
Graphic3d_StructureManagerPtr.hxx
Graphic3d_StructurePtr.hxx


Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0055978)
git (administrator)
2016-07-16 15:58

Branch CR27684 has been created by kgv.

SHA-1: d3caf66f12ef99729a83f0f71d5ad0a69b6d4f8d


Detailed log of new commits:

Author: kgv
Date: Sat Jul 16 15:57:23 2016 +0300

    0027684: Coding rules - drop unused declarations from Graphic3d
    
    The following headers have been removed:
    - Graphic3d_TypeOfPolygon
    - Graphic3d_TypeOfPrimitive
    - Graphic3d_Array1OfVector.hxx
    - Graphic3d_Array1OfVertex.hxx
    - Graphic3d_Array2OfVertex.hxx
    - Graphic3d_CBitFields4.hxx
    - Graphic3d_CBitFields8.hxx
    - Graphic3d_CBitFields16.hxx
    - Graphic3d_CBitFields20.hxx
    - Graphic3d_CStructurePtr.hxx
    - Graphic3d_CycleError.hxx
    - Graphic3d_DataStructure.pxx
    - Graphic3d_HSequenceOfStructure.hxx
    - Graphic3d_InitialisationError.hxx
    - Graphic3d_ListIteratorOfListOfShortReal.hxx
    - Graphic3d_ListOfShortReal.hxx
    - Graphic3d_NListOfHAsciiString.hxx
    - Graphic3d_StructureManagerPtr.hxx
    - Graphic3d_StructurePtr.hxx
    
    Graphic3d_StructureManager - remove default aspects, which have been never used.
(0055979)
kgv (developer)
2016-07-16 15:58

Please check compilation, regression testing is not needed.
(0056026)
apv (tester)
2016-07-19 14:06
edited on: 2016-07-19 14:08

Dear BugMaster,

Branch CR27684 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms.
SHA-1: d3caf66f12ef99729a83f0f71d5ad0a69b6d4f8d

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1126

Compilation errors have been detected during building of
Qt-based Products samples on Linux:
http://jenkins-test-05.nnov.opencascade.com/view/CR27684-master/job/CR27684-master-Products-Debian70-64-qt-samples-linux/1/parsed_console/ [^]
MFC-based OCCT samples on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27684-master/job/CR27684-master-OCCT-Windows-64-VC10-mfc-samples/2/parsed_console/ [^]
C# Products sample on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27684-master/job/CR27684-master-Products-Windows-64-VC10-csharp-samples/1/parsed_console/ [^]
Java Products sample on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27684-master/job/CR27684-master-Products-Windows-64-VC10-java-samples/1/parsed_console/ [^]
MFC-based Products samples on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27684-master/job/CR27684-master-Products-Windows-64-VC10-mfc-samples/1/parsed_console/ [^]
Qt-based Products samples on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27684-master/job/CR27684-master-Products-Windows-64-VC10-qt-samples-windows/1/parsed_console/ [^]

(0056027)
apv (tester)
2016-07-19 14:09

Dear Kirill,

Branch CR26684 has been rejected due to:
- compilation errors
(0056031)
git (administrator)
2016-07-19 14:59

Branch CR27684 has been updated by kgv.

SHA-1: ad53ce898ab69c8a1f3432d67263a106fc5d7d07


Detailed log of new commits:

Author: kgv
Date: Tue Jul 19 15:00:16 2016 +0300

    do not include non-existing header Graphic3d_Array1OfVertex.hxx from MFC sample

(0056033)
kgv (developer)
2016-07-19 15:02

Please check OCCT/Products samples on updated branch CR27684 (occt and products); occt itself was not modified.
(0056050)
apv (tester)
2016-07-20 13:37

Dear BugMaster,

Branch CR27684 from occt git-repository (and CR27684 from products git-repository) was compiled on Linux, MacOS and Windows platforms.
SHA-1: ad53ce898ab69c8a1f3432d67263a106fc5d7d07
SHA-1: ab4324c18ed67f6c114a367824bf30008fbc1bcf

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1118

Compilation errors have been detected during building of
C# Products sample on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27684-CR27684/job/CR27684-CR27684-Products-Windows-64-VC10-csharp-samples/2/parsed_console/ [^]
Java Products sample on Windows:
http://jenkins-test-05.nnov.opencascade.com/view/CR27684-CR27684/job/CR27684-CR27684-Products-Windows-64-VC10-java-samples/2/parsed_console/ [^]
(0056051)
apv (tester)
2016-07-20 13:38
edited on: 2016-07-20 13:39

Dear Kirill,

Branches CR27684 from occt git-repository and CR27684 from products git-repository have been rejected due to:
- compilation errors

(0056052)
git (administrator)
2016-07-20 13:57

Branch CR27684 has been updated by kgv.

SHA-1: 6f228083fefce00f9df03099890bf37638a41530


Detailed log of new commits:

Author: kgv
Date: Wed Jul 20 13:58:27 2016 +0300

    Graphic3d_Group::MinMaxValues() - add missing Standard_EXPORT

(0056053)
kgv (developer)
2016-07-20 13:58

Updated patch should fix the issue - please check compilation.
(0056066)
apv (tester)
2016-07-21 08:51

Dear BugMaster,

Branch CR27684 from occt git-repository (and CR27684 from products git-repository) was compiled on Linux, MacOS and Windows platforms.
SHA-1: 6f228083fefce00f9df03099890bf37638a41530
SHA-1: ab4324c18ed67f6c114a367824bf30008fbc1bcf

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1152
(0056096)
git (administrator)
2016-07-22 10:43

Branch CR27684 has been deleted by inv.

SHA-1: 6f228083fefce00f9df03099890bf37638a41530

- Related Changesets
occt: master 59ec40f8
Timestamp: 2016-07-16 12:57:23
Author: kgv
Committer: bugmaster
Details ] Diff ]
0027684: Coding rules - drop unused declarations from Graphic3d

The following headers have been removed:
- Graphic3d_TypeOfPolygon
- Graphic3d_TypeOfPrimitive
- Graphic3d_Array1OfVector.hxx
- Graphic3d_Array1OfVertex.hxx
- Graphic3d_Array2OfVertex.hxx
- Graphic3d_CBitFields4.hxx
- Graphic3d_CBitFields8.hxx
- Graphic3d_CBitFields16.hxx
- Graphic3d_CBitFields20.hxx
- Graphic3d_CStructurePtr.hxx
- Graphic3d_CycleError.hxx
- Graphic3d_DataStructure.pxx
- Graphic3d_HSequenceOfStructure.hxx
- Graphic3d_InitialisationError.hxx
- Graphic3d_ListIteratorOfListOfShortReal.hxx
- Graphic3d_ListOfShortReal.hxx
- Graphic3d_NListOfHAsciiString.hxx
- Graphic3d_StructureManagerPtr.hxx
- Graphic3d_StructurePtr.hxx

Graphic3d_StructureManager - remove default aspects, which have been never used.

do not include non-existing header Graphic3d_Array1OfVertex.hxx from MFC sample

Graphic3d_Group::MinMaxValues() - add missing Standard_EXPORT
mod - samples/mfc/standard/01_Geometry/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/Common/Primitive/Sample2D_Markers.h Diff ] File ]
mod - samples/mfc/standard/Common/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/Common/User_Cylinder.cxx Diff ] File ]
mod - src/Graphic3d/FILES Diff ] File ]
rm - src/Graphic3d/Graphic3d_Array1OfVector.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_Array1OfVertex.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_Array2OfVertex.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_ArrayOfPrimitives.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_ArrayOfPrimitives.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_CBitFields16.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_CBitFields20.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_CBitFields4.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_CBitFields8.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_CStructurePtr.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_CView.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_CycleError.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_DataStructure.pxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Group.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Group.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_HSequenceOfStructure.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_InitialisationError.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_ListIteratorOfListOfShortReal.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_ListOfShortReal.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_NListOfHAsciiString.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Structure.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_StructureManager.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_StructureManager.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_StructureManagerPtr.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_StructurePtr.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_TypeOfPolygon.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_TypeOfPrimitive.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_AVIWriter.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_FrameBuffer.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_GraphicDriver.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_LayerList.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Window.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Window_1.mm Diff ] File ]
mod - src/OpenGl/OpenGl_Workspace.cxx Diff ] File ]
mod - src/V3d/V3d_CircularGrid.cxx Diff ] File ]
mod - src/WNT/WNT_WClass.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-07-16 14:36 kgv New Issue
2016-07-16 14:36 kgv Assigned To => kgv
2016-07-16 15:58 git Note Added: 0055978
2016-07-16 15:58 kgv Note Added: 0055979
2016-07-16 15:58 kgv Assigned To kgv => bugmaster
2016-07-16 15:58 kgv Status new => resolved
2016-07-16 15:58 kgv Status resolved => reviewed
2016-07-18 17:30 apv Assigned To bugmaster => apv
2016-07-19 14:06 apv Note Added: 0056026
2016-07-19 14:06 apv Assigned To apv => kgv
2016-07-19 14:06 apv Status reviewed => assigned
2016-07-19 14:08 apv Note Edited: 0056026 View Revisions
2016-07-19 14:09 apv Note Added: 0056027
2016-07-19 14:59 git Note Added: 0056031
2016-07-19 15:02 kgv Note Added: 0056033
2016-07-19 15:02 kgv Assigned To kgv => bugmaster
2016-07-19 15:02 kgv Status assigned => resolved
2016-07-19 15:02 kgv Status resolved => reviewed
2016-07-19 16:37 apv Assigned To bugmaster => apv
2016-07-20 13:37 apv Note Added: 0056050
2016-07-20 13:37 apv Assigned To apv => kgv
2016-07-20 13:37 apv Status reviewed => assigned
2016-07-20 13:38 apv Note Added: 0056051
2016-07-20 13:39 apv Note Edited: 0056051 View Revisions
2016-07-20 13:57 git Note Added: 0056052
2016-07-20 13:58 kgv Note Added: 0056053
2016-07-20 13:58 kgv Assigned To kgv => bugmaster
2016-07-20 13:58 kgv Status assigned => resolved
2016-07-20 13:58 kgv Status resolved => reviewed
2016-07-20 17:35 apv Assigned To bugmaster => apv
2016-07-21 08:51 apv Note Added: 0056066
2016-07-21 08:51 apv Assigned To apv => bugmaster
2016-07-21 08:51 apv Status reviewed => tested
2016-07-21 08:51 apv Test case number => Not needed
2016-07-22 10:23 bugmaster Changeset attached => occt master 59ec40f8
2016-07-22 10:23 bugmaster Status tested => verified
2016-07-22 10:23 bugmaster Resolution open => fixed
2016-07-22 10:43 git Note Added: 0056096
2016-12-09 16:29 user533 Status verified => closed
2016-12-09 16:40 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker