MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027639Open CASCADE[OCCT] OCCT:Configurationpublic2016-06-24 16:562016-12-09 16:38
Reporterrnv 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027639: Add possibility to build OCCT 7X without TCL/TK
DescriptionThis bug came from SALOME project.

It is possible to build OCCT 6X without TCL/TK third-party products using automake build system (--without-tk and --without-tcl options).
But it is impossible to build OCCT-7.0.0 without TCL/TK using CMake. It is necessary to add such option(s) to the CMake build system.
Steps To Reproduce• exclude DRAW module from building
• build and install occt
Result: files draw.sh/bat were not created in install and binary folders
Additional information
and documentation updates
Note: Target version for this issue is 7.1.0, but firstly we need a patch for OCCT-7.0.0, because it is very important for the customer.
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0055470)
vsr (developer)
2016-06-24 18:17

Sorry, colleagues, this was just a misunderstanding.

In fact, it is possible to build OCCT 7.0 without tcl/tk features; it is just necessary to use -DBUILD_MODULE_Draw=OFF option.

Sorry for disturbing.

The only remaining point that might need a minor correction is that even with this option the resulting "bin" directory contains draw.sh script which is redundant since there is no DRAWEXE executable there.

It is OK to thus close this issue (please decide if it's necessary to fix the bug with draw.sh script).
(0055471)
abv (manager)
2016-06-24 18:23

Sergey, please fix the issue with installing draw.sh
(0055494)
git (administrator)
2016-06-27 14:53

Branch CR27639 has been created by ski.

SHA-1: 0b0172ce4f2cd20c901addbed460b7f05640783f


Detailed log of new commits:

Author: ski
Date: Mon Jun 27 14:53:53 2016 +0300

    0027639: Add possibility to build OCCT 7X without TCL/TK
    
    draw.bat/sh files will not be generated/installed to binary/install directories if DRAWEXE toolkit is excluded from build.
(0055495)
ski (developer)
2016-06-27 14:57

Dear ibs,

please review occt branch CR27639.

generating and installation of draw.sh/bat files were excluded if DRAWEXE toolkit will not be built.
(0055546)
ibs (developer)
2016-06-28 16:50

dear bugmaster,
there are no remarks
(0055684)
git (administrator)
2016-07-05 11:26

Branch CR27639 has been updated forcibly by inv.

SHA-1: 3eabbe1b4e2c8805eb24fcac0c422f42274aea8b
(0056122)
git (administrator)
2016-07-22 10:44

Branch CR27639 has been deleted by inv.

SHA-1: 3eabbe1b4e2c8805eb24fcac0c422f42274aea8b

- Related Changesets
occt: master 3eabbe1b
Timestamp: 2016-06-27 11:53:53
Author: ski
Committer: bugmaster
Details ] Diff ]
0027639: Add possibility to build OCCT 7X without TCL/TK

draw.bat/sh files will not be generated/installed to binary/install directories if DRAWEXE toolkit is excluded from build.
mod - CMakeLists.txt Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-06-24 16:56 rnv New Issue
2016-06-24 16:56 rnv Assigned To => bugmaster
2016-06-24 17:03 rnv Summary Add posibility to build OCCT 7X without TCL/TK => Add possibility to build OCCT 7X without TCL/TK
2016-06-24 18:17 vsr Note Added: 0055470
2016-06-24 18:17 vsr Assigned To bugmaster => abv
2016-06-24 18:17 vsr Status new => feedback
2016-06-24 18:23 abv Note Added: 0055471
2016-06-24 18:23 abv Assigned To abv => ski
2016-06-24 18:23 abv Status feedback => assigned
2016-06-27 14:53 git Note Added: 0055494
2016-06-27 14:57 ski Note Added: 0055495
2016-06-27 14:57 ski Assigned To ski => ibs
2016-06-27 14:57 ski Status assigned => resolved
2016-06-27 14:57 ski Steps to Reproduce Updated View Revisions
2016-06-28 16:50 ibs Note Added: 0055546
2016-06-28 16:50 ibs Assigned To ibs => bugmaster
2016-06-28 16:50 ibs Status resolved => reviewed
2016-07-05 11:26 git Note Added: 0055684
2016-07-06 16:14 bugmaster Status reviewed => tested
2016-07-08 11:57 bugmaster Changeset attached => occt master 3eabbe1b
2016-07-08 11:57 bugmaster Status tested => verified
2016-07-08 11:57 bugmaster Resolution open => fixed
2016-07-22 10:44 git Note Added: 0056122
2016-12-09 16:31 user533 Status verified => closed
2016-12-09 16:38 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker