MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027527Community[OCCT] OCCT:Visualizationpublic2016-05-20 17:212017-09-29 16:24
ReporterVico Liang 
Assigned Tobugmaster 
PrioritylowSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version[OCCT] 6.3.1 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0027527: Visualization - can't highlight polyline presentation of Wire after setting transparency
DescriptionIt's can be reproduced with AIS_Shape which has wireframe presentation. User has to set the transparency and then select the object by AIS_InteractiveContext::MoveTo command. Though the object is selected under mouse, it won't be highlighted.
Steps To Reproduce
pload MODELING VISUALIZATION
box b 1 2 3
explode b W
vclear
vinit View1
vdisplay -dispmode 1 b_1
vfit
vsettransparency b_1 0.8
vmoveto 118 102
# OK on current master - dynamic highlighting works
vselect 118 102
# KO on current master - selected object is not highlighted


1. Make AIS_InteractiveContext and SetDisplayMode(AIS_Shaded);
2. Create a wire and make AIS_Shape for it.
3. Display the wire AIS_Shape object.
4. Set wire transparency = 0.8
5. Select by MoveTo command.
TagsNo tags attached.
Test case number
Attached Files

- Relationships
related to 0027925closedbugmaster Open CASCADE Visualization - implement order-independent transparency algorithm within rasterization rendering 
has duplicate 0024929closedbugmaster Open CASCADE Edge and vertex in compound are not highlighed in shading mode if compound is transparent 

-  Notes
(0055735)
git (administrator)
2016-07-07 10:32

Branch CR27527 has been created by isk.

SHA-1: d2e364b07c0aa13a2e0c1fce81c27167b958a2f8


Detailed log of new commits:

Author: isk
Date: Thu Jul 7 10:32:37 2016 +0300

    0027527: Visualization - can't highlight polyline presentation of Wire after setting transparency.
    Add a new parameter theDispMode in the SelectMgr_EntityOwner::HilightWithColor().
    Add a new parameter thePriority in the PrsMgr_Presentation::Highlight(). This parameter is priority of presentation in display mode.
    Add a new parameter thePriority in the Graphic3d_Structure::Highlight().
(0055760)
git (administrator)
2016-07-08 16:08

Branch CR27527 has been updated forcibly by isk.

SHA-1: aed7dcd5392a8ca7d2f5b2dce866b320314801f7
(0055761)
isk (developer)
2016-07-08 16:08

Add a test case.
(0065797)
git (administrator)
2017-05-10 11:54

Branch CR27527 has been deleted by kgv.

SHA-1: aed7dcd5392a8ca7d2f5b2dce866b320314801f7
(0065798)
kgv (developer)
2017-05-10 11:55

Dear bugmaster,

please switch bug into VERIFIED state - it has been fixed by patch for 0027925.
Test case is not needed.

- Issue History
Date Modified Username Field Change
2016-05-20 17:21 Vico Liang New Issue
2016-05-20 17:21 Vico Liang Assigned To => kgv
2016-05-20 17:32 Vico Liang Steps to Reproduce Updated View Revisions
2016-05-23 14:49 kgv Product Version 6.9.1 => 6.3.1
2016-05-23 14:49 kgv Summary Can't highlight wireframe object after setting transparency => Visualization - can't highlight polyline presentation of Wire after setting transparency
2016-05-23 14:49 kgv Steps to Reproduce Updated View Revisions
2016-06-16 20:55 kgv Relationship added duplicate of 0024929
2016-06-30 11:10 kgv Relationship added related to 0027655
2016-06-30 12:29 san Relationship added related to 0026695
2016-07-05 17:58 kgv Assigned To kgv => isk
2016-07-05 17:58 kgv Priority normal => low
2016-07-05 17:58 kgv Status new => assigned
2016-07-07 10:32 git Note Added: 0055735
2016-07-08 16:08 git Note Added: 0055760
2016-07-08 16:08 isk Note Added: 0055761
2016-07-08 16:09 isk Assigned To isk => kgv
2016-07-08 16:09 isk Status assigned => resolved
2016-11-22 11:08 kgv Target Version 7.1.0 => 7.2.0
2017-02-07 11:20 kgv Relationship added related to 0027925
2017-05-10 11:54 git Note Added: 0065797
2017-05-10 11:55 kgv Note Added: 0065798
2017-05-10 11:55 kgv Assigned To kgv => bugmaster
2017-05-10 11:55 kgv Status resolved => feedback
2017-05-10 12:03 kgv Relationship replaced has duplicate 0024929
2017-05-10 12:17 kgv Relationship replaced has duplicate 0026695
2017-05-11 12:27 bugmaster Status feedback => tested
2017-05-11 12:27 bugmaster Status tested => verified
2017-05-11 12:27 bugmaster Resolution open => fixed
2017-09-29 16:20 user533 Fixed in Version => 7.2.0
2017-09-29 16:24 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker