MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027409Open CASCADE[OCCT] OCCT:Configurationpublic2016-04-21 12:392020-09-23 17:59
Reporterabv 
Assigned Toabv 
PrioritynormalSeverityfeature 
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0027409: Provide API header files for OCCT
DescriptionFor using OCCT in projects it can be convenient to provide API header files, one per toolkit and / or module, including all API headers in corresponding toolkit or module. This would allow user to include only a few OCCT headers in his code, instead of adding header for each class used. It can be also useful for enabling precompiled headers on OCCT classes for compiler time optimization, see http://dev.opencascade.org/index.php?q=node/1158 [^]
Steps To ReproduceDuring CMake configuration set BUILD_API_HEADER_FILES variable to any non-default state.
Check that build/inc directory contains Toolkits/Modules API header files.
Check that install/inc directory contains Toolkits/Modules API header files too.
TagsNo tags attached.
Test case numberNot required
Attached Filespatch file icon 0001-0027409-Provide-API-header-files-for-OCCT.patch (9,270 bytes) 2020-09-23 17:47

- Relationships

-  Notes
(0069931)
git (administrator)
2017-08-25 18:44

Branch CR27409 has been created by ski.

SHA-1: 07816750680ad1e894af2bf9d5ce4e3b57326395


Detailed log of new commits:

Author: ski
Date: Thu Aug 24 13:11:41 2017 +0300

    0027409: Provide API header files for OCCT
    
    Added possibility to generate API header files for toolkits and modules.
(0069932)
git (administrator)
2017-08-25 19:17

Branch CR27409 has been updated forcibly by ski.

SHA-1: 7cce6b04943007a0074149096bbfee181ae9f654
(0069933)
ski (developer)
2017-08-25 19:20

Dear abv,

occt branch CR27409 contains changes to generate Toolkits/Modules API header files (CMake variable BUILD_API_HEADER_FILES can be used for that).

Please, review.
(0093567)
kgv (developer)
2020-08-20 17:16

+++ b/adm/templates/headerAPI.in
@@ -0,0 +1,13 @@
+// Copyright (c) 1999-2014 OPEN CASCADE SAS
+//
+// This file is part of Open CASCADE Technology software library.
...

Normally it is expected that generated files will have a header indicating their generation rather than a license status.
(0095246)
abv (manager)
2020-09-23 17:58

Support of precompiled headers for building OCCT has been implemented within 0027407 (for CMake builds, using Cotire tool). The same tool can be used to accelerate builds of depenednt projects, so cumulative API header files do not seem to be necessary for that.

Use of cumulative API can have adverse effect on build time due to too many headers included.

Thus there seem to be no real need in this feature, so I am closing this issue.

The patch (content of branch CR27409 based on commit cba287d62a1a29194cd5bd424ae4094586ef1ba9) is attached for archiving.
(0095247)
git (administrator)
2020-09-23 17:59

Branch CR27409 has been deleted by abv.

SHA-1: 7cce6b04943007a0074149096bbfee181ae9f654

- Issue History
Date Modified Username Field Change
2016-04-21 12:39 abv New Issue
2016-04-21 12:39 abv Assigned To => bugmaster
2016-06-02 17:59 bugmaster Assigned To bugmaster => ski
2016-11-09 11:17 abv Target Version 7.1.0 => 7.2.0
2017-07-27 10:38 abv Target Version 7.2.0 => 7.4.0
2017-08-15 14:35 apv Test case number => Not required
2017-08-25 18:43 ski Status new => assigned
2017-08-25 18:44 git Note Added: 0069931
2017-08-25 19:17 git Note Added: 0069932
2017-08-25 19:20 ski Note Added: 0069933
2017-08-25 19:20 ski Assigned To ski => abv
2017-08-25 19:20 ski Status assigned => resolved
2017-08-25 19:20 ski Steps to Reproduce Updated View Revisions
2017-09-08 09:45 kgv Severity minor => feature
2019-07-10 21:12 abv Target Version 7.4.0 => 7.5.0
2020-08-20 17:16 kgv Note Added: 0093567
2020-09-23 17:47 abv File Added: 0001-0027409-Provide-API-header-files-for-OCCT.patch
2020-09-23 17:58 abv Note Added: 0095246
2020-09-23 17:58 abv Status resolved => closed
2020-09-23 17:58 abv Resolution open => won't fix
2020-09-23 17:58 abv Target Version 7.5.0 =>
2020-09-23 17:59 git Note Added: 0095247


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker