MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027379Open CASCADE[OCCT] OCCT:Configurationpublic2016-04-12 13:202016-12-09 16:37
Reporteremv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027379: Unable to build TKXDESTEP using WOK (wgenproj command) in current master
DescriptionError 1 error LNK2019: unresolved external symbol "public: class opencascade::handle<class Geom_BSplineCurve> __cdecl ShapeConstruct_Curve::ConvertToBSpline(class opencascade::handle<class Geom_Curve> const &,double,double,double)const " (?ConvertToBSpline@ShapeConstruct_Curve@@QEBA?AV?$handle@VGeom_BSplineCurve@@@opencascade@@AEBV?$handle@VGeom_Curve@@@3@NNN@Z) referenced in function "public: static class opencascade::handle<class StepVisual_TessellatedGeometricSet> __cdecl STEPCAFControl_GDTProperty::GetTessellation(class TopoDS_Shape)" (?GetTessellation@STEPCAFControl_GDTProperty@@SA?AV?$handle@VStepVisual_TessellatedGeometricSet@@@opencascade@@VTopoDS_Shape@@@Z) D:\PROJECTS\dev\occt\adm\msvc\vc12\STEPCAFControl_GDTProperty.obj TKXDESTEP


The new dependency of the toolkit TKXDESTEP from the TKShHealing has been introduced in the bug fix #0027235. This dependency had to be reflected in TKXDESTEP/EXTERNLIB file.

The problem is not reproduce when project files are generated by cmake.
Steps To ReproduceBuild OCCT with projects generated by genproj.bat
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0052601)
git (administrator)
2016-04-12 13:26

Branch CR27379 has been created by emv.

SHA-1: d6115b60c1de99ca1f66fde503f89c63bbb38931


Detailed log of new commits:

Author: emv
Date: Tue Apr 12 13:26:10 2016 +0300

    0027379: Unable to build TKXDESTEP using WOK (wgenproj command) in current master
    
    The dependency on TKShHealing has been added.
(0052602)
emv (developer)
2016-04-12 13:30

Dear bugmaster,

Git branch CR27379 contains the patch. Please review.

There is no need in testing, check compilation only.
(0052673)
bugmaster (administrator)
2016-04-13 16:18

Compilation has been checked with cmake nd genproj on Windows, Linux and MacOS platforms. Result is OK
0 warnings was detected on compilation of OCCT
(0053191)
git (administrator)
2016-04-17 14:31

Branch CR27379 has been deleted by kgv.

SHA-1: d6115b60c1de99ca1f66fde503f89c63bbb38931

- Related Changesets
occt: master 94074ec6
Timestamp: 2016-04-12 10:26:10
Author: emv
Committer: bugmaster
Details ] Diff ]
0027379: Unable to build TKXDESTEP using WOK (wgenproj command) in current master

The dependency on TKShHealing has been added.
mod - src/TKXDESTEP/EXTERNLIB Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-04-12 13:20 emv New Issue
2016-04-12 13:20 emv Assigned To => bugmaster
2016-04-12 13:26 git Note Added: 0052601
2016-04-12 13:30 emv Note Added: 0052602
2016-04-12 13:30 emv Status new => resolved
2016-04-12 13:30 emv Steps to Reproduce Updated View Revisions
2016-04-12 15:32 abv Steps to Reproduce Updated View Revisions
2016-04-13 16:16 bugmaster Status resolved => reviewed
2016-04-13 16:18 bugmaster Note Added: 0052673
2016-04-13 16:18 bugmaster Status reviewed => tested
2016-04-15 12:16 bugmaster Changeset attached => occt master 94074ec6
2016-04-15 12:16 bugmaster Status tested => verified
2016-04-15 12:16 bugmaster Resolution open => fixed
2016-04-17 14:31 git Note Added: 0053191
2016-12-09 16:33 user533 Status verified => closed
2016-12-09 16:37 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker