MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027365Open CASCADE[OCCT] OCCT:Configurationpublic2016-04-07 23:332016-12-09 16:37
Reporteribs 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027365: Configuration, CMake - file writing error appears if 3RDPARTY_DIR is empty
Descriptionif 3RDPARTY_DIR is empty, the error below appears:

CMake Error at CMakeLists.txt:384 (file):
  file FILE([TO_CMAKE_PATH|TO_NATIVE_PATH] path result) must be called with
  exactly three arguments.
Steps To Reproducerun the configuration process on a system containing all required 3rdparties
TagsNo tags attached.
Test case number
Attached Files

- Relationships
child of 0027355closedabv Open CASCADE Configuration, CMake: install path on Windows is incorrectly processed 

-  Notes
(0052489)
git (administrator)
2016-04-07 23:39

Branch CR27365 has been created by ibs.

SHA-1: 31f1bdab9816ed6ce25c2584a86436dec9b11c45


Detailed log of new commits:

Author: ibs
Date: Thu Apr 7 23:38:03 2016 +0300

    0027365: Configuration, CMake - file writing error appears if 3RDPARTY_DIR is empty
    
    3RDPARTY_DIR quoted in a corresponding command to avoid error appearance when it is empty
(0052491)
ibs (developer)
2016-04-07 23:46

dear apn,

please have a look on CR27365 branch. May be, it will be useful for your 0027363 issue
(0052492)
git (administrator)
2016-04-08 06:23

Branch CR27365 has been updated forcibly by abv.

SHA-1: 1d505bb0f8a64feb87c76a230b64168242461d94
(0053226)
git (administrator)
2016-04-17 14:42

Branch CR27365 has been deleted by kgv.

SHA-1: 1d505bb0f8a64feb87c76a230b64168242461d94

- Related Changesets
occt: master 1d505bb0
Timestamp: 2016-04-07 20:38:03
Author: abv
Committer: abv
Details ] Diff ]
0027365: Configuration, CMake - file writing error appears if 3RDPARTY_DIR is empty

3RDPARTY_DIR and INSTALL_DIR are quoted in a file TO_CMAKE_PATH command to avoid error when variable is empty
mod - CMakeLists.txt Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-04-07 23:33 ibs New Issue
2016-04-07 23:33 ibs Assigned To => ibs
2016-04-07 23:37 abv Relationship added duplicate of 0027363
2016-04-07 23:39 git Note Added: 0052489
2016-04-07 23:39 ibs Note Added: 0052490
2016-04-07 23:39 ibs Assigned To ibs => ski
2016-04-07 23:39 ibs Status new => resolved
2016-04-07 23:45 ibs Note Deleted: 0052490
2016-04-07 23:46 ibs Note Added: 0052491
2016-04-07 23:46 ibs Assigned To ski => apn
2016-04-07 23:46 ibs Status resolved => feedback
2016-04-08 06:23 git Note Added: 0052492
2016-04-08 06:32 abv Relationship added child of 0027355
2016-04-08 11:55 abv Changeset attached => occt master 1d505bb0
2016-04-08 11:55 abv Assigned To apn => abv
2016-04-08 11:55 abv Status feedback => verified
2016-04-08 11:55 abv Resolution open => fixed
2016-04-17 14:42 git Note Added: 0053226
2016-12-09 16:33 user533 Status verified => closed
2016-12-09 16:37 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker