View Issue Details

IDProjectCategoryView StatusLast Update
0027319Open CASCADEOCCT:Configurationpublic2021-09-03 14:13
ReporteribsAssigned Tobugmaster  
PrioritynormalSeverityminor 
Status assignedResolutionopen 
PlatformAOSL 
Product VersionUnscheduled 
Target Version7.7.0 
Summary0027319: Configuration, Cmake - cmake's c/cxx corresponding flags are not updated in cmake gui after changes in cmake script
Descriptionocct_defs_flags.cmake script updates CMAKE_CXX_FLAGS and similar variables but these changes are not shown in cmake gui application. There the old values of these variables are shown
Steps To Reproducen/a
TagsNo tags attached.
Test case number

Relationships

related to 0027417 closedbugmaster Community Choose a Better Default Release Optimization Parameter for MinGW-w64 

Activities

git

2016-03-30 12:07

administrator   ~0052167

Branch CR27319 has been created by ibs.

SHA-1: 68050429d2d01aaf614020c93e0dd376c682b289


Detailed log of new commits:

Author: ibs
Date: Wed Mar 30 12:03:13 2016 +0300

    0027319: Configuration, Cmake - cmake's c/cxx corresponding flags are not updated in cmake gui after changes in cmake script
    
    update the corresponding variables by force

ski

2016-03-30 16:46

developer   ~0052197

There is a problem:

during generation in CMake try to press Generate button several time
=> corresponding cmake's c/cxx variables will contain repeated flags

For example:
"/MD /O2 /Ob2 /D NDEBUG -DNo_Exception -DNo_Exception -DNo_Exception -DNo_Exception -DNo_Exception"

git

2016-03-30 18:43

administrator   ~0052212

Branch CR27319 has been updated forcibly by ibs.

SHA-1: ee29aa9e70fda0775b6f4bf96046da4a3a51dad1

ibs

2016-03-30 18:46

developer   ~0052214

before a new flag adding to a cache variable, the check for its existence is done. please review

ski

2016-03-31 10:23

developer   ~0052222

Reviewed with no remarks, please proceed.

ibs

2016-04-11 12:22

developer   ~0052565

there's an error on *nix systems due to an incorrect regex string:

RegularExpression::compile(): Nested *?+.
RegularExpression::compile(): Error in compile.
CMake Error at adm/cmake/occt_defs_flags.cmake:13 (string):
  string sub-command REGEX, mode MATCH failed to compile regex "/std=c++0x".

git

2016-05-02 22:15

administrator   ~0053773

Branch CR27319 has been updated forcibly by ibs.

SHA-1: 7472882f0b982771e94d63f7e6b54f9c8d56d121

Issue History

Date Modified Username Field Change
2016-03-30 12:01 ibs New Issue
2016-03-30 12:01 ibs Assigned To => bugmaster
2016-03-30 12:07 ibs Assigned To bugmaster => ski
2016-03-30 12:07 ibs Status new => resolved
2016-03-30 12:07 ibs Steps to Reproduce Updated
2016-03-30 12:07 git Note Added: 0052167
2016-03-30 16:46 ski Note Added: 0052197
2016-03-30 16:47 ski Assigned To ski => ibs
2016-03-30 16:47 ski Status resolved => feedback
2016-03-30 18:43 git Note Added: 0052212
2016-03-30 18:46 ibs Note Added: 0052214
2016-03-30 18:46 ibs Assigned To ibs => ski
2016-03-30 18:46 ibs Status feedback => resolved
2016-03-30 18:46 ibs Steps to Reproduce Updated
2016-03-31 10:23 ski Note Added: 0052222
2016-03-31 10:23 ski Assigned To ski => bugmaster
2016-03-31 10:23 ski Status resolved => reviewed
2016-03-31 11:39 abv Target Version 7.0.0 => 7.1.0
2016-04-11 12:22 ibs Note Added: 0052565
2016-04-11 12:22 ibs Assigned To bugmaster => ibs
2016-04-11 12:22 ibs Status reviewed => assigned
2016-04-25 11:14 ibs Relationship added related to 0027417
2016-05-02 22:15 git Note Added: 0053773
2016-11-03 17:21 abv Target Version 7.1.0 => 7.2.0
2017-07-27 09:43 abv Target Version 7.2.0 => 7.4.0
2019-07-10 21:12 abv Target Version 7.4.0 => 7.5.0
2020-09-11 15:36 utverdov Assigned To ibs => inv
2020-09-11 15:40 utverdov Target Version 7.5.0 => 7.6.0
2020-09-11 17:08 bugmaster Assigned To inv => bugmaster
2021-09-03 14:13 bugmaster Target Version 7.6.0 => 7.7.0