MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027221Community[OCCT] OCCT:Modeling Algorithmspublic2016-03-03 11:132017-09-29 16:31
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.1 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0027221: Regression vs. 6.7.0: bcut fails without notice
DescriptionThe problem is reported on http://dev.opencascade.org/index.php?q=node/1150 [^]

OCCT 6.7.1 and later (including current master) fails to make a cut of two solids without giving any error message (produced result is geometrically equivalent to original solid).
Steps To ReproduceTest case for this issue has been created in frame of the fix for issue 0027252.

pload MODELING

restore [locate_data_file bug27221.brep] a
explode a
mkplane f a_2
prism p f -25 0 0
bcut result a_1 p
donly result a_2

checkprops result -v 56860.2 -s 72076
TagsNo tags attached.
Test case numberbugs modalg_6 bug27221
Attached Files? file icon bug27221.brep (22,399 bytes) 2016-03-03 11:14

- Relationships
parent of 0027252closedapn Open CASCADE Implicit-implicit intersection (Cylinder-Plane) loses intersection curve 

-  Notes
(0051346)
msv (developer)
2016-03-03 12:14

The newer versions of OCCT do not find intersection curve between a pair of faces (see script below). Without this intersection Boolean operation cannot work right.

restore bug27221.brep a
explode a
mkplane f a_2
prism p f -25 0 0

explode a_1 f
explode p f
don a_1_7 p_3
bopcurves a_1_7 p_3
(0051350)
nbv (developer)
2016-03-03 12:57

Intersection curve is found. It is an ellipse (cylinder-plane intersection) and seems to be valid.

However, it is rejected by post-processing of Boolean algorithm in GeomInt_LineConstructor::TreatCircle(...) method.

Most likely, the reason is in putting incorrect vertexes (IntPatch_Points) to the intersection curve.

In OCCT 6.7.0 version the result seems to be valid. In OCCT 6.7.1 and higher (including current MASTER) result of "bopcurves" command is empty.
(0051560)
nbv (developer)
2016-03-11 17:00

IntPatch_Points are found in IntPatch_ImpImpIntersection::Perform(...) (solrst.Perform(...)) as intersection point between surface (in this case, cylinder) domain and quadric (plane).

In fact, domain is 2d-representation of surface boundaries.

In other words, there are some points in surface boundary, which are in quadric with given tolerance (3.0e-7). However, the distance between it and intersection line (ellipse) is greater than tolerance. Therefore, this point is rejected.

Possible reason is that the distance between the point and the curve computes wrong (with big error - see issue 0027252). If it is not other reasons of described behavior are possible.
(0052482)
nbv (developer)
2016-04-07 17:54

Dear Mikhail,

Fix in branch CR27252 solves this problem completely. Please review.
(0053629)
msv (developer)
2016-04-27 12:11

Dear bugmaster, please check and close this bug after resolving 0027252.
(0062967)
nbv (developer)
2017-01-24 17:13
edited on: 2017-01-24 17:14

Dear Andrey,

This bug is fixed in frame of the issue 0027252 (branch CR27252_4). Please see the message 0027252:0062944.

(0062971)
mkv (tester)
2017-01-24 17:31

Testing cases:
http://occt-tests/CR27252_4-CR27252prod-OCCT/Debian70-64/bugs/modalg_6/bug27221.html [^]
http://occt-tests/CR27252_4-CR27252prod-OCCT/Windows-64-VC10/bugs/modalg_6/bug27221.html [^]
bugs modalg_6 bug27221: OK
(0062972)
mkv (tester)
2017-01-24 17:32

TESTED.

- Issue History
Date Modified Username Field Change
2016-03-03 11:13 abv New Issue
2016-03-03 11:13 abv Assigned To => msv
2016-03-03 11:14 abv File Added: bug27221.brep
2016-03-03 11:20 abv Status new => assigned
2016-03-03 11:20 abv Steps to Reproduce Updated View Revisions
2016-03-03 11:44 msv Assigned To msv => emv
2016-03-03 12:14 msv Note Added: 0051346
2016-03-03 12:14 msv Assigned To emv => nbv
2016-03-03 12:57 nbv Note Added: 0051350
2016-03-11 10:34 nbv Severity minor => major
2016-03-11 16:10 nbv Relationship added parent of 0027252
2016-03-11 17:00 nbv Note Added: 0051560
2016-03-14 10:34 nbv Relationship added related to 0026748
2016-04-07 17:54 nbv Note Added: 0052482
2016-04-07 17:54 nbv Assigned To nbv => msv
2016-04-07 17:54 nbv Status assigned => resolved
2016-04-07 17:54 nbv Steps to Reproduce Updated View Revisions
2016-04-27 12:11 msv Note Added: 0053629
2016-04-27 12:11 msv Assigned To msv => bugmaster
2016-04-27 12:11 msv Status resolved => feedback
2016-04-28 10:05 bugmaster Assigned To bugmaster => apn
2016-08-18 10:14 bugmaster Assigned To apn => apv
2016-11-18 17:30 msv Assigned To apv => nbv
2016-11-18 17:30 msv Target Version 7.1.0 => 7.2.0
2017-01-24 15:24 mkv Test case number => bugs modalg_6 bug27221
2017-01-24 17:13 nbv Note Added: 0062967
2017-01-24 17:14 nbv Note Edited: 0062967 View Revisions
2017-01-24 17:14 nbv Assigned To nbv => abv
2017-01-24 17:31 mkv Note Added: 0062971
2017-01-24 17:32 mkv Note Added: 0062972
2017-01-24 17:32 mkv Assigned To abv => bugmaster
2017-01-24 17:32 mkv Status feedback => tested
2017-01-27 16:17 apn Status tested => verified
2017-01-27 16:17 apn Resolution open => fixed
2017-09-29 16:21 user533 Fixed in Version => 7.2.0
2017-09-29 16:31 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker