MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027209Open CASCADE[OCCT] OCCT:Configurationpublic2016-02-28 14:302016-04-20 15:49
Reporterabv 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0027209: CMake - warnings on configuration step for VTK when using vc14 target
DescriptionWhen I build OCCT (current master) with CMake for vc14-64, and select to use VTK (I have VTK-6.1 downloaded from OCC web site), CMake reports this warning:

CMake Warning (dev) at adm/cmake/vtk.cmake:98 (get_target_property):
  Policy CMP0045 is not set: Error on non-existent target in
  get_target_property. Run "cmake --help-policy CMP0045" for policy details.
  Use the cmake_policy command to set the policy and suppress this warning.

  get_target_property() called with non-existent target "vtkIOEnSight".
Call Stack (most recent call first):
  CMakeLists.txt:12 (include)
  CMakeLists.txt:315 (OCCT_INCLUDE_CMAKE_FILE)
This warning is for project developers. Use -Wno-dev to suppress it.
Steps To ReproduceTry to configure occt with vc14 via CMake
TagsNo tags attached.
Test case number
Attached Files

- Relationships
child of 0027040closedabv IVtk does not compile after configuring with CMake 

-  Notes
(0051407)
ski (developer)
2016-03-04 15:32

I tried to build VTK-6.1-vc14-win64 on my local station (Win7) and got a lot of compile errors.
VTK-6.1-vc10 was successfully configured and built.
All obtained errors are reported in VTK bug tracker.
And it seems that VTK-6.1 does not correctly support vc-14.
From VTK-6.3 supporting of vc-14 was added:
"In terms of compatibility, VTK 6.3 now has support for MSVC 2013 and 2015." (see https://blog.kitware.com/vtk-6-3-0 [^])
(0051409)
abv (manager)
2016-03-04 15:52

As agreed, please check building OCCT with VTK 6.3
(0051469)
git (administrator)
2016-03-09 15:28

Branch CR27209 has been created by ski.

SHA-1: 5f2f80a83d423804218664b26b10900249fa65e7


Detailed log of new commits:

Author: ski
Date: Wed Mar 9 15:16:36 2016 +0300

    0027209: CMake - warnings on configuration step for VTK when using vc14 target
    
    Eliminated redundant dependence of OCCT with VTK-6.3.
(0051570)
abv (manager)
2016-03-12 19:06

The CMake warning is caused by incorrect fix previously made for 0027040: that fix does not work when using VTK 6.1 with vc14 (cannot find CMake variable). The consequence is that problem described in 0027040 appears again (for vc14).
(0052011)
git (administrator)
2016-03-25 15:04

Branch CR27209_1 has been created by ski.

SHA-1: e9dcccf095b2ab06eb68aa12d4403042facfd6b4


Detailed log of new commits:

Author: ski
Date: Fri Mar 25 15:03:55 2016 +0300

    0027209: CMake - warnings on configuration step for VTK when using vc14 target
    
    Added check for existence of VTK library target.
(0052012)
ski (developer)
2016-03-25 15:04

Dear abv,

It seems that it is the problem of VTK/CMake.

Command find_package(VTK QUIET) (see adm/cmake/vtk.cmake (line 59)) created VTK_LIBRARIES variable which contains non-existing library name "vtkIOEnSight".
In CMake GUI building of module vtkIOEnSight is OFF.

The easiest way to escape with situation is to check existing of TARGET for current VTK_LIBRARY name. Corresponding changes were done in OCCT branch CRCR27209_1
(0052013)
ski (developer)
2016-03-25 15:05

please review.
(0052042)
abv (manager)
2016-03-25 20:13

I wonder: cannot we just use libpath variables defined by vtk, and rely on EXTERNLIB for list of libs. Besides, note that Vtk and Cmake are made by the same company, thus it is extremely unlikely that Vtk build is incorrect, rather we can misuse it.
(0052080)
abv (manager)
2016-03-28 15:49

Please consult with SALOME team on correct way to use VTK settings in CMake projects
(0052082)
abv (manager)
2016-03-28 17:41

Ok, warning has gone. Still I cannot build OCCT using CMake with VS 2015 when VTK is used but D3D is not (subject of 0027040). Please fix!
(0052145)
git (administrator)
2016-03-30 07:47

Branch CR27209_2 has been created by abv.

SHA-1: 8f87db161697bff436c5ba9020fb3d7afc15ce28


Detailed log of new commits:

Author: ski
Date: Fri Mar 25 15:03:55 2016 +0300

    0027209: CMake - warnings on configuration step for VTK when using vc14 target
    
    Added check for existence of VTK library target.
    
    Removal of hard-coded path to D3D9 library is amended for VTK 6.1 built with VC12 and VC14.
(0052148)
git (administrator)
2016-03-30 09:49

Branch CR27209_2 has been updated forcibly by abv.

SHA-1: d44cf55ae4c7c16dc749807690ba3a81e9f8daa9
(0052153)
abv (manager)
2016-03-30 10:01

Build with vc12-14 is fixed by replicating the fix made previously for 0027040 for another CMAKE variable used by VTK 6.1 configuration in these builds. Note that use of hard-coded path to D3D seems to be permanent problem of VTK builds (and is also present in VTK configuration used by SALOME).

Please integrate branch CR27209_2 (tested with vc10, vc12, vc14).
(0052813)
git (administrator)
2016-04-17 13:07

Branch CR27209 has been deleted by kgv.

SHA-1: 5f2f80a83d423804218664b26b10900249fa65e7
(0052814)
git (administrator)
2016-04-17 13:07

Branch CR27209_1 has been deleted by kgv.

SHA-1: e9dcccf095b2ab06eb68aa12d4403042facfd6b4
(0052815)
git (administrator)
2016-04-17 13:07

Branch CR27209_2 has been deleted by kgv.

SHA-1: d44cf55ae4c7c16dc749807690ba3a81e9f8daa9

- Related Changesets
occt: master 16b40363
Timestamp: 2016-03-25 12:03:55
Author: abv
Committer: abv
Details ] Diff ]
0027209: CMake - warnings on configuration step for VTK when using vc14 target

Added check for existence of VTK library target.

Removal of hard-coded path to Direct 3D import library is generalized and amended for VTK built with VC12 and VC14.
mod - adm/cmake/vtk.cmake Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-02-28 14:30 abv New Issue
2016-02-28 14:30 abv Assigned To => bugmaster
2016-02-28 14:31 abv Target Version 7.1.0 => 7.0.0
2016-03-02 13:01 abv Assigned To bugmaster => ski
2016-03-02 13:01 abv Status new => assigned
2016-03-04 15:32 ski Note Added: 0051407
2016-03-04 15:33 ski Assigned To ski => abv
2016-03-04 15:33 ski Status assigned => feedback
2016-03-04 15:52 abv Assigned To abv => ski
2016-03-04 15:52 abv Note Added: 0051409
2016-03-09 15:28 git Note Added: 0051469
2016-03-12 18:54 abv Relationship added child of 0027040
2016-03-12 19:06 abv Note Added: 0051570
2016-03-12 19:07 abv Status feedback => assigned
2016-03-25 15:04 git Note Added: 0052011
2016-03-25 15:04 ski Note Added: 0052012
2016-03-25 15:05 ski Note Added: 0052013
2016-03-25 15:05 ski Assigned To ski => abv
2016-03-25 15:05 ski Status assigned => resolved
2016-03-25 15:05 ski Steps to Reproduce Updated View Revisions
2016-03-25 20:13 abv Note Added: 0052042
2016-03-28 15:49 abv Note Added: 0052080
2016-03-28 17:41 abv Note Added: 0052082
2016-03-28 17:41 abv Assigned To abv => ibs
2016-03-28 17:41 abv Status resolved => assigned
2016-03-30 07:47 git Note Added: 0052145
2016-03-30 09:49 git Note Added: 0052148
2016-03-30 10:01 abv Note Added: 0052153
2016-03-30 10:01 abv Assigned To ibs => bugmaster
2016-03-30 10:01 abv Status assigned => resolved
2016-03-30 10:01 abv Status resolved => reviewed
2016-04-06 10:33 abv Changeset attached => occt master 16b40363
2016-04-06 10:33 abv Assigned To bugmaster => abv
2016-04-06 10:33 abv Status reviewed => verified
2016-04-06 10:33 abv Resolution open => fixed
2016-04-17 13:07 git Note Added: 0052813
2016-04-17 13:07 git Note Added: 0052814
2016-04-17 13:07 git Note Added: 0052815
2016-04-20 15:43 aiv Fixed in Version => 7.0.0
2016-04-20 15:49 aiv Status verified => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker