MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027165Open CASCADE[OCCT] OCCT:Configurationpublic2016-02-16 16:492016-04-20 15:50
Reporteribs 
Assigned Tobugmaster 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0027165: Configuration, CMake - add an option to choose a variant of the theme of the install paths
DescriptionThere are two themes for install paths, for Windows and for *nix OS. A new CMake variable is required to be introduced (INSTALL_THEME) to offer the possibility to choose one of them.

Windows theme:

<prefix>/win64/vc10/bind - [executables]
<prefix>/ - [scripts]
<prefix>/win64/vc10/libd - [libraries]
<prefix>/inc - [headers]
<prefix>/src - [resources]
<prefix>/doc - [docs]
<prefix>/data - [data]
<prefix>/samples - [samples]
<prefix>/tests - [tests]
<prefix>/results - [test results]

Unix:

<prefix>/bin - [executables]
<prefix>/bin/opencascade-7.0.0 - [scripts]
<prefix>/lib - [libraries]
<prefix>/include/opencascade-7.0.0 - [headers]
<prefix>/share/opencascade-7.0.0/resources - [resources]
<prefix>/share/opencascade-7.0.0/doc - [docs]
<prefix>/share/opencascade-7.0.0/data - [data]
<prefix>/share/opencascade-7.0.0/samples - [samples]
<prefix>/share/opencascade-7.0.0/tests - [tests]
<prefix>/share/opencascade-7.0.0/results - [test results]
Steps To Reproduce1. choose Windows/Unix scheme
2. build & install
3. run draw
4. run demo tests
TagsNo tags attached.
Test case number
Attached Files

- Relationships
related to 0026916closedabv Configuration, CMake - configure variables to customize installation path separately for executables, libraries and resources 
parent of 0027176closedabv Configuration, CMake - INSTALL_DIR is a common prefix for all other install variables 
related to 0027181closedbugmaster Configuration, CMake - samples and data files are not found by tests when they are installed in "share" subfolder 

-  Notes
(0050932)
git (administrator)
2016-02-18 11:57

Branch CR27165 has been created by ski.

SHA-1: 6ffe6f5457cc5fd32accc818883bb40a86b5b8fd


Detailed log of new commits:

Author: ski
Date: Thu Feb 18 11:21:20 2016 +0300

    Added possibility to run samples with Unix install theme

Author: ski
Date: Thu Feb 18 11:05:11 2016 +0300

    Added possibility to run draw.bat with Unix install theme

Author: ski
Date: Wed Feb 17 14:34:56 2016 +0300

    0027165: Configuration, CMake - add an option to choose a variant of the theme of the install paths
    
    Option INSTALL_THEME was added.
(0050941)
git (administrator)
2016-02-18 12:56

Branch CR27165 has been updated by ski.

SHA-1: 8168c4d19baa46333c695494976ba2c4aa1fb9e7


Detailed log of new commits:

Author: ski
Date: Thu Feb 18 12:42:25 2016 +0300

    Corrected test cases to use new environment

(0050963)
git (administrator)
2016-02-18 16:16

Branch CR27165 has been updated forcibly by ski.

SHA-1: 2bda2d95a6a5e83440555d2591188642616bf653
(0050967)
git (administrator)
2016-02-18 16:58

Branch CR27165 has been updated by ski.

SHA-1: 7383d0ade06c2c55db5f06891f6d7a60e7b3be3d


Detailed log of new commits:

Author: ski
Date: Thu Feb 18 16:58:09 2016 +0300

    Reset variables if INSTALL_THEME was changed.

(0050968)
git (administrator)
2016-02-18 17:07

Branch CR27165_27181 has been created by ibs.

SHA-1: 727bd23065b9ae37f5ca2edc9f01ae449339a216


Detailed log of new commits:

Author: ski
Date: Thu Feb 18 16:58:09 2016 +0300

    Reset variables if INSTALL_THEME was changed.

Author: ski
Date: Thu Feb 18 16:11:22 2016 +0300

    Corrected source files to use new environment variable OCCT_RESOURCE_PATH

Author: ski
Date: Thu Feb 18 15:43:47 2016 +0300

    Update samples to use new environment during compilation

Author: ski
Date: Thu Feb 18 13:00:02 2016 +0300

    Corrected *.xsd resource files to use new environment

Author: ski
Date: Thu Feb 18 11:21:20 2016 +0300

    Added possibility to run samples with Unix install theme on Windows

Author: ski
Date: Thu Feb 18 11:05:11 2016 +0300

    Added possibility to run draw.bat and sample.bat with Unix install theme on Windows

Author: ibs
Date: Fri Feb 5 19:14:56 2016 +0300

    0027138: Configuration, Cmake - incorrect binaries installation path for single generators
    
    specify a path for toolkit shared library

Author: ski
Date: Wed Feb 17 14:34:56 2016 +0300

    0027165: Configuration, CMake - add an option to choose a variant of the theme of the install paths
    
    Option INSTALL_THEME was added.
(0051041)
git (administrator)
2016-02-20 13:50

Branch CR27165_27181 has been updated by ibs.

SHA-1: b8c4b21e1364e455b6a4db738f5f87e2d7e7aee8


Detailed log of new commits:

Author: ibs
Date: Thu Feb 18 17:16:27 2016 +0300

    misprints removed from batch files
    
    1. OCCT_SHARE_PATH & OCCT_RESOURCE_PATH are used instead CASROOT
    2. CASROOT left to support compatibility but their priority is lower than OCCT_SHARE_PATH & OCCT_RESOURCE_PATH
    3. check existence of CASROOT variable before using it
    4. the environment variables updated of DRAWEXE project to use OCCT_RESOURCE_PATH and OCCT_SHARE_PATH instead CASROOT

(0051043)
git (administrator)
2016-02-20 16:06

Branch CR27165_27181 has been updated by ibs.

SHA-1: a8f19610445353d327705574bc1c46223ae8edce


Detailed log of new commits:

Author: ibs
Date: Sat Feb 20 16:06:14 2016 +0300

    OCCT_TEST_RESULT_PATH variable introduced to specify a location of "results" folder of the automated test system

Author: ibs
Date: Sat Feb 20 15:21:12 2016 +0300

    sources updated

(0051047)
git (administrator)
2016-02-20 18:09

Branch CR27165_27181 has been updated forcibly by ibs.

SHA-1: 9bee17fcff8d9b64343a11db4d0e26226f83676f
(0051048)
ibs (developer)
2016-02-20 18:15

dear ski,
please review CR27165_27181 branch of OCCT git
(0051076)
git (administrator)
2016-02-24 11:35

Branch CR27165_27181 has been updated by ibs.

SHA-1: ef0114e72d3c90fb5e88a6f9c4ac68b3acc3465e


Detailed log of new commits:

Author: ibs
Date: Wed Feb 24 11:31:29 2016 +0300

    the location of test results folder unbound from OCCT_TEST_RESULT_PATH and OCCT_SHARE_PATH
    
    restore the old approach to specify the path of a test results folder (within DRAW "cd" to corresponding folder which will contain further test results), i.e. the logic specifying a path of test result place is left to DRAW

(0051143)
git (administrator)
2016-02-25 17:52

Branch CR27165_27181 has been updated by ski.

SHA-1: 806ace54fc5e3bf5621aaa42c73978d49623cd13


Detailed log of new commits:

Author: ski
Date: Thu Feb 25 17:50:41 2016 +0300

    env.bat files in samples were replaced by unified env.samples.bat.in for proper work with both Windows and Unix install themes.

Author: ski
Date: Thu Feb 25 16:07:09 2016 +0300

    *.bat files were updated to use environment correctly

Author: ski
Date: Thu Feb 25 16:06:29 2016 +0300

    Added description for INSTALL_THEME variable

(0051158)
git (administrator)
2016-02-26 12:15

Branch CR27165_27181 has been updated forcibly by ski.

SHA-1: ec428f2ec54e14f601b4c15a87802b4031529e9a
(0051165)
git (administrator)
2016-02-26 14:43

Branch CR27165_27181 has been updated forcibly by ski.

SHA-1: 698d1fd004382111832caccf9721f06ac9faa716
(0051301)
ski (developer)
2016-03-02 11:48

There is no major remarks.
From my side I have added description for new variable INSTALL_THEMES.
I have checked and corrected all *.bat files for samples to correct run.
env.bat/sh files for samples are generated from template by cmake now (with path to products env.*).

Also,

PRODUCTS branch CR27165 was created.

It contains the same changes as in OCCT repository. For the moment it is impossible to use Unix install theme on Windows station because samples will work incorrect (only for products), i propose to create separate issue if it is necessary for products.

Separate commit was made for Java sample. New dependence was added for OCCWrapJava (TKFeat). It could not be compiled on Unix without it.
(0051303)
git (administrator)
2016-03-02 12:13

Branch CR27165_27181 has been updated forcibly by ski.

SHA-1: 5e2ccee0187a75ca6810dfd879379e58745e2171
(0051304)
ibs (developer)
2016-03-02 12:17

dear bugmaster,
the patches have been reviewed without remarks.
(0051321)
git (administrator)
2016-03-02 16:13

Branch CR27165_27181 has been updated forcibly by ski.

SHA-1: aa3901bf1d1f58bc246954740016830deeb7370b
(0051322)
ski (developer)
2016-03-02 16:14
edited on: 2016-03-02 16:21

OCCT branch CR27165_27181 was rebased on current state of master.
PRODUCTS branch CR27165 was rebased on current state of master.

(0051450)
abv (manager)
2016-03-09 10:03

Please correct default value of INSTALL_DIR on Windows to be like "C:/opencascade-7.0.0.rc". Current default is to "C:/Program Files" which can be write-protected.

On Linux, current default "/usr/local" is correct, see http://www.faqs.org/docs/Linux-HOWTO/Program-Library-HOWTO.html#AEN46 [^] 3.1.2. Filesystem Placement

Scripts on Linux must be installed to bin without sub-folders, as they are not allowed in bin -- see http://refspecs.linuxbase.org/FHS_3.0/fhs-3.0.html#theUsrHierarchy [^] 4.4.2

For subdirectories created in include and share, I believe we shall have it without version number suffix. Having this suffix can be useful to support several instances of OCCT installed "side-by-side", however it requires more support also from scripts etc., and seems to be not worth effort. Note that (a) separate versions of OCCT can easily be installed in custom folders, and (b) installation made by CMake is only for development, installation for distribution should be different in any case.
(0051512)
git (administrator)
2016-03-10 14:56

Branch CR27165_27181_1 has been created by ski.

SHA-1: 1ea32e077d685d34dbfc30181b6b48e387715843


Detailed log of new commits:

Author: ski
Date: Thu Mar 10 14:43:42 2016 +0300

    0027165: Configuration, CMake - add an option to choose a variant of the theme of the install paths
    
    INSTALL_THEME variable introduced
    *. environment scripts use 0CCT_BIN_PATH, OCCT_LIB_PATH, OCCT_RESOURCE_PATH now
    *. OCCT_SHARE_PATH & OCCT_RESOURCE_PATH are used by the OCCT sources and test cases instead CASROOT (CASROOT left to support compatibility but their priority is lower than OCCT_SHARE_PATH & OCCT_RESOURCE_PATH)
    *. DRAWEXE project uses OCCT_RESOURCE_PATH and OCCT_SHARE_PATH instead CASROOT during debugging
    *. OCCT_TEST_RESULT_PATH variable introduced to specify a location of "results" folder of the automated test system
    *. OCCT samples use OCCT_INCLUDE_PATH variable now
    *. env.build.sh/bat.in files unified; CASROOT specification moved to "custom" file
    *. the location of test results folder unbound from OCCT_TEST_RESULT_PATH and OCCT_SHARE_PATH
    *. the old approach to specify the path of a test results folder was restored (within DRAW "cd" to corresponding folder which will contain further test results), i.e. the logic specifying a path of test result place is left to DRAW
    *. *.bat files were updated to use environment correctly
    *. env.* files in samples were replaced by unified env.samples.*.in for proper work with both Windows and Unix install themes.
(0051530)
git (administrator)
2016-03-10 17:55

Branch CR27165_27181_1 has been updated forcibly by ski.

SHA-1: d7fd2dd4ba7168ce4a7d4b3ccb1dd41e70142ca0
(0051814)
bugmaster (administrator)
2016-03-21 15:17

Fix has been integrated with fix for 27176
(0052844)
git (administrator)
2016-04-17 13:18

Branch CR27165_27181 has been deleted by kgv.

SHA-1: aa3901bf1d1f58bc246954740016830deeb7370b
(0052873)
git (administrator)
2016-04-17 13:27

Branch CR27165 has been deleted by kgv.

SHA-1: 7383d0ade06c2c55db5f06891f6d7a60e7b3be3d
(0052902)
git (administrator)
2016-04-17 13:40

Branch CR27165_27181_1 has been deleted by kgv.

SHA-1: d7fd2dd4ba7168ce4a7d4b3ccb1dd41e70142ca0

- Issue History
Date Modified Username Field Change
2016-02-16 16:49 ibs New Issue
2016-02-16 16:49 ibs Assigned To => ski
2016-02-16 16:49 ibs Relationship added related to 0026916
2016-02-16 16:49 ibs Description Updated View Revisions
2016-02-17 11:48 ski Status new => assigned
2016-02-18 11:57 git Note Added: 0050932
2016-02-18 12:56 git Note Added: 0050941
2016-02-18 16:16 git Note Added: 0050963
2016-02-18 16:58 git Note Added: 0050967
2016-02-18 17:07 git Note Added: 0050968
2016-02-18 17:22 ibs Relationship added related to 0027181
2016-02-20 13:50 git Note Added: 0051041
2016-02-20 16:06 git Note Added: 0051043
2016-02-20 18:09 git Note Added: 0051047
2016-02-20 18:14 ibs Status assigned => resolved
2016-02-20 18:14 ibs Steps to Reproduce Updated View Revisions
2016-02-20 18:15 ibs Note Added: 0051048
2016-02-24 11:35 git Note Added: 0051076
2016-02-25 17:52 git Note Added: 0051143
2016-02-26 12:15 git Note Added: 0051158
2016-02-26 14:43 git Note Added: 0051165
2016-03-02 11:48 ski Note Added: 0051301
2016-03-02 12:13 git Note Added: 0051303
2016-03-02 12:17 ibs Note Added: 0051304
2016-03-02 12:17 ibs Assigned To ski => bugmaster
2016-03-02 12:17 ibs Status resolved => reviewed
2016-03-02 16:13 git Note Added: 0051321
2016-03-02 16:14 ski Note Added: 0051322
2016-03-02 16:21 ski Note Edited: 0051322 View Revisions
2016-03-02 17:27 ski Relationship added parent of 0027176
2016-03-03 13:30 bugmaster Status reviewed => tested
2016-03-03 13:47 abv Product Version 7.1.0 => 7.0.0
2016-03-03 13:47 abv Target Version 7.1.0 => 7.0.0
2016-03-03 17:28 bugmaster Assigned To bugmaster => isv
2016-03-03 17:28 bugmaster Status tested => assigned
2016-03-03 17:29 bugmaster Assigned To isv => ski
2016-03-09 10:03 abv Note Added: 0051450
2016-03-10 14:56 git Note Added: 0051512
2016-03-10 17:55 git Note Added: 0051530
2016-03-21 15:15 bugmaster Assigned To ski => bugmaster
2016-03-21 15:15 bugmaster Status assigned => resolved
2016-03-21 15:16 bugmaster Status resolved => reviewed
2016-03-21 15:17 bugmaster Note Added: 0051814
2016-03-21 15:17 bugmaster Status reviewed => verified
2016-03-21 15:17 bugmaster Resolution open => fixed
2016-04-17 13:18 git Note Added: 0052844
2016-04-17 13:27 git Note Added: 0052873
2016-04-17 13:40 git Note Added: 0052902
2016-04-20 15:43 aiv Fixed in Version => 7.0.0
2016-04-20 15:50 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker